Hello, Guest the thread was called1.5k times and contains 39 replays

last post from advotax at the

Reparaturbericht: C128-Netzteil

  • Big Block Bonanza - C128 Netzteil mit C64-Stecker

    Ein Reparaturbericht




    Vorbemerkungen

    Das Projekt wartet schon eine Weile auf Fertigstellung. Das Netzteil war typischer Beifang in einer größeren Sammlung und gehörte vielleicht zu einer REU, kann aber auch einfach ein umgebautes C128-Netzteil sein. Es hat einen C64-Stecker und keinerlei Beschriftung. Vielleicht fehlt bloß der Aufkleber. Es war noch ein anderes Netzteil dieser Art dabei, das ich aber nicht mehr habe.


    Jedenfalls sah es nach einer kurzen Nummer aus, weshalb ich gar nicht an eine Dokumentation gedacht hatte und die ersten Schritte deswegen nur nacherzähle.



    Wie besser nicht


    Da das Netzteil äußerlich unversehrt und auch der Rest der Sammlung bis auf eine etwa 20 Jahre alte Staubschicht (trocken, aber leider offen in der Scheune gelagert) in gutem Erhaltungszustand war, hab ich es einfach mal riskiert und den Netzstecker in die Steckdose gesteckt. Gleich Live-Test ohne viel Gewese.


    Ich rate dringend davon ab!


    Unbekannte Geräte bzw. Geräte mit unbekanntem Zustand einfach so ans Netz anschließen ist mindestens leichtsinnig. Zumal ich sowieso noch kontrolliert hätte, ob innen alles koscher ist, war das wieder reine Faulheit und Ungeduld. Besonders bei Netzteilen keine gute Kombination!


    Es ging zum Glück alles gut. Sicherungsautomat und FI rührten sich nicht. Allerdings konnte ich durch die Lüftungsschlitze des Netzteils was blitzen sehen. Da weder ein Brummen des Trafos zu hören, noch irgendwas am Stecker zu messen war, wird das wohl eine Sicherung, sehr wahrscheinlich die primärseitige gewesen sein, die sich da verabschiedet hat.


    Also auf damit! Vorher natürlich den Netzstecker wieder ziehen!! :rolleyes:



    Innere Abteilung

    Auf den ersten Blick war zu erkennen, dass ich nicht der erste Interessent bin. Bevor ich die Primärsicherung überhaupt ausgemacht hatte, fiel mir ein Stück Kaugummipapier auf (vermutlich Wrigley's), mit dem eine andere Sicherung überbrückt wurde. Stark!


    Ansonsten ist es ein recht übersichtliches Design, um nicht zu sagen: grobschlächtig, jedenfalls ohne fitzelige SMD-Teile. Genau mein Fall.


    Ein Schaltplan lag auch schon bereit. Googlesuche nach "C128 Netzteil" (in allen mir geläufigen Sprachen) bringt, abgesehen von den internen für die Desktops, mehrere Varianten zum Vorschein. Die wesentlichen Unterschiede bestehen in der Erzeugung der 5V Gleichspannung. Da es sich ja um ein Netzteil für die Versorgung eines C64 handelt und auch für diesen Zweck weiterverwendet werden soll, entfallen immerhin die Varianten, die noch zusätzliche 12 Volt anbieten. Das Service Manual zum C128 enthält leider "nur" den Computer und gerade nicht das externe Netzteil.


    Auf den ersten Blick entspricht das vorliegende Netzteil dem Schaltplan der mit "POWER SUPPLY, EXTERNAL C 128" beschriftet ist und von den ISMET-Werken in Schwenningen stammt. Ähnlich, um nicht zu sagen fast identisch ist der Plan "POWER SUPPLY SCHEMATIC", der offenbar ein Mitsumi Netzteil mit der Nr. "PN-252449-01" zeigt.


     


    (auch bei den üblichen Verdächtigen, wie Zimmers und Ray Carlsen usw. zu finden)


    Der Gum-Paper-Fire-Hazard war demnach F2, die Sekundärsicherung für die 9V-Wechselspannung. Das ist laut Aufdruck auf der Platine eine mit 1.5 A und die war schnell ersetzt. Die Primärsicherung F1 war wie vermutet und auch gut sichtbar der Grund für den Lichtblitz. Auch dafür hatte ich Ersatz im Fundus.


    Nun folgte eine weitere nicht nachvollziehbare Handlung meinerseits: Nach dem Ersetzen der beiden Sicherungen war meine erste, beste - einzige - Idee, den Netzstecker in die Steckdose zu stecken. Warum? :nixwiss:


    Wenig überraschend: noch ein Blitz, F1 war wieder durch. Sauber! :roll:


    Wenn die Sicherung fliegt, ist was nicht in Ordnung. Das ist eigentlich logisch. Ich habe ja aber nur die Sicherung ersetzt, nichts weiter gemacht. Generationen von Lehrmeistern stöhnen auf...


    Nun wusste ich aus Erfahrung und, weil das mein erstes NT dieser Art war, auch aus erster kurzer Recherche, dass gern mal die großen Elkos austrocknen, lecken, jedenfalls Ärger machen. Quasi die µT-RAMs bei den Netzteilen. :D Ist bei dem Alter nicht überaschend, warm wird es da drin unter Volllast sicher auch und gerade die hohen Kapazitäten sind nicht für die Ewigkeit gemacht.


    Die zwei großen Jungs (C4 mit 2200µ und C9 mit 4700µ) waren schnell raus und genauso schnell mit neuen 105°C-Typen gleicher Kapazität ersetzt. Die alten habe ich leider nicht mehr, kann damit also keine Tests mehr anstellen oder auch nur sagen, was es für Typen waren. Sie hatten ein anderes Rastermaß, soviel weiß ich noch. Die Platine ist aber für unterschiedliche Typen gemacht.



    Egal, easy fix, Stecker rein - zack und Sicherung Nr.3 war hinüber.



    Das war der Moment, wo ich damals das Ganze erstmal beiseite gelegt habe. Erstens hatte ich außer den Kondensatoren keine weiteren spontanen Ideen und war mir auch gar nicht so sicher, ob der Schaltplan tatsächlich passt. Zweitens, und das war entscheidend, hatte ich keine passenden Sicherungen für F1 mehr. Und auch kein Kaugummi-Papier. :S


    Ich habe das Teil so gut weggepackt, dass es mir nicht ständig im Weg ist. Damit war es allerdings auch aus dem sprichwörtlichen Sinn. Bis jetzt.

  • Schaltungsanalyse


    Inzwischen hatte ich mir neue Sicherungen besorgt und auch ein paar andere Teile, die ich eventuell ersetzen muss. Der ISMET-Schaltplan ist nicht mit Werten beschriftet, der von Mitsumi fast vollständig. Die Werte stehen allerdings auch relativ gut lesbar auf den meisten Bauteilen drauf. Ein weiterer Vorteil solch rustikaler Designs.


    Ich hab mir die Mühe gemacht, das ganze abzuzeichnen und zu beschriften, soweit es mein Netzteil hergibt.




    Das sieht den beiden Plänen sehr ähnlich, muss aber nicht auch auf andere Netzteile passen. Allerdings sind da auch einige unkritische Sachen verbaut, die wohl auch deswegen nicht mit Werten versehen wurden. Die Spulen sind unbeschriftet, ließen sich aber zumindest berechnen. Zu beidem weiter unten mehr.


    Das Wort Analyse ist hier mit Vorsicht zu genießen. Ich bin kein Fachmensch, nur interessierter Hobbyist und erhebe auch keinen Anspruch auf Vollständigkeit und Detail(er)kenntnisse. Das meiste lässt sich für jedermann in der Fachliteratur nachlesen, mein Vorgehen aber hoffentlich auch so einigermaßen nachvollziehen. Ich verstehe halt gern, woran ich arbeite. Meistens genügt mir dabei aber ein Level, auf dem ich das Prinzip und die grundsätzliche Funktionsweise erfassen kann. Ich will auch nicht unbedingt etwas umbauen, verbessern oder "hacken", einfach nur reparieren, wenn und wie es meine Möglichkeiten erlauben. :)


    Primärseite


    Primärseitig ist ein Netzfilter zu sehen. Drei Kondensatoren eine Spule, die eigentlich zwei sind. Hab ich in meinem Plan als BandPass-Filter eingezeichnet. Wie diese Baugruppe funktioniert, ist erstmal nebensächlich. Da die Sicherung im Stromkreis erst dahinter liegt und die Haussicherung nicht auslöst, gibt es im Filter offenbar keinen Kurzschluss zwischen den Leitern und da es eine Verbindung (überprüft!) zum Schutzkontakt gibt, der FI aber nicht auslöst, ist auch in dieser Hinsicht alles in Ordnung. Ob der Netzfilter wirklich filtert und wie gut er das macht: meh. Momentan wirklich nicht wichtig. Notfalls kann man aber alle Teile austauschen, Werte stehen ja drauf.

    Wichtiger ist da schon die Primärsicherung F1 (a.k.a. "Blitz-Dings"). Beim Mitsumi-Plan steht dort 600mA, im Netzteil selbst sind 315 mA auf einem Aufkleber zu sehen.



    Das bedeutet, dass der Mitsumi-Plan wohl für die 115V-Regionen dieser Welt gedacht war (halbe Spannung = doppelter Strom, bei gleicher Leistung). Da sekundärseitig aber alles gleich ist, spielt das tatsächlich nur an dieser Stelle eine Geige. Der genaue Wert ist nicht wirklich kriegsentscheidend, es ist aber trotzdem sinnvoll, so nah wie möglich am vorgeschriebenen Wert zu bleiben. Sicherungen kosten auch nicht die Welt. Doppelter Sicherungswert ist aber höchstens halbe Sicherheit.

    Im Plan steht nicht, ob träge oder flink, der Aufkleber zeigt aber ein "T" wie "träge" bzw. "time-delay". Bei Transformatoren ist es generell sinnvoll, träge Sicherungen zu verwenden. Flinke können bei hohen Einschaltstromstößen schon mal ungewollt auslösen. Sollte die Sicherung also den richtigen Wert haben und trotzdem "durch" sein, könnte das auch daran liegen. In Netzteilen dieser Leistungsklasse dürfte aber auch eine flinke Sicherung ihren Dienst tun.



    Sekundärseite

    Die 9V-Schiene ist ohne jegliche Geheimnisse. Einfach eine Sekundärwicklung mit Sicherung. Dass der Trafo für 220V und nicht 230V auf der Primärseite ausgelegt ist (s. Aufkleber auf dem Trafo), kann hier vernachlässigt werden und spielt auch keine größere Rolle. Wichtig(er) sind für den konkreten Einsatzzweck lediglich die 50Hz, die C64/128 als ein Taktsignal für die Echtzeituhren nutzen, was aber in so gut wie keinen Anwendungsfällen überhaupt zum Einsatz kommen, soweit ich weiß.

    Ansonsten dient dieser Teil der Spannungsversorgung dem Antrieb des Datasettenmotors und als durchgeschleifte Spannungsversorgung für manche Userport-Erweiterungen, wie z.B. Modems und Eprom-Brenner. Die funktionieren aber auch mit ein wenig höherer Spannung einwandfrei. Generell hält sich das alles immer noch in den vorgesehen Toleranzgrenzen.



    Die Sicherung ist beschriftet, im Plan wie auch im NT. Da steht zwar 125V und normale Sicherungen haben eine Spannungsfestigkeit von 250V. Ich hab tatsächlich mal Feinsicherungen mit 125V gesehen, die scheint es aber (neu) nicht mehr zu geben. Es ist aber auch nebensächlich, ein Mehr schadet hier nicht. F2 war bereits ersetzt, somit ist dieser Teil auch schon abgehakt.



    Der 5V-Teil ist nun der ganze und wesentliche Rest der Schaltung. Das es sich um ein geregeltes Netzteil handelt, ist hier die durch die heutige Netzspannung etwas höhere Eingangsspannung erst recht nachrangig. Am Ausgang sollten - so denn alles funktioniert - in jedem Fall regungslose 5V (oder wie viel auch immer) anliegen.




    V1-V4 + C4

    V1 bis V4 bilden zusammen mit C4 eine unspektakuläre Gleichrichterschaltung und machen aus der sekundären Wechselspannung eine Gleichspannung. Wie hoch, ist an dieser Stelle noch unbekannt und per Messung auch (noch) nicht zu ermitteln, solange der Defekt vorliegt. Da aus ihr die 5V erzeugt werden, dürfte sie an dieser Stelle deutlich höher als 5V sein. C4 ist mit 35V Spannungsfestigkeit angegeben und ziemnlich sicher auch ein solcher verbaut war, lässt das eine Spannung in dieser Größenordnung vermuten. Da 16V- oder 25V-Typen billiger gewesen wären, wären die verbaut worden. Kleiner waren die auch noch. Ich habe einen 50V-Typ ersetzt, der trotzdem noch kleiner ist, als das Original. 30 Jahre Fortschritt.


    Die so grob erzeugte Gleichspannung dient auch der Versorgung der aktiven Elektronik, also IC1 über R1 (Pin13 ist Vcc, Pin 11 ist GND). Das gibt allerdings auch nur wenig Aufschluss über die Höhe der Spannung, da der hier verbaute verwendete µA78S40 lt. Datenblatt mit 2.5V bis 40V zurecht kommt.


    IC1

    IC1 ist dann auch das Herzstück der Schaltung, Es ist ein nach heutigen Standards ziemlich antikes Design, was aber die Sache nicht schlechter macht, als heutige durchschnittliche China-Böller. Das Blockdiagramm im Datenblatt



    entspricht in der eher ungewöhnlichen Ausrichtung dem Blockdiagramm im Mitsumi-Plan und offenbart das Funktionsprinzip.


    Über einen Spannungsteiler (R10, R11, R12) wird die Ausgangsspannung - verstärkt über den im IC1 eingebauten Operationsverstärker (Pins 4, 6 und 7) zusammen mit der internen Spannungsreferenz (Pin 8) über den Komparator (Pin 9 und 10) intern so verwurstelt (genaue Funktionsweise ist in Motorolas AN920 beschrieben; s. Anhang), dass die eingebauten Transistoren (zwischen Pin 3 und Pins 15, 16) ein- und ausgeschaltet werden, je nachdem, ob die gemessene Ausgangsspannung über oder unter dem Schwellwert liegt. Mehr macht das Ding eigentlich nicht und daher kommt auch der Namen SCHALTnetzteil (switching mode power supply, SMPS).

    Das Ganze passiert recht flott, nämlich mit der Geschwindigkeit des Oszillators, die über C7 und das Verhältnis von Eingangs- und Ausgangsspannung bestimmt wird. Da das Verhältnis noch unbekannt ist, kann man das nicht genau sagen, es wird aber im zweistelligen kHz-Bereich liegen. Über Pin 5 wird der interne OPV versorgt und die interne Diode (Pin 1 und 2) ist auf Masse gelegt, weil die nur für relativ kleine Ströme geeignet ist. Alles andere ist externe Beschaltung.


    Der Teil um die V6 und V7 sieht nicht nur zufällig den internen Transistoren ähnlich, er macht genau das Gleiche, nur "in groß". Der 78S40 kann zwar bis zu 1.5 Ampere "schalten", das erfordert allerdings - vermutlich zu großen - Aufwand und funktioniert stabil nur unter bestimmten Bedingungen. Für hohe Ströme wird die eigentliche Arbeit deshalb ausgelagert, in diesem Fall auf V6, der von V7 angetrieben wird, der wiederum von den internen Transistoren angetrieben wird. Warum der Leistungsteil nun mit pnp-Transistoren umgesetzt wurde, hat wahrscheinlich einfach praktische Gründe (V6 hat den Kollektor als Gehäuseteil nach außen geführt und ist unisoliert mit der ebenfalls unisolierten Diode V8 auf dem Kühlkörper montiert), ist aber auch nicht so wichtig. Da die beiden tatsächlich nur an und ausschalten, sind da wohl eine Menge verschiedener Typen geeignet, die einfach nur genügend Strom vertragen müssen. Wahrscheinlich sind sie deshalb auch nicht in den Plänen beschriftet.


    Zum Rest des eigentlichen Netzteils gehören dann noch die schon erwähnte Schottky-Leistungsdiode V8 und die Spule L2. Ganz grob gesagt wird durch das schnelle Ein- und Ausschalten in L2 eine Spannung induziert, die über V8 mehr oder weniger gleichgerichtet und mittels C9 geglättet wird. Deshalb ist der auch so groß. C5 parallel zu V8 dient der Entstörung, wegen den hohen Schaltgeschwindigkeiten. (Stichwort: Snubber)


    L3 und C10 bilden einen Tiefpass am Ausgang, der noch evtl. vorhandene hochfrequente Anteile der Ausgangsspannung unterdrücken soll. Mangels Beschriftung ist L3 nur zu schätzen, aber die Grenzfrequenz wird in etwa der Schaltfrequenz entsprechen oder etwas darunter liegen. Auch das ist nicht wirklich wichtig. L3 auf Durchgang prüfen und C10 auf Kurzschluss, mehr ist da vorerst nicht zu beachten.


    Was V5, C6 und R3 da unten machen, ist mir nicht ganz klar. Vermutlich wird aber einfach das (Masse)Potential vom OPV in IC1 ein wenig geliftet und/oder ein anderer Teil von IC1 braucht das irgendwie. Ich hab da keine genaue Vorstellung, aber in den Application Notes steht an mehreren Stellen etwas zu solchen Maßnahmen. Es sind keine kritischen bzw. exotischen Bauteile und notfalls auch schnell auf Verdacht ersetzt.


    Die beiden Shunts R4 und R14 (im Mitsumiplan unbeschriftet mit Sternchen) sind die beiden Drahtbügel.



    Ob die was machen und was - keine Ahnung. Sehen nicht soo wichtig aus und können wohl auch nicht groß kaputt gehen. :D



    Bleiben nur noch V10, V9 und R13 übrig. Das ist eine klassische "Crow Bar" mit Thyristor, wie man sie so oder ähnlich in einigen Schutzschlatungen und "C64 Savern" sieht oder z.B. auch in der hervorragenden NLQ-HD von NLQ .


    Es ist im Prinzip ein ziemlich rigoroser Überspannungsschutz. Sobald die Z-Diode V9 ihre Zener-Spannung erreicht (hier: wenn die Ausgangsspannung 6.2V erreicht) "zündet" sie den Thyristor V10, der dann einfach den Ausgang des Netzteils kurzschließt, um so den angeschlossenen Computer vor der Überspannung zu schützen. Je nachdem, wie schnell das passiert, hilft das was oder auch nicht. :)


    Idealerweise ist die Crow-Bar extra abgesichert, da sonst das Netzteil einfach kurzgeschlossen bleibt, bis irgendwas durchschmort. Deswegen ist V10 auch an einem Kühlblech. So brennt er nicht schon durch, bevor er seine Aufagbe (lang genug) erfüllen kann. Warum der 5V-Teil nun keine eigene Sekundärsicherung hat, bleibt ein Geheimnis der Entwickler. Eine mögliche Erklärung ist, dass zum Wechsel der Sicherung das Teil sowieso aufgeschraubt werden muss. Da ist es dann wohl egal, welche Sicherung getauscht werden muss. Wenn natürlich die - Achtung! - Primärsicherung F1 durchbrennt, weil der Strom im Kurzschlussfall ja auch primärseitig ansteigt und zu groß wird, sorgt das natürlich gleichzeitig auch für die Abschaltung des 9V-Strangs. Wiederum nicht unclever und vielleicht sogar die bessere/sicherere Variante?



    Jedenfalls drängt sich hier doch schon der erste Ansatzpunkt für die Ursachenforschung förmlich auf!



    Bevor es mit der Fehlersuche losgeht: Beim wiederholten Umdrehen des Netzteils während der Schaltplanerstellung habe ich mehrfach laut geflucht, weil sich die Kabel nie so bewegt haben, wie sie sollten, dafür immer dann, wenn sie es nicht sollten. Also müssen sie erstmal ab. Da sie einfach nur angelötet sind, ist die Verbindung sowieso nicht allzu robust, dafür umso leichter gelöst. Gleich viel besser!


    Ich habe Flachstecker eingelötet und an die Kabelenden die passenden Gegenstücke gecrimpt. Eigentlich nur als Provisorium, aber das wird vermutlich gleich so bleiben. Schraubklemmen passen leider nicht in die vorhandenen Löcher, jedenfalls keine, die ich habe. Die waren eigentlich vorgesehen.


    An dieser Stelle kann man die Kabel auch gleich auf Brüche und Isolationsfehler/Kurzschlüsse prüfen. Die offenen Enden mit dem Stecker und alle Anderen gegeneinander.


    Der Stecker sieht aus, als wäre er nicht zum ersten Mal verbaut. Der könnte von einem C64-Netzteil stammen. Auf der Platine ist noch ein ehemals 5. Kabel zu sehen



    Das ist bei C128-NT der Schirm des Kabels und gleichzeitig die Verbindung (des C128) zum Schutzkontakt. Sowohl an der Platine als auch am Kabel selbst sieht es aus wie einfach abgekniffen. Ein weiteres Indiz, dass es sich eher um einen Umbau handelt. Aber auch das ist am Ende egal. Funktionieren soll es!

  • Fehlersuche

    Crow-Bar


    Erster Ansatz sollte ja die Crow-Bar sein. Das liegt wirklich nahe, denn wenn die macht, was sie soll, ist die Sicherung richtigerweise durch. Wie da jetzt eine zu hohe Spannung entsteht und ob die beteiligten Bauteile i.O. sind und richtig funktionieren, ist zweitrangig. Am einfachsten ist es, diesen Teil von der Schaltung zu trennen. Da ja kein empfindlicher Computer dranhängt, ist eine evtl. zu hohe Spannung erstmal unschädlich.


    Man könnte jetzt alle drei Teile auslöten (Widerstand, Z-Diode, Thyristor). Weniger Aufwand wäre es, nur die Anode von Vxx zu trennen. Dann kann nichts mehr kurzschließen. Die Anode beim TICxxx ist der mittlere Pin. Den könnte man einfach durchkneifen. Ich habe mich für einen Mittelweg entschieden und den Thyristor komplett ausgelötet. Erstens ist der an das Kühlblech genietet. Falls ich den ersetzen muss, müsste ich wahrscheinlich die Niete aufbohren. Außerdem kann so alles "im Stück" wieder eingesetzt und das Kühlblech ist vor allem erstmal aus dem Weg.


     


    Man sieht nun übrigens, dass es kein TIC106D wie im Plan ist. Man kann TAG als Hersteller erkennen und Google findet auch Thyristoren von TAG, aber keinen TAG8842. Bis ich darauf kam, dass das der Date Code ist, vergingen einige Zeit! :whistling: ^^


    Es ist also ein TAG X0403 und zwar in der Ausführung mit extralanger Kühlfahne. Der ist von den Werten fast identisch, auf jeden Fall austauschbar und hat vor allem das gleiche Pinout. Ob ich notfalls einen TIC im TO220-Gehäuse an das Kühlblech bekomme? Jetzt noch nicht wichtig. Das Netzteil funktioniert ja theoretisch - und hoffentlich auch praktisch - ohne die Crow-Bar.


    R13 und die Z-Diode V9 hängen zwar noch zwischen den Polen, können da aber auch bleiben. Unbelastet hält die 6,2V-Z-Diode mit dem 1k Vorwiderstand so um die 80V aus. Da sehe ich keine Gefahr. Auf Kurzschluss getestet war ja schon. Wer auf Nummer sicher gehen will, lötet mindestens eins der vier verbliebenen Beinchen aus oder eben gleich alles. Ist auch beides schnell und günstig ersetzt.


    Nun folgte der nächste Versuch. Erstmal ohne Sicherung F1 Stecker rein, Licht bleibt an, FI bleibt drin. Der Netzfilter ist somit auch nochmal überprüft.


    Stecker raus, Sicherung rein, Stecker rein, heller Blitz, F1 ist durch, Stecker raus. Verdammt.


    Die Crow-Bar war es also nicht, oder nicht nur. Weiter geht's.


    Netztrafo

    Was ist die nächste sinnvolle Maßnahme? Bevor ich anfange, wild alle Teile zu tauschen, auch wenn ich die alle nur deswegen angeschafft hab, halte ich systematisches Vorgehen für sinnvoller.


    Also den Schaltplan wieder zur Hand. Nach Netztfilter und Sicherung kommt der Netztrafo. Der sollte als Verursacher möglichst auszuschließen sein. Ist es der Trafo, ist die Geschichte wohl hier zu Ende. Passenden Ersatz zu finden, dürfte schwierig sein und an mindestens genauso guten Netzteil-Alternativen mangelt es nicht.


    In Frage kommen hier eigentlich nur Wicklungsschlüsse. Da ja irgendwo zuviel Strom fließt, sind es wohl keine Unterbrechungen. Aber auch die wären natürlich ein Aussch(l)usskriterium. Man kann erstmal bei allen drei Wicklungen den Widerstand messen. Alles über 0 Ohm lässt hoffen.


    Es wird überall ein messbarer Widerstand angezeigt. Soweit erstmal beruhigend.


    Die meisten Durchgangsprüfer dürften hier immer mit vermeintlichem Kurzschluss "anschlagen". Das sollte man beachten. Da gerade die Sekundärwicklungen sehr geringe Widerstände haben, sollte die Messung idealerweise direkt am Transformator erfolgen. Somit stellt man sicher, dass nicht irgendwelche Übergangswiderstände an den Lötstellen die Messung verfälschen und nur einen Widerstand in der zu erwartenden Größenordnung vortäuschen. Ohne Ausbauen wird das aber nichts.


    Sollte der Trafo in Ordnung sein (wovon ich insgeheim ausgehe), würde sich daran der nächste Test anschließen: Die Spannungsmessung der Sekundärwicklungen im Betrieb. Dazu muss er netzseitig wieder angeschlossen werden, möglichst mit einer Sicherung, und standfest, und so berührungssicher wie möglich. Fliegender Aufbau? Nein, danke. Den lassen wir also besser mal da, wo er ist. Vermutlich liegt der Fehler sowieso "weiter hinten" in der Schaltung. Es muss also irgendwie eine Unterbrechung her, und das möglichst zerstörungsfrei. Leiterbahnen durchkratzen fällt somit aus.


    Es bietet sich an, die Gleichrichterdioden V1-V4 wenigstens einseitig auszulöten. Das sind die ersten Teile auf der Sekundärseite und alle vier sind mit der Trafowicklung verbunden. Egal was dahinter im Argen ist, der Trafo kann ohne die vier zumindest erstmal im Leerlauf überprüft werden. Die Dioden sind auch nicht teuer und waren auch schon vorhanden, weshalb hier der Seitenschneider zum Einsatz kam. Sie hätten sich aber auch sehr gut "im Stück" entfernen lassen, wie ich feststellte.



    Nochmal nachsehen, ob auch wirklich keine Verbindung mehr irgenwohin besteht.



    Sieht nicht so aus. Zeit für den nächsten Test.



    Neue Sicherung rein. Stecker rein. Kein Blitz!



    Allerdings auch kein Trafo-Brummen, wobei ich mit dem Ohr nicht allzu nah ran bin. Soviel Respekt habe ich dann doch. :strom:


    Also Stecker wieder raus und die Platine aus dem Gehäuse und umgedreht. Stecker wieder rein, immer noch kein Blitz. Einfach mal messen. Tadaa! wir haben ca. 11V~ an der einen und ca. 23V~ an der anderen Wicklung. Der Trafo ist soweit in Ordnung und es kann weitergehen!


    Die Werte kamen mir bekannt vor. Es könnte der gleiche Trafo wie in einer 1540/1541 sein. Aber egal, der tut doch noch.



    Kurzschluss, wo bist du?


    Was in der Schaltung kommt überhaupt in Frage? Fest steht - es hat oft genug geblitzt -, dass irgendwo ein zu hoher Strom, also höchstwahrscheinlich ein Kurzschlussstrom fließt. Der Verursacher kann eigentlich nur zwischen V+ und Masse, mit mehr oder weniger direkter Verbindung zwischen den beiden Polen zu finden sein.


    Die Crow-Bar ist deaktiviert. C10 am Ausgang ist o.k. Die Spannungsversorgung von IC1 wird es eher nicht sein. Die Bonding-Drähte im Inneren sind dünner als der in der Sicherung, brennen viel schneller durch. Vertrauen, Kontrolle - aber auch da alles i.O., kein Kurzschluss zwischen Vcc und GND (Pins 13 und 11). Von Pin 15/16 gibt es keine Verbindung nach Masse. Das bedeutet, die internen Transistoren sind ok und V6/V7 sind auch soweit ok. Ob sie tatsächlich arbeiten, wird damit nicht festgestellt. Es geht erstmal nur um die Suche nach einem Kurzschluss!


    Andere (direkte) Pfade sind auch nicht ersichtlich. Dafür ist übrigens die Darstellungsweise wie im ISMET-Plan besser geeignet, also ohne Masse-Symbole. So sieht man besser, wer mit wem verbunden ist. Es heißt ja Stromkreis.


    C4 und C9 sind neu. Das muss nichts heißen. Die können kaputt gewesen oder beim bisherigen Probieren kaputt gegangen sein. Beim Durchgangs-/Widerstandstest sieht man, wie der Widerstand steigt, sie laden sich also erwartungsgemäß auf und haben keinen Kurzen. Ein echter "leakage test" ginge allerdings nur im wenigstens einseitig ausgelöteten Zustand. Hier lehne ich mich mal aus dem Fenster und erkläre sie für gut. Sie sind auch richtig rum drin! Das hatte ich beim Wechsel damals mehrfach überprüft. Auch so ein Fehler, der ganz schnell passiert! :whistling:


    Weiterhin kommt der Strang R1, R2 mit V5+Gedöns in Frage. Die Widerstände messen, was sie sollen. Aber selbst wenn V5 einfach durchleiten würde, fließen [Ohmsches Gesetz in voller Pracht] max. 30mA, also deutlich unter den zu erwartenden 2.5A, die das Netzteil liefern müsste und darauf ist die Sicherung dann auch ausgelegt. Das kann es also auch nicht sein. R10, R11, R12 haben noch höhere Werte und messen auch i.O.


    Bleibt noch V8/C8. Der Kondensator ist i.O. Die Diode sperrt in eine Richtung, in der anderen zeigt der Diodentest, was das Datenblatt verspricht, jedenfalls keinen Kurzschluss.


    Hmm. Was nun? Nirgends sonst kann nennenswert Strom fließen. Einfach mal gedanklich Bauteil für Bauteil durch ein Stück Draht ersetzen und anhand des Schaltplans verfolgen, ob man wieder am Trafo ankommt. Und da machte es Klick!


    Was war eigentlich mit den dicken Gleichrichtern? Die waren ja schon im Abfall. Rausgekramt, durchgemessen und tatsächlich, eine zeigt im Diodentest 0V und im Durchgangstest Nullkommairgendwas Ohm an. Es hatte tasächlich eine 1N5400 erlegt!


    Die neuen sind so schnell rein, wie die alten raus waren. Ein kleiner Gefallen für die Nachwelt:



    Man kann nun einigermaßen ablesen, welche Typen verbaut sind, wenn man die zweite Null in der Reflexion vom Kühlblech beachtet. :D


    Ok, Zeit für den nächsten Test. Stecker rein. Kein Blitz. Aber auch kein Brumm oder überhaupt ein Geräusch. Zum Glück aber auch kein Pfeifen oder Surren. Das ist nicht wirklich wild, im Gegenteil, so wünsch ich es mir. Es ist nur etwas ungewohnt bei so einem dicken Ding.


    Messgerät dran. An den 9V~ hat sich nichts geändert, die sollten anliegen und tun das auch (also die Leerlaufspannung 10.xV~).


    Und DC liefert - tatsächlich 5.03V! Begeisterung!



    Ich glaub, das war's schon.


    Nun hab ich hier noch einen Komplettsatz Austauschteile liegen... :)



    Ursachenforschung

    Man kann nun fragen, warum wegen einer in alle Richtungen leitenden Gleichrichterdiode die Sicherung fliegt bzw. der Stromfluss dermaßen steigt. Wer will, kann sich das mal ausrechnen. Da braucht man keine konkreten Werte, die kann man sich einfach ausdenken. Einfach immer jeweils eine der vier Dioden durch einen Strich ersetzen und überlegen, was passiert. Das kann man auch experimentell bestimmen (dann bitte nicht mit Netzspannung!) oder ganz ungefährlich per Software simulieren.


    Der pragmatische (und auch mein liebster) Ansatz: Da es wieder funktioniert, war es die Diode. Der Defekt ist behoben. Das Warum, also das Symptom "Sicherung fliegt" ist hier egal. Die Ursache für den Defekt, also warum die Diode versagt hat, ist da schon interessanter.


    An einen Verschleiß durch (jahrelange) Vollast mag ich nicht so recht glauben. Den damaligen Angaben des Vorbesitzers nach war die Nutzungszeit eher gering. Als er sich das alles geleistet hatte, vielmehr leisten konnte, war er eigentlich schon "zu alt" für das Hobby (vermutlich jünger als ich jetzt :alt:) und ist wohl auch nicht wieder reingewachsen. Auszuschließen ist das deswegen zwar nicht, aber das sind eigentlich auch Dioden, die "dick" genug sind für diesen Einsatzzweck und dauerhafte Volllast war mit dem C64-Setup, dass ich da erworben hatte, sehr, sehr unwahrscheinlich.


    Eine weitere Möglichkeit ist natürlicher Verfall, also z.B. durch schlechte Passivierung oder sonstige Qualitätsmängel bei der Fertigung der Bauteile. Schließlich war ja eine offenbar funktionierende Sicherung drin, die erst bei meinem ersten Kamikaze-Versuch auslöste. Warum die ersetzt worden sein soll, und die andere (Kaugummi) nicht und dann ohne Ausprobieren in die Scheune? Kann sein, oder auch nicht. Vielleicht war es auch eine Kombination daraus.


    Für am wahrscheinlichsten halte ich das Szenario, dass einer der Kondensatoren (die vor dem Tausch) oder gleich beide einen Schluss hatten, wofür schon das Alter spricht. Wenn dann die volle Leistung des Trafos durch die Bauteile strömt, gibt die erstbeste Schwachstelle nach, woraufhin dann die Toleranzgrenze des Systems und der Auslösestrom der Sicherung überschritten wird. Lawineneffekt. Ist aber auch nur gemutmaßt. :)


    Jedenfalls ein anschauliches Beispiel, warum bei Netzteilen immer abgesichert werden sollte, wenigstens primärseitig. Wie man sieht, können auch ohne direkten oder direkt erkennbaren Kurzschluss hohe Ströme fließen. Auch bei nur 2 oder 3 Ampere wird's schnell mal heiß. Da besteht zumindest Brandgefahr!

  • Ob die was machen und was - keine Ahnung. Sehen nicht soo wichtig aus und können wohl auch nicht groß kaputt gehen.

    Nein, aber ihre Lötstellen können. Ich hatte bereits ein C128-Netzteil bei dem die Löstellen dieser Drahtwiderstände weggefault waren. Sie wollten sich auch nur ungerne wieder anlöten lassen.


    Wenn die Primäsicherung sofort durchgeht würde ich als erstes den Regler vom Trafo trennen und nochmal probieren. Ist jetzt die nächste Sicherung durch hat der Trafo einen Windungsschluss und die Sache ist damit erledigt weil nicht reparierbar. Brennt die Sicherung dann wieder durch wären die nächsten zu testenden Bauteile die 4 großen Dioden aus denen der Gleichrichter besteht. Wenn eine davon zum Kurzschluss mutiert ist hat man einen solchen was die durchbrennende Sicherung erklärt. Erst wenn klar ist, daß Trafo, Gleichrichter und Siebung (Großer Elko) OK sind fängt man an den Schaltregler genauer anzuschauen.


    Nachtrag... Wie man liest kam die Idee mit den Dioden von selbst.

  • Abschließende Maßnahmen


    Wo es einmal in der Mache ist, kann man an so einem Netzteil vielleicht noch ein paar andere Maßnahmen zur "Modernisierung" ergreifen.



    R11

    In anderen Reparaturberichten ist auch mal von einem Defekt und/oder Verschleiß des Trimmpotis für die Spannungseinstellung zu lesen. Wenn dadurch vielleicht eine zu hohe Spannung eingestellt wird, löst zumindest die Crow-Bar aus und keiner weiß, warum. Das Original ist ein offenes Modell mit 200 Ohm.



    Es gibt zwar diesen Wert auch zu kaufen, ich habe aber nur den Standardwert 250 Ohm bekommen. Der kann problemlos eingesetzt werden. 150 oder 100 Ohm sollten auch funktionieren, wie es auch 500 Ohm noch tun sollten. Alles dazwischen geht natürlich ebenfalls. Noch größere Werte machen die Einstellungsmöglichkeiten aber wahrschienlich schon zu "grob" und kleinere Werte vielleicht nicht weit genug. Mehrgang-Potentiometer ("Präzisionstrimmer") gehen natürlich prinzipell auch, sind aber nicht unbedingt notwendig. Es kommt jedenfalls bei dem Spannungsteiler vorrangig auf das Teilungsverhältnis an (ungefähr 3:1), nicht unbedingt auf die konkreten Werte.


    Ich hatte von Piher ein PT10 mit 250 Ohm besorgt. Das passt ganz ohne Verrenkungen in die vorhandenen Löcher.



    Mit dem kleinen Pfeil wirkt es auch gleich viel professioneller. :D


    Spannung habe ich erstmal auf 5.1 Volt eingestellt. Es wird übrigens entgegen der Intuition beim Linksdreh mehr. :)



    V10

    Den Thyristor V10 wollte ich ja wieder so, wie er ist einsetzen. Ich habe keine wirklich Möglichkeiten, einen richtigen Funktionstest zu machen, schon gar nicht unter Praxisbedingungen. Man könnte natürlich eine Testschaltung basteln, die man allerdings auch erst berechnen und designen muss. Da macht es doch auch ein neuer TIC106, den ich ja deswegen angeschafft habe. Aber da war ja die Sache mit dem angenieten Kühlblech. Man könnte einen anderen, "richtigen" Kühlkörper nehmen ist dafür überhaupt Platz?


    Oder ich lass die Crow-Bar bzw. V10 ganz weg. Das ist viel einfacher. :D


    Es ist eine simple und wirkungsvolle Maßnahme gegen Überspannungen. Ich hab sie aber sonst auch nirgends im Einsatz, an keinem meiner anderen Netzteile. Wer das Risiko nicht eingehen will, ist mit einem externen "C64 Saver" nicht schlechter dran und sogar noch flexibler. Gibt es zu kaufen, ist aber auch ganz schnell selbst gebaut.


    Upgrades

    Eine schon ganz frühe Idee war noch, einen Netzschalter nachzurüsten. Allerdings haben Schaltnetzteile - auch solche alten - den großen Vorteil, eine geringe Ruhestromaufnahme zu haben. Geräusche macht es weder im Leerlauf, noch im normalen Einsatz und an einer schaltbaren Steckdose hängt es bei mir im Normalfall sowieso. Da spare ich mir doch die mechanische Bearbeitung. Rechteckige Löcher sind sowieso nicht meine Freunde. Außerdem würde die einfache Entnehmbarkeit der Platine entfallen, wenn der Schalter fest mit dem Gehäuse verbunden ist. Überhaupt ist da wahrscheinlich gar nicht genug Platz.


    Zur Betriebsanzeige eine LED oder auch für beide Zweige je eine? Geringer Aufwand, für 1.8mm-LEDs auch nur ein kleines Loch. Mit relativ großen Vorwiderständen ist die zusätzliche Belastung völlig zu vernachlässigen und blenden soll es sowieso nicht. Das Problem mit der festen Verbindung zum Gehäuse stellt sich aber auch hier. Herausnehmbare LEDs, die man so elegant schräg nach links rein- und rausbugsiert, das versuche ich gar nicht erst. Das bekomme ich nie passend hin. Höchstens noch direkt auf die Platine gelötet und so angeordnet, dass man das Leuchten durch die Lüftungsschlitze sehen kann. Da wo die Crow-Bar-Teile sind, wär ja jetzt Platz. Na vielleicht so.



    Lasttest

    Ich werde auf jeden Fall noch ein wenig testen, sowohl auf Dauer als auch auf Leistung und gegebenenfalls hier updaten.




    Bis dahin! :)

  • Gleich Live-Test ohne viel Gewese.


    Ich rate dringend davon ab!

    Zumindest würde ich keinen C64 anschließen, immer nur eine künstliche Last, auch wenn es beim ersten Mal nicht gleich "schießt".

    Quasi die µT-RAMs bei den Netzteilen.

    :lol33:

    Ob die was machen und was - keine Ahnung. Sehen nicht soo wichtig aus und können wohl auch nicht groß kaputt gehen.

    Natürlich machen die was, mit denen wird der Strom gemessen, der für die Crowbar und die Abschaltung des ICs maßgebend ist. Die müssen drin bleiben.


    Ich hatte übrigens letztens ein C128-Netzteil, das keine 5 V mehr lieferte, nur noch ca, 4,5 Volt bei "vollem Aufdrehen" am Poti. Schuld war ein schwingendes Regler-IC. In AN920 ist ein Kondensator mit 100 nF eingezeichnet (und zwar nur in Figure 32!), der im Schaltbild und bei meinem Netzteil von "Nov. '85" fehlte. In einem zweiten Netzteil von "Dec '85" war er nachgerüstet. Hier der entsprechend korrigierte Schaltplan:



    Dieser stammt glaube ich aus dem Service Manual, die "freifliegenden" bei Zimmers sind entweder für ein anderes Modell oder ohne Werte, Das rot eingezeichnete C wäre nachzurüsten. Ohne war die Referenz-Spannung an Pin 8, die laut Datenblatt mindestens +1,1 V und typisch +1,25 V betragen sollte, keine Gleichspannung, sondern ein Sägezahn von 1,0 V Mittelwert und Variation von 0,8 bis 1,2 V.


    [EDIT]


    advotax Bei dir scheint der Kondensator auch zu fehlen, was hat dein Netzteil für einen Datecode?


    [/EDIT]

  • Bei dir scheint der Kondensator auch zu fehlen, was hat dein Netzteil für einen Datecode?

    Datecode vom Thyristor ist 1984, der vom 78S40 ist Mitte 1985. Andere äußere Kennzeichnungen gibt es wie gesagt nicht (mehr).


    In welchem Service Manual ist das finden? Weißt du das noch?


    Ist vielleicht bei den Mitsumi für die 60Hz-Gebiete noch eher aufgetreten.

  • Ich meinte den Datecode auf dem Typenschild des Gehäuses, da ist bei meinen ein Stempel drauf.


    Der Schaltplan ohne das C ist hier.


    http://www.zimmers.net/anonftp…rvice_Manual_1987_Nov.pdf


    Der 100 nF-Kondensator is wie gesagt nur in AN920, Figure 32 eingezeichnet. Sonst habe ich ihn nirgends gefunden. Die rote Ergänzung oben stammt von mir. Seit ich den drinnen haben, ist der Sägezahn weg und das Netzteil wieder OK.


    [EDIT]


    Es ist aber auch möglich, dass das C abhängig vom Hersteller des 78S40 ist.


    [/EDIT]

  • wow. toll zusammengeschrieben.

    ich hab mir auch mal ein defektes c128 netzteil repariert und für den c64 adaptiert. die beiden fetten elkos defekt und 1 der dioden hatte nen schluß.

    für profis gibt es da einen besonderen trick wie man rausbekommt was defekt ist wenn die glassicherung fliegt. den verrate ich aber lieber nicht. zisch bumm krach und der FI fliegt und da sganze haus ist finster.

  • Vllt. sollte man den generell mal nachrüsten (ist ja ein Akt) und Schaden kann es auch nicht.

    Das denke ich auch. Bei mir sieht es so aus:


    Netzteil #1 ist vom Nov. 1985 und hat die P/NO 310416-02, das ist das fehlerhafte (von mir modifizierte), urspünglich ohne 100 nF.

    Netzteil #2 ist vom Dec. 1995 und hat die P/NO 310415-03, da ist der 100 nF offensichtlich serienmäßig eingebaut.


    Netzteil #3 ist nur noch ein Leergehäuse, hat P/NO 310416-03 und ist vom Nov. 1985. Da muss also gerade die Umstellung gewesen sein, und die Änderung der P/NO deutet darauf hin, dass die Jungs bei Krummodore drauf gekommen sind, dass da was nicht passt. ;)

  • Wo hast du ihn denn bei dir angebracht? Unterseite?

    Ja, ich habe ihn "unelegant" auf der Unterseite angebracht, man kann natürlich auch zwei Löcher in den Print bohren und ihn ordentlich bestücken. Bei Rev 03 hat Commodore ihn an Pin 8 in der Verlängerung der beiden Widerstände untergebracht, siehe Fotos:


    Netzteil #1 ohne C:



    Netzteil #2 mit C:



    Typenschilder:


  • Allerdings haben Schaltnetzteile - auch solche alten - den großen Vorteil, eine geringe Ruhestromaufnahme zu haben.

    Äh, nein... Auch nicht weniger als ein unbelastetes Netzteil mit 7805. Das Problem ist hier der Trafo, der hat einen gewissen Ruhestrom. Den echten Vorteil bekommst du erst wenn du ein primär getaktetes Netzteil ohne Trafo verwendest.

  • Auch nicht weniger als ein unbelastetes Netzteil mit 7805.

    Klar, Ist eigentlich logisch. Ich hatte gar nicht verglichen, nur die Lobpreisungen des Datenblatts gelesen und wahrscheinlich eben jene primär getakteten NTs im Hinterkopf.


    Dann sagen wir mal, sie ist so oder so vernachlässigbar gering. Gering genug, nicht für einen Netzschalter am Gehäuse zu feilen. :)