Hello, Guest the thread was called514 times and contains 10 replays

last post from kuhbaert at the

Atari 520 ST mag nur im Hires Mode am SM124

  • Ich hab hier einen ST520 den ich etwas unvollständig von einem Kumpel bekommen habe.


    Dabei waren der ST mit Netzteil eine Floppy mit Netzteil , leider kein Floppykabel dazu und ein SM124 SW Monitor.

    Die fehlende Maus dazu hab ich mir mittlerweile dazu gebastelt.


    Am SM124 geht der ST an und ich bekomme den TOS Bildschirm.

    Jetzt wollte ich aus platzgründen den SM124 erstmal in den Keller schaffen und den ST an einem Röhrenfernseher anschliesen der gerade ohnehin meinen Schreibtisch belagert.

    Ich habe zunächst versucht den ST über den RF ausgang an den TV zu bekommen, ich finde beim Suchlauf am TV dann auch ein graues Bild aber keinen Desktop.

    Wenn ich mit der Maus herumfahre kommt auch manchmal ein Zeiger ins Bild. Mit einem selbstgebasteltem Composite Kabel schaut es nicht besser aus.

    Meistens kommt nur graues Bild manchmal sind auch die berüchtigten Bomben zu sehen.


    Mir erscheint es fast so als wäre der ST noch im HiRes Modus allerdings dürfte da ja eigentlich gar kein RF Signal ausgegeben werden.


    Vieleicht hat ja einer einen schlauen Tip warum der ST keinen LowRes Mode mag.

  • Mal ein Paar wirre Gedanken, da meine ST-Zeit sehr lang her ist und sehr kurz war (gott sei dank...)


    Erstmal muss der SM124 keinen wertvollen Platz im Keller verbrauchen - Einfach Kabel abschneiden um den Stecker weiter nutzen zu können und den blöden Rest entsorgen. Die Dinger will doch eh niemand nutzen. Aus dem Stecker kann man einen hübschen Adapter auf VGA und RGB basteln.


    Der 520er kann afaik kein Composite darstellen. RTFM.


    Was in Erinnerung geblieben ist, ist dass der ST ohne Floppy (bei dir scheint ja das Kabel noch zu fehlen) ewig brauchte um überhaupt mal ein Bild zu machen. Biste sicher, dass du lang genug wartest?


    Ohne angeschlossenen SM124 ist der ST nichtmehr im HiRes-Modus: Im Stecker ist ein Pin der auf GND gelegt wurde. Hierüber erkennt der ST, dass er HiRes darstellen soll. Wenn diese Pins nicht verbunden sind da kein HiRes-Monitor dran ist stellt er LowRes dar.


    So wie ich deine Beschreibung lese würde ich davon ausgehen, dass du über RF ein Farb-Bild bekommen müsstest, wenn du eben lang genug wartest.


    Und ganz wichtig: Kannst du erkennen wie viele Bomben angezeigt werden? Ändert sich die Anzahl? Ich glaub im Handbuch stand was drin welche Anzahl zu welchem Fehler gehört. RTFM weiter.

    Steht auf dem Typenschild wirklich nur 520ST oder ist dahinter noch ein kleines f und/oder m und/oder e?

  • Die Anzahl der Bomben kann ich nicht erkennen, das ist wenn Sie auftauchen zu schnell wieder weg.


    Auf dem Schild steht nur 520ST ohne Zusatz, aber er hat einen RF ausgang somit sollte er auch wenn ich das korrekt Recherchiert habe ein Composit Signal ausgeben.


    Ein Monochrom VGA Kabel hab ich mir schon gebastelt das geht auch am vorgesehenem TFT Monitor, ansonsten hätte ich da aber eigentlich gerne zu Spielen stilecht eine RöhrenTV dran.

    Ich finde die Graphic leidet unter der Darstellung am TFT.

  • ...


    Der 520er kann afaik kein Composite darstellen. RTFM.

    ...

    Das ist schlichtweg falsch. Ein ST ohne Modulator hat an der Monitorbuchse Pin 2 ein einfaches CSync, das aus Kopplung von HSync und VSync gewonnen wird. In einem ST mit Modulator wird für diesen unter Verwendung eines MC1377 aus RGBHV ein echtes Composite-Video Signal erzeugt, das nebenbei dann an der Monitorbuchse Pin 2 anliegt!

    ...


    Was in Erinnerung geblieben ist, ist dass der ST ohne Floppy (bei dir scheint ja das Kabel noch zu fehlen) ewig brauchte um überhaupt mal ein Bild zu machen. Biste sicher, dass du lang genug wartest?


    ...

    stimmt auch so nicht. Wenn man einen ST mit angeschlossenem (oder eingebauten) Disklaufwerk ohne eingelegte oder formatierter Disk startet, dauert es etwa eine halbe Minute, bis man den Desktop sieht. ohne angeschlossenes Laufwerk deutlich schneller. Allerdings ist eine nachträglich angeschlossene Floppy mW. nicht ansprechbar. Aber bei der empfindlichen Elektronik im ST ist sowieso ratsam, vor Einschalten alle Laufwerke anzuschließen ...!

  • ohne angeschlossenes Laufwerk deutlich schneller.

    Ok, ich geh mal davon aus, dass ich nur noch im Hinterkopf hatte, dass es ohne eingelegte Diskette mit angeschlossenem Laufwerk lange dauerte. Lange kann dann jeder für sich selbst definieren.

    Da aber meine ST-Zeit wie angegeben sehr lang her ist und ich wie ebenfalls angegeben nicht behauptet habe, dass alles stimmt was ich da geschrieben habe schonmal danke wenn du mein Halbwissen richtig stellst.

  • Ich hatte den Atari heute mal zerlegt, hauptsächlich um zu schauen ob ich ein evtl ein Gotek intern direkt an der Floppybuchse anlöten könnte.


    Nachdem das Board ordentlich eingestaubt war hab ich es erst mal abgesaugt, und siehe da: Jetzt funktioniert die Farbausgabe am Modulator wieder!


    Das mit dem direkt anlöten hab ich mir allerdings erst mal verkniffen, somit suche ich weiterhin nach einem Floppykabel oder wenigstens einen Stecker.

  • Der 520er kann afaik kein Composite darstellen. RTFM.

    Das ist schlichtweg falsch. Ein ST ohne Modulator hat an der Monitorbuchse Pin 2 ein einfaches CSync, das aus Kopplung von HSync und VSync gewonnen wird. In einem ST mit Modulator wird für diesen unter Verwendung eines MC1377 aus RGBHV ein echtes Composite-Video Signal erzeugt, das nebenbei dann an der Monitorbuchse Pin 2 anliegt


    Die Aussage ist nicht falsch. Lt.Dan meint damit natürlich "Composite Video" (in Englisch: CVBS, in Deutsch: FBAS). Dann wird ein Schuh draus... mit Modulator liegt Composite Video an Pin 2 der Monitorbuchse an, ohne Modulator eben nur Composite Sync, womit kein Fernseher etc. dieser Welt ohne weitere Informationen (eben "RGB") etwas anfangen kann.


    Zum Thema Floppy: Bei TOS 1.04 (evtl. wurde das ja nachgerüstet) kann es durchaus sein, daß der Rechner mit Bomben startet, wenn kein Laufwerk A: erkannt wurde. Beim TOS 1.00 und 1.02 dauert es locker 20-30 Sekunden, ehe der Desktop erscheint, wenn KEIN Laufwerk A: erkannt wird.


    @kuhbaert: Bevor Du Dir für viel Geld irgendwelche Teile besorgst (die großen 14 poligen DIN 14F Stecker sind extrem schwer zu bekommen und auch fertige Kabel oft sehr teuer), überlege genau, was Du mit dem ST wirklich machen möchtest und wieviel Du bereit bist, zu investieren. Geht es Dir primär um alte Spiele der ersten Zeit der STs, dann besorg Dir ein HcX oder ein Gotek/FlashFloppy Laufwerk und bastel Dir das passend zurecht. Willst Du Dich "voll reinhängen" und auch komplexere Spiele spielen etc., dann - mein Vorschlag - rappel Dich gar nicht erst mit dem Floppy-Gedöns ab, sondern kauf Dir ein UltraSATAN Adapter. Gibt´s auf eBay und bei Lotharek. Allerdings sollte dann der 520 ST auf längere Sicht mit etwas mehr Speicher ausgestattet werden :-)


    Gruß, Jürgen

  • Ein Gotek hab ich schon hier liegen aber mangels interner Anschlüsse im 520 ST bin ich auch da auf mindestens einen Stecker angewiesen :-/

    Hab mir schon überlegt eine Stecker pzw Pinhalter 3d drucken zu lassen aber ich hab auch noch keine gute Idee wo ich die losen Pins dafür hernehmen soll.


    Dann hole dir einen bei eBay. Aktuelles Angebot z.B. das hier. Zehner inkl. Porto ist mittlerweile "Normalpreis", günstiger wirst Du ihn kaum bekommen.

  • Die Aussage ist nicht falsch. Lt.Dan meint damit natürlich "Composite Video" (in Englisch: CVBS, in Deutsch: FBAS). Dann wird ein Schuh draus... mit Modulator liegt Composite Video an Pin 2 der Monitorbuchse an, ohne Modulator eben nur Composite Sync, womit kein Fernseher etc. dieser Welt ohne weitere Informationen (eben "RGB") etwas anfangen kann.

    Um das mal kurz richtigzustellen: Die Aussage war schon falsch. Hier handelt es sich ja um einen 520er mit Modulator. Mir war nur nicht klar, dass FBAS in dem Videostecker integriert ist.

    Ich bin davon ausgegangen, dass man dort bloß nen VGA-Monitor (high) und nen RGB-Monitor (mid/low) anschließen kann, und ansonsten ausschließlich ein RF-Signal am Modulator hat bzw. irgendwas hätte zurechtbasteln müssen um ein FBAS-Signal zum Monitor legen zu können.

    Naja, wie bereits erwähnt anfänglich erwähnt alles nur Halbwissen da meine ST-Zeit kurz war und meine Eltern mich damit eigentlich bloß ärgern wollten.