Hello, Guest the thread was called2.7k times and contains 76 replays

last post from OliverW. at the

Probleme / Schwierigkeiten / Lösungen Pi1541

  • Ich habe in Allem Jiffy am Start.

    Es scheint so weit zu funktionieren.


    Lediglich das "Surfen" durch das PI-SD-Kartenverzeichnis funktioniert nicht.

    Ich vermute, dazu ist die spezielle Version

    des Filebrowsers gemacht worden?

    Wäre mir fast egal, da ich durch das TFT Display und die Tasten alles am Gerät erledigen kann.

    Sehr schade ist, dass der Schreibzugriff via USB - Easyflash Probleme macht. Aber wer weiß was da noch kommt.


    Unterstützung für den Drehdecoder ist natürlich toll, das kann aber warten bis die FW stabil läuft.


    Was noch keiner erwähnt hat, ist, dass sich ja auch die Raspberry-Firmware ab und an ändert. Das sind drei Dateien im root-Ordner, die man normalerweise nicht aktualisiert,

    Soll ich mein RootVerzeichnis zum Vergleichen online stellen?


    Stefan

  • Hast Du Linux? Bist Du im Stande, den Sourcecode von Pi1541 von github zu clonen und lokal zu kompilieren?

    nein und nein


    Allgemein macht sich niemand die Mühe, penibel aufzuschreiben, wie das eigene Setup aussieht. So kann ja entweder ein Raspberry Pi 3 B+ oder ein Raspberry Pi 3 A+ im Spiel sein (ich ignoriere den neuen Support für Raspi Zero/1/2 hier mal). Dass auch wichtig ist, welche-Floppy-ROM-Files zum Einsatz kommen, haben wir ja oben schon besprochen. Die Einstellungen in der options.txt und der config.txt wären auch interessant.


    Dein Problem war: Hat schon mal funktioniert (1.19), funktioniert jetzt (ab 1.20) nicht mehr. Rückkehr zu 1.19 bringt es wieder zum Funktionieren.

    Deine Möglichkeiten sind:

    • Falls eine Software-Änderung in v1.20 zu einem erhöhten "Strombedarf" führen sollte, mal mit einem besser geeigneten Netzteil testen. Ist aber unwahrscheinlich.
    • Dieses Posting hier lesen über den Test mit bitnax.d64 und über die Option GraphIEC=0. Testen mit bitnax.d64 und auch Testen mit GraphIEC=0. Wenn kein Display über HDMI angeschlossen ist, braucht man auch kein GraphIEC.
    • Wenn kein Linux vorhanden ist (immer ein Fehler), dann unter Windows 10 entweder das Windows Subsystem for Linux installieren, um eine Ubuntu Bash unter Windows zu haben oder eine grafische virtuelle Maschine mit Ubuntu Linux via VirtualBox, VMWare, etc.) Danach kann man sich den Pi1541-Kernel innerhalb von ein paar Minuten selbst kompilieren und dann eigene kernel.img's testen - man kann dann Softwarestände aus dem git testen, die zwischen dem Release 1.19 und 1.20 liegen und kann sich an den git Commit heranpirschen, der das Problem reinbringt (git-bisect).
  • Allgemein macht sich niemand die Mühe, penibel aufzuschreiben, wie das eigene Setup aussieht.

    Also: Raspberry Pi 3B (ohne +), Pi1541 Platine V4 bigby , Version B , verbunden über 40pol Flachbandkabel (20cm).


    config.txt

    Code
    1. kernel_address=0x1f00000
    2. force_turbo=1 //0 -> device not present
    3. hdmi_force_hotplug=1
    4. // start_debug=1

    options.txt


    // GraphIEC = 1 , keine Änderung bei ´0´ (und natürlich auskommentiert)


    was ich mir vorstellen könnte, dass die Verbindung über Flachbandkabel nicht so gut ist, bzw. 20cm schon zu lang.


    EDIT: bitnax.d64 hab ich probiert und bei FW 1.22 stoppt es schon beim ersten Track mit rot, FW 1.20 läuft problemlose Runden

  • Das 1581er Rom muss auch drauf ins root Verzeichnis. Es gibt 2 verbindliche Namen für das Rom, von denen du dich für einen entscheiden musst.

    (Siehe Config. Txt)

    Wenn du das. D81 anwählst, geht das umschalten von alleine.

    Vielen Dank, die Info hatte ich nicht (gelesen).

    Ich habe jetzt mein 1581 ROM 'JiffyDOS_1581.bin' genannt. Im Root ist es auch, genau wie das 1541 ROM (Das heisst übrigens Jiffy.bin). Geändert hat sich aber nix. Geht weiterhin kein 1581 Image. Was habe ich übersehen?? Ist der Name vom 1541 ROM in Ordnung? Mit der Config. Txt bzw. options.txt werde ich nicht schlau...


    Auf der Pi1541 Seite kann man sich A disk image containing FB64 downladen. Bei mir ist das D64 nur 3kb groß. Hat das jemand in korrekt - also funktionsfähig? Danke.

  • Habe nun auch alles mögliche mit meinem Pi1541 ausprobiert, hat leider alles nichts gebracht.

    Bin dann drüber gestolpert das die meisten hier einen 3B+ verwenden und ich nur einen 3B ohne Plus.

    Unterschied 3B->3B+ sind immerhin 200Mhz.

    Ok dachte ich mir vielleicht liegt es ja nur an der Leistung und die neueren Firmwares sind einfach rechenintensiver.

    Raspberry "sanft" auf 1300Mhz overclocked und schwupps... Firmware 1.22 läuft wie vorher die 1.19! :thumbsup:

    Habe es auch mit 1250Mhz versucht aber das hat noch nicht gereicht.


    Wissen wir wenigstens schon einmal wo die Probleme FW >1.19 liegen.


    Wer auch einen Raspberry 3B ohne Plus sein eigen nennt und das bei sich auch mal ausprobieren möchte hier mal

    meine aktuelle config.txt.


    Code
    1. kernel_address=0x1f00000
    2. force_turbo=1
    3. arm_freq=1300
    4. over_voltage=1
    5. disable_auto_turbo=1
    6. boot_delay=1


    Gruß Plastix

  • Wissen wir wenigstens schon einmal wo die Probleme FW >1.19 liegen.

    OK, das mit dem Übertakten klingt interessant. Wobei ich da eher eine Timing-Berechnung als die wirklich notwendige Geschwindigkeit sehe . Aber ich hab keine Ahnung vom Programmieren, wie hardwarenah da zu Werke gegangen wird.


    Achso, 1.20 funktioniert bei mir noch einwandfrei


    EDIT: mal etwas underclocked (1100 MHz) und schon läuft es nicht mehr;

    mit 1280 MHz läuft Ghost´s n Goblins :) bei FW 1.22; StarWarsDemo hat Grafikfehler und stürzt ab;

    mit 1300 MHz läuft die Demo :)

  • Irre

    EDIT: mal etwas underclocked (1100 MHz) und schon läuft es nicht mehr

    Wahnsinn 8|


    Vielen Dank, die Info hatte ich nicht (gelesen).

    Ich habe jetzt mein 1581 ROM 'JiffyDOS_1581.bin' genannt. Im Root ist...

    Die beiden "//" hast du entfernt?

    ROM1581 = JiffyDOS_1581.bin

    Dass das Display bei der Emulation keine 'BAM' anzeigt, scheint normal zu sein.

    (Fotos im Anhang) tut aber ;)


    Stefan

  • Die beiden "//" hast du entfernt?

    ROM1581 = JiffyDOS_1581.bin

    Dass das Display bei der Emulation keine 'BAM' anzeigt, scheint normal zu sein.

    Ja, die Auskommentierung hatte ich entfernt.

    Aber die Option 'ROM1581' war mir neu. Jetzt läuft es!! D A N K E !! :-D

    Über HDMI habe ich noch gar nix angeschlossen, soweit bin ich noch nicht...

  • Wer auch einen Raspberry 3B ohne Plus sein eigen nennt und das bei sich auch mal ausprobieren möchte hier mal

    meine aktuelle config.txt.

    Jupp, damit läuft auch bei meinem Pi ohne '+' das Ghost´s n Goblins. :-D

    Danke.

    StarWars Demo ebenso. Hatte es aber vorher nicht probiert. Und JiffyDos musste ich im C64 ausschalten...

  • emulaThor : schreibst Du die Erkenntnisse von Plastix in Sachen Overclocking ins lemon64 - Forum ?

    Ja, in den nächsten Tagen. Da hier so viele schreiben, ist es schwer, den Überblick zu behalten. Meine Grundfrage ist:


    Wenn V1.20 ohne Übertakten funktionierte, warum muss dann für V1.21/1.22 übertaktet werden? Diese Frage bleibt wohl unbeantwortet, wenn hier jetzt alle wunschlos glücklich sind. ;)

  • Ja, in den nächsten Tagen. Da hier so viele schreiben, ist es schwer, den Überblick zu behalten. Meine Grundfrage ist:


    Wenn V1.20 ohne Übertakten funktionierte, warum muss dann für V1.21/1.22 übertaktet werden? Diese Frage bleibt wohl unbeantwortet, wenn hier jetzt alle wunschlos glücklich sind.

    Super, danke emulaThor :thumbsup:

    Bei mir funktionierte übrigens schon die 1.20 nicht mehr ohne overclocking.

    Vielleicht kann Mr.White da ja was drehen so das wir bei zeiten das overcklocking wieder aus der config.txt entfernen können.

    Evtl. gibt es dann ja bald eine separate Version für 3B und 3B+ falls es nicht anders zu lösen sein sollte.

    Im Moment bin ich aber zufrieden und froh das ich die neueren Firmwares benutzen kann.


    Gruß, Plastix

  • Wenn V1.20 ohne Übertakten funktionierte, warum muss dann für V1.21/1.22 übertaktet werden? Diese Frage bleibt wohl unbeantwortet, wenn hier jetzt alle wunschlos glücklich sind. ;)

    es waren doch bisher nur die Erkenntnis und die Bestätigung von drei Leuten, dass mittels Overcklocking V1.>19 PI1541 mit Ghosts 'n Goblins und der Starwars-Demo laufen. Von wunschlos glücklich ist nicht die Rede.

    Im Übrigen lief der Test mit bitnax noch problemlos durch, wo oben genannte Titel schon abschmierten. Also ist dieser Test auch nicht allumfassend.


    Kann man beim Komplilieren des kernels schon Pi-Hardware Einstellungen festlegen ? Anzahl der genutzeten Core´s , CPU / GPU / RAM - clocking usw. ? Vielleicht ist da schon Optimierungspotential ?

  • es waren doch bisher nur die Erkenntnis und die Bestätigung von drei Leuten, dass mittels Overcklocking V1.>19 PI1541 mit Ghosts 'n Goblins und der Starwars-Demo laufen. Von wunschlos glücklich ist nicht die Rede.

    Im Übrigen lief der Test mit bitnax noch problemlos durch, wo oben genannte Titel schon abschmierten. Also ist dieser Test auch nicht allumfassend.

    Kann man beim Komplilieren des kernels schon Pi-Hardware Einstellungen festlegen ? Anzahl der genutzeten Core´s , CPU / GPU / RAM - clocking usw. ? Vielleicht ist da schon Optimierungspotential ?

    Wie splittet man im Forums-Editor ein Zitat elegant in mehrere Brocken, so dass man auf einzelne Sätze antworten kann?