Hello, Guest the thread was called1.8k times and contains 13 replays

last post from schergentoni at the

Tass zickt!

  • immer wieder kommt es bei mir vor, wenn man ein ganzes Stück Code hat (1500 Zeilen+), daß Turboass keine Labels maher annimmt; ok, man denkt: wird halt kein Platz mehr für Lanels frei sein, also löscht man ein paar unwichtige/unnötige, startet alles neu aber Fehlanzeige. Es passiert dann z.B. folgendes: ich will "jsr label" tippen, tass löscht mein label und markiert die Zeile als falsch (was sie in dem Moment dann ja auch ist, jsr alleine z.B.) oder aber ich möchte eine Zeile nachträglich "belabeln", schreib das label davor und er löscht mir die komplette Zeile ersatzlos. Was ist da los. Ist mein Code zu lang? Zu viele Labels?? Aber ich hatte auch schon längeren Code und noch mehr labels ohne dieses Phänomen?! Spielt die Labellänge (Zeichen) ein Rolle? Wie werden denn die labels verwaltet und wo werden sie abgelegt?!

  • Es ist gut möglich, das der LABEL Speicher voll ist. Der geht beim normalen Turbo Ass (der ab $9000 liebt) von $e000-$fffa. Am besten du schaust mal mit dem Mon rein, wieviel davon belegt ist.


    Auch früher mal benutzte, aber danach gelöscht oder geänderte Labels bleiben in dieser Liste enthalten. Auch, wenn du deinen Source mit Pfeil Links + "S" savest. Die Labelliste wird mitgespeichert. Um nun die alten unbenutzten loszuwerden, und wieder etwas Platz zu bekommen, Speichere deinen Source als AscII. Das machst du mit Pfeil Links + "W" (write). Der Source wird nun um einiges größer auf Disk, also sorge für genug Platz. Nachdem er fertig gesaved hat, resettest du den Turbo Ass (Pfeil Links + "C". Die Labelliste ist nun gelöscht. Nun lädst du den Source mit Pfeil Links + "E" (enter). Jetzt wird quasie dein Source komplett neu eingetippt! Das dauert etwas länger als das normale laden, aber dafür sind nur noch die wirklich benutzen Labels später in der Labelliste, die nach dem Assemblieren erzeugt wird. Längere Labelnamen, verbrauchen natürlich auch mehr Platz.
    Vielleicht hilft dir das weiter.


    Für große Projekte, ist der Turbo Ass keine gute Wahl. Der Assblaster ist da etwas besser, da er beim Assembliervorgang, dein Programm auch auf Disk Speichern kann, wenn der Source zu groß geworden ist. Das bietet nochmal etwas mehr Luft. Die beste Möglichkeit ist aber, entweder den Acme mit Schergentonis Editor zu benutzen (cross-ass), oder den Virtual Ass mit SCPU Unterstützung. Aber leider, kostet die ein haufen Geld. Aber zum Coden ist es die beste Plattform, die man sich nur wünschen kann. Dein Turbo Ass Source, kann auch ohne Probleme in den Virtual Ass Importiert werden. ~16 MB Source Code kannst du hier eintippen :). Die Bedienung ist der des Turbo Ass nachempfunden. Man fühlt sich sofort wie zu Haus. Das beste aber ist der 64 Char Modus für mehr Übersicht. :)

  • Da kann ich nur zustimmen. Das ist wenigstens gleich eine komplette Entwicklungsumgebung. Mit Monitor und vielen anderen Funktionen. Da wirst du sicher keine Probleme mehr mit den Labels haben. Aber wenn du eine REU besitzt solltest du dir mal den TurboAssembler fuer die REU anschauen. Da gibt es einige versionen... Da hast du wie beim Virtual Assembler die ganzen 64k frei und eben massig Platz fuer den Source...

  • danke. Das mit dem write, reset und enter hab ich inzwischen auch schon selbst rausgefunden, jetzt weiss ich aber wenigstens ein bisschen besser bescheid über die arbeitsweise von tass. Tja, da bleibt mir wohl im Moment nix anderes übrig als diese Methode, bis dann wirklich alles aus allen Nähten platzt ;). Crossassemblen wäre ne Alternative ich versuch auch gerade, Schergentonis Editor einzurichten, aber irgendwie funktioniert das mit dem ACME noch nicht so ganz (beim assemblieren: error while opening top level file, oder so...), krieg ich aber bestimmt noch hin. SCPU will ich mir eigentlich keine zulegen in naher Zukunft aber die REU-Variante würde mich doch auf jeden Fall reizen. Da will ich doch gleich mal frech fragen (obwohl im falschen Brett): Hat da vielleicht jemand eine zu verkaufen???! Oder ne Bezugsquelle (Das Auktionshaus mal aussen vor...)

  • also, acme funktioniert soweit wenn ich ihn von der Kommandozeile starte, aber aus dem Editor raus eben nicht, wie gesagt. Die Pfadangabe hab ich im Editor bei "Einstellungen -> Kompilereinstellungen" gemacht. Zum Testen hab ich auch den Sourcecode extra im Acme-Verzeichnis gespeichert. Wie meinst du das mit "includes"??
    Noch was anderes: Ein automatisches Einrücken labels links -> TAB -> Anweisungen gibts bei deinem Editor nicht?! Muss man von Hand "tabben"?
    Ansonsten aber echt ein kooles Tool, dein Editor. Respekt!
    P.S.: Gibts ne Möglichkeit, den Src dann wieder bei Bedarf ins Tass Format zurückzukonvertieren?!
    (Hinkonvertiert hab ich mit pet2asc.exe, war bei 6502tass mit dabei)
    P.P.S.: zum Tassproblem mit den labels: die stehen also im Moment bei mir von $e000-$e230 (Adressen) und von $ec60-$f0b2 (Namen), also sollte doch noch genügend Platz dasein, der Rest ist mit $ff's gefüllt. Eigentlich müsste da doch noch massig Platz sein??! Aber die Zickereien nehmen kein Ende. Inzwischen stürzt derTass sogar komplett ab, wenn ich ein neues Label eingeben will (reagiert nicht mehr auf RunSTop/Restore...). Na jaAber ich muss mir über kurz oder lang schon was anderes einfallen lassen.

  • welche parameter hast du denn bei acme eingestellt im menü kompiler-einstellungen? normalerweise sollten die leer sein.


    ach ja, es kann sein, dass acme mit den pfad-angaben der source-datei nicht klarkommt? gerade, wenn sich leerzeichen in der pfadangabe befinden, kann es unter umständen zu fehlern führen.


    daher würde ich acme in ein verzeichnis wie "c:\programme\acme\" oder "d:\c64\acme\" legen, und die sources dann bspw. in "c:\programme\acme\sources\" oder "d:\c64\acme\sources\".



    der eingabecursor wird automatisch eingerückt. wenn die vorige zeile am anfang beginnt, ist der cursor in der neuen zeile auch am anfang. wenn du die vorige zeile mit 2x tab eingerückt hast, wird der cursor in der nächsten zeile aich eingerückt.



    wenn du nun die ascii-datei übersichtlich gestalten willst (gerade bei importierten sources macht das sinn), würde ich zuerst per suchen/ersetzen alle leerzeichen vor jeder zeile mit nichts ersetzen, dass also der ganze source links sitzt.
    dann mit der funktion "zeilenweise textergänzung" in jede zeile ein, zwei tabs setzen. dazu musst du den ganzen text markieren, zeilenweise textergänzung ausführen (menü extras) und das häkchen bei "vor jede zeile tabulator setzen" setzen.



    includes sind dateien, die du einbindest (font, music, sinen etc.). kannst dir ja mal das sample zum programm angucken, da siehst du, wie das gemeint ist.

  • aha. Ja das kann sein mit den Leerzeichen im Pfad. Muss ich gleich mal probieren und danke für die Tips zum Textformat. Was eine Include-Datei ist weiss ich schon, nur wusste ich nicht genau, was Du mir damit im obigen POsting sagen wolltest??! Ich benutz (im moment) keine Includes, aber wahrscheinlich dachtest, daß wenn ich welche hätte, diese überprüfen solle; ah jetzt dämmerts! Klar.... ;)
    Hab jetzt übrigens (doch beim Auktionshaus...:rolleyes: ) überraschenderweise ne REU erstanden aber das gehört ja jetzt nicht hier he. Nur kurz @nikon: ich hab irgendwie im Kopf, auf der hp von der reu-angepaassten Tass-Version, wo war denn das gleich??!, daß diese nur für die 1750 (512K) getestet/ ausgelegt ist. Meine ist dann aber ne 1764 (256K), macht das was? Dürfte eigentlich egal sein, oder?!

  • alles klar inzwischen! Funktioniert alles... der Editor ist echt genial. Was mir aufgefallen ist: Die Lesezeichen setzen-Shortcuts (Cntrl-Shift-[1-9]) funktionieren scheinbar nicht... kann das sein?
    Gibts beim Acme einen Switch, der Warnungen ignoriert? Und kann es sein (nur interessehalber, eigentlich ist es auch egal), daß Acme immer nur die ersten 10 Fehlermeldungen anzeigt?

  • also, das mit den lesezeichen sollte eigentlich funktionieren. hm... hab's gerade mal getestet. die shortcuts funktionieren nicht, man muss die lesezeichen direkt über das menü setzen. ich versuch das mal zu beheben. abgesehen davon nutze ich die lesezeichen eigentlich nie, sondern die absatz-funktion (menü einfügen => abschnittmarke und dann menü suchen => gehe zu abschnitt).



    acme hat fast gar keine optionen, jedenfalls hab ich kaum welche entdeckt. ich denke, einen switch fürs abschalten der fehler gibt es daher nicht. und fehlermeldungen zeigt acme durchaus mehr an, aber wenn ein fehler mehrere folgefehler zur folge hat, dann wird die komplette auflistung abgebrochen.

  • ja, ausser -vX und -h gibts wohl keine switches beim acme. Muss ehrlich sagen, daß mir da der 6502tass besser gelegen hat, na ja. Aber jetzt hab ich schon den ganzen Sourcecode im Acme Format (die ganzen Pseudo Opcodes usw...), dass ich schon vorerst beim acme bleib. Das mit den Absätzen ist in der Tat besser als Lesezeichen...