Hello, Guest the thread was called8.3k times and contains 166 replays

last post from kinzi at the

Mein erster VC20 (Oder: Ugh! Kann man bei dem Bild noch was machen?)

  • Jo, allerdings könnte man ja nur die eine Leiterbahn an der Din Buchse durchtrennen, denn auch wenn man das Board zwar dann "verändert" hat, funktioniert es doch auch ohne S-Video mod noch ganz genauso weiter wie ohne die Leiterbahn die pin 4 und 5 verbindet, wenn ich das richtig verstanden hab.

    Abgesehen von dem Detail, dass dann das Composite-Signal nur noch an PIN 4 nach außen geführt wird. Bei vorhandenen Kabeln kann das zum Konflikt führen.


    Auf Pin 1-3 liegen 5V, GND und Audio. Blieben also 2 Pins für Chroma, Luma und Composite. Selbst wenn man den fehlenden Pin irgendwo finden würde, müsste man dann natürlich das Composite-Signal auf der Zwischplatine "sauber" zusammensetzen.

    Pin 4 ist doch für Composite Out... Und wird doch dort von C64er Compostite DIN Kabeln erwartet. Wieso also ein Konflikt? Müsste doch mit nem ganz nornmalen Kabel dann funktionieren. In diesem Modus (ohne Zwischenplatine - Normalzustand) stelt sich doch garnicht die Frage mit Luma und Chroma Signal Auftrennung und verfügbarkeit.


    Wird S-Video statt Composite gewünscht könnte man dann eine Zwischenplatine einsetzen, und müsste die Schlatung für nen getrenntes Luma/Chroma mit drauf packen, welche dann beide Signale ggf. mit Clips an die Buchse bringt...


    Die Ursprüngliche Schaltung auf dem Board müsste dabei dann mithilfe der Platine natürlich gleichzeitig übergangen/ignoriert/tot gestellt werden.


    Zumindest war das so mein Gedanke. Ob das so geht... dat wees ich nix elektoniker nid... :rolleyes:

  • Sag mal, warum sind denn so häufig die Platinenfolien so gewellt?

    Das hat keine einzige meiner bisher getestetn Platinen, habe das aber schon häufiger gesehen und mich gewundert, wo sowas herkommt?

    ich kann sogar eine Platine aufbieten, die ist nicht nur auf der Unterseite ne Berg- und Talbahn sondern sogar auf der Bestückungsseite. Hab ich bisher auch so noch nie gesehen, aber besonders im RAM-Bereich gibts da auch schöne Wellen.

  • Pin 4 ist doch für Composite Out... Und wird doch dort von C64er Compostite DIN Kabeln erwartet. Wieso also ein Konflikt? Müsste doch mit nem ganz nornmalen Kabel dann funktionieren. In diesem Modus (ohne Zwischenplatine - Normalzustand) stelt sich doch garnicht die Frage mit Luma und Chroma Signal Auftrennung und verfügbarkeit.


    Wird S-Video statt Composite gewünscht könnte man dann eine Zwischenplatine einsetzen, und müsste die Schlatung für nen getrenntes Luma/Chroma mit drauf packen, welche dann beide Signale ggf. mit Clips an die Buchse bringt...

    Genau so könnte das gemacht werden:

    • Verbindung Pin 4 und 5 trennen - entweder auf der Platine oder an der Buchse selbst. Das wäre der einzige "impact".
    • Ohne Zwischenadapter: An Pin 4 kommt Composite raus. Pin 5 ist nicht (mehr) belegt.
    • Mit Zwischenadapter: An Pin 4 kommt nur noch Luma raus, Chroma wird auf dem Adapter neu generiert und "von Hand" auf Pin 5 geführt.

    Man könnte sogar einen Jumper vorsehen, dass Chroma wahlweise auch wieder zurück auf das Board geführt wird, dann muss man die Adapterplatine nicht mal mehr rausführen.


    Oder eben die Buchse austauschen gegen eine 8-polige.

    Die Ursprüngliche Schaltung auf dem Board müsste dabei dann mithilfe der Platine natürlich gleichzeitig übergangen/ignoriert/tot gestellt werden.

    Nö, die wird weiter verwendet für Luma, wäre ja auch schade drum. ;-)

  • Pin 4 ist doch für Composite Out... Und wird doch dort von C64er Compostite DIN Kabeln erwartet. Wieso also ein Konflikt?

    Gemeint ist wohl umgekehrt. Am VC20 liegen Composite-Signale auf Pin 4 und Pin 5. Deshalb "nur noch" an Pin 4. Wobei die beim VIC20CR einfach parallel liegen müssten. Die alte VIC20-Version hatte dort noch einen zusätzlichen Tiefpass auf Pin 4.


    Ob es überhaupt Kabel gibt, die Composite nicht an Pin 4 abgreifen, weiß ich nicht. Glaube ich fast nicht. Jedenfalls keine neueren Datums.

  • Genau so könnte das gemacht werden:

    • Verbindung Pin 4 und 5 trennen an der Buchse selbst.

    Das würde aber die einfache Rückbaufähigkeit (wenn gewünscht) aber erschweren, daher eher ungeeignet *denk*

    Nö, die wird weiter verwendet für Luma, wäre ja auch schade drum. ;-)

    Wenn das geht ist ja gut, ich dachte könnte evtl. das Signal an der Buchse dann irgendwie stören.

  • Das würde aber die einfache Rückbaufähigkeit (wenn gewünscht) aber erschweren, daher eher ungeeignet *denk*

    Na ja, eine neue 5-polige Buchse einlöten ist jetzt kein Drama, wenn man es unbedingt zurückbauen muss, weil man Millionen mit dem Verkauf des wieder originalen VC-20 verdienen will und kann. :-P


    Jedenfalls besser, als eine Leitung zu zerkratzen. Das lässt sich nicht so leicht vollständig und originalgetreu zurücknehmen.

    Wenn das geht ist ja gut, ich dachte könnte evtl. das Signal an der Buchse dann irgendwie stören.

    Nein, das stört nicht, hab' ich bei meinem Test mit dem Lochrasteraufbau (siehe paar Seiten weiter vorne) ja genau so gemacht. ;-) Für das Chroma-Signal habe ich die Transistorstufe nochmals nachgebaut, für das Luma-Signal habe ich die auf dem Board vorhandene weiter verwendet.

  • Na ja, eine neue 5-polige Buchse einlöten ist jetzt kein Drama, wenn man es unbedingt zurückbauen muss, weil man Millionen mit dem Verkauf des wieder originalen VC-20 verdienen will und kann. :-P

    Jedenfalls besser, als eine Leitung zu zerkratzen. Das lässt sich nicht so leicht vollständig und originalgetreu zurücknehmen.

    Ja, weiß was Du meinst, ich dachte da auch eher an die Leute die keinen Lötkolben halten oder nutzen können :)

    Und die Leiterbahn muss man ja auch nid flicken.. kann ja so bleiben ^^


    Nein, das stört nicht, hab' ich bei meinem Test mit dem Lochrasteraufbau (siehe paar Seiten weiter vorne) ja genau so gemacht. ;-) Für das Chroma-Signal habe ich die Transistorstufe nochmals nachgebaut, für das Luma-Signal habe ich die auf dem Board vorhandene weiter verwendet.

    :thumbsup:

  • Lochrasteraufbau.. Platine.. ah ok.

    Ja, für den Nachweis, dass die Idee mit der separaten Transistorstufe taugt. Bevor ich mir da Arbeit aufhalse will ich erst wissen, dass es tut, was ich mir ausgedacht habe, :-P

    Ich dachte an eine Platine die unterm VIC montiert wird.. Daher dann auch der komplette Chroma Luma Aufbau dazu darauf

    Ja, das wäre jetzt der Plan. In etwa so:


    • Die Platine kommt in den VIC-Sockel auf dem VC-20-Board.
    • Der VIC (6561) auf die Fassung auf der Platine.
    • Luma wird wie bisher auf das VC-20-Board geschickt, durch die dort vorhandene Transistorstufe verstärkt und liegt an Pin 4 an.
    • Chroma wird entweder wie bisher auch auf das VC-20-Board geschickt, dort wie bisher mit Luma zusammengemischt - dann liegt an Pin 4 "Composite" an - wie bisher. (Jumper auf die oberen beiden Pins.)
    • Oder aber - Jumper auf die unteren beiden Pins - Chroma wird durch die Transistorstufe auf der Adapterplatine verstärkt und liegt am Lötpunkt rechts an, von wo es z. B. auf Pin 5 der Video-Buchse gelegt werden kann.

    Nein, ganz ohne Löten geht es nicht. Man muss einen(!) Draht von der Adapterplatine zur Buchse legen und Pin 4/5 irgendwie aufgetrennt bekommen. Eine Herkulesaufgabe ...

  • ich dachte da auch eher an die Leute die keinen Lötkolben halten oder nutzen können

    Hat mich jemand gerufen? :strom:

  • Ja, das wäre jetzt der Plan. In etwa so:

    Aber das hat doch schon was. Ich könnte mir vorstellen, dass ich davon ein paar Platinchen machen lasse, wenn Du das freigibst?

    Dann könnte man nach und nach fertig bestückte Platinen zum Selbstkostenpreis abgeben. Hat jeder was davon.


    Tolle Arbeit!

    :thumbup:

  • wenn Du das freigibst?

    Mache ich, wenn ich weiß, dass es so tut, wie ich es mit vorstelle. Es hat niemand was davon, wenn halbgares Zeug unter die Leute geworfen wird. ^^

    Also bitte ein wenig Geduld. ;-)

    Dann könnte man nach und nach fertig bestückte Platinen zum Selbstkostenpreis abgeben. Hat jeder was davon.

    Das kann sehr gerne dann jemand machen, dann ist allen geholfen.

  • kinzi :thumbsup:


    Ja, genau, sehr gut! In etwa das hätte ich auch vorgehabt, wenn mich nicht der Mut verlassen hätte. :) Kommt für mein Board leider zu spät. Aber mal schauen, vielleicht probiere ich das dann trotzdem mal. Bei mir wäre ja dann durch den Jumper zwischen beiden S-Video Mods umschaltbar. Ob man einen Unterschied erkennt?

  • wenn mich nicht der Mut verlassen hätte.

    Ich hab ihn inzwischen wieder gefunden. EasyEDA im Browser ist derart Klasse, da macht das Layouten sogar Spaß. Mal sehen, ob ich in Übung komme und nicht alles vergessen habe, :-)

  • Ich hab schon Platinen gelayoutet, da dachtest du noch, "Platine" sei eine Eissorte von Schöller! :alt:


    :D


    (Ich bin sonst so gar kein "Cloud"-Fan, aber hier werfe ich meine Prinzipien alle über Board.)

  • Mal sehen, ob ich in Übung komme und nicht alles vergessen habe,

    Wenn Du so gut in Fahrt bist... :D ...ein Nachtrag zu meinem letzten Post: Ich hatte ursprünglich noch die Vision, Y/C auf der Platine zusätzlich "sauber" zusammenzuführen, vielleicht zumindest in der Qualität eines C64. Wie man das dann vielleicht sogar noch Pin-Kompatibel nach außen führen würde, ist wieder eine andere Frage.

  • Ich will mich jetzt nicht von der Arbeit drücken :-D ... aber das könnte natürlich im Stecker des Kabels erfolgen - zumal ja bei der 5-poligen Buchse ein Pin für Composite dann fehlt.

    Das probieren wir aus, wenn das Zeug auf dem Tisch liegt. Retro-Computing ist vor allem eines: ein Marathonlauf. :-D