C64 geht nicht wenn man ihn verwendet


This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • C64 geht nicht wenn man ihn verwendet

    Hallo,

    Problem: C64 läuft, aber funktioniert nicht, wenn man ihn verwenden möchte.

    Platine 407
    Der C64 hat immer dieses Problem
    Kenntnisse vorhanden

    Was passiert:
    Schwarzes Bild.

    Mit MAX Modul: schwarzes Bild

    Mit 1541U: Menü wird im Besten Fall korrekt dargestellt, inkl. Cursor. Man kann sich im Menp bewegen, jedoch nichts starten -> schwarzes Bild.
    Das Menü der 1541U wird mittels "DMA" erzeugt - ich weiß nicht in wie fern sich da auf die ICs bzw. Testgenauigkeit auswirkt.

    D.h. für mich, dass CPU, ROMs (-> Max Cart Test), CIA(s? zumindest jener der Tastatur müsste OK sein), PLA (trotzdem ausgelötet und getestet -> OK), VIC-II (getestet -> OK), Takterzeugung OK sein müssen, sonst würde es ja auch mit 1541U nicht laufen.

    Der SID gibt einen "typischen Ton" von sich, wenn man Reset drückt ändert sich der Ton so lange man Reset hält (d.h. wohl auch -> Reset ist OK).

    Der TV zeigt ein Bild an, jedoch schwarz. Es ist nicht "kein Signal", d.h. Takterzeugung, VIC-II, Modulator ist OK.

    Es ist fast alles gelötet, daher keine weiteren (einfachen) Tests möglich. Die Platine ist einfach zu löten, Tests sind also mit etwas Aufwand möglich.

    Speicher hatte ich im Verdacht, jedoch sind es gute OKI Chips und Piggyback bringt keinerlei Änderungen. Mit dem Max Modul Test ist es auch eher unwahrscheinlich, weil ja weite Teile des Speichers nicht verwendet werden. Meist wird zumindest irgendwas dargestellt mit einem Max-Modul.

    Es sind keine MOS TTL verbaut.
    Kein Chip wird extrem HEISS.
    Das Netzteil ist natürlich OK (mit anderem C64)
    Die Farben sind im 1541U Menü korrekt dargestellt - 2114 Color RAM wird etwas warm, aber nicht sehr.


    Ich habe dann
    U15 LS139
    U14 LS258
    U8 LS06
    getauscht (blank screen lt. Ray Carlsen), jedoch keine Änderung am Verhalten.


    Vielleicht hat jemand eine Idee bzw. weiß, was genau die 1541U macht bzw. welche Teile bei DMA verantwortlich oder nicht benötigt werden (und daher ausgeschlossen werden können).

    LG
    Images
    • IMG_20190419_020706 (Custom).jpg

      267.38 kB, 1,280×960, viewed 14 times
  • computercollection wrote:

    Das Menü der 1541U wird mittels "DMA" erzeugt
    Ich kenne das Teil nicht, aber wenn das so ist, wird doch die interne CPU (6510) nicht verwendet? Dann wird nur der Bildschirminhalt per DMA ins RAM geschrieben, das der VIC dann darstellen soll? Dann würde ich mal auf die CPU tippen, oder eines der ROMs zieht den Bus runter; das RAM ist vom CPU-Bus abgekoppelt ist und kann offensichtlich vom VIC angesprochen werden.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)