Probleme mit OS 4.1 FE und der UAE Zorro 3


  • Eisman
  • 217 Views 11 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Probleme mit OS 4.1 FE und der UAE Zorro 3

    Hallo Leute,

    ich habe mir Amiga OS 4.1 FE auf Winuae emuliert. Leider kann ich die umfangreiche Farbpalette nicht nutzen da die UAE Zorro 3 Karte nicht funktioniert. Entweder bleibt das Bild Schwarz oder Rosa. Habe mich schon durch mehrere Seiten/Beiträge belesen. Auch wenn ich versuche OS 4.1 auf AGA Grafikeinstellung zu installieren, hört es mitten in der Installation auf. Weiß jetzt nicht mehr weiter. Vielleicht kann mir einer von euch helfen. Libs sind installiert und bei Monitors ist die Datei UaeGfx Datei hinzugefügt.
  • Habe mal Screenshots gemacht:

    EDIT: Bilder ins Forum hoch geladen und in den Beitrag eingefügt! war64burnout





    Bei OS 3.9 klappt es ohne Probleme, habe es gerade probiert. Bei 4.1 bekomme ich halt nur rosa oder schwarz zu sehen. Außer auf der farbarmen Picasso IV.

    The post was edited 1 time, last by war64burnout ().

  • Eisman wrote:

    Mit Picasso 4 läuft es ja ohne Probleme. Bloß sobald ich UAE Zorro 3 verwende bekomme ich nur noch einen schwarzen oder einen rosa Bildschirm.
    Was heist den "UAE Zorro 3"?

    Im ersten Wurf von WinUAE und OS4.1 wars wichtig, dass man einen A4000 zurechtkonfigurierte in den Hardware-Settings. Ob das noch so ist, weiß ich nicht...
    • A4000 Kickroms
    • 2MB Chip
    • 256MB RAM auf der Turbokarte (und 16MB RAM onboard, wenn gewünscht) mit den Eproms der CyberstormPPC
    • Picasso IV im Zorro3 Modus (keine UAE-Grafiktreiber)
    • Eine HDF, kein Windows-Ordner als Filsystem
    Neo Geo AES 3-4 || Apple IIe || C64 ASSY 250425 || A500+ || A1000 (GB-Edition) || A3000D rev.9.01 || A4000D rev.B
  • Ich meine UAE Zorro III RTG Graphic Card. Die bietet deutlich mehr VRAM und höhere Auflösungen als die Picasso IV mit 4MB. (siehe Bilder)


    Picasso IV OS4.1

    UAE GFX OS3.5


    Das klappt bei OS 3.5 ohne Probleme aber bei OS 4.1 eben nicht. Habe schon viele Videos gesehen aber bei mir funktioniert es nicht. Vielleicht hat ja jemand die perfekte Einstellung für dieses Problem beim WinUAE.

    The post was edited 1 time, last by Eisman ().

  • Eisman wrote:


    Ich meine UAE Zorro III RTG Graphic Card. Die bietet deutlich mehr VRAM und höhere Auflösungen als die Picasso IV mit 4MB. (siehe Bilder)
    Du meinst, in welchem Modus die PIV benutzen willst/kannst.
    Die PIV kann ZorroII und ZorroIII.
    ZorroII kann nur 8MB verwalten, womit die 4MB PIV reinpassen sollte. Die hat ja nur 4 MB Video RAM.

    Im ZorroIII Modus steht dem Zorro-Bus fast 4GB Adressen parat. Da dürfte genug luft sein für weitere Karten.

    Im echten Amiga ist auch der Takt ein anderer. ZorroIII ist deutlich flotter als der alte Standart. In wie weit das in WinUAE implementiert ist weiß ich nicht.
    Mit der Video RAM-Größe auf der PIV hat die Zorro-Einstellung jedoch nichts zu tun.

    Eisman wrote:


    Vielleicht hat ja jemand die perfekte Einstellung für dieses Problem beim WinUAE.
    Schau dir mal die Einstellungen von Thomas an, der hatt das auf jeden fall richtig eingestellt:
    thomas-rapp.homepage.t-online.de/os41uae/index.html
    Neo Geo AES 3-4 || Apple IIe || C64 ASSY 250425 || A500+ || A1000 (GB-Edition) || A3000D rev.9.01 || A4000D rev.B
  • Die Einstellungen von Thomas hatte ich ja schon. Funktioniert gut mit Picasso III. Mit der Einstellung kannst du aber nicht das UAE Zorro III Board nutzen. Was nun mal mehr Leistung hat. Ich habe auch schon Videos im Internet gesehen wo es geklappt hat. Leider kann man die Einstellungen von den nicht nachvollziehen. Auf 3.5 klappt es, bei OS4.1 startet er nicht mal. Sobald du das UAE Zorro 3 Board nimmst
  • New

    Habe alle nötigen Roms, sonst würde ja OS 3.9 nicht laufen ;)

    Aber das Problem ist gelöst, habe Thomas Rapp angeschrieben. Es war eine Einstellung in WinUAE. Jetzt funktioniert es endlich mit einer höheren Auflösung.

    Obwohl ich sagen muss, ich bin nicht so begeistert, dachte einige Sachen wurde im vergleich zu OS 3.9 geändert(zb. die Probleme mit Warp3D) aber leider blieb der gewollte Erfolg aus. Und kann eigentlich nur davon abraten OS 4.1 zu kaufen wenn man den Vorgänger besitzt. In meinen Augen sind die Verbesserungen nur kosmetischer Natur.