Only 3 cores working - other not

  • Hi!


    Today arrived my new MiST with MIDI. I downloaded wanted cores and tried to test.
    Sadly only 3 cores working, even ST core not.
    Working cores are: Amiga, Commodore 16 and PC Engine.
    Not working, tested was FAT and FAT32 filesystem: Commodore VIC20, Commodore 64, Atari 800, Atari ST, Apple II+, Macintosh, MSX, Amstrad, ZX81, ZX Spectrum, Sam Coupé (Amstrad and Sam Coupé is possible that haven't all required files, other had).


    Devices connected to MiST:
    - USB power supplied by PC
    - Japanese 109 key USB keyboard
    - 5 button USB mouse
    - Competition Pro DB9 joystick (from my Commodore 128)
    - 2GB and 4GB microSD card with adapter


    Symptoms:
    - 3rd LED blinks 5 times - in troubleshotting text is written: FPGA did not respond properly to the initialization attempt. Make sure there's a valid core.rbf on the card
    - valid core there was - in case of 3 working submitted
    - MiST firmware: ARM s/w ATH160910 - flashed by date 10th September 2016


    Really I was at beginning surprised and confused that I have no all files for tested core required, so after failure I checked them (except last Amstrad and Sam Coupé - I had wrong feel)...
    Amiga works in config 68020 with turbo, PAL, AGA chipset, LoRes and HiRes HV filters, chip RAM 2MB, slow 1.5MB, fast 24MB, Kickstart 3.1 ROM and empty harddisk - tested games: Last Ninja 3, Lotus 1 (n-w), Lotus 2, Lotus 3 (n-w).
    Commodore 16 works with 64K and 16K RAM too, tested Basic program
    PC Engine works, only know not what a ROM it needs (I used from PCE, loaded, then not responding)...


    Where I do mistake?
    Miro

  • I connected it to power by my phone charger.
    I tried 3 microSD cards (2GB, 2GB, 4GB formatted with FAT32 and also FAT) with adapter - can be problem here? If, why Amiga and C16, PCE too, cores working?
    I used 2 LCDs.


    In all not working cores at power-on MiST reports problem (5 times LED blink) that no core work or init problem. But don't know how to solve it...


    My mist.ini
    [mist]
    scandoubler_disable=0 ; leave 0 if not sure
    mouse_boot_mode=0
    joystick_ignore_hat=0
    ; key_remap=04,05
    ; key_remap=05,04


    Miro

  • I mean you're true.
    I found no one SD card at home, only old 16 MB (!!!! Megabyte !!!!) MMC card.
    I tried to format it to FAT32, but not supported, only FAT and exFAT.
    But I tried - I put there C16 core (working) as default and C64 too.
    After power-on LED blinks 2 times - not usable FS on card - so also C16 core started not.
    But it has lot info - LED blinks 2 times (other error message), so there is problem not in MiST - it's in card used.
    Tomorrow I buy any card and reply. If will no reply, don't have card yet.


    For to be sure:
    Want to buy 32 GB SDHC card.


    Thank you.
    Miro

  • My friend helped me and lent me 1GB SD card. Tomorrow I will buy or buy not my 8GB SD card.
    Why maybe not?


    I put on SD card Atari ST core, not start - 5 times blinks LED.
    Then I made default C64 core - the same
    Put there also mist.ini - nothing helped.
    Make default C16 core - works, but this core was working on microSD with adapter too.
    Card is formatted by FAT32 FS.


    So, what to do?
    Where is problem? In firmware?
    Or?


    Miro

  • So, I tested other cores, in list are most important for me:
    C64 - works, 2 versions - I tried it also on microSD and there works too
    C16 - works
    VIC20 - not found in other location than downloaded (not working)
    Atari 800 - starts, after pushing menu button displays garbage
    ZX Spectrum - failure except old one, but this only starts and displays garbage, not possible to access menu, so MiST restart required
    Macintosh Plus - failure
    Menu - even this works not
    ...
    I tried not Amiga and PCE because they were working also with microSD
    ...
    So, I mean when some working on SD and also microSD - for example here downloaded C64 - it is not only or not totally problem of SD vs microSD
    Tomorrow I buy 8GB SD card and test all detaily.
    But it looks bit like firmware (flash is dated to 10.9.2016) problem - maybe has bug(s) or I need other because older versions working...
    What do you mean now?


    Miro

  • Yes, cores downloaded from here haven't problem.
    Ok, if ou can I want these cores:
    Commodore VIC20
    Atari 800 and XL
    Atari ST
    Amiga tool for logo exchange
    Apple II+
    Macintosh Plus
    MSX
    Amstrad CPC
    Amstrad Trex
    ZX Spectrum 128
    ZX81
    Sinclair QL
    BBC
    Sam Coupé
    PC Engine (to be sure)
    Menu
    Please if you can pack in cores all required files.


    I want to ask for Commodore PET 2001 for Nexys3 - I downloaded it from GitHub and tried to generate bitstream but Vivado reports missing files... can you help me with download too?


    Thank you. If is it possible I add you to friends and both can share more.
    Thank you very much!


    Miro

  • Aha!
    I did it by context menu save link as...


    Thank you, it's very useful for future.
    Ok, you helped me also in other case. I own also Nexys4DDR and using there Mega 65 and Apple II. Yesterday I tried to compile Commodore PET project downloaded same way, but few files were missing - archive was not corrupted, for now I hope that problem was in download.
    Thank you again, Kris.
    Miro