Austausch Nano SID gegen 6581R4AR


  • Zack
  • 365 Views 16 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Austausch Nano SID gegen 6581R4AR

    Hallo. Damit sich mein guter, alter Brotkasten nicht so fürchtet, habe ich ihm ein C64 II Brüderchen zur Seite gestellt. War zwar nicht billig, aber man gönnt sich ja sonst nichts 8o .
    Der Cevi II ist top in Schuß. Alle IC's sind gesockelt, statt des alten Basic/Kernal ROM hat er einen umschaltbaren Kernal. Nur eines gefällt mir nicht - er hat keinen originalen SID drin, sondern den Nano.
    Mir geht es nicht um den Sound oder seine Qualität, aber es funktionieren keine Joysticks, Paddels und die Mouse mehr. Und die möchte ich vordringlich haben.
    Nun habe ich noch einen wohlgehüteten SID 6581R4AR da liegen. Ich möchte den Nano gegen 6581 austauschen. Im Forum habe ich aber gelesen, das der 6581 an einem Pin aber 12V braucht, das 250469Rev.3 Board aber nur 9V bringt. Ist in dem Fall die Funktion des 6581 gewährleistet, oder gibt es Probleme oder Einschränkungen? Ist beim Tausch etwas wichtiges zu beachten, außer dem Üblichen, wie Position usw.? Ich würde den Nano auch gerne tauschen gegen einen originalen 8580 und, wenn der Preis vernünftig ist, auch entsprechenden Wertausgleich zahlen.
    Was meint Ihr dazu?
  • Zack wrote:

    Also bringt der Nano auch Joystick Unterstützung?
    Die Joysticks haben nichts mit dem SID zu tun, wie laufen über die CIA (6526). Wenn die Joysticks nicht gehen hast du aber i.d.R. auch probleme mit der Tastatur...

    Zack wrote:

    Ich habe einen Quickshot II dran und der Kursor zappelt im Programm wie irre hin und her.
    Autofire ist aber aus, oder ? :gruebel

    Zack wrote:

    Aber zum 6581, kann ich den bedenkenlos an statt des Nano einsetzen?
    Das kannst du probieren. Kann funktionieren, muss aber nicht (das Board liefert halt nur 9V statt 12V). Und bedenke: die externen Filter sind etwas anders beschaltet, somit wird der auch anders klingen.
    Idealerweise nimmt man bei einem 469er Board einen 8580 und baut noch den DigiFix dazu.

    Gruß, Gerd
    Wer andern eine Bratwurst brät braucht ein Bratwurstbratgerät.
  • Hallo Gerd,
    ein Foto habe ich nicht. Da müßte ich ihn noch mal aufschrauben, wenn es nötig ist. Soll ich auf etwas besonderes achten?
    Ich habe mal meine FCIII+ und zwei Joysticks angeschlossen. Kurz nach dem Start der Karte beginnt der Zeiger zu zappeln, auch ohne Joysticks. Mit Joys läßt er sich nicht steuern nur mit der Tastatur. Ich habe den Doctor64 von der Cartridge durchlaufen lassen. Alles funktioniert ohne Probleme, Sound, RAM, Video, Joysticks und Tastatur. Laufwerke und Drucker habe ich keine angeschlossen. Jetzt bin ich etwas ratlos. Die Tests sprechen für einwandfreie Funktion. Ich möchte den Fehler gern einkreisen, bevor ich sinnlos teure Ersatzteile kaufe.

    Grüße Enrico
  • Zack wrote:

    Ich habe mal meine FCIII+ und zwei Joysticks angeschlossen. Kurz nach dem Start der Karte beginnt der Zeiger zu zappeln, auch ohne Joysticks.
    Das kommt vom FCIII, das fragt die Paddles ab (für die Maussteuerung). Und da der NanoSwin das nicht kann (ich gleube ein Paddles sind hier einfach offen) kommt es zu dem Zittern.

    Ich vermute mal stark: an den Joyports ist nix karpott. Probier mal ein paar Spiele aus ...

    Gruß, Gerd
    Wer andern eine Bratwurst brät braucht ein Bratwurstbratgerät.
  • Soooo, folgendes. Ich habe alles, bis auf das Floppy abgezogen, ein Spiel eingelegt und reibungslos gestartet. Danach einen Joystick angeschlossen, Spiel gestartet, läuft reibungslos und läßt sich spielen. Meine zweites Floppy (oceanic) mit angeschlossen und schon ging das Spiel nicht mehr zu laden. Also Floppy 2 ab und alles funktionierte wieder. Dann habe ich das SD2IEC angeshlossen und den darauf gespeicherten Browser "NAV96" gestartet. Und der Mouszeiger des Programms zappelte auch wie wild herum. Zu weiteren Test's bin ich nicht mehr gekommen. Nächste Woche geht's weiter.

    VG Enrico :winke:
  • Zack wrote:

    Browser "NAV96" gestartet. Und der Mouszeiger des Programms zappelte auch wie wild herum.
    Alles was eine proportional Maus nutzt wird mit dem SwinSid nicht laufen (zu Glück ist das nicht so vieles)

    Zack wrote:

    Meine zweites Floppy (oceanic) mit angeschlossen und schon ging das Spiel nicht mehr zu laden.
    Welches Spiel? Einige Loader akzeptieren nur ein Gerät am IEC
    Wer andern eine Bratwurst brät braucht ein Bratwurstbratgerät.
  • ADAC wrote:

    Zack wrote:

    Ich habe mal meine FCIII+ und zwei Joysticks angeschlossen. Kurz nach dem Start der Karte beginnt der Zeiger zu zappeln, auch ohne Joysticks.
    Das kommt vom FCIII, das fragt die Paddles ab (für die Maussteuerung). Und da der NanoSwin das nicht kann (ich gleube ein Paddles sind hier einfach offen) kommt es zu dem Zittern.

    CapFuture1975 wrote:

    War da nicht was, dass der SwinSid nicht kompatibel mit dem FCIII ist, daher auch das Zappeln des Mauspfeils.
    Die Joysticks müssten aber in Spielen noch funktionieren, wenn nicht, ist die CIA kaputt.
    Ja, im FCIII spinnt der Maus Zeiger definitiv bei nem Nano Swinsid... Ist völlig normal und korrekt, was ADAC und CptFuture geschrieben haben.

    Du könntest aber noch nen SwinSid Ultimate statt nem richtigen 8580 nehmen, der hat auch Paddle Support...
    Demnächst hoffentlich wieder bei Ihrem Dealer des Vertrauens erhältlich (Restore-Store oder Polyplay). @Bobbel kann sicher was zum aktuellen Stand sagen...

    Oder Du packst z.B. nen MixSid auf Dein Board drauf, bei dem Du dann beide Arten von SID's inkl. der richtigen Filter/Digifix nutzen kannst