Hello, Guest the thread was called3.1k times and contains 62 replays

last post from muhahaha at the

Eine weitere Linuxpartition in Bootmanager von Debian 9 einfügen.

  • Da sind aber mehrere Platten verbaut, nicht nur mehrere Partitionen auf einer Platte. Was sind denn die zwei 500 GB-Platten? Da sind WIndows-Partitionen drauf.

  • Auf den weiteren Platten sind keine Betriebsysteme drauf. Die sollen später als Datenspeicher für die NAS-Funktion dienen.


    - Unter anderem ist da eine 500GB SATA-Festplatte
    - Ein Stripe-Verbund von 3 SCSI-Platten (Hardware Raid) ca. 460GB


    - Zwei SCSI-Platten im Wechselrahmen (260GB, 80GB) aber momentan deaktiviert.


    Die Platten sind zur Zeit noch unter NTFS formatiert.

  • Dann hast du da aber eine relativ krude Anordnung ... ich würde erwarten, dass man die Systemplatte so anschließt, dass sie zu /dev/sda wird. Aber egal.

    Quote from shodan

    Von Openfiler könnte ich kein Fdisk absetzen. Da gibt es keine Benutzeroberfläche. Ich konfiguriere Openfiler über das WEB-Interface. Dann aber auch nur die NAS-Funktionen.

    Das wäre aber sehr hilfreich. Das Ding hat doch sicher mindestens eine Text-Konsole?


    Auf jeden Fall ist auf einer der Platten noch ein Windows 7 (-Rest) drauf, daher der zweite Eintrag. So wie es aussieht in der grub.cfg ist die Aufteilung:


    (hd1,msdos1) -> Windows 7 "Rest" von irgendeiner Installation (vermutlich auf einer der 500er-Platten)
    (hd2,msdos1) -> Windows 7 auf Platte 2 (von der auch XP gebootet wird) -> dürfte die 250er sein.
    (hd2,msdos3) -> Windows XP auf Platte 2
    (hd7,msdos1) -> Openfiler


    Der Knackpunkt dürfte sein, dass unter Openfiler die Platten anders heißen, daher wäre ein fdisk -l von dort auch vorteilhaft, siehe oben. Vermutlich ist das Problem der Parameter "root=/dev/sdh2" am Ende der mit "linux" beginnenden drittletzten Zeile [EDIT] der Datei /boot/grub/gerub.conf bei Debian [/EDIT]:

    Ändere das mal bitte testweise auf

    Code
    1. root=UUID=d5abcb8c-d3f6-432c-81b7-c33137888b50

    das ist die UUID der Platte, dann müsste es egal sein, welchen sdXX-Bezeichner die Platte bekommt.


    [EDIT 2]


    Sorry, noch ein Fehler im Eintrag, UUID= vergessen!
    Jetzt müsste es passen.


    [/EDIT 2]

  • Ach ja, und wenn du schon Debian bootest :D mach mal bitte ein

    Code
    1. ls -halF /dev/disk/by-uuid

    damit man die UUID- <-> Disk-Zuordnung erkennen lann.

  • Ja. Da gibt es eine Textkonsole. Da kann ich mich aber nicht einloogen, da folgende Meldung erscheint:



    Das mit der grub.cfg und der UUID-Zuordnung mache ich gleich.

  • Ja. Da gibt es eine Textkonsole. Da kann ich mich aber nicht einloogen, da folgende Meldung erscheint:

    Na prima ... :cursing::thumbdown: ...
    Per SSH geht auch nicht?

  • Muss ich gleich probieren. Hab gerade wieder über Debian gebootet.


    Hier erst mal die UUID-Zuordnung:




    Edit:


    Wie kann ich die grub.cfg bearbeiten?

  • Wie kann ich die grub.cfg bearbeiten?

    Kommt drauf an, was du für Editoren hast:

    • nano /boot/grub/grub.cfg
    • vi /boot/grub/grub.cfg
    • mcedit /boot/grub/grub.cfg
    • joe /boot/grub/grub.cfg

    nano ist der einfachste für DOSen-Benutzer. vi ist der mächtigste, aber SEHR gewöhnungsbedürftig. mcedit ist für Norton-Commander-Benutzer. joe kenne ich glaube ich nur dem Namen nach.


    Hier erst mal die UUID-Zuordnung:

    Prima.


    Irgendwie würfelt der dir aber ständig deine Plattenbezeichnungen neu, wie mir scheint.


    Jedenfalls muss in der grub.cfg als root=UUID= Eintrag die Partition stehen, die auf der 17 GB-Platte die zweite ist, die ist 8 GB groß und sehr wahrscheinlich die root-Partition des Openfilers. Im vorherigen Screenshot war das /dev/sdi2. Die Partition /dev/sdi1 dürtfe die Boot-Partition des Openfilers sein.


    Am besten machst du "fdisk -l" und "ls -halF /dev/disk/by-uuid" mal gleich nacheinander, dann sollten die Bezeichnungen zueinander passen.

  • Die 8GB Partition ist eine leere NTFS-Partition.


    Das mit dem Editor habe ich nicht ganz verstanden. Ich habe versucht aus der Root-Konsole per Edit die grub.cfg zu bearbeiten. Das wurde abgelehnt, da grub.cfg nur lesend ist.

  • Ja, das sollte so sein. Wenn du "id -u" eingibst und "0" ausgeworfen wird, bist du User Nr. 0 (= root).


    In dem Fall mach bitte ein "mount | grep sd" (das | ist ein "pipe", kein L) und poste bitte das Ergebnis.

  • Gut, ich verstehe zwar noch nicht, wieso auf der 17 GB-Openfiler-Platte eine 8 GB-WIndows-Partition ist :gruebel , aber welche ist dann die Openfiler-Root-Partition? Du hast da wirklich ein seltsames Partitions-Schema ...


    Die Platte mit 17 GB heißt anscheinend /dev/sdi, suche die UUID-Bezeichner aus der Liste oben und trage die Root-UUID als Parameter für die drittletzte Zeile ein. Dann müsste das klappen.

  • Die Partitionsgrößen hatte Openfiler bei der Installation automatisch so vorgegeben. Die 8GB hatte ich mit NTFS formatiert, da ich es ansonsten als Speicherplatzverschwendung empfunden habe.


    Die Platte mit 17 GB heißt anscheinend /dev/sdi, suche die UUID-Bezeichner aus der Liste oben und trage die Root-UUID als Parameter für die drittletzte Zeile ein. Dann müsste das klappen.


    Da wären wir wieder bei dem Problem, dass ich nicht schreiben kann.


    Der Cursor springt wild in der Datei herum und die angefügte Meldung erscheint.


  • Ah, nein, vergiss, du meinst eije andere 8 GB-Partition, grad nochmals nachgeschaut, es gibt auch noch eine 8 GB "Linux"-Partition (sdi2)
    Es müsste also /dev/sdi2 sein, vor der bitte die UUID nehmen.


    Was ist das für ein Editor? "vi" z. B. gibt diese Warnung aus, mit ":wq!" kann man das Schreiben trotzdem erzwingen.


    [EDIT]


    OK, du verwendest vi, die Meldung "W10" und schreibgeschützt kommt von vi. Das ist nur eine Warnung, du kannst mit angehängtem "!" trotzdem schreiben bzw mit einem


    :wq!


    den Editor mit schreiben verlassen.


    [/EDIT]

  • Ich habe einfach "edit grub.cfg" in der Root-Konsole eingegeben.

    Autsch ...


    Warum nimmst du nicht nano wie geraten?


    Und siehe mein Edit oben.

  • Okay. Mit Nano habe ich das nun gerafft. Ich kann nun grub.cfg editieren.


    Sorry für meine Schwerfälligkeit. :schande:



    Ich habe allerdings keine UUID für sdi2. sdi2 scheint es gar nicht zu geben.









    Die UUID welche du im Beitrag 23 genannt hast, funktiomiert jedenfalls nicht.