ASSI 250407 Schwarzes Bild


  • stones73
  • 1197 Views 66 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • ASSI 250407 Schwarzes Bild

    Hallo,

    ich hab von eine Kollegen insgesammt 2 C64 und 2 1541 bekommen, alle ohne Funktion, von daher möchte ich der Reihe nach die Geräte Reparieren.

    Anfangen möchte ich mit ner 250407 mit Schwarzem Bild und ohe Funktion.
    Floppy läuft an beim einschalten aber blind Ladebefehle eingegeben passiert nichts.

    Gesockelt sind die beiden CIA´s der Kernal und U13 UND U25
    Die beiden waren schonmal der Übeltäter auf einem alten Board von mir, die wurden hier schonmal gegen SN74LS257AN getausch. evtl. sind die ja wieder hinüber.
    Bild habe ich angehängt.

    Punkt 1:
    Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.

    250407

    Punkt 2:
    Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?

    Orginal
    nb
    Punkt 3:
    Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?

    wurde mit einem Funktionierenden getestet

    Punkt 4:
    Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?

    nein

    Punkt 5:
    Tritt das Problem sporadisch auf oder ständig?

    ständig

    Punkt 6:
    Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?

    nein

    Punkt 7:
    Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?
    (Die billigen 5-Euro Multimeter reichen für diesen Job aus)

    Ja

    Punkt 8:
    Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.

    Ja

    Nachträge:
    Punkt 9: Reagieren Laufwerke korrekt auf Ladebefehle, mit LED-Blinken oder gar nicht?

    Garnicht aber beim einschlaten läuft die Floppy kurz an

    Bonusbitte: Ein Foto von der Platine auf dem man die Chipbezeichnugnen lesen kann, erleichtert die Fehlersuche auch ungemein.

    Bilder hänge ich an

    Wer mit dem Multimeter umgehen kann, kann auch gleich noch die Spannungen messen: Versorgungsspannungen messen: Messpunktbilder

    5 und 12 Volt liegen an VR1 und VR2 an

    Jemand ne Idee was ich noch testen könnte?

    Danke und Gruß
    Stones
    Images
    • 20190322_151653-min.jpg

      497 kB, 2,264×4,032, viewed 30 times

    The post was edited 1 time, last by stones73 ().

  • Haben alle ICs Spannung? Hier (Klick) kann man das C64_Service_Manual_314001-02_(1985_Feb) .pdf runterladen, da stehen die Pinbelegungen drin, so dass man das messen kann.

    Hat Dein Multimeter ne Frequenzmessfunktion? In dem Fall koenntest Du durch diese (Klick) Punkte gehen und die Frequenzen durchgeben.

    Hat der zweite C64 die gleiche Platine, und hat der auch gesockelte ICs (falls man zum testen umstecken will)?

    Hast Du ne Sichtpruefung von der Unterseite der Platine gemacht?

    Welche ICs werden heiss? Sollten CPU, PLA, VIC und SID sein.
    Mein USB + Game Port Joystick Projekt: gitlab.com/edge-records/joyweiler
  • So Spannungen:
    U1 5V CIA
    U2 5V CIA
    U3,4,5 5V wenn ich richtig gemessen habe
    U7 5V
    U9-12 5V RAM
    U17 5V PLA
    U18 5V SID
    U19 5V
    U21-24 5V RAM

    Heiß werden U3,U4,U18 und U19. die anderen werden Handwarm

    Reset an CPU

    Pin 40 geht auf 5V

    CIA rausgenommen weiter schwarzes Bild CIA getauscht weiter schwarzes Bild.
    Federkontaktsockel für das Kernal hab ich nicht... werd ich aber mitbestellen
  • stones73 wrote:

    Heiß werden U3,U4
    U3 und U4 werden normalerweise nicht heiß ... das ist verdächtig. SID Und VIC werden heiß ... das ist grundsätzlich normal.

    Man muss systematisch vorgehen, weil es für einen schwarzen Bildschirm mehrere Fehlerquellen geben kann.

    Werden einzelne RAM-ICs heiß? Kannst du mit dem Fingerrücken erfühlen ... das wäre auch ein Indiz.

    Hast du zufällig irgendein Spielmodul zum Einstecken?

    Diagnose-Hardware hast du sicherlich nicht ... ich empfehle übrigens das CHECK64 von @GMP.
  • U3 (Basic-ROM) + U4 (Kernel-ROM) sollten nicht heiß werden!

    Falls sie wirklich heiß werden, ziehen sie höchstwahrscheinlich auch den Bus nach unten.

    Ein Ultimax-Modul würde eher Aufschluss bringen als das "Nordic Power" aber das eher mit entfernten BASIC-ROM und KERNEL-ROM!
  • stones73 wrote:

    Kernel und Basic raus Nordic eingesteckt -> Schwarzes Bild
    Ich kenne das Nordic Power nicht, aber startet das denn überhaupt im Ultimax-Mode, sodass kein Kernal-ROM benötigt wird?
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • stones73 wrote:

    So... alle ic´s drinn, Nordic Power eingesteckt -> Schwarzes Bild
    Kernel und Basic raus Nordic eingesteckt -> Schwarzes Bild

    Temperaturen:
    Basic Heiß

    Kernal Heiß
    Das hatte ich doch letztens auch mal...

    Wenn ich jetzt noch wüsste obs die CPU oder die PLA war *grübel*
    Kernal und Basic waren nämlich okay.
  • Korrigiert mich wenn ich falsch liege, aber von hier waere alles weitere Raetselraten. Du hast entweder die Option die ueblichen Verdaechtigen in der Reihenfolge der Wahrscheinlichkeit zu tauschen bis es wieder geht, oder Du musst mit nem Frequenzmessgeraet weitermachen, evtl sogar reicht das nicht, und brauchst nach einigen Tests ein Oszilloskop, um den Fehler weiter einzugrenzen.
    Mein USB + Game Port Joystick Projekt: gitlab.com/edge-records/joyweiler
  • Gerrit wrote:

    Eine defekte PLA, die die /CS-Leitungen für KERNAL und BASIC dauerhaft auf LOW hält kann zu heissen Chips führen, ja.
    Kann mir jemand die Pins sagen und ob ich die mit dem Multimeter ausmessen kann?
    Hat jemand noch nen tipp für ein Multimeter mit Frequenzmessung? Budget "klein"
    Bis wieviel MHZ sollte die Frequenzmessung gehen?

    PLA muss ich eh für das andere Board bestellen... den könnte ich dann hier testen.
    Wo bekommt man noch CPU`s her?
  • stones73 wrote:

    Kann mir jemand die Pins sagen und ob ich die mit dem Multimeter ausmessen kann?
    Schaltplan der 250425 in der Schaltplangalerie (ist auch für 250407 gültig, wenn es um die ROMs geht):


    Pinouts der wichtigsten RAMs EPROMs und ROMs in der Schaltplangalerie:


    Mit dem Multimeter (Spannungsmessung) prüfen, ob "/CS" an den ROMs dauerhaft auf 0 V liegt.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)