Hello, Guest the thread was called2.1k times and contains 20 replays

last post from CommieSurfer at the

C64 (ASSY 250469) sehr langsamer Start, schwarzer Bildschirm

  • Hallo zusammen,


    ich habe hier einen C64 (ASSY 250469) der mir ziemliche Sorgen macht. Er hat offenbar gleich mehrere Defekte. Die Symptome sind folgende:
    Er braucht sehr lange, bevor er überhaupt ein Lebenszeichen von sich gibt. Ich dachte zuerst sogar, dass er komplett tot ist. Das Netzteil scheint in Ordnung und liefert die gewünschten 5V und 9V (wobei es etwas mehr als 9V sind). Wenn ich ihn einschalte und an den Chips oder dem Kassettenport messe, stelle ich fest, dass der Computer zu Beginn statt der 5V lediglich 1,2 V Gleichspannung bekommt, die dann aber ganz langsam ansteigt. Irgendwann erreicht er knapp 5V, die LED geht an (wenn angeschlossen) und der Bildschirm bekommt anscheinend ein Signal, bleibt aber schwarz. Anschließend kann ich ihn ein- und ausschalten ohne dass er lange braucht. Dabei blitzt immer das Bild kurz weiß auf und bleibt dann schwarz. Wenn ich ihn dann wieder stehen lasse und er "kalt" wird, dauert es beim nächsten Einschalten wieder sehr lang.


    Bei der Fehlersuche habe ich als erstes festgestellt, dass die beiden RAM-Chips extrem heiß werden, also habe ich sie als erste Maßnahme gleich mal ausgetauscht. Die neuen werden nicht mehr heiß - geändert hat sich aber sonst nichts. Außderdem habe ich den Hinweis bekommen, dass ein defekter An/Aus-Schalter die Ursache sein könnte, also habe ich den ebenfalls getauscht. Das war es aber auch nicht (es sei denn, der Ersatz ist ebenfalls defekt...).


    Wegen der langen Verzögerung beim ersten Start habe ich die Kondensatoren in Verdacht, obwohl sie zumindest von außen alle einwandfrei aussehen. Deshalb werde ich als nächstes wohl alle Kondensatoren austauschen. Ich wollte aber vorher mal fragen, ob es noch andere Ideen gibt. Hatte schon mal jemand diese Symptome? Was könnte es sonst noch sein?


    An dem Gerät ist, soweit ich weiß, nie etwas modifiziert worden (Garantiesiegel war noch intakt).

  • Wenn das Netzteil im Leerlauf 5V liefertt, heist es nicht, dass es dies unter Last auch tut. Hast Du einen anderen C64, der damit läuft? Ist das ein Originalnetzteil oder ein Neues? Ich würde einmal gleich an der Eingangsbuchse messen. Und fann sehen, ab wo die 5V nicht mehr 5V sind.


    Außerdem kannst Duna einmal so viele Bausteine rausziehen, wie geht. Die LED liegt nur über einen Widerstand auf 5V, ist beim 469er aber auf dem anderen Ende. Vielleicht ist die Leiterplatte irgendwo gebrochen und die Spannung bahn sich irgendwie den Weg über Datenleitungen oder ähnlich. ICs, bei denen die Netzspannung fehlt, aber Pegel an den Eingängen hat, machen komische Sachen. Ich würde mir erst einmal die +5V und GND durchmessen.

  • So einen Kandidaten habe ich auch mit der gleichen Assy.
    Bei mir muß der Rechner aber schon Wochenlang ohne Strom sein, dann denkt man beim ersten anschalten immer "das wars dann"


    Da ich den Rechner aber seit längerem als Hauptrechner mit dem TC64 betreibe ist das Problem eigentlich weg.
    Ich vermute auch mal die Kondensatoren.Die werden wohl beim ersten Start zunächst soviel Saft ziehen bis sie wieder "voll" sind.

  • Das Netzteil kann ich als Fehlerquelle wohl ausschließen. Ich habe ihn jetzt noch mal eine Weile laufen lassen und an verschiedenen Stellen gemessen. Die Spannung ist zu Beginn überall viel zu niedrig (und zwar gleichmäßig), nur an der Eingansbuchse ist es in Ordnung. Es steigt dann gleichmäßig an und nach einer Weile kommt dann ein (schwarzes) Bild beim Monitor an. Wenn ich jetzt noch mal messe, bekomme ich überall sehr gute Werte im Bereich von 5,0 - 5,1 V. Egal ob am Kassettenport, am SID, an der CPU, an den RAM-Chips oder am VIC II. Auch wird kein Chip mehr übermäßig heiß. Das Bild bleibt aber schwarz.


    Ich vermute also eher zwei Probleme - eines sorgt für den langsamen Start (nicht weiter tragisch), ein anderes für das schwarze Bild - vermutlich noch ein defekter Chip?

  • Der Schalter wäre auch ein heißer Kandidat für mich und lässt sich rasch ausschließen: Einfach die Lötpunkte überbrücken und das Netzteil anstecken. Fehler weg? -> Schalter hin.
    (Lötbrücken wieder entfernen und Schalter reparieren/tauschen. :D )

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Außderdem habe ich den Hinweis bekommen, dass ein defekter An/Aus-Schalter die Ursache sein könnte, also habe ich den ebenfalls getauscht.

    Ich meine mich daran zu erinnern, das so ein verhalten eventuell auch am Schalter liegen könnte.

    Der Schalter wäre auch ein heißer Kandidat für mich

    :gruebel

  • :gruebel

    (es sei denn, der Ersatz ist ebenfalls defekt...)

    :thumbsup:


    Ich würde intuitiv auch erstnal auf einen der dicken Elkos tippen- aber hat die 469 überhaupt welche im 5V-Zweig?


    Der Schalter wäre auch ein heißer Kandidat für mich und lässt sich rasch ausschließen: Einfach die Lötpunkte überbrücken und das Netzteil anstecken.

    :!::thumbsup::!::thumbup::!:

  • :gruebel

    Es soll schon vorgekommen sein, dass ausgetauschte Bauteile auch defekt sind. Aber ja, erwischt, das hatte ich nicht gelesen. :P:rolleyes:

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Um mal konstruktiv zu werden: Hast du den Strom gemessen, den das Board zieht, sowohl wenn die Spannung "unten" ist als auch im Normalbetrieb? Da muss ja ganz ordentlich was fließen, wenn die Spannung an der Eingangsbuchse passt. Außer ... es wäre der Schalter, der einen enormen Übergangswiderstand hat. Aber den hatten wir ja ausgeschlossen. Ich würde ihn trotzdem testweise überbrücken.


    Der Siebelko auf der 5 V-Schiene ist 100 µF/16V. Die sind normalerweise total "durch" und machen einen Kurzschluss. Ein IC, das einen Kurzschluss macht und bei Erwärmung langsam aufmacht käme vielleicht auch noch in Betracht, obwohl ich glaube ich von sowas noch nie was gehört habe,


    Also, ich würde jetzt mal mit einer Strommessung beginnen, auf der 5 V-Schiene.


    [EDIT]


    Ohne der Strommessung vorzugreifen: Wenn da wirklich so ein enormer Strom fließen würde, dass die Spannung einbricht, würde sie wohl auch an der Eingangsbuchse zusammenbrechen. Das bringt mich eher zur Erkenntnis, dass da doch eine kalte Lötstelle oder ein großer Übergangswiderstand irgendwo ist, eventuell auch an der Buchse oder bei diesem Filter ("L1") am Eingang - das ließe sich ja auch ganz einfach mal "brücken".


    [/EDIT]

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Ja, der Schalter ist es leider nicht. :D Ich bin aber tatsächlich nicht auf die Idee gekommen, ihn einfach zu überbrücken. Um ganz sicher zu gehen, habe ich das eben ausprobiert, und es hat leider keine Besserung gebracht. Ich werde dann doch mal die Kondensatoren austauschen, sind ja auch nicht so viele. Ich glaube aber nicht, dass das schon alles ist. Wenn der Bildschirm selbst dann komplett schwarz bleibt, wenn die Spannungen nach einer Weile überall okay sind, ist wahrscheinlich noch mindestens ein Chip defekt. Vielleicht besorge ich mir in dem Fall ein weiteres Board, um die Chips testen zu können.


    Jedenfalls danke schon mal für die Anregungen. :)

  • Siehe noch mein EDIT oben ... und mach mal die Strommessung, und wenn's nur zum Ausschluss ist.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Ein IC, das einen Kurzschluss macht und bei Erwärmung langsam aufmacht käme vielleicht auch noch in Betracht, obwohl ich glaube ich von sowas noch nie was gehört habe,

    Ich kenne das eher umgekehrt.


    Aber unter dieser Berücksichtigung könnte man bei den Strommessungen alle gesockelten IC's entfernen.

  • was ist, wenn die Elkos, oder einer davon im Board defekt sind, weil die Spannung sich ja langsam aufbauen ?

    Konfuzius sagt…Hüte dich vor Männern, deren Bauch beim Lachen nicht wackelt.

    Es ist keine Schande, nichts zu wissen, wohl aber, nichts lernen zu wollen.


    Wenn ich tot bin, dann begrabt mich mit dem Gesicht nach unten! Dann kann mich die Welt am Arsch lecken. ** Der Joker **

    --------------------------------------------------------------------------------------------------------------------------

  • Ich kenne das eher umgekehrt.


    Aber unter dieser Berücksichtigung könnte man bei den Strommessungen alle gesockelten IC's entfernen.

    Ja, klar, es war ja auch nur der (schlechte) Versuch, das seltsame Verhalten irgendwie :nixwiss: zu erklären.

    was ist, wenn die Elkos, oder einer davon im Board defekt sind, weil die Spannung sich ja langsam aufbauen ?

    Schon möglich, nur meistens sind die Elkos "durch" und bleiben das (Dauerkurzschluss) oder aber haben einen Kurzschluss, der sich dann "auflöst" (durchbrennt), Aber dieses "Aufladeverhalten" finde ich komisch, vor allem, weil die 469 keine großen Elkos hat und die 5 V ja am Eingang da sind.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Wenn die Spannung an der Buchse stimmt, danach nicht, dann liegt es aber nicht an einer Überlast irgendwo. Miss doch einmal am Schalter... davor und danach. Wenn sie an Eingang des Schalters höher als am Ausgang ist, dann ist der Schalter hochohmig. Die Dinger sind teilweise arg oxidiert. Wenn Du ihn auslötest und öffnest, dann kannst du es sehen. Guten Ersatz gibt es beim retro-store.de. Besser als ein Original von ebay (3€ vs 10€).

  • @kinzi kenne das von Videorecordern, wenn die Elkos alt werden, fangen sie an zu pumpen, bis sie volle Kraft haben und arbeiten.


    Danach kommt der Exodus.


    Die Idee mit Schalter ist such OK. Aber das kann man ja schnell testen, wie oben schon geschrieben.

    Konfuzius sagt…Hüte dich vor Männern, deren Bauch beim Lachen nicht wackelt.

    Es ist keine Schande, nichts zu wissen, wohl aber, nichts lernen zu wollen.


    Wenn ich tot bin, dann begrabt mich mit dem Gesicht nach unten! Dann kann mich die Welt am Arsch lecken. ** Der Joker **

    --------------------------------------------------------------------------------------------------------------------------

  • @kinzi kenne das von Videorecordern, wenn die Elkos alt werden, fangen sie an zu pumpen, bis sie volle Kraft haben und arbeiten.


    Danach kommt der Exodus.

    Ja, das gibt's, dieses Phänomen ist meiner Meinung nach aber anderes gelagert: Der Elko verliert Kapazität, daher "pumpt" das Schaltnetzteil, d. h. die Regelung läuft nur schleppend an, bis der Elko am Ende schließlich so wenig Kapazität hat, dass die Schaltung gar nicht mehr anläuft. Das kenne ich auch von Monitoren, Grundig hatte in diese Richtung mal eine Zeit lang einen "Lauf". :D


    Im C64 kann da für mein Verständnis aber nichts "pumpen". Die Elkos sind nur zur Filterung/Glättung drin, wenn du die rauslötest ist die Spannung bei einem ansonsten intakten C64 trotzdem bei 5 V und baut sich nicht erst langsam auf. (Dass ohne die Elkos der C64 nicht oder nicht richtig funktioniert ist klar, weil die ganz kurzen Belastungsspitzen nicht abgefangen werden, das ist aber ein anderes Problem.)


    Und ein kurzgeschlossener Elko kann es eigentlich nicht sein, aus den oben dargelegten Gründen. Aber gut, mich wundert mittlerweile gar nichts mehr. :bgdev

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Ich habe mir jetzt ein zweites Board besorgt, und konnte dadurch einiges ausschließen:
    - Das Netzteil arbeitet einwandfrei
    - Der VIC II funktioniert ebenfalls
    - Auch dem SID geht es gut


    RAM hatte ich wie erwähnt bereits ausgetauscht, der schwarze Bildschirm könnte also noch an irgendeinem der anderen festgelöteten Chips liegen. Da gibt es ja noch einige Kandidaten. Ich bin aber schon mal froh, dass VIC II und SID überlebt haben. Mal schauen, ob ich das Board selbst auch noch retten kann, wenn ich mir etwas mehr Zeit nehme um die anderen Teile zu überprüfen.