Seltsam störrische 1541

  • Hallo,


    Ich habe zwei meiner C64 mit Jiffy (Rechner und Floppy) ausgestattet. Läuft. Mein "Hauptrechner", mein eigener C64 aber macht Probleme. Bzw. dessen Floppy:


    Ich habe den C64 in den frühen 80er Jahren in Berlin auf Speedos Pr mit 40 Tracks umrüsten lassen. In der Floppy wurde also ein Speedos eingesetzt mit einem Schalter (40 Tracks on / off). Ihr seht die "Bastelei" auf dem angefügten Bild.


    PROBLEM DER FLOPPY 1541:


    Entferne ich diesen Adapter / Sockel mit dem Parallelkabel: Kann die Floppy nicht mehr angesprochen werden. (!)


    Ganz gleich, ob ich ein originales ROM (Hier als Beispiel auf dem Kabel liegend), JiffyDos 1541 (liegt mal für das Foto neben dem Laufwerk) einsetze: Das Laufwerk kann nicht angesprochen werden, btzw. reagiert nicht. Nur, wenn ich das alte Bastelrom UND Parallelkabel wieder zwischen den Chip stecke, funktioniert das Gerät einwandfrei.
    (Laufwerk / Leuchten erscheinen normal, leuchten beim Start auf, Betriebskleuchte bleibt, Schreibzugriffleuchte verlischt: Also ganz normal, wie alle meine Floppies).
    Load "$",8" gebe ich ein, der Rechner steht, keine Reaktion der Floppy.


    Nochmal:


    Floppy mit Bastel-Speedos-ROM + Adapter Parallelkabel : Läuft


    Floppy mit orig. Rom + Orig Chip des Paralellkabel: Läuft nicht
    Floppy mit Chip + Orig Chip des Paralellkabel: Läuft nicht


    Der Chip an dem Parallelbastelwerk ist aber original. Ich erinnere mich, das das Speedoskabel einfach "dazwischengesteckt" wurde und Speedos alles weitere regelte. Warum also funktioniert die Floppy an meinem C64, wenn ich das parallele Kabel erntferne? Mir gelingt es nicht einmal, das Ding zurückzubauen (Also Eproms raus, Parallelkram raus, org. Chips rein). Der Chip über dem Paralellkram scheint doch der richtige / originale, oder?


    PS;: Ich habe meine zwei funktionierenden Floppies nicht hier im "Bastelhaus", dort komme ich erst in zwei Wochen wieder hin, um die Floppies auzuschrauben und den Parallel-Chip zu vergleichen.


    Jemand einen ungefähren Rat, was ich übersehe?


    Gruss Ray

  • Mir fällt auf, daß der eine 6522 ausgeixt ist. Das macht man normalerweise nur um einen Chip als Defekt zu Kennzeichnen. Möglicherweise geht er noch für Paralellbetrieb aber nicht mehr für Seriell.


    Andere Möglichkeit die ich wüßte wäre, daß im C64 ein anderes Kernal Eingesetzt wurde das nur Paralell kann. Ein anderes Kernal ist bestimmt drinnen, weil das Originale nur Seriell kann.

    Wem es beim Bit zählen schwindelig wird, der hat zuviel davon.


    Alt werden ist schön, das Altern nicht.

  • Huhuu, die "xxx" habe ich vor zwei, drei Wochen gemacht, als ich meine zwei anderen Floppy mit Jiffy versorgt und diese das erste Mal geöffnet hatte. (cIch habe noch einen anderen Chip gehabt mit "OOO", und wollte die nicht verwechseln. ;) )


    Im C64 selber, bzw. die zwei Testgeräte hier werkeln originale Chips, die gegen Jiffy getauscht werden sollen.


    Ich weiss mir da im Moment keinen Rat. Mir gelingt es derzeit nicht, die Floppy "zurückzubauen", Obwohl ich die originalen Chips hier habe.


    Hmmmm.

  • Es könnte ja auch sein, dass Dein Originales Dos Rom inzwischen ne Macke hat...


    Da Du aber keine weitere Floppy aktuell da hast, musst Du wohl warten, bis Du auf den Rest zugreifen kannst - oder Du hast die Möglichkeit Dir mal fix eins zu brennen...

  • Hallo. Die Chips hatte ich ja schon raus. Optisch habe ich an den Sockeln keine Basteleien, Veränderungen oder ominöse Kabel sehen können. Ich schaue morgen aber nochmal.


    Nur komme ich nicht dahinter: mit Parallelkabel, das nicht mal am c64 mehr steckt, läuft die Floppy einwandfrei. Entferne ich den Sockel mit den Parallelkabeln und ersetze das Rom durch funktionierendes Jiffy oder Original : funktioniert das Ding nicht mehr. Zum Haare raufen, ich kam nicht dahinter. Wenn das Ding so mit Bastellösung nicht laufen würde, wäre der oder ein Defekt irgendwie...
    ...verständlich.


    Grübel.

  • Was passiert denn, wenn Du das Parallel Kabel drin läßt, und dann ein Original oder JiffyDOS rein steckst.


    Das Kabel nutzen diese beiden sowieso nicht, und darf auch nicht stören.


    Sollte die Floppy dann laufen, stimmt da etwas nicht.

  • Nur komme ich nicht dahinter: mit Parallelkabel, das nicht mal am c64 mehr steckt, läuft die Floppy einwandfrei. Entferne ich den Sockel mit den Parallelkabeln und ersetze das Rom durch funktionierendes Jiffy oder Original : funktioniert das Ding nicht mehr. Zum Haare raufen, ich kam nicht dahinter. Wenn das Ding so mit Bastellösung nicht laufen würde, wäre der oder ein Defekt irgendwie...
    ...verständlich.


    Grübel.


    Täuscht es mich oder hat Deine Floppy diese billigen 1 seitigen Federkontakt Sockel drauf?


    Du hast in diesen Sockeln (sowohl beim VIA als auch beim DOS) Präzisionssockel drauf stecken, auf denen dann die IC's drauf sind -diese haben breite runde pins und auch mehr Kontakt im Sockel.


    Check mal genau die Kontakte der Federkontaktsockel auf der Platine.. und vorallem schau auch, dass wenn Du die IC's ohne die Präzisionssockel rein stopfst auch die Pins nicht zu sehr nach außen abstehen, da bei den 1 Seitigen Sockeln nur innen so ne Feder-Nase ist.


    Alternativ könntest Du auch mal testen, was passiert, wenn Du das Jiffy Kernal nicht direkt sondern mit dem Präzisionssockel (also speedos runter) einbaust.
    Falls Du das aber die ganze Zeit schon so machst, dann machs direkt.. Denn Präzisionssockel passen sich meist dem IC an was eingesteckt wurde und bei einem anderen kann auch da ein Kontaktproblem bestehen...Sie sind nicht für zuviel oder mehrfachen IC-Wechel gemacht...


    Könnte sich evtl. um nen reines Kontaktproblem bei einem der beiden IC's/Sockel handeln (vermutlich beim VIA Sockel, da Du ja schreibst, dass wenn Du den Parallel-Sockel drin hast es läuft - vermute dann hast Du im DOS Sockel ja auch Jiffy drinnen)


    Mach doch mal Bilder ohne die zusätzlich aufgesteckten Sockel.

  • Ich hab noch was Entdeckt, das Parrom ist 28 polig und steckt in einem 28 poligen Sockel. Das Originale hat aber nur 24 pole, ebenso die Anschlüße vom Jiffy. Daß das Par-Rom so Funktioniert, kann nur bedeuten, daß da was Verändert wurde, möglicherweise an dem Sockel selbst.

    Wem es beim Bit zählen schwindelig wird, der hat zuviel davon.


    Alt werden ist schön, das Altern nicht.

  • Leute, Leute ... das ist ein *stinknormales* SpeedDos mit 35 Tracks ... da passt das Eine nicht zum Anderen ... schaut doch mal genau hin ... :facepalm: .


    Und keiner weiß, was da auf dem EPROM drauf ist ... ?


    Brenne das EPROM mal neu & mache zunächst mal ein normales SpeedDos-System daraus ... dann schreibe ich hier supergerne weiter.

  • Ich hab noch was Entdeckt, das Parrom ist 28 polig und steckt in einem 28 poligen Sockel. Das Originale hat aber nur 24 pole, ebenso die Anschlüße vom Jiffy. Daß das Par-Rom so Funktioniert, kann nur bedeuten, daß da was Verändert wurde, möglicherweise an dem Sockel selbst.

    1) Deswegen ist ja mal interessant zu wissen, was er eigentlich genau wie rein stopft...


    2) Nein da muss nix verändert sein... Er muss aber, falls er das Jiffy Rom inkl. Platine auf den 28 poligen Präzisions Sockel steckt (und nicht direkt auf den 24 poligen Sockel in der Platine) darauf achten, nicht vorne an der Kerbe das Jiffy anzusetzen, sondern halt von hinten aus anzusetzen (natürlich mit der Kerbe in Richtung Kerbe) . Die Pins der Adapter-Platine müssen praktisch auf gleicher Höhe liegen wie das Rom daneben. Die Pins im roten Kästchen bleiben leer





    Leute, Leute ... das ist ein *stinknormales* SpeedDos mit 35 Tracks ... da passt das Eine nicht zum Anderen ... schaut doch mal genau hin ... :facepalm: .


    Und keiner weiß, was da auf dem EPROM drauf ist ... ?


    Brenne das EPROM mal neu & mache zunächst mal ein normales SpeedDos-System daraus ... dann schreibe ich hier supergerne weiter.

    Er will doch gar kein SpeedDOS und Parallel-Betrieb... Sondern Jiffy und Seriell.,..-.Wozu sollte er das neu brennen...

  • ... um sein System zu testen, weswegen er hier einen Thread aufgemacht hat.


    Er kann das Jiffy-EPROM mit dem gelben Aufkleber aus seinem Adptersockel rausmachen ... das ominöse SpeedDos-EPROM (Umschalter?) aus der Floppy rein ... alles einsetzen ... das RICHTIGE Kernal in den C64 ... dann sollte zumindest das SpeedDos laufen.


    Hat er die richtige 28/24-ROM-Umschaltplatine überhaupt?


    Falls er kein SpeedDos möchte ... JiffyDos rein ... Klappe zu ... und gut ist.


    Wozu hier der ganze *Bohei* ... ach ja ... ist Karneval? :silly:


    Störrische 1541 ... die 1541 ist definitiv nicht störrisch, sondern funktioniert doch einwandfrei.


    Nun alles mal in Ruhe gedanklich sortieren ... Marcel ... du müsstest das doch wissen ... :party2: .


    P.S.: Ein vernünftiges SpeedDos 40 Tracks sieht SO aus ... nachstehend Beispielbilder ... simple as that.

  • Bevor wilde Spekulationen auftauchen, mal bitte rekapitulieren.


    Soweit ich verstanden habe, hat er getestet:


    SpeedDOS Rom + Adapter für Parallelkabel = Läuft
    Anderes Rom ohne Adapter für Parallelkabel = Läuft nicht.


    Daher wäre es mal extrem interessant zu wissen, ob ein anderes ROM läuft, wenn der Adapter für das Parallelkabel drin bleibt. Wenn ja, dann liegt es nicht am ROM. Wenn der nackte 6522 keinen richtigen
    Kontakt hat, läuft die Floppy auch nicht.


    Und wenn man auf dem Bild mal genau schaut, dann ist das JiiffyDOS wesentlich höher, als die PROMS daneben. Also scheint da ein Adapter zwischen zu sein. Und auf dem Bild sieht man ja auch, dass das JiffyDOS
    unten einen 24pol. Sockel hat. Also werden die anderen EPROMS ebenso einen Adapter haben.


    Also als nächstes den Adapter für das Parallelkabel drin lassen UND ein anderes EPROM/PROM rein. Wenn sie dann läuft, ist es NICHT das EPROM.

  • Hallo,


    "vernünftiges" Speedos und solche Spielereien: Seit 1985 steckt genau diese Lösung unverändert in dem Laufwerk. Genau zu der Zeit, 1985 / 1986 in Berlin eingesetzt. Damalig war das eine saubere und vernünftige Lösung. 2002 wurde das Laufwerk einmal generalüberholt: Neuer Antriebsriemen, neuer Motor aber Platine und Bastelei unverändert belassen. In den ganzen Jahren lief das Laufwerk zwar wenig aber unverändert einwandfrei. Und ja, es handelte sich um ein Speedos Pro 35/40. Damalig war das der "Renner". 1986 waren die mir zugänglichen Möglichkeiten technisch beschränkter als so ein sauberer aufbau wie im Bild. Da gab es Dutzende "Builds" des Speedos, teils angepasste Modifikationen in einem Chip. Die wildesten Lösungen.


    Das Speedos hängt mit Unterverlötungen / Kabel auf einem Adaptersockel und "passt" daher. Quasi ein Adapter ohne Platine. Solche "Bastellösungen" waren damalig in meinem Kreis sehr weit vertreten. Ich komme aus einer ländlichen gegend, war aber Sportler und während Schule mit 14 bis 18 Jahren in Berlin unterwegs. Und da gab es eine wirkliche "Bastelszene", die solche wilden Lösungen reihenweise umgesetzt hatte. So wurde mein zweiter C64 z.B. in ein PS_Gehäse gebaut, mit externer Tastatur und Spiralkabel. Völlig simpel, heutzutage lächerlich aber damalig war das einfach der "Renner". Gerade dann wieder zurück aus Berlin in normaler Gegend. ;) Ihr müsst etwas zurückdenken: Damalig war ich 14 jähriger Schüler und die anderen jene Bastler Elektroniker. Selbst ich Laie würde heute anders und sauberer ansetzen: Damalig war das aber absolut "normal". Und Niemand hatte damit gerechnet, einen C64 nach dreissig Jahren noch zu nutzen. Ich kam nach Berlin, da schwärmte dann einer der Bastler von wieder einer neuen Speedos-Lösung, also wurde die wieder eingesetzt. Und immer von eben den "Bastlern".


    Ziel: Speedos soll raus. Alle Floppies werden auf Jiffy umgestellt, alle C64 haben oder werden auch. Für meine heutigen Retroaufgaben reicht mir die Lösung vollkommen aus und so kann ich jederzeit C64 oder und Floppies zu- und untereinander tauschen = alles "ein" System. Das halte ich für eine gute Idee. Ich muss nur noch ein paar Jiffy ordern, jetzt wo soweit alles vorbereitet ist.


    LÖSUNG: Zur Laufzeit: genau DA liegt das Problem. 1986 wurde dieses Speedos eingesetzt und unter dem Chip die Parallelösung. Seit dem lief das unverändert:


    In den 30+ Jahren gab es eine Materialermüdung (!): Sowohl Eprom Adapter wie auch der mit dem Kabel haben diese Euch sicher bekannten, runden aber massiven "Füsse". Die Floppychips selber haben diese sehr zarten, ganz flachen, verglichen dünnen Pins. Im Laufe der Zeit (man bedenke dreissig Jahre) ist einfach der Druck der Chipfassungsklemmen auf die runden und somit minimal umfangreicheren Pins angepasst. Der normale, originale Chip mit den Flachen Pins, gibt einfach keinen (zuverlässigen) Kontakt mehr in der Fassung (!).


    Darauf bin ich überhaupt nicht gekommen. Danke einem Nutzer.


    Edit: Ja, das Speedos sitzt auf einem Zwischensockel, also "Adapter". Und meine Jiffys (sowohl Floppies wie auch C64) habe ich auf die für mich absolut sauberen Lösungen des Restore-Store gesetzt. Für meine Zwecke absolut ausreichend. Und natürlich hatte ich ein Jiffy, das funktioniert, in den Bastellaufwerken immer eingesetzt zum Test. Und gerade getestet: Ja, JiffyDos (oder das originale) MIT der Parallellösung funktionieren.


    Ihr hattet gestern Abend also Recht: Es ist ein ganz simples "Kontaktproblem". Ich komme leider gerade erst wieder an einen PC. Lösung: Ich löte das Parallelkabel einfach ab und lasse den alten (aber so dann funktionierenden Adapter) einfach als Zwischenstecker eingesetzt.


    Sorry, aber auf die Lösung Kontakt der Beine bin ich so nicht gekommen. Ich vermutete einen Defekt oder was auch immer. Daher: DANKE wieder an Euch.

  • Doch, absolut: Das ist ein 40 Track Speedospro. ich habe versucht das zu erklären, dann noch einmal kürzer:


    Andere Zeiten, andere Techniker, andere Lösungen. An dem Speedos-ERprom ist ein Schalter, der zwischen 35 oder 40 Tracks umschalten lässt. Ich habe das jahrelang genutzt und vor Wochen noch einmal vor dem Öffnen getestet. Das Ding ist noch original von 1986 und ich hatte in ein paar meiner alten Floppies unterschiedliche Speedos 35/40 Track Lösungen in einem Chip.
    Von "BCS Speedos" (die Berliner Bärencracker" über "Klaus Pagen" bis zu zwei andere Namen in der Einschaltmeldung. Einige Bastler, die damalig EPrombrenner hatten (1984 bis 1986 war das noch etwas besonderes) hatten Speedos angepasst: Die F Tasten etwas anders belegt, die Einschaltmeldungen verändert, die List Routinen nochmals verändert. Solche Dinge. Ich erinnere mich, vier Laufwerke gehabt zu haben, in jedem eine andere SpeedDos Lösung. Fast alle mit Umschalter 40 Tracks.


    Mir wurde ja unverfroren "keine Technikkentnisse" vorgeworfen, aber 1986 war ich "dabei". Gerade Berlin war wirklich "Szene". So hatte ich z.B. eine Speedosversion mir angepasst, in dem ich die Bildschirmfarbe angepasst hatte und die F-Tasten so, wie ich sie an meiner CP-C64 Externtastatur z.B. besser nutzen konnte konnte. Irgendejemand brannte das, ein anderer setzte das auf Sockel und fertig. Persönlich hatte ich z.B. nur BASF-Disketten genutzt, zweiseitig, die auch bei / mit 40 Tracks mir keine Fehler lieferten. Schon damalig sortierte ich Spiele zusammen, fasste "Onefiler" oder packte meine eigenen Trainer drauf. (Ich mochte keinen Vorspann: Spiel laden, unlimited Life y/n, Spiel startet, fertig. Das hatte ich für fast meine Spielesammlung selber so angepasst und auch jetzt für meien SD Lösungen in Nutzung).


    Ich habe hier meine originale Hardware teils immer noch. Ein paar Floppies / Rechner waren seit 1986 ungeöffnet. Ich habe jetzt alles gereinigt, überholt, in ein paar C64 schon Jiffy eingesetzt, die Laufwerke gereinigt, auch Jiffy und so weiter.


    Ich bitte zu bedenken: Das letzte mal hatte ich 2002 meine C64 / Floppies aufgebaut. Da gab es vorherrschend noch nicht die SD-Lösungen, einfache Dinge wie 1541U oder SD2IEC und Co. Zumindest für mich nicht. Jetzt haben wir 2019, ich setze derzeit wieder an und versuche, die Hardware einheitlich und auf längere Sicht zu halten. Für mich sind einige Dinge nur neu. Und ich möchte an den C64 meine überholten Laufwerke weiter nutzen, auch, wenn SD2IEC und Co bequem(er) sind.


    Meine 4 Amiga 1200, meine ganzen A600 und Co habe ich inzwischen selber "recapped", erneuert, aktualisiert, teils sogar Abschirmbleche ersetzt, Minilüfter, Kickumschalter, SD-Karten, Speichererweiterungen. Das wollte ich nicht: nicht wieder unendlich "basteln". Zudem schaffe ich das zeitlich nicht, da ich weltweit als Fotograf tätig bin. Was auch hier im Forum zu Abwertungen führte. Nebenher mal ein paar Jiffyplatinen löten oder Dinge tauschen: Kleinkram. Aber aufwendiges, da suche ich mir einfach zuverlässige Bastler. Mit Möglichkeiten und Werkzeug. Und wenn das einen Monat dauert, ist das unwichtig.


    Anbei ein Foto des SpeedDos Bastelwerks. ;)