Vorstellung Projekt magicFlash64


  • zschunky
  • 5035 Aufrufe 185 Antworten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Neu

    zschunky schrieb:

    falls du einen parallel programmer hast, der den avr flashen kann (zb minipro). könntest du noch mal den atmega rausziehen und die mf64-firmware.bin aus dem release flashen. Die Fuses müssen wie folgt gesetzt sein lo:e6, hi:7f, ext:fe
    Ich habe genau das gerade mal getan, und das Ergebnis ist verblüffend: Es funktioniert ALLES wieder. Der Flash scheint völlig in Ordnung zu sein, das Menü funktioniert (Ohne, daß ich dieses neu geflasht hätte!) und es meldet auch keinerlei CRC Fehler mehr für die Slots. 8|
  • Neu

    bigby schrieb:

    Ich habe genau das gerade mal getan, und das Ergebnis ist verblüffend: Es funktioniert ALLES wieder. Der Flash scheint völlig in Ordnung zu sein, das Menü funktioniert (Ohne, daß ich dieses neu geflasht hätte!) und es meldet auch keinerlei CRC Fehler mehr für die Slots.
    schön zu hören. Ich frage mich nur wie der avr auf einmal alzheimer bekommen hat und wie es dazu gekommen ist. wahrscheinlich waren nur teile der firmware defekt und deswegen hat noch die restore taste reagiert, aber das umschalten des kernal nicht mehr.
    Hattest Du evt. vorher mal angeschaut wie die Fuses stehen?
  • Neu

    zschunky schrieb:

    Ich frage mich nur wie der avr auf einmal alzheimer bekommen hat und wie es dazu gekommen ist. wahrscheinlich waren nur teile der firmware defekt und deswegen hat noch die restore taste reagiert, aber das umschalten des kernal nicht mehr.
    Das würde ich auch gerne wissen. Klingt alles recht unwahrscheinlich.


    zschunky schrieb:

    Hattest Du evt. vorher mal angeschaut wie die Fuses stehen?
    Du meinst, bevor ich den AVR neu programmiert habe? Ja, habe ich: Die Fuses hatten alle noch die richtigen Werte. Was ist leider nicht gemacht habe, ist, den restlichen Inhalt des AVR zu sichern.
  • Neu

    @zschunky Wie weit bist Du eigentlich mit v0.3? Der neue "Form-Faktor" sieht ja sehr vielversprechend aus! Wenn ich das richtig überschlagen habe ist die Platine am Ende nur gut 20% größer als die geplante SMD-Variante. Ist die Aussparung an der einen Ecke eigentlich für die Tastaturhalter gedacht?

    Ein Vorteil von v0.2 war, daß man die Platine bei Bedarf noch um 3mm hätte kürzen können, so daß dann 4 Stück auf ein 10x10cm Panel mit V-Cut gepaßt hätten. Das geht mit v0.3 vermutlich nicht mehr.
  • Neu

    bigby schrieb:

    @zschunky Wie weit bist Du eigentlich mit v0.3? Der neue "Form-Faktor" sieht ja sehr vielversprechend aus! Wenn ich das richtig überschlagen habe ist die Platine am Ende nur gut 20% größer als die geplante SMD-Variante. Ist die Aussparung an der einen Ecke eigentlich für die Tastaturhalter gedacht?

    Ein Vorteil von v0.2 war, daß man die Platine bei Bedarf noch um 3mm hätte kürzen können, so daß dann 4 Stück auf ein 10x10cm Panel mit V-Cut gepaßt hätten. Das geht mit v0.3 vermutlich nicht mehr.
    Ich wollte eigentlich noch ein wenig abwarten, bis es ein paar mehr Rückmeldungen gibt. Aktuell weiß ich dass ein System nicht läuft und das RW-Signal wohl Probleme macht. Wenn dann die Ursache bekannt ist kann ich die Schaltung dann anpassen, dass diese Problem dann nicht mehr auftreten soll, aber soweit ist es noch nicht.

    Die Platine v0.3 hat aktuell eine Größe von 41,275mm x 53,34mm (v0.2 ist 41.275mm x 52,705). Für v0.2 hatte ich auch ein Panel erstellt, welches in 10x10cm passt:


    Für v0.3 sollte das auch möglich sein. Mit V-Cut kenne ich mich nicht aus.
  • Neu

    zschunky schrieb:

    Aktuell weiß ich dass ein System nicht läuft und das RW-Signal wohl Probleme macht.
    Was ist das denn für ein System?


    zschunky schrieb:

    ie Platine v0.3 hat aktuell eine Größe von 41,275mm x 53,34mm (v0.2 ist 41.275mm x 52,705). Für v0.2 hatte ich auch ein Panel erstellt, welches in 10x10cm passt:

    Für v0.3 sollte das auch möglich sein. Mit V-Cut kenne ich mich nicht aus.
    Ah, ok. Ich hatte die Abmessungen Anhand des Fotos geschätzt und dacht, v0.3 wäre länger. Mit Breakaway-Tabs geht das natürlich auch, V-Cuts sind nur etwas einfacher und sauberer auseinander zu bekommen, finde ich.
  • Neu

    bigby schrieb:

    zschunky schrieb:

    bei bobbel auf seinen 250466er Board gibt es noch Probleme.
    Ah, okay. Ein 250466 Board habe ich leider nicht in meiner Sammlung, sonst hätte ich in der Richtung auch noch getestet.
    Also ich hab eins da und könnte sicher auch noch daran testen.

    Was genau geht denn nicht oder wo hakt es?

    Oder betrifft es nur ein spezielles 250466 Board und bei anderen gehts?
  • Neu

    So wie versprochen die ersten Bilder von der SMD Version. Flashen des Atmel geht. Rest kommt die Tage!
    Im Footprint ist noch ein Fehler im Widerstandnetwerk das habe ich schon im PCB geändert!
    Deswegen sieht das jetzt nicht so Toll aus bei den 10K Widerständen.





    Und Platine ist noch nicht geputz!
    Rhein Main Success Member.... / ex. Member.. BOMBZ.....

    github.com/zschunky/magicFlash64

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von cmc1976scs ()

  • Neu

    Habe jetzt nicht alles gelesen - leider reicht meine Zeit dafür nicht - aber ist dieses Projekt sowas ähnliches, wie das "36 in 1 Superkernal" ?
    Liest sich jedenfalls so ähnlich für mich Anfänger...

    Weiß jemand zufällig, wo ich was zu Gemeinsamkeiten und Unterschieden dazu finden kann? Und gibts HIERVON aktuell noch Bausätze??
    VIC20 / C64 / C128D / C16 / C+4 / Amiga 500(+) / Amiga 2000 / Amiga 1200 / Amiga 4000 / Amiga 4000 PPC / CD32 / PSone / PS2 / PS3 / PS4 / N64 / Wii / WiiU / Switch - hab ich! :D
  • Neu

    Boulderdash64 schrieb:

    Habe jetzt nicht alles gelesen - leider reicht meine Zeit dafür nicht - aber ist dieses Projekt sowas ähnliches, wie das "36 in 1 Superkernal" ?
    Liest sich jedenfalls so ähnlich für mich Anfänger...

    Weiß jemand zufällig, wo ich was zu Gemeinsamkeiten und Unterschieden dazu finden kann? Und gibts HIERVON aktuell noch Bausätze??

    ch1ller schrieb:

    everslick schrieb:

    Was sind denn die wesentlichen Unterschiede zum Superkernal 36 in 1? Ausser frei, mehr Slots, kein WLAN.
    Ganz klar... schnellere Verfügbarkeit... :bgdev Beim Superkernal wartet man ja schon ewig auf ein neues Release... (bin mir fast sicher, das MagicFlash wirds eher für alle geben)
    ..und es ist ruck zuck selbst aufgebaut.., man muss also nicht warten, bis eine Sammelbestellung umgesetzt wurde...

    tulan schrieb:

    Es sind doch einige Unterschiede vorhanden:


    magicFlashSuperkernal
    LizenzOpen Sourceclosed
    WLAN-x
    ProgrammiermenüExtra Programmintegriert
    Kernal / Programm Selectüber Restoreüber Reset
    erhältlich als Bausatz?THT / SMD-
    Benötigt Verkabelung?x-

    + günstiger
  • Neu

    Nach viel zu langer Zeit habe ich das MF64 inzwischen zusammen- und eingebaut und lasse es auf einem 407er laufen (getestet mit EPROM-PLA und PLS100). Disclaimer: ich habe noch keine Firmware aktualisiert!



    Der Test läuft anstandslos durch, aber mein SID (genauer: ein SwinSID Nano) spielt lustige Geräusch ab, wenn ich im Menu bin, und bei den Kernels mit Funktionstastenbelegung kommt immer ein kurzes Rauschen, wenn ich F-irgendwas drücke. Woran könnte das liegen? Eigentlich dachte ich, es ist alles dort auf der Platine, wo es hingehört ;) Die Kernels etc. scheinen auch alle zu funktionieren…



    Zum Test: wenn ich ihn einige Minuten laufen lasse, verfärbt sich der Rand nicht -- wenn ich Restore drücke, dann schon. Dann mag der C64 auch erst wieder, wenn er ein paar Sekunden ausgeschaltet war.
  • Neu

    Ich habe mir ja in der Zwischenzeit ein NeoRAM zusammengebaut, und habe das MF64 auch damit ein wenig getestet: Es gab keinerlei Probleme.

    Frenetic schrieb:

    Der Test läuft anstandslos durch, aber mein SID (genauer: ein SwinSID Nano) spielt lustige Geräusch ab, wenn ich im Menu bin, und bei den Kernels mit Funktionstastenbelegung kommt immer ein kurzes Rauschen, wenn ich F-irgendwas drücke. Woran könnte das liegen?
    Da bin ich überfragt, aber falls es Hilft: Es kann kein grundsätzliches Problem mit dem SwinSID Nano sein. Auf meinem 407er Bastel-Board habe ich auch einen SwinSID Nano und dort kann ich die beschriebenen Symptome nicht beobachten.
  • Neu

    Ich würde mal vermuten, dass irgendwas auf den Datenleitungen unterwegs ist... habe ein kleines Intro geladen, da klingt's auch so, als bekommt der SID alles mögliche an Daten geschrieben.

    @zschunky wo müsste ich denn suchen (kann ja gut sein, dass ich beim Aufbau was falsch gemacht habe), was ist dafür zuständig, dass MF die Finger weg vom Bus lässt?