C128 - nur C64 Modus startet

  • Hallo von einem "Neuen".
    Ich habe hier auch so einen Kandidaten: C128, vom Kollegen geschenkt bekommen. Der hatte ihn vom Flohmarkt, aber dann doch nur in die Ecke gelegt.
    Es ist ein C128, keiner mit Floppy im Gehäuse. Nachdem ich ein Netzteil besorgt hatte wollte ich mal sehen: Das Gerät ging entweder mit schwarzem Bildschirm an,
    oder es kam der grüne Rahmen, aber nur Müll in der Bildmitte. Drückte ich die Commodore Taste kam ein blauer Rahmen und wieder nur Müll in der Bildmitte.
    Ich hab das Dingen aufgemacht und gereinigt (Pinsel+Staubsauger). Dabei fiel mir auf, das ein ROM durch ein EPROM ersetzt worden war. Nach meinem Dafürhalten
    das Character-ROM - liegt am unteren Rand der Platine ziemlich in der Mitte. Das Abschirmblech hat genau da eine Lücke, sodass man da dran kommt ohne das Blech
    abzumachen. Das EPROM hat einen Adaptersockel drunter. Diese ganze Konstruktion war halb herausgerutscht und hing in der Luft. Ich habe es wieder reingesteckt.
    Fehlerbild jetzt:
    Bei gedrückter Commodore Taste startet er als C64 hoch - soll ja auch so sein. Ohne Commodore Taste kommt nur ein schwarzer Bildschirm. Schliesse ich eine 1541
    an startet er nie, wenn die Floppy angeschlossen und eingeschaltet ist. Die Floppy kriegt aber den RESET mit beim Einschalten. Es kommt dann immer ein schwarzer
    Bildschirm. Ist die Floppy aus (aber angeschlossen) kann ich den C64 Modus wieder starten. Schalte ich die Floppy danach an stürzt der Rechner nicht ab.
    Ich kann die Floppy dann ansprechen. Ich wäre für Ideen dankbar, was ich ohne herumlöten erst noch ausprobieren kann oder was ich für Infos hier ankarren soll.


    Mfg
    Tank_TEC

  • Dabei fiel mir auf, das ein ROM durch ein EPROM ersetzt worden war. Nach meinem Dafürhalten
    das Character-ROM - liegt am unteren Rand der Platine ziemlich in der Mitte.

    Das ist normal, einige haben das ab Werk schon so.


    Als nächsten würde ich mal alles was gesockelt ist rausziehen und neu stecken.


    Ansonsten wäre noch ein Bild von der Platine sehr hilfreich (besonders von der Ecke unten links)


    Gruß, Gerd