aufgerüsteter C16: Spiele crashen [aus: Speichertest für +4/C16]


  • AREA51HD
  • 104 Views 8 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • aufgerüsteter C16: Spiele crashen [aus: Speichertest für +4/C16]

    Ich habe einen C16 aufgerüstet auf 64K mit suspekten verhalten hier.
    Viele Spiele laufen unauffällig ohne probleme.
    Sehr viele Spiele die vorher einen entpacker laufen lassen, Crashen.

    Ein Video vom Memtest habe ich angehängt, ich vermute es geht etwas "Schief" wenn sich der Zeichensatz umstellt.



    Ich würde mich freuen wenn man das Verhalten etwas Analysieren könnte, Soll oder Fehlverhalten ist die Frage...
  • Ja andere RAM Bausteine sind verbaut die zumindest in der C64 ASSY250469 ihren job machen.
    Die zusätzlichen verbindungen sind auch gezogen und auch mehrfach geprüft.
    Es ist halt so ein "Bisschen kaputt" fehler, vieles Läuft, einiges weniges nicht, aber das Programm läuft in Vice Fehlerfrei.
    In Vice bleibt das Klammeraffen symbol stehen, bei meinem problemrechner ist es nach einigen sekunden weg...
  • In dem Video sieht es so aus, als würde der Test weiterlaufen, aber der TED plötzlich die Zeichensatzdaten von woanders holen. Auf Anhieb fällt mir keine Erklärung ein.

    Bitte probier einmal den C16-Test aus, nur zum Vergleich.

    Und bitte prüfe auch einmal, ob Du die ersten drei Bildschirmzeilen mit den Screencodes Null (@) und 255 beschreiben kannst - vielleicht liegt ein Bitfehler direkt dort vor, wo das Testprogramm liegt.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Die Ersten Bildschirmzeilen lassen sich beschreiben mit @ und 255 (gepoked)
    Die 16 Variante läuft wie in Vice, also Passt
    Ich habe die PLA Getauscht nun läuft auch die +4 Testvariante, so richtig verstehen tue ich technisch den fehler aber noch nicht.
    Problem-->Solved :thnks:
  • Users Online 1

    1 Guest