Vor langer langer Zeit :)


  • badpac
  • 315 Aufrufe 19 Antworten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Vor langer langer Zeit :)

    Hallo liebe Gemeinde,

    zuerst einmal was über mich. Werde bald 40 Jahre und komme aus NRW (Raum Dortmund). Das Thema C64/Amiga beschäftigte mich immer wieder da es mich in meiner ganzen Kindheit verfolgte. Damals hatte ich die Auswahl zwischen ein benzinbetriebenes Fahrzeug (Auto oder Boot) oder einen Computer. Mein älterer Bruder überredete mich für den Computer. So nahm alles seinen Lauf und nach einem C64 folgten 128, amiga 500 , 386er, 486er usw. Zuvor hatten wir noch einen Atari 2600. Leider wurde damals wie bei sovielen alles weggeschmissen da die neueren Games immer interessanter wirkten. Da mein Büro mitlerweile komplett als Spielhölle umgebaut habe, beschloss ich mir all diese schönen dinge nach und nach zuzulegen. Habe einen super seltenen Peakcock Laptop (386er) mit MS-DOS und win3.11 in besitzt. Nun habe ich mir einen C64 gekauft ohne Diskettenlaufwerk.

    Nun zum eigendlichen Thema. Da ich kein Diskettenlaufwerk besitze dachte ich mir holst gleich ein SD2IEC. Gemacht getan... angeschlosse am serial und Strom bezieht das teil vom Joystick.Port wo man dennoch weiterhin beide Ports nutzen kann. Auf dem SD2IEC befinden sich 3 Jumper? nennen wir es mal Jumper xD. Nr.1 steht drüber (ON). Bei den anderen beiden ist ne beschreibung bei welches angibt welche Adresse gewählt werden soll (8,9,10 oder 11). Eigendlich alles sehr einfach und logisch. Habe zum testen auch eine 32gb sd karte genommen und das ganze mit einem SD formatter formatiert. Ins root verzeichnis kam dann die nav96.d64 rein weil ich ganz gern schon ein filebrowser nutzen wollte.

    Also C64 an beide LED blinken auf (Rot und Grün) dann leuchtet die grüne (read) noch ne weile und dann leuchtet nix mehr. Denke mir soweit sogut. aber egal welche befehle ich eingebe entweder bekomme ich ein ?device not present error oder ein Seareching for ......

    Nun weiss ich nicht ob der C64 ein weg hat oder das SD2IEC oder ich persönlich was falsch mache. Was mich aber stützig macht ist, das man mit bestimmten befehlen die adressen ja auch manuell wechseln kann und selbst da reagiert er auf ein Device not present.


    Hat jemand vielleicht noch einen TIPP oder kommt aus NRW und hätte eventuell ein wenig Zeit und lust? Vielleicht kann man ja mit nem floppy Laufwerk oder meine Hardware an einem anderen C64 irgendwas ausschliessen.


    liebe grüsse
    baddy
  • Moin BadPac und willkommen ^^

    Versuche mal folgendes:

    Load"$", 8 (not present?)
    Load"$", 9 (not present?)
    Load"$", 10 (not present?)
    Load"$", 11 (not present?)

    Das schließt dann schon mal aus,
    ob du die DIPschalter falsch interpretierst.
    Eine 32 GB Speicherkarte ist... ähm...
    mit Kanonen auf Spatzen schießen...
    Ich hab das nie versucht, benutze nur max 4GB.

    Ein Foto der Platine hier einstellen wäre auch nicht schlecht...

    Stefan
  • Danke erstmal,

    habe es jetzt auch nochmal mit einer 4GB probiert und alle Adressen einmal durchprobiert. Immer gleiches Problem. (not present) und nach mehrmaligen probieren bleibt er irgendwann bei searching for $ hängen.

    Foto von der Platine ist so ne Sache. Da müsste ich das Gehäuse für entfernen
  • OSSI64 schrieb:

    Das SD2IEC mag keine SD HC ,wenn ich mich recht entsinne.
    Die 32GB Karte wird eine Solche sein.
    Außerdem ist sie viel zu groß,das ist wie eine Salami in den Hausflur geschmissen... ;)
    ok dann muss ich mal schauen ob ich keine SDHC finde. Weil die 4 GB die ich hier noch habe beide SDHC sind. Aber sollte man den SD2IEC nicht auch ohne ein Massenspeicher ansprechen können?
  • So,ich habe es mal ohne Karte probiert,das SD2IEC anzusprechen...
    Es kommt "saerching for $ " und "loading" ,weiter nichts.
    Abbruch mit "RUN/STOP" geht... :)
    War es nicht so,das die grüne LED immer leuchtet? (bei mir defekt!)
    Die rote Led zeigt,glaube ich,das laden des Bootladers an und geht dann aus. :gruebel
    Da hat wohl dein C64 einen Schaden davongetragen,vermute ich.
  • OSSI64 schrieb:

    Das SD2IEC mag keine SD HC ,wenn ich mich recht entsinne.
    Es hat nie eine Version von sd2iec gegeben, die nicht mit SDHC-Karten umgehen kann.

    Außerdem ist sie viel zu groß,das ist wie eine Salami in den Hausflur geschmissen... ;)
    256GB-Karten funktionieren übrigens auch, wenn man sie von exFAT zu FAT32 umformatiert hat.

    Quellcode

    1. 10 x=rnd(-1963):fori=1to81:y=rnd(1):next
    2. 20 forj=1to5:printchr$(rnd(1)*16+70);:next
    3. 30 printint(rnd(1)*328)-217

    sd2iec Homepage
  • OSSI64 schrieb:

    So,ich habe es mal ohne Karte probiert,das SD2IEC anzusprechen...
    Es kommt "saerching for $ " und "loading" ,weiter nichts.
    Abbruch mit "RUN/STOP" geht... :)
    War es nicht so,das die grüne LED immer leuchtet? (bei mir defekt!)
    Die rote Led zeigt,glaube ich,das laden des Bootladers an und geht dann aus. :gruebel
    Da hat wohl dein C64 einen Schaden davongetragen,vermute ich.
    Bei dir kommt wenigstens das loading :D
  • Wenn Du ein D64 also ein Diskettenimage in das Root Verzeichnis packst, musst Du erstmal IN das D64 Navigieren.

    Lege einen Filebrowser als PRG Datei als erstes auf die Karte ab.
    Dann kannst Du mit Load"*",8,1
    das laden und starten.

    Du kannst mit d64editor.com

    Oder Dirmaster style64.org/ddirmaster

    Das PRG extrahieren

    Edit : Ich benutze gerne den CBM Filebrowser
    commodore.software/index.php?o…-v1-6&catid=29&Itemid=126
    Dies ist der Anfang einer langen Reise...
    leicht und atemlos.
    Dies ist der Weg aus dem Tal der Tränen
    Nimm meine Hand und lass sie nie wieder los

    B.O.
  • Der Filebrowser ist natürlich notwendig,da ja komplette .d64-Diskettenseiten auf der Speicherkarte sind.Aber zuerst muss der Rechner das SD2IEC als "Laufwerk" erkennen,was momentan nicht der Fall ist.
    Ich habe mal eine x-beliebige Karte eingelegt.
    Damit "liest" er zumindest das Inhaltsverzeichnis der Karte und zeigt auch etwas an. :)

    edit:
    mein SD2IEC hängt am Datasettenport... :

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von OSSI64 ()