A500 Rev. 8.a1: 2MB-RAM-Erweiterung läuft nicht


  • Tyrex
  • 888 Views 31 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • A500 Rev. 8.a1: 2MB-RAM-Erweiterung läuft nicht

    Hallo in die Runde,

    ich würde gerne eine +2MB-Erweiterung über Trapdoor und mit Gary-Adapter an meinem Amiga 500 Rev. 8.a1 betreiben können.
    Leider weigert der sich aber und läuft nur mit der vorhandenen +512k-Karte.
    Bei der +2MB-Karte handelt es sich um eine
    Neuroth Hardware Design Mega 2/8
    mit Uhr.
    Ist da etwas zu beachten, damit sie am Rev. 8.a1 funktioniert?
    An meinem älteren 500er Rev.5 läuft sie.

    Danke vielmals,

    Arne
  • Update: Hab nochmal ohne RAM-Karte getestet. Der Rechner stürzt willkürlich ab bei Games, die auch mit 512k laufen sollten. Außerdem gibt es merkwürdiges Verhalten beim Einschalten. Mal geht er gar nicht an, macht keinen Mucks. Mal läuft er, aber mit total entstelltem Sound. Dann wieder läuft er, aber eben mit den Abstürzen. Netzteil ist eine mögliche Ursache, vermute ich als mehr oder weniger Laie mal. Auch habe ich jetzt einen korrodierten (grünspanigen) Pin 3 an U37 festgestellt. Weiß nicht, ob das auch solche Probleme machen kann (?). Somit liegt der Fehler jedenfalls nicht an der RAM-Karte, würde ich sagen.
  • Eloy_Dorian wrote:

    Grünspan an einem Chip? Hat das Board einen Akku drauf? Ein Bild vom Board und dem betroffenen Bereich sowie Typ und Revision wäre gut.
    Ja, U37 hatte an Pin 3 Grünspan. Hab ich entfernt. Desweiteren war eine RAM-Karte dran, deren Akku ausgelaufen war und wo die Lauge wohl auch einige Pins des Trapdoor-Anschlusses erschlossen hatte. Hab das so gut es ging auch entfernt. Der Rechner ist ein A500 (ohne Plus) mit dem letzten Board, dem heruntergerüsteten A500+ (Rev. 8a.1). Also steht zwar A500+ drauf, aber es fehlen schon ab Werk Akku, Uhr und einiges RAM. Akku war AFAIK nie drauf. Die Schlieren sind Rückstände der Reinigungsaktionen mit Zahnbürste und Isopropanol aus der Apotheke.

  • Mach mal den Power-Stecker und die Buchse ordentlich sauber, am besten mit Kontaktspray und dann einige Male aus- und einstecken.

    Dann mal alle gesockelten Chips etwas nachdrücken, bei dem viereckigen Sockel vom Agnus wäre am besten, diesen herausnehmen und die Kontakte zu reinigen, aber bitte nur mit korrektem Aushebewerkzeug, oder vorsichtig mit einem passenden Schraubendreher durch die Löcher auf der Rückseite herausdrücken.
    Wer die Ironie findet, darf sie behalten ^^
  • So, hab alles gemacht, was ihr mir geraten habt. Hab extra noch ne PLCC-Zange für den Agnus besorgt. Und geholfen scheint es zu haben, denn die willkürlichen Abstürze, Soundprobleme und Stromschwierigkeiten sind danach bis jetzt nicht mehr aufgetreten. Irgendwo war also tatsächlich ein Kontaktproblem. Danke vielmals, Leute! :) :) :)
    Weiterhin habe ich das 3.1.4-ROM wieder gegen das alte Kick 1.3 getauscht. Seit dem läuft auch Systest 1.2 ohne Exception und bestätigt die 512k on board als fehlerfrei.
    Außerdem laufen Games wie R-Type, Lotus II, Hybris, Rod-Land, Nebulus, IK+, Pinball Dreams und auch die Turrican-Trilogie einwandfrei.
    Mit dem 3.1.4er gibt es womöglich so einige Kompatiblitätsprobleme?
    Der letzte Test steht noch aus, nämlich mit RAM-Karte (+512k sowie +1,5/1,8MB). Die +512k-Karte, die vorher drin war, habe ich in Zitronensäure waschen müssen, wegen Laugenschaden. Hat schön gesprudelt. Der Amiga bootete dann damit ger nicht mehr, allerdings war das vor den hier empfohlenen Reinigungsarbeiten. Ich traue mich nicht so richtig, die Karte jetzt ein zweites Mal anzuschließen.
    Kann eine defekte Trapdoor-RAM-Karte den Amiga schrotten?
  • Ich habe es bis jetzt immer riskiert eine vermutlich defekte Speichererweiterung an den Trapdooranschluss auszuprobieren. Solange keine Kurzschlüsse auf der Erweiterung vorhanden sind sollte es keinen Schaden verursachen. Kann mich aber auch komplett Irren. Profi bin icke keener. Andere können wahrscheinlich eine fundierte Aussage machen.
    Wenn icke bei Selbstbau Speichererweiterungen zwischen den Pins der RAM Bausteine Kurzschlüsse hatte ist mir bis jetzt beim Testen nix abgeraucht.
  • MalleB wrote:

    Solange keine Kurzschlüsse auf der Erweiterung vorhanden sind sollte es keinen Schaden verursachen. Kann mich aber auch komplett Irren. Profi bin icke keener. Andere können wahrscheinlich eine fundierte Aussage machen.
    Wenn icke bei Selbstbau Speichererweiterungen zwischen den Pins der RAM Bausteine Kurzschlüsse hatte ist mir bis jetzt beim Testen nix abgeraucht.
    OK, danke auf jeden Fall für den Erfahrungsbericht. Ist bei mir ähnlich, ich musste einen neuen Uhrensockel verlöten, da die Pins sich aufgelöst hatten durch die Lauge. Ich bin aber kompletter Anfänger eigentlich, meine Lötarbeiten kann ich an höchstens zwei Händen abzählen. Und wie gesagt, die Karte hatte komplett in ZitroSäure gelegen, dann unter Leitungswasser und auf der Heizung zum Trocknen. Ich hab mir zur Sicherheit doch nen Neubau von BooBip bestellt (gibt AFAIK mit Chipram-Mod max. 3MB). Wenn ich bis dahin doch mal bierselig oder sonstwie risikofreudig drauf sein sollte, hab ich hier ja noch die alte Erweiterung. ;)
  • der AGNUS Sockel will nach soviel Jahren des öfteren mal getauscht werden. Schon der Verzug der bei bewegen des A500 entsteht kann der Sockel irgendwann kontaktprobleme haben. Meinen Sockel musste ich tauschen weil ich immer wieder spor Abstürze hatte. Gut nachvollziehbar wenn ich meinen A500 leicht bewegt / verwunden hatte. Danach war nix mehr. auch bei Bewegung. MMn ein bekanntes Problem
  • Tyrex wrote:

    Ich hab mir zur Sicherheit doch nen Neubau von BooBip bestellt
    Die hab ich auch, auch auf gleichem Board wie Du (A500+ Board als A500 ausgelegt), sieht bei mir so aus:


    Das gibt mir diese Speicherbelegung (sorry fuer die schlechte Bildqualitaet, wird wohl eins der naechsten Projekte werden muessen, was besseres als mein A520 zu basteln):
    Mein USB + Game Port Joystick Projekt: gitlab.com/edge-records/joyweiler