Infos zum Commodore PC 40-01


  • nino
  • 652 Views 25 replies

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Infos zum Commodore PC 40-01

    Hab vor ein paar Wochen eher zufällig noch einen Commodore PC 40-01 (obendrein auf einen Amiga 2000) erstanden. Leider finde ich zu dem Gerät (im Gegensatz zum PC 40-III) im Internet nahezu keine Informationen, ausgenommen ein paar Bilder. Das Board hat Commodore bei diesem PC zugekauft und nicht selbst entwickelt. Es trägt die Bezeichnung PC/900-2 . Dennoch handelt es sich um keinen umgelabelten standard PC; das Netzteil etwa hat denselben Formfaktor wie das Amiga 2000 Netzteil (ist elektrisch jedoch AT-kompatibel) und auch das Gehäuse ist dem des A2000 von der gesamten Konstruktionsweise sehr ähnlich. Auch ist das Parallel/Seriell-Interface auf einer von Commodore selbst entwickelten 8bit ISA-Karte untergebracht.

    In welchen Ausstattungen war der PC zu haben? Wie ist der RAM original bestückt? Welcher Jumper konfiguriert was?
    Mit welchen ISA-Karten kam das gute Stück ab Werk?
    Mit welchen HDD/FDD-Laufwerken kam es ab Werk, welcher Controller wurde dafür benutzt? (wenigstens die Festplatte stimmt mit dem "ASSEMBLED HARDDISK"-Aufkleber auf der Rückseite überein)
    Gibt es Bedienungsanleitungen, Katalogeinträge/Werbungen, Serviceanleitungen, Stücklisten usw?

    Meiner kam mit einem Floppy/MFM-HDD Controller von WDC

    Ich bin bisher kaum fündig geworden :(

    Hab noch nen ganzen Haufen Bilder gemacht und ein paar vom Vorbesitzer übernommen:


    Auf dem Mainboard sind einige Tantal-Elkos hochgegangen und das Netzteil hat einen Wasserschaden (scheint durchs Lüftergitter von außen reingekommen zu sein), allgemein ist alles sehr verdreckt und bedarf viel Pflege und Liebe. Aber darum werd ich mich natürlich noch kümmern.

    Doch zunächst hätte ich eben gerne ein paar Infos mehr :D

    The post was edited 1 time, last by nino ().

  • mingos-commodorepage.com wrote:

    Im Gegensatz zu vielen anderen PC's von Commodore, sucht man vergeblich nach der Aufschrift "PC-40" auf der Mutterplatine. Stattdessen handelt es sich um eine etwas weniger weit verbreitete PC-900 Platine. Der PC-40 war der erste PC von Commodore mit einen 286er Prozessor.
    Ein Vorgänger vom PC40-III also. Das wusste ich nicht.
  • Der Amiga 2000 ist jedem Standard PC eher ähnlich. Da kann man nix draus ableiten.

    Dein PC sieht dem ersten PC 10 und PC 20 sehr ähnlich, die Ausstattung würde ich mal als Standard bezeichnen. Wobei die Video Seven Karte ja schon was feineres für die Zeit ist.

    Schickes und seltenes Gerät, bitte aufarbeiten.

    Auf dem einen Foto das "PC 900/2" hat mich zu de.wikipedia.org/wiki/CBM_900 geführt, der sieht dem optisch ähnlich aber das war es auch schon.
  • Der PC 40 ist auch nochmal ein gutes Stück wuchtiger als der ohnehin schon monströse A2000. Da hab ich dann ja nen interessanten Beifang zu meinem A2000 bekommen :D Über weitere Infos freue ich mich natürlich.

    Leider fehlen auch ein paar Gehäuseschrauben. Die sind aber sicher schnell beschafft. Ausserdem sind der Lüfter und der Netzfilter und die female netzbuchse am Netzteil festgenietet. Die Nieten musste ich lösen, um das Netzteil komplett zu zerlegen, was leider dringend nötig war, aber die werd ich durch Schrauben mit Muttern ersetzen. Die Platine von dem Netzteil sah aus wie vollgekotzt, alles mit einem weissen film und grünem Kupferrost an Komponenten überzogen. Mal schauen, ob ich das gerettet bekomme. Mit Glück wurde dasselbe Netzteil ja auch in anderen Commodore Geräten verbaut? In dem Fall wärs leichter, an kompletten Ersatz zu kommen. Modellnummer liefer ich gleich nach.

    Edit: Hier ein paar Bilder aus dem Netzteil, inkl. Modellnummer am Netzteilgehäuse. Ist alles schon Oberflächlich gereinigt, damit man wenigstens die einzelnen Komponenten erkennen kann. Sah also mal viel schlimmer aus....
    Außerdem ist das Heatsink inkl. drangenieteter/geschraubter Komponenten runtergelötet, damit man die Komponenten darunter sehen kann.
    Die Bezeichnung des Netzteils macht mir nicht viel Hoffnung, dass es da viel Ersatz geben könnte, außer natürlich, dieselbe Platine wurde in einem anderen Gehäuse mit anderem Formfaktor ebenfalls verbaut. Einfach mal hoffen, dass der Wasserschaden keine non-standard Sachen wie den Trafo oder Spulen zerstört hat. Die sehen aber zum Glück alle ganz gut aus.

    The post was edited 2 times, last by nino ().

  • Das mit dem Wasserschaden hab ich doch schon gesagt :(

    nino wrote:

    Auf dem Mainboard sind einige Tantal-Elkos hochgegangen und das Netzteil hat einen Wasserschaden (scheint durchs Lüftergitter von außen reingekommen zu sein), allgemein ist alles sehr verdreckt und bedarf viel Pflege und Liebe.
  • ADAC wrote:

    @Parser hat viel Dolumentation zu den Commodore PCs... vllt. hat der ja was.
    Auf jeden Fall habe ich einiges an Dokumentation dazu ... ich besitze zufällig genau den gleichen Commodore PC-40 ... voll funktionsfähig und technisch 100 % in Ordnung.

    Ich stelle nach und nach mal ein paar weiterführende Infos hier ein ... muss ich erst raussuchen & passend machen.
    Images
    • commodore-family-c64-c128-pc10-pc20-pc40-amiga.jpg

      452.03 kB, 2,792×2,037, viewed 25 times
    • 20180526_161518.jpg

      207.69 kB, 929×1,239, viewed 7 times
    • 20180526_162634.jpg

      342.89 kB, 1,238×929, viewed 10 times
    Files
    • MBOARD.zip

      (35.61 kB, downloaded 1 times, last: )
    • BATTERY_CR2NP.TXT

      (95 Byte, downloaded 1 times, last: )

    The post was edited 1 time, last by Parser ().

  • ... noch ein paar Bilder von Karten & Zubehör aus dem Gerät, die ich seinerzeit fotografiert habe ...
    Images
    • 20180526_162721.jpg

      343.27 kB, 1,238×929, viewed 5 times
    • 20180526_162837.jpg

      61.31 kB, 826×619, viewed 3 times
    • 20180526_162903.jpg

      79.25 kB, 826×619, viewed 5 times
    • 20180526_162916.jpg

      316.4 kB, 1,238×929, viewed 5 times
    • 20180526_162803.jpg

      437.86 kB, 2,064×1,548, viewed 7 times
  • ... 2 Bilder von der dazugehörigen Tastatur habe ich auch noch ... das war es erstmal für heute.

    Viel Erfolg bei der Wiederbelebung!

    Bei Fragen, fragen ... ;) .

    P.S.: Ich würde an deiner Stelle mal nach "zimmers.net commodore pc" googeln ... damit hättest du dann fast alles zu deinem Computer.
    Images
    • 20180411_222420.jpg

      452.78 kB, 3,264×1,836, viewed 7 times
    • 20180411_222537.jpg

      450.86 kB, 3,264×1,836, viewed 4 times

    The post was edited 1 time, last by Parser ().

  • Zumindest die Grafikkarte ist schon einmal nicht mehr original bei meinem, da der PC-40 laut Broschüre ja nie mit VGA zu haben war. Allerdings passt sie von den Datecodes her zum Rest. Mich würden die original-Karten dennoch interessieren, v.a. die AGA-Karte (ja, hat nix mit dem Amiga-AGA zu tun, ich weiß :D ) von Commodore.

    Edit: Deine ATI Graphics Solution IST anscheinend das, was Commodore als "AGA" vertrieben hat.

    The post was edited 1 time, last by nino ().

  • nino wrote:

    Mich würden die original-Karten dennoch interessieren, v.a. die AGA-Karte
    ... ist im Commodore PC-10 Manual ausführlich beschrieben.
    Images
    • 20171201_224152.jpg

      462.92 kB, 3,264×1,836, viewed 4 times
    • 20171201_224210.jpg

      454.45 kB, 3,264×1,836, viewed 8 times
    • 20171201_224233.jpg

      458.46 kB, 3,264×1,836, viewed 1 times
    Files
  • So wie ich das hier sehe, kam der PC 40/20 mit genau deiner ATI Graphics Solution als "AGA", der PC 40/40 jedoch mit einer EGA-Karte (Quelle). Du weißt nicht rein zufällig, welche?

    Interessanter Weise sind die Gehäusefronten auf dem PC 40/20 in der Broschüre mit "PC-AT", die des PC 40/40 mit "PC 40-40" gelabelt. Auf meinem steht allerdings einfach nur PC-40. Ob das einfach ein regionaler Unterschied ist?