A2630 lebt wieder. Restfragen


This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • A2630 lebt wieder. Restfragen

    Hallo liebe Mitstreiter,

    ich habe eine defekte 2630 wieder zum Leben erweckt und habe noch ein paar Restfragen an die glücklichen A2630er Besitzer.

    Testsetup: A2000 Rev. 6 ohne weitere Steckkarten, A2630 Rev. 9 unverbastelt

    Problem: Sehr instabiler Lauf, der primär die Filesysteme korrumpierte. Grüner Bildschirm

    Was habe ich getan:

    > Defekten Ram ausgelötet => kein grüner Bildschirm mehr
    > Alle gesockelten Chips herausgenommen, Pins poliert und wieder eingesetzt
    > Entfernung der FPU führt zu einem stabilen Lauf
    > Von den 300er Jumper nur der 301er geschlossen für 2 MB. Rest offen

    Was ist noch offen:

    > Sysinfo zeigt mir eine Frequenz von 24,2 MHZ an. Kann es sein, dass der Oszi nicht sauber schwingt oder ist das so hinnehmbar (Messungenauigkeit usw.)
    > Passen die Sysinfopunkte für eine Karte ohne FPU, mit deak. MMU und "nur" 2 MB Ram (also mit Chip-Ram dann 3 MB)
    > War der Jumper 202 richtig gesetzt (nicht das die FPU doch in Ordnung ist). Stellung war rechts geschlossen. Pin-Beschriftung
    fehlt leider, daher habe ich die Werkstellung so gelassen. Laut Handbuch sind Pin 1 und 2 zu schließen für die Nutzung des CPU Oszis

    Im Anhang ein Bildchen.
    Images
    • 20190107_211924_resized.jpg

      370.38 kB, 1,080×1,080, viewed 13 times
    • 20190107_211920_resized.jpg

      435.06 kB, 1,080×1,080, viewed 13 times
    • 20190107_211545_resized_1.jpg

      169.27 kB, 540×540, viewed 11 times
    • 20190107_211537_resized.jpg

      160.27 kB, 540×540, viewed 9 times
  • Ich habe ein wenig Schützenhilfe von einem sicherlich nicht unbekanntem Youtuber aus unserer Szene erhalten. Dieser gab mir schon mal die Frequenz seiner 2630er, die brav mit 25 MHZ läuft. Eigl. wäres mir egal, ob 24.2 oder 25 MHZ, aber vielleicht führt auch dies zu Problemen mit der FPU. Ich werde mal den Quarz tauschen und gleich sockeln. Parellel dazu schicke ich dem Youtuber meine FPU. Er will diese auf seinem Board testen. Die Jumper-Belegung ist korrekt.

    Falls die FPU hinüber ist, betreibe ich die Karte halt ohne. So viel bringt das Teil beim Amiga eh nicht oder um mal einen anderen Youtuber zu zitieren: "Solange man nicht die Mondlandung plant..."
  • wir kommen einen Schritt weiter. Ich habe auf ein paar ausgelutschten CF-Karten eine Workbench installiert und das System ein wenig länger getestet. Es läuft wunderbar. Im Diskettenbetrieb hatte ich die besagten 24.2 MHZ. Nun komischerweise nicht mehr. Ich habe zusätzlich noch meine PC-Karte eingebaut und was soll ich sagen. Die Kiste ist flink wie'n Wiesel, sehr stabil und Plattencontroller und PC-Karte laufen auch fein.

    Es sieht dann wohl doch nach einer defekten FPU aus. Ich erwarte da noch auf Rückmeldung vom Youtuber. Schade, einen Oszi hätte man einfacher tauschen können als eine FPU. Naja. Ich sollte happy sein, dass ich mit sehr viel Löterei die Karte hab wiedererwecken könnnen.
  • Ach Gott, hier kommt die Maus ;)

    Besagte FPU ist heute bei mir eingetroffen und ich kann daran keinen Fehler feststellen. Sie erzielt bei Benchmarks die gleichen Werte wie meine FPU in meiner A2630. System läuft auch stabil, keine Abstürze, keine Slowdowns und, nein, außergewöhnlich heiß wurde die FPU auch nicht.

    Ich kann bis jetzt nur sagen: Dem Chip gehts gut.
  • so und hier mein Feedback. Ja, was soll ich sagen: Mig kann FPUs reparieren. Also bitte alle Anfragen jetzt an yesterchips.

    Nein, im Ernst:

    Erfreulich ist, dass mein System nun auch mit FPU stabil läuft, aber ich habe keine Ahnung warum, nach dem Ausbau der FPU habe ich an der Karte keine Verschlimmbesserungen mehr vorgenommen. Es ist mir ein Rätsel wie ein technisches System seine Eigenschaften ändern kann, obwohl nichts dran gemacht wurde. Ich dachte immer das wir im Gegensatz zur Juristerei eine seriöse Wissenschaft betreiben.

    Trotz der Selbstheilungskräfte der A2630 habe ich noch ein Problem mit der Frequenz. Wenn man Sysinfo trauen kann, läufte die Maschine einmal mit 25 MHZ und ein anderes Mal mit 30,2 MHZ, obwohl die Karte im Originalzustand läuft bzw. nicht auf 30 MHZ umgerüstet wurde. In beiden Betriebszuständen bleibt die Kiste aber stabil. Völlig normaler Betrieb. Ich werde daher nun doch mal den Oszi tauschen. Leider finde ich keine Oszis mehr vom ursprünglichen Hersteller und würde daher diesen nehmen:

    reichelt.de/quarzoszillator-25…szi-25-000000-p13699.html?

    Maße passen, Anschlüsse auch, Frequenz sowieso. Woanders finde ich jetzt kein passendes Bauteil. Hoffe mal, dass dieser passt. Ich gebe Feedback, wenn das Teil mit Sockel eingebaut ist. Vielleicht nächstes WE. So und nun muss ich meine Frau davon überzeugen, dass wir jetzt unbedingt ein Oszilloskop brauchen. Wie soll man sonst Oszis vermessen.
  • und der abschließende Post: Habe den Oszi getauscht und nun torkelt die Kiste nicht mehr. FPU war also die ganze Zeit in Ordnung, RAM und Oszi waren die Übertäter. Falls es jm nachbauen will/muss, hier die Teilnr von Reichelt:

    OSZI 25,000000

    MPE 001-1-014-3 (Sockel)


    Beim Sockel müssen natürlich die internen Pins weg. Aus- und Einlöten ist recht simpel..im Vergleich zu den Rams.

    Images
    • 20190131_210849_resized.jpg

      428.75 kB, 1,080×1,080, viewed 4 times
    • 20190131_210938_resized.jpg

      459.85 kB, 1,080×1,080, viewed 4 times