Hello, Guest the thread was called6.7k times and contains 93 replays

last post from axorp at the

C64 Assy 250466 bunter Bildschirm

  • Ich habe auch so ein Problemboard (andere Assy), das eine leere Einschaltmeldung bringt. Normalerweise das Basic-ROM, wurde auch schon fast alles getauscht und will nicht.


    Meine letzte Idee: genaues Prüfen jeder Lötstelle und Verbindungen mit Schaltplan messen. Es reicht ein Krümel Zinn, der sich irgendwo quer festgesetzt hat oder eine winzige Beschädigung an der Platine.

  • Die 466er (four/for six six 'six') sind ggf. manchmal für den Teufel vorgesehen, da geht's dann auch nicht mehr anders ;).
    Ich glaube sie simple Frage wegen "Wurde der VIC schonmal getestet / getauscht ?" von Seite 1 wurde trotz zweimaligen Nachfragens noch nicht konkret beantwortet. Also.. ?

    ja der VIC wurde getauscht und 5 andere Funktionierende wurden auch probiert... ich habe auch den VIC Sockel gewechselt


    Ich habe das Board jetzt einmal auf die Seite gelegt.... und werde in ein paar tagen weitermachen, suchen, messen....
    Werde berichten

  • Ja, strafe es mal mit Verachtung, das wirkt oft Wunder. :bgdev

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Ian Watson, britischer SF-Autor, *1943.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Es reicht ein Krümel Zinn, der sich irgendwo quer festgesetzt hat oder eine winzige Beschädigung an der Platine.

    deswegen nie auf gut glück ics auslöten und tauschen.
    besonders wenn man nicht die entsprechenden messgeräte oder testadapter hat!


    Ich habe das Board jetzt einmal auf die Seite gelegt.... und werde in ein paar tagen weitermachen, suchen, messen....
    Werde berichten


    bitte platine weglegen.
    ich sende dir dann später einen satz meiner testadapter oder du besuchst meinen reparaturtreff, im sommer.


    [....]



    gruß
    helmut






    <EDIT MOD>Postings zu "Testadapter" wurde verschoben, bitte hier weiter diskutieren:
    Testadapter für Platinen-Tests

  • neuer Tag, neues Glück :thumbsup:
    heute habe ich mit das Board nocheinmal vorgenommen..... habe es nochmal durchgemessen :search: ..... ja was soll ich sagen - alles ok


    dann habe ich ein SD2IEC angeschlossen und siehe da es funktioniert nicht - er kommt "device not present error"


    also einmal den 7406 gewechselt und siehe da, der Bunte Bildschirm ist weg und


    das Board funktioniert wieder einwandfrei :ChPeace:ChPeace:ChPeace:ChPeace


    habe den defekten 7406 wieder hergerichtet (habe ihn ja teilweise herausgezwickt) un den fehler zu reproduzieren


    hier mit dem defekten 7406



    und hier mit neuem 7406





    ich sage wieder einmal :thnks: an Alle die mir geholfen haben :thumbsup:

  • Lief denn nur ein SD2IEC nicht, oder sämtliches am Serial Port (1541, Ultimate) nicht ?
    Das hätte -falls letzteres- auch früher auffallen können, wenn man sich nicht nur auf die Einschaltmeldung (und Diag. CRT) versteift hätte, sondern auch einmal zwischendurch versucht Software (Spiele) zu laden. Auch zum Test wie die Software sich dann so verhält (einladen können vorausgesetzt, klar). :prof: [Siehe Post 58]
    Naja, hast du ja auch gemacht letztendlich dann ;) .

  • wg.: der LS hat keine OpenCollector Ausgänge

    Das stimmt nicht, der 74LS06 ist natürlicn auch ein Open Collector-Typ, sonst wäre es ja ein 74LS04. ;) Siehe: http://www.ti.com/lit/ds/symlink/sn74ls06.pdf


    Ich selbst hatte moch keine Probleme mti einem 74LS06 statt einem 7406.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Ian Watson, britischer SF-Autor, *1943.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Lief denn nur ein SD2IEC nicht, oder sämtliches am Serial Port (1541, Ultimate) nicht ?

    den seriellen port habe ich leider nicht vorher ausprobiert
    ich habe die ganzen Spiele über eine EasyFlash3 geladen, und die hatten alle den Farbfehler
    und das Kickman Modul habe ich auch probiert - siehe post 1

  • Das ist aber besonders merkwürdig, dieser Fehler ... der 7406 steckt im Reset-Kreis, in der IEC-Ansteuerung, bei der /NMI-Erzeugung mittels RESTORE-Taste und schaltet AEC auf die Multiplexer.


    Da Frage ich mich, wie genau kaputt der sein muss, um exakt diesen bunten Bildschirm zu provozieren ... :gruebel:nixwiss:

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Ian Watson, britischer SF-Autor, *1943.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Auch nicht in einer Floppy?

    Glaube nicht ... Floppies habe ich nicht so oft. Kann mich jedenfalls nicht erinnern. Nur an ein Problem mti 7414 statt 7404.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Ian Watson, britischer SF-Autor, *1943.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • In der 466 kann man einen LS06 nehmen? Üblicherweise ist das meist problematisch (wg.: der LS hat keine OpenCollector Ausgänge)...

    nein kein problem.


    der 7406 und der 74ls06 haben gleiche daten.


    anfang der 80er, als der c64 entwickelt wurde, gab es noch keine 74ls06 nur 7406. der 74ls kam erst später.
    soweit ich mich erinnern kann, zuerst von einem japanischen herstelle.



    Ich selbst hatte moch keine Probleme mti einem 74LS06 statt einem 7406.

    ich auch nicht.

    Da Frage ich mich, wie genau kaputt der sein muss, um exakt diesen bunten Bildschirm zu provozieren ...

    ich vermute, timing problem am treiber aec /aec signal. der hat es wohl nicht mehr geschafft. hätte man wohl mit einem oszi gesehen.
    er hat es nicht mehr geschafft richtig auf low zu ziehen. der pegel war nicht mehr unter ca. 0,5V (0,8V) oder zu sehr verzögert.


    bei manchen boards ist der pullup widerstand, am ausgang vom 7406 (/aec), 1kohm bei den anderen 150 ohm.
    da gab es schon damals beim c64 oder sx64 probleme. hatte ich aber schonmal irgendwo geschrieben.


    Auch nicht in einer Floppy? Irgendwas war doch da, sonst hätte ich nicht beides hier (also 06 und LS06)

    auch keine probleme


    gruß
    helmut