Hello, Guest the thread was called5.5k times and contains 34 replays

last post from c64user at the

Problem mit Wake on Lan

  • Hallo ich wende mich hiermit verzweifelt an die Profis.
    Habe hier ein PC mit Win10 64Bit und ein Asus Board H170M-Ed3.
    Nun möchte ich gerne mit der Steam-Link gemütlich von der Couch aus den PC mittels Wake on Lan einschalten/ausschalten.
    Habe im BIOS Power on PCI auf "enabled" gesetzt und damit funktioniert es soweit ganz gut - das Einschalten -
    Nur wenn ich den Pc wieder herunter fahre sei es mit der Steam Link oder auch direkt am Desktop startet der Pc einfach wieder neu.
    Das kann ich nur verhindern, wenn ich "power on PCI" auf " disabled stelle.Allerdings kann ich dann nicht mehr den PC mittels Wake on LAn einschalten :(
    Hab jetzt auch bald alles durch "Magic Paket" einschalten/auschalten ,Schnellstart on/off.
    Ich weis jetzt wirklich nicht mehr weiter und hoff hier gibt es ein paar die mir einen Tipp geben können.
    Danke!

  • Muss auf dem ferngesteuerten Rechner nicht eine bestimmte Software laufen, welche mit der Netzwerkkarte kommuniziert?


    Ich meine, dass der Rechner über den Impuls über die LAN-Karte zwar geweckt werden kann, aber nur mit der Software in der Lage ist, wieder herunter zu fahren.



    Ich hab mich mit dem Thema noch nicht so intensiv beschäftigt.

  • Normalerweise sollte der PC nur beim Empfang des "Magic Packet" wieder hochfahren. Habe jetzt keine Erfahrung mit Steamlink kann dir aber im Prinzip bestätigen das du soweit alles richtig gemacht hast. ^^


    Wie ist denn das Verhalten wenn du (falls vorhanden) von einem 2. Rechner aus das WOL Signal sendest und dann den PC herunterfährst? (Evtl. sendet der Steamlink sofort nach dem der Rechner "weg" ist erneut das Paket)?
    Ist deine Netzwerkkarte Onboard oder eine "eigenständige" Karte?


    Habe hier seit Jahren eine "ähnliche" anordung laufen, nur das es bei mir ein Raspi mit OpenElec ist der den Server per WOL startet. Das Board ist auch ein ASUS, allerdings ein P5WDG2.

  • Habe im BIOS Power on PCI auf "enabled" gesetzt

    Wäre mir neu, dass man das machen muss. Normalerweise gibt es explizit eine BIOS-Setup-Option "Wake On LAN off/on".


    Ich nehme an, es handelt sich um die Onboard-Netzwerk-"Karte"? Oder hast du eine separate im Slot stecken?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Ich finde leider keine Bios Option die "Wake on LAn" heisst
    Nur eben das "power on by PCI"

    OK, ich kenne das nur von den HP- und Lenovo-Modellen mit eigenem BIOS, da ist das so. Rein vom Verständnis her ist "Power on by PCI" ja nicht ganz richtig, weil jedes PCI-Gerät dann den PC aufwecken darf. Das ist vielleicht auch das Problem.


    Ich hab dir ein kleines Tool angehängt, damit kann du nicht nur WOL-Pakete generieren - im "Receive"-Mode siehst du auch alle WOL-Pakete, die für deinen Rechner anlommen. Damit kannst du überprüfen, ob andauernd WOL-Pakete ankommen und daher dein Rechner nicht abschaltet.


    [EDIT]


    Ach ja, bei "Port Number" musst du experimentieren, gängige Ports für WOL sind 7, 9 und 12287.


    [/EDIT]

    Files

    • WakeOnLan.zip

      (18.14 kB, downloaded 8 times, last: )

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


    Edited once, last by kinzi ().

  • Es gibt natürlich auch Mainboards wo es kein Wake on Lan gibt !
    Aber bei deinem gibt es das anscheinend schon. Ich habe mir das deutsche PDF Manual geladen und habe bei Kapitel 2.6.10 etwas gefunden. Siehe Bild,



    Weiter vorne steht auch noch was,



    Wenn der PC ganz normal ausgeschaltet wird, der PC am Strom hängt und das LAN Kabel dransteckt leuchten dann am LAN Port die Lampen ? Das wäre ein Hinweis das der PC am LAN Port mithört um z.B. über LAN aufgeweckt zu werden.

  • So, grad eben geschaut.Wenn ich power on by PCI ausgeschaltet habe blinkt hinten am Lan Port unregelmässig die LED und wenn ich von der Steam Link aus den Wake Befehl schicke dann blinkt genau in dem Moment die LED, also sollte so die Steam Link korrekt den Befehl senden.Nur dass so der Rechner nicht hochfährt.Hab auch Die Fritzbox vor dem Herunterfahren vom Strom genommen.Immer das selbe --> mit PCI Power on fährt der Rechner alleine wieder hoch, also kann es daran nicht liegen.


    Edit:


    @Bazong



    habe dein Programm gestestet.Auf Port 9 Wird mir der Wake Befehl von der SteamLink angezeigt.

  • Ok man lernt nie aus ;)


    Im Manual habe ich jetzt gelesen das man die wake on lan Funktion unter Power on by PCI... aktiviert, also warst du schon am richtigen Weg.



    D.h. du hast eigentlich nur mehr das Problem mit dem Neustart. Ich würde mal die Poweroptionen kontrollieren, im Manual steht einiges drin was man durchtesten kann.
    Andere Möglichkeit ist noch im Windows die erweiterten Poweroptionen zu checken, vielleicht liegt es daran.

  • Ich nehm an, du meinst mich ^^ ...


    Das heißt, das WOL-Paket kommt nur auf Befehl, nicht andauernd selbstständig, richtig? Dann wette ich, dass irgendein Gerät am PCI(E)-Bus bei dir (Soundkarte, Grafikkarte, was weiß ich) beim Auschalten irgeneinen Mist macht und die Kiste wieder anwirft. Hast du im BIOS irgendeine Option, die Power-On Quellen für PCI genauer zu spezifizieren? Oder hast du irgendwo eine Übersicht über die integrierten Geräte?


    Hast du irgendeine spezielle Maus oder Tastatur, drahtlos vielleicht? Es könnte natürlich was am USB sein, Drucker, Kamera, Stick, ... ich würde mal alles vom USB entfernen und dann nochmals probieren.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Klar mein ich dich :D !!


    Die Grafikkarte hatte ich auch mal im Verdacht, hab sie im Gerätemanager abgeschaltet ,aber es war keine Änderung fest zu stellen. Andere PCI Geräte habe ich nicht dran.
    Hab mal auch ALLE !! Anschlüsse hinten rausgezogen, aber der Rechner will immer neu starten , biss ich den Power Knopf drücke und ein paar Sekunden warte bis ich ihn wieder einschalte.
    Dann kann ich normal mit der Steam Link der Rechner hochfahren. Und dann geht die Geschichte wieder von vorne los ?(?(


    @Bazong


    woher hast du diese PDF? Kannst du die mir bitte zukommen lassen. Oder hast du einen Link?
    Danke :thumbup:

  • Das BIOS ist auf dem neuesten Stand? Netzwerkkarten- und andere Treiber sind aktuell?


    Du scheinst nicht alleine mit dem Problem zu sein, verschiedene ASUS-Boards mit RealDreck-Netzwerk-Adapter haben anscheinend dieses Problem.


    [EDIT]


    Probier mal das:


    Run powercfg /lastwake in the RUN window and it should tell you what is causing the reboot. It's mostly likely a driver issue, so I would make sure everything is up to date.


    [/EDIT]

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Für das Power-off/on Problem:
    Ich kenne Dein Asus Board nicht, aber ich hatte mal ein ähnliches Problem mit einem Maximus Hero Asus Board und ein BIOS Update hat das dann korrigiert.
    Wie ich hier lese, probier mal in den Power Einstellungen im BIOS, ob eine Einstellung wie diese hier hilft:

    Try going into the bios and find the power settings, if it's set to "power on after power loss" set that to off or disabled whatever it says. It sounds like it's powering back on because it's considering you turning it off as "power loss" I don't know why it is doing that but please try and let me know if this works


    Für WOL:
    Was auch wichtig ist, dass der aufzuweckende PC und das weckende Geräte am gleichen Subnetz hängen und nicht irgendein Router etc. die Magic Packets ausfiltert.


    Ich verwende im Büro das Nirsoft WOL Tool, welches eigentlich ziemlich zuverlässig funktioniert und verschiedene Arten von WOL erlaubt:
    https://www.nirsoft.net/utils/wake_on_lan.html



    Hier steht auch, dass für WOL "Power on by PCIE/PCI" korrekt ist:
    https://www.howtogeek.com/7037…n-and-how-do-i-enable-it/

  • also kann es nicht an der Lan Schittstelle liegen

    Das hatte ich ja weiter oben bereits vermutet. Diese BIOS-Einstellung "Power Up on PCI(E)" ist nonsens, weil dann jedes Gerät am PCI(E)-Bus potenzielle Aufwachursache sein kann.


    Deaktiviere im Windows-10-Gerätemanager mal die Soundkarte. Hast du ein BIOS-Update gemacht?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.