Hello, Guest the thread was called45k times and contains 692 replays

last post from wweicht at the

DT128-Native-Copy Test für MegaPatch128

  • Vielleicht findet sich ja jemand hier, welcher das mal testen könnte?

    In welchem VLIR-Datensatz sind wir gerade? Dann probiere ich das mal (heute oder morgen) hier mit nem Diskmonitor aus ......


    Gruß

    Werner


    Das wäre die 128 DESKTO/H.

    Musst Dich aber nicht mit einem Diskettenmonitor rumquälen. Anbei findest Du die aktuelle 5.03 mit dieser Anpassung und inklusive Fehlerbehebung der o.g. Bugs.


    Pusti64

  • Anbei findest Du die aktuelle 5.03 mit dieser Anpassung und inklusive Fehlerbehebung der o.g. Bugs.

    Wobei ich nicht glaube das dies etwas hilft. GeoDOS macht das "Ähnlich"... nur mit zwei getrennten Befehlen. Beim TopDesk ist es ja nur ein Befehl in zwei Abschnitten.


    Bei mir am C64 konnte ich die 1571 mit GeoDesk ja formatieren, wo ebenfalls gemeldet wurde das Format von einseitig nach doppelseitig an der 1571 nicht funktioniert. Und das Programm macht es wie GeoDOS.


    Da alle Programme den DOS-Befehl "N:" verwenden kann ich da keine Systematik sehen wann es geht und wann nicht. Das es bei mir unter VICE mit TopDesk128 geklappt hat muss nichts heißen, wie gesagt: Ich hab etliche Versuche machen müssen um es überhaupt durchzutesten. Evtl. war es auch nur Zufall.


    Mit der Änderung Wechselt TopDesk jetzt nach 1571, sendet den Format Befehl und wechselt ggf. wieder zurück. Es wird nur zwischendurch kein "I:"(Initialize) gesendet, was m.M.n. auch nicht erforderlich ist.

  • Anbei findest Du die aktuelle 5.03 mit dieser Anpassung und inklusive Fehlerbehebung der o.g. Bugs.

    Hier bei mir wird jetzt die 1571 gar nicht mehr formatiert. Einmal hat er bei 1571 --> 1541 die Blöcke auf 664 geändert. Danach, ob 1571 oder 1541 Format keine Änderung mehr. Kann es sein, dass Du den N: Befehl abgeschaltet hast? Das Formatieren hört und sieht man normalerweise ;-) . Hier passiert aber nichts dergleichen.


    Bei der Block-Anzeige unten fehlt mir irgendwie ein ":" nach "Blöcke" ;-) .


    Gruß

    Werner

  • Ich hab jetzt die neue Version getestet. Keine Ahnung warum, aber jetzt kann ich mit der 1571 unter VICE testen ohne das ich ständig neu booten muss.


    Mit dem ersten Fix scheint jetzt kein Format mehr zu funktionieren. Ich lande fast sofort wieder im DeskTop.


    Dann hab ich den Befehl nochmals abgeändert:

    Code
    1. >C:6ea9 55 30 3e 4d 31 0d 00 00 00 00

    Jetzt kann ich problemlos zwischen Format einseitig und doppelseitig wechseln, sprich: wechselseitig formatieren geht hier unter VICE ohne Probleme. Ich hab sogar ein leeres, unformatiertes D71-DiskImage erstellt. Geht damit auch Problemlos in beiden Modi (also einseitig oder doppelseitig).


    Wenn die Disk nicht formatiert ist, dann muss man ein anderes Fenster öffnen, da sonst das Formatieren-Menü nicht erscheint... es braucht wohl immer ein offenes Fenster.


    Ich hab das im TopDesk128 im Anhang geändert. Ist bis auf die Korrektur die gleiche Version wie von Pusti64 ...

  • Ich sehe gerade wweicht hatte das schon getestet. Sorry für den Fehler...


    Ich hab die Befehle auch mal in BASIC unter VICE128 getestet, also die gleichen die TopDesk, GeoDOS und GeoDesk verwenden: U0>xx, mit und ohne "I"-Befehl und N0:... Unter VICE scheint es immer zu funktionieren.


    Ich vermute mal das muss an was anderem liegen. Vielleicht kann man hier mal sammeln bei wem es mit welcher Hardware und Programm funktioniert bzw. nicht funktioniert.


    P.S. Es geht um das formatieren einer 5,25"-Disk die einseitig formatiert ist (664Blocks) und mit einem GEOS-Programm doppelseitig formatiert werden soll.

  • es braucht wohl immer ein offenes Fenster.

    Ja. Irgendein Fenster muss immer geöffnet sein. Dann kommt die Lfw-Auswahl für das Formatieren, in dem nur Laufwerke angezeigt werden, die formatiert werden können.


    Es geht um das formatieren einer 5,25"-Disk die einseitig formatiert ist (664Blocks) und mit einem GEOS-Programm doppelseitig formatiert werden soll.

    Hardware: C128 DCR, interne 1571 (JiffyDos) auf Adresse 10 und unter MP3 auch als C:


    Mit dem TD von darkvision formatiert er erstmal wieder. Aber 1541 --> 1571 bricht nach der ersten Seite (Kopf fährt noch zurück) mit Fehler $1D ab. Aber nicht immer.


    Diskette rumgedreht, nochmal als 1571 formatiert: geht, wieder rumgedreht und als 1571 formatiert geht auch.

    Dann die Diskette auf beiden Seiten als 1541 formatiert und anschließend als 1571 formatiert geht auch.


    Wir hatten das Thema schonmal früher ;-). Irgendwie scheint es Zufall zu sein. Mal geht es, mal nicht......



    Mit geoDesk unter MP3-64 (gleiche Konfiguration) habe ich diese Probleme nur auf einer von 4 Disketten. Aber nachdem rumdrehen, 1571 formatieren, rumdrehen, 1571 formatieren waren die Probleme weg.


    Gruß

    Werner


    PS: das neue geoDirSelect habe ich bisher nur unter MP3-128 getestet. Funktioniert jetzt tadellos. Danke.

  • Irgendwie scheint es Zufall zu sein. Mal geht es, mal nicht......

    Auch unter GeoDOS? Im anderen Thread wurde ja behauptet das es damit gehen würde. Das würde mich dann doch sehr wundern weil ja alle Programme das gleiche machen (mehr oder weniger...) Vielleicht ist die 1571 einfach nur eine Diva ;)


    PS: das neue geoDirSelect habe ich bisher nur unter MP3-128 getestet. Funktioniert jetzt tadellos. Danke.

    Kein Problem... an meinem C64 mit SD2IEC scheint es auch keine Probleme damit zu geben...

  • Auch unter GeoDOS?

    Habe es jetzt mal probiert und keine Probleme festgestellt. Geht einfach.


    Vielleicht ist die 1571 einfach nur eine Diva

    Der muß doch bei zu kommen sein ;-) .


    Im Prinzip scheint es zu haken, wenn der Kopf zurückgefahren ist und dann auf den anderen Kopf umgeschaltet wird.

    Die Fehlermeldung bei TD besagt ja:


    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    (Zitat aus 1571-Handbuch)


    29 DISK ID MISMATCH

    "(nichtübereinstimmung von Disketten-IDs)

    Die Diskettensteuereinheit sollte auf eine Diskette zugreifen, die nicht initialisiert worden ist. Diese Fehlermeldung kann auch ausgegeben werden, wenn eine Diskette über einen falschen Kennsatz verfügt."

    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    Aber eben, wenn es denn einmal funktioniert hat, dann funktioniert es immer wieder (siehe Disk umdrehen) ......



    Funktioniert das Formatieren denn so mit dem DoubleDesk von den Bachmännern?

    Du wirst doch nicht ...... ;-) .


    Kann ich nicht sagen. DoubleDesk braucht gateWay und hat somit wieder (völlig) andere Laufwerkstreiber. Ob das zusammenpaßt, wage ich zu bezweifeln.



    Wir haben das Problem ja auch in geoDesk (bei mir zumindest mit einer Diskette). Kann da irgendwas am 1571-Laufwerkstreiber sein? ......


    Gruß

    Werner

  • Wir haben das Problem ja auch in geoDesk (bei mir zumindest mit einer Diskette). Kann da irgendwas am 1571-Laufwerkstreiber sein? ......

    Aber dann dürfte es mit GeoDOS ja auch nicht funktionieren. GeoDesk sendet auch nur den N0-Befehl. Allerdings könnte es einen kleinen Unterschied geben:

    GeoDOS wechselt zuerst in den 1571-Modus, sendet dann Initialize... Dann der Format-Befehl. Der Unterschied ist aber das GeoDOS jedesmal PurgeTurbo, InitForIO und danach DoneWithIO aufruft. GeoDesk und TopDesk scheinen das alles innerhalb eines InitForIO/DoneWithIO-Durchgangs zu erledigen.


    Ich könnte das mal in GeoDesk so nachstellen, ist evtl. einfacher als das in TopDesk zu testen. Dann bräuchte es aber jemand der das mit GeoDesk testen kann. Ich habs am C64 mehrfach mit meiner 1571 getestet... (Nachtrag: mit der nicht angepassten Version) ohne Probleme. Ich kann den Fehler hier also nicht nachstellen :(


    Die Frage ist ob man dazu einen neuen Thread aufmachen sollte oder ob man das als generelle Fehlersuche hier weiter diskutiert...

  • Ich habs am C64 mehrfach mit meiner 1571 getestet... (Nachtrag: mit der nicht angepassten Version) ohne Probleme.

    Auch wenn ich nicht der Hardware-Guru bin, da war doch mal was ...


    Innerhalb der 1571 werkeln unterschiedliche Chips. Als ich damals das ZoomFloppy gekauft hatte, wurde just eine neue Firmware für das ZoomFloppy veröffentlicht, mit der der schnelle Transfer über seriellen Anschluß bei allen 1571 möglich war. Es ging da um einen speziellen Chip (der in meiner externen 1571 auch drin war). Glück gehabt, so konnte ich die 1571 gleich mit dem ZoomFloppy nutzen.....


    Muss die Floppy (ist normalerweise immer am ZoomFloppy dran) mal an meinen C128DCR stecken, ob da irgendetwas anders ist.........

    (weiss noch nicht, ob ich das heute noch schaffe).


    Zum Testen wäre ich natürlich bereit ;-) .


    Gruß

    Werner


    PS: Habe mal schnell nachgelesen.

    Es ging damals um nibtools (nicht die Zoomfloppy- firmware) und bei der externen 1571 ging es um den 6526A, wo der serielle Transfer vor dem Update nicht funktioniert hätte (war 2015).

    In einer 1571 können auch folgende Cips verbaut sein: 8520 oder 8521

  • Dann müsste ja GeoDOS in der Lage sein die Hardware-Unterschiede zu umgehen. Das einzige wäre ja evtl. die Sache mit InitForIO/DoneWithIO. Evtl. wird dadurch ja was an den Registern oder am Timing geändert damit es funktioniert.


    Ich hab jetzt mal eine neue Version vom GeoDesk hochgeladen, da werden die Befehle jetzt wie bei GeoDOS getrennt an das Laufwerk gesendet.


    Hab die Version auch mal unter VICE128 getestet. Im 40Z-Modus konnte ich mit GeoDesk64 eine 664Blk-Disk nach 1571 formatieren. Aber das ging ja auch schon vorher ?(

  • Dann müsste ja GeoDOS in der Lage sein die Hardware-Unterschiede zu umgehen.

    Na ja, ich bin da ja ein "gebranntes Kind" ;-) .

    Das neue MP3-128 wollte ja auf meinem C128 DCR auch nicht, bis ich dem Rechner JiffyDos verpasst hatte.


    Ich hab jetzt mal eine neue Version vom GeoDesk hochgeladen,

    Danke. Da ich gleich weg muss, kann ich noch nicht sagen, ob ich heute noch dazu komme, etwas zu testen....


    Gruß

    Werner

  • Bin heute zum probieren gekommen.


    C128D (Plastik) mit JD-Deutsch.

    MP3-128 V3.3R5


    A: SD2IEC 1581

    B: REU-Native

    C: 1541 (Ultimate 2+)

    D: 1571

    Die LfW-ID's entsprechen dem GEOS-Buchstaben.


    TD-128 R0.2 V5.0 27.04.19


    Kurz gesagt, nix, tut was es soll, funktioniert einfach.

    Egal ob von 41 nach 71 oder umgekehrt.

    Auch falsch eingelegte 1571-Disk werden nach einer Weile formatiert.


    Bei MP3-64 (64'er-Modus des C128) und TD64 bzw. GeoDesk siehts anders aus.

    MP3-64 V3.3R5

    TD-64 R0.7 V4.1 25.04.19


    Von 41 auf 71 nicht möglich, bricht mit Fehler $1D ab.

    Es wird auch nur eine Seite formatiert.


    GeoDesk siehe im GeoDesk-Thread.


    Gruss C=Mac.

  • Bin heute zum probieren gekommen.

    TD-128 R0.2 V5.0 27.04.19


    Kurz gesagt, nix, tut was es soll, funktioniert einfach.

    Egal ob von 41 nach 71 oder umgekehrt.

    Auch falsch eingelegte 1571-Disk werden nach einer Weile formatiert.

    Mal abgesehen davon, dass der TD128 dazu zu alt ist ;-) (aktuell ist der hier: DT128-Native-Copy Test für MegaPatch128 ), verwundert mich das Ergebnis ein wenig. Wir hatten das Format-Problem 1571 ja schon früher (Du hast es die Tage hier verlinkt, es war Ende 2018).


    Frage: Sind an C128 und am C64 die gleichen 1571-Laufwerke am werkeln oder hat jeder Computer "sein eigenes". Wenn ja, was sind die Unterschiede zwischen den Laufwerken. Irgendwie bestärkt mich das in der Annahme, das die eventuell in den Laufwerken verbauten CIAs (6526A, 8520 oder 8521) da reinspielen .......


    Gruß

    Werner


    PS:

    Bei MP3-64 (64'er-Modus des C128) und TD64 bzw. GeoDesk siehts anders aus.

    MP3-64 V3.3R5

    TD-64 R0.7 V4.1 25.04.19


    Von 41 auf 71 nicht möglich, bricht mit Fehler $1D ab.

    Es wird auch nur eine Seite formatiert.

    Auch wenn Du jetzt die Disk mit einer 2. Schreibschutz-Kerbe versiehst und sie direkt nach dem Fehler rumdrehst und nochmal formatierst? Zumindest bei mir hilft das.

  • Mal abgesehen davon, dass der TD128 dazu zu alt ist ;-) (aktuell ist der hier: DT128-Native-Copy Test für MegaPatch128 ),

    Ist mir bekannt, hab's extra mit der älteren Version getestet. ^^



    Frage: Sind an C128 und am C64 die gleichen 1571-Laufwerke am werkeln oder hat jeder Computer "sein eigenes".

    Da es ein C128D (Plastik) ist und in beiden Modi (128 und 64) getestet wurde, ist es zwangsweise die selbe 1571.

    Ehrlich gesagt, bin ich zu faul um die externe 1571 aus dem Keller zu holen und die C64-Anlage umzurüsten.


    Was mir aber grade einfällt, ich hab beim Wechseln vom 128 in den 64'er-Modus einen Fehler gemacht.

    Bin zwar nicht mit GO64 in den 64'er, sondern durch ein Reset und gedrückter C= Taste, dabei wird aber das LfW nicht neu initialisiert.

    Ob das beim Starten von MP3-64 eine Rolle spielt weiss ich nicht.



    Auch wenn Du jetzt die Disk mit einer 2. Schreibschutz-Kerbe versiehst und sie direkt nach dem Fehler rumdrehst und nochmal formatierst?

    Hab ich mit TD-64 nicht probiert.


    Gruss C=Mac.

  • Da es ein C128D (Plastik) ist und in beiden Modi (128 und 64) getestet wurde, ist es zwangsweise die selbe 1571.

    Wollte ich nur mal wissen ;-) . Vielleicht hilft es bei der Fehlerfindung....

    Hab ich mit TD-64 nicht probiert.

    OK, blöd gefragt. TD64 ist vorerst out ;-) .


    Aber in MP3-128 mit dem neuesten TD128 (momentan der von darkvision) bekomme ich so den Fehler weg. Disk mit 2. Schreibschutz-Kerbe versehen (falls nicht vorhanden), rumdrehen, als 1571 formatieren: geht bei mir. Dann nochmal rumdrehen und erneut als 1571 formatieren, geht bei mir dann auch problemlos.

    Keine Ahnung warum.


    Gruß

    Werner


    PS: auch bitte mal das Formatieren 1541 -> 1571 mit geoDOS probieren. Da scheint es ohne Probs zu funktionieren .....

  • Hallo C=Mac, Pusti64 und darkvision ,


    Bei MP3-64 (64'er-Modus des C128) und TD64 bzw. GeoDesk siehts anders aus.

    MP3-64 V3.3R5

    TD-64 R0.7 V4.1 25.04.19


    Von 41 auf 71 nicht möglich, bricht mit Fehler $1D ab.

    Es wird auch nur eine Seite formatiert.

    Und jetzt komme ich ;-) .


    Habe jetzt mit der externen 1571 (die mit der CIA 6526A, die normalerweise am ZoomFloppy am PC steckt und dort tadellos funktioniert ;-) ) herumprobiert. Gleiches MP3-64, gleicher TD-64, Konfiguration A: SD2IEC, B: C-ReuNative, C: 1571 (die interne), D: 1571 (die externe) (war ne ganz schöne Bastelei bis ich es hatte; mußte die FD, die normalerweise beim Booten 11 ist auf Adresse 13 schalten bis es funktionierte) und was soll ich sagen:


    TD64 formatiert die Disketten problemlos von 1541 nach 1571 habe jetzt mehrere durch (immer zunächst beide Seiten auf 1541 und dann auf 1571 formatiert). Absolut keine Probleme. Geht einfach so wie es soll.


    Jetzt wird es wieder mysteriös: plötzlich funktioniert auch das Formatieren mit der internen 1571 auf 10, auf 11 ist dabei die externe 1571. Was ist denn da los??


    Also hat das Ganze wohl doch irgendwie mit den unterschiedlichen Elektroniken innerhalb der 1571 (externe, interne im C128D und interne im C128DCR; wohl mit den möglichen 3 CIAs) zu tun. Um das zu prüfen, müsste bei den externen 1571 mal nachgeschaut werden, welche CiA da verbaut ist.

    Warum dann geoDOS häufiger funktioniert und sehr selten mal nicht, kann ich nicht sagen. geoDesk teste ich vielleicht nachher auch noch mal.


    Gruß

    Werner