C128D-CR - Probleme mit doppelseitigen Disketten und der 1571

  • Hallo.


    Ich habe meinen C128D-CR mit JiffyDOS umgebaut und mit einem SD2IEC (mit LCD) ausgerüstet.
    Die interne 1571 wurde auf Adresse 9 umgestellt und funktioniert auch soweit einwandfrei im C128 und auch im C64 Modus.


    Das Problem beginnt wenn ich versuche z.B. unter GEOS eine Diskette doppelseitig zu formatieren.
    Es kommt eine Fehlermeldung (die ich gleich am Abend nachreichen werden), einseitiges Formatieren funktioniert reibungslos.
    Auch doppelseitige Disketten können nicht gelesen werden.


    Die Kabel sollten richtig rum angebracht sein (ich nehme an sonst würde das Laufwerk nicht wirklich mehr funktionieren)


    Kann mir hier jemand weiterhelfen?


    lg Andreas

  • Kann mir hier jemand weiterhelfen?

    Ja, es wird einer der üblichen Probleme bei der 1571 sein:


    - Kopf1 (=oberer Kopf) verschmutzt
    - Anpressdruck stimmt nicht
    - Halteblech an Kopf1 gebrochen/verbogen
    - Kopf1 defekt (das kann man messtechnisch prüfen)


    Mit Geos hat das erstmal nix zu tun.

  • messe ich den Kopf um zu prüfen ob er defekt ist?

    Vereinfachte Version: Den schwarzen Stecker abziehen (da hängt der Kopf dran). Hier an beiden seiten jeweils mit einem Multimeter (Einstellung 200Ohm) das rote Kabel gegen das blaue messen. Da müsste jeweils was um die 20 Ohm rauskommen.



    Wie kann ich den korrekten Anpressdruck einstellen

    Das geht nur nach Gefühl. Du kannst mal versuchen unter die Feder am oberen Kopf eine 1cent Münze zu klemmen (vorsicht, das ist wackelig) und dann nochmal probieren. Bitte benutze eine Diskette, die auch dabei kaputt gehen kann.
    Wenn das hilft: die Feder etwas nachbiegen.


    Ob das Halteblech gebrochen/verbogen ist sieht man oft wenn man von vorne auf das LW schaut (offen, keine Disk drin). Der schwarze Bügel (welcher den Kopf anhebt) sollte wagerecht sein und nicht nach rechts hängen.


    Gruß, Gerd

  • So ein Problem hatte ich kürzlich auch. Verursacher war die Feder für den oberen S/L-Kopf. Der Anpressdruck hatte nachgelassen und war zu schwach. Habe die ausgebaut und sanft an dem Knick des langen Schenkel nachgebogen. Anfangs etwas zu viel, aber beim 2. Versuch hat es gepasst. Läuft wieder.


    Viel Glück!

  • Erstmal den einfachsten aller Tests machen: Eine Disk einlegen und im 128er-Modus header"testdisk",iaa,u9 eingeben. Das formatiert die Disk in Laufwerk 9 mit der ID "aa" und damit ist zumindest schon mal GEOS-Treibergedöns außen vor. Durch den Zugriff im 128er-Modus sollte das Laufwerk auch in den 1571-Modus gehen und somit doppelseitig formatieren.
    Wenn die Laufwerks-LED blinkt: print ds$ eingeben und hier die Laufwerksfehlermeldung nennen.
    Danach directory u9 oder diR u9 eingeben, um die Anzahl der freien Blocks zu überprüfen, das sollten dann 1328 sein.

  • Wenn die Laufwerks-LED blinkt: print ds$ eingeben und hier die Laufwerksfehlermeldung nennen.

    Also der Header befehl bringt einen "?BAD DISK ERROR".
    Die Laufwerks LED blinkt zwar nicht, aber der Print gab aus: "20,READ ERROR,00,00".


    Das Multimeter ergab für beide Köpfe jeweils ca. 20 OHM. Sollten also OK sein.
    Halteblech sollte auch OK sein, hab jedenfalls nix dergleichen bemerkt.

  • Zum Halteblech: wenn du ein Detailfoto machen kannst (am besten Macro)...


    Das Multimeter ergab für beide Köpfe jeweils ca. 20 OHM. Sollten also OK sein.

    Ja, sieht gut aus.


    Dann würde ich mal die Feder (Anpressdruck) verdächtigen. Anheben ein 1 oder 2 Cent Stück dazwischen und und eine Disk nehmen, die auch kaputt gehen darf.


    Gruß, Gerd

  • Zum Halteblech: wenn du ein Detailfoto machen kannst (am besten Macro)...


    Ja, sieht gut aus.
    Dann würde ich mal die Feder (Anpressdruck) verdächtigen. Anheben ein 1 oder 2 Cent Stück dazwischen und und eine Disk nehmen, die auch kaputt gehen darf.


    Gruß, Gerd

    Ja, hört sich nach Anpressdruck an. @ADAC warum das gefummel mit dem centstücken? Um erstmal zu testen?


    Ich habe bei dem Problem bei meiner internen 1571 gleich die Andruckfeder vorsichtig etwas nachgebogen und gut. Man darf nur nicht zuweit biegen, sonst hat man zuviel Druck auf den S/L-Kopf was auch wieder Fehler produziert. Ich hatte auch nach Federwerten gesucht, aber nichts gefunden. Damit könnte man ja (wenn man die richtigen Daten hätte) mit einer Federwaage den Anpressdruck genau einstellen.


    Nach der Zeit, ist das aber wohl nicht ungewöhnlich, dass der Anpressdruck des oberen S/L-Kopfes etwas nachlässt.

  • Muss schauen ob ich noch eine alte doppelseitige Diskette finde. Wird geprüft.


    Nur für mich zum Verständnis.
    Die 1541 hat einen Lesekopf der auf der Oberseite liest.
    Warum ist dann bei der 1571 der obere Kopf der Probleme macht?
    Sollte es nicht der untere sein, da einseitige Disketten problemlos gelesen werden?
    Steh da am Schlauch.


    lg Andreas

  • Die 1541 hat einen Lesekopf

    Richtig.


    der auf der Oberseite liest.

    Falsch. Der Kopf in der 1541 liest und beschreibt die Unterseite.


    Der untere Kopf ist zudem fest mit dem Schlitten verbunden, der obere ist hingegen schwimmend gelagert (also leicht beweglich).. wenn da was verbogen oder abgerissen ist, dann ist auch schnell Schicht im Schacht.

  • Kann man diese austauschen?

    Nur das Blech? Nein, das ist im Kunststoff vergossen und meist bündig abgebrochen.
    Den ganzen Kopf? Ja (wenn man das passende Justierwerkzeug hat, dann läuft das danach auch sogar)


    Ich meine zu wissen, dass ich noch einen Kopf in meinem Fundus habe... PN me diesbezgl. mal...


    Gruß, Gerd