Hello, Guest the thread was viewed1.8k times and contains 18 replies

last post from Daniel78 at the

Tastaturfunktionen fallen aus

  • In meinem Einstandsthread sollte es eigentlich um eine weiße 1541 gehen, die beim Laden der LIST "FILE NOT FOUND ERROR" bringt, beim Testen mit einem C64 von 1983 zeigte sich aber zunächst, das der C64 einen Fehler hat und nach weiteren Tests (nur Testen, nichts verändert) funktionierte die 1541, aber der Fehler beim C64 bleibt.



    Aber zum Fehler:


    Wenn der Rechner eingeschaltet wird, dann erscheint das übliche Startbild. Betätigt man nun mehrfach Shift+ die Cursor UP/DWN-Taste, dann lässt sich der Cursor nicht mehr mit den Pfeiltasten bewegen. Auch die Return-Taste bleibt ohne Funktion, sowie RUN/STOP und RESTORE.
    Alle Zeichen-Tasten (1-9, A-Z und Sonderzeichen) funktionieren.
    Normalerweise ist es ja so, dass beim "Startbildschirm" der Cursor kurz dunkelblau wird, wenn man z.B. eine F-Taste oder eine andere Taste, die gerade mit keiner Funktion belegt ist, drückt.
    Wenn der Fehler bei meinem Gerät eintritt, dann bleibt dieses kurze "Erlöschen" des Cursors aus.


    Wie gehe ich nun die Fehlersuche an ? Bin für jede Hilfe dankbar :)


    Gruß,
    Daniel


    Nachfolgend noch ein paar Bilder des Gerätes...

  • Danke für den Hinweis,


    an Ersatz-ICs für den 64er habe ich leider nichts. Da müsste ich mal ein anderes Gerät als Spender hernehmen. Ich hab nur einige MOS-ICs für die 1541, aber da dürfte ja wohl nichts dabei sein was passt.
    Vielleicht komme ich heute abend dazu, aus einem anderen C64 mal das Teil umzustecken. Dann werde ich berichten.

  • Ich hab gerade mal nachgeschaut: Hier habe ich nur C64-II, da dürfte das Kernal-IC nicht passen.
    Morgen komme ich in die alte Heimat, da steht noch eine Kiste auf dem Dachboden mit zwei oder drei Brotkästen und einer wahrscheinlich defekten VC-20. Die werde ich mal mitnehmen.

  • Der Tipp war gut ! :)


    Ehrlich gesagt hätte ich nicht geglaubt, dass der Fehler von der Tastatur selbst kommen könnte. Aber nachdem ich nun eine vom C 64 II dran habe, ist der Fehler nicht mehr gekommen. Die 1541 hat wohl ein eher einfaches mechanisches Problem: so wie ich das sehe hat der "Drehteller" für die Disk Schlupf. Da werde ich mal den Riemen reinigen und mit etwas Orangenöl behandeln. Das wirkt bei alten Videorecordern wunder. Ich hab dem 1541 ja schon "den Kopf gewaschen" (mit AHK Spiritus).


    Dann werde ich die originale Tastatur mal zerlegen und innen reinigen.

  • Dasselbe Problem mit der Tastatur hatte ich auch einmal, deine Schilderung hat mich gleich daran erinnert! Was ich mich noch erinnern konnte, war nur die "Restore"-Taste betroffen und die "Run-Stop"-Taste nicht. Bei mir wars auch so, dass diese Tasten nach ca. 10-15 Minuten wieder funktionierten, bis zum nächstenmal Ein- und Ausschalten.


    Wirkt das Orangenöl bei alten Keilriemen "längerfristig"? Und kann man damit den Gummi von Idler-Wheels auch "auffrischen"?

  • Manche Gummiteile sind oft nur an der Oberfläche hart oder durch Schmutz nicht mehr griffig. Das Orangenöl löst diese Schichten ab. Das Putztuch wird an diesen Stellen oft dunkelgrau beim ersten Durchgang. Dadurch werden die Gummiteile wieder etwas griffiger.
    Einen Sanyo Betamax (das Schlachtschiff mit den Druckhebeltasten) konnte ich dadurch wieder zum Spulen bewegen - nicht wie neu, aber immerhin.
    Zitronensaft soll auch helfen - da ist ja auch Zitrusöl drin. Manche Leute legen z.B. Dichtgummis von Autoscheiben in Waschmittellösung ein, das soll das Gummi wieder geschmeidig machen.


    Aber nochmal zum "Problem-C64": Den hatte ich aus der Schrottonne geborgen. Das Gerät war extrem verdreckt, aber hatte wenig Gebrauchsspuren. Bei der Tastatur machte ich gestern den Brachialversuch einer Reinigung: Ich hatte sie ausgebaut und so wie sie war mit Bref eingesprüht, das ganze mit einem weichen Pinsel einmassiert und mit der Brause abgespült. Dann hab ich die Tastatur bis heute morgen senkrecht zur Seite gestellt.
    Eigentlich hätte ich ja drauf kommen können. Das Risiko, dass die Tastatur zumindest anfangs Ärger machen würde, bin ich ja bewußt eingegangen. Ich wollte mal versuchen, ob sich die Tastatur auch komplett zusammengebaut reinigen lässt, was bei PC-Tastaturen schon funktioniert hat, aber da stecken ganze Gummimatten drin und die sind auch oft so gebaut, dass Spritzwasser von Oben nicht ins Innere laufen kann.
    Beim nächsten Mal wieder ich die Platine abschrauben und den Tastenträger separat reinigen. Das ist immernoch besser, als alle Tasten abzuhebeln - die Kunststoffteile werden mit den Jahren auch nicht besser...


    Nachtrag:
    Der Riemen hat seine Orangenölbehandlung hinter sich. Das Küchenkrepp war beim ersten Durchgang gelb und schwarz. Beim Reinigen der dunkelbraunen Kunststoffblende mit Bref lief bereits eine braune Brühe weg - eindeutige Nikotinspuren.
    Beim zweiten Durchgang war das Küchenkrepp nur noch etwas verfärbt. Die Riemenscheiben habe ich auch beide gereinigt - da ging auch nochmal Dreck ab. Der Riemen ist spürbar griffiger geworden, aber wenn er ausgeleihert sein sollte, nützt das nicht viel...

  • Jo, Tasten aushebeln tue ich auch nie. Da kommt man auch so mit Pinsel und allem bei.


    Wenn es eine Platine mit nackten (goldenen Kontakten) ist, ohne Graphithuppel, dann die Gummi-Tastenstempel mit in Graphit (von Grapitspray) getauchte Wattestäbchen an derer beiden Kontakte eintupfen. Dann sollte es spätestens, wenn auch die Platine wieder rein ist, wieder problemlos gehen.


    [Oder der Stecker hat nur nicht in allen Löchern Kontakt (Rost). Kommt aber eher selten vor. Dann den 'mal so halb anheben und schräg stecken, und gucken ob sich 'was ändert / dadurch mit Glück wieder alles Kontakt hat. Muss ich bei meiner sog. compressed T. immer so machen, sonst hat eine Leitung keinen Kontakt zur Cevi Stiftleiste.]

  • Ich hab immer Montagereiniger genommen, der geht bei den Keilriemen ganz gut. Bei den Idlers bringts zwar eine Verbesserung aber leider doch nicht ganz die gewünschte Wirkung.
    Ja, der Sanyo ist ein schöner massiver Toploader.


    Commodore Tastaturen reinige ich immer händisch und nehme mir da wirklich schön Zeit dafür. Bei deinem Fehlerfall vermute ich eher einen Ausfall (hochohmig) einer Leiterbahn auf der Tastaturplatine oder vielleicht liegt das Problem auch direkt an der Anschlussleiste bzw. deren Verkabelung.


    Ich denke, dass die Gummis der Tastenstempel ok sind, die ausgefallenen Tasten liegen verdächtig in einem Eck beinander.

  • Es kann aber etwas vom Wasser übrig bleiben, so leichte Anflüge von 'Rost-Schmand' auf bzw. in Leiterbahnen, irgendwie. Kenne sowas nämlich. Auch wenn man sie erst Monate später nach dem Waschen abnimmt und betrachtet. Aber nicht soo stark, leiten tut die Bahn dann immernoch.


    Richtiger Dreck / Staub (so dass es deswegen nicht mehr funzen würde) kommt da aber nie rein, also jetzt wieder allg. unabhängig vom Waschen gesprochen.
    Dazu liegt die viel zu luftdicht an u. auch durch die Kolben der Stempel wird eigentl. nichts oder nichts großartiges durchdringend bis auf die Platine befördert.
    Es sei denn man gießt eine Cola o.ä. oben auf die Tasten und tippt weiter :) .

  • Wenn es eine Platine mit nackten (goldenen Kontakten) ist, ohne Graphithuppel, dann die Gummi-Tastenstempel mit in Graphit (von Grapitspray) getauchte Wattestäbchen an derer beiden Kontakte eintupfen. Dann sollte es spätestens, wenn auch die Platine wieder rein ist, wieder problemlos gehen.

    Es gibt noch eine andere Methode, diese Tastaturen wieder gangbarer zu machen, ohne sich das ganze Grafit gefummel/gepinsel anzutun :)
    Selbst erst die Tage gemacht und eine sehr schlecht reagierende Tastatur dadurch wiederbelebt *g*


    Die goldenen Kontakte laufen über die Jahre etwas an und eine Reinigung nur mit Alkohol oder Spiritus bekommt diesen Belag nicht ab.
    Man ninmmt dann einfach einen Radiergummi und radiert die Flächen sanft wieder blank. Reinigt danach nochmal mit Alkohol und dann funktioniert alles wieder schön geschmeidig :)
    Und nen Radiergummi hat eigentlich jeder zuhause rumfliegen.. Das teure Graphit muss man erst bestellen ^^


    Das gleiche Verfahren eignet sich im Übrigen auch prima um die Kontakte von Karten/Cartridges zu reinigen :)



    Beim letzten Bild spiegelt der Blitz so stark, dass die Flächen dunkel erscheinen, beim ersten Bild sind sie noch stumpf ;)



    Weil ich eh grad ein zum Bleichen zerlegtes Modul hier liegen hab... Mal fix die Kontakte mit obigem Verfahren eben gereinigt..



    Beim 3ten Bild ist der obere Teil gereinigt, die 3 Kontake mitte/unten noch nicht..

  • Die Tastatur funktioniert wieder, dafür ist jetzt der Ton ausgefallen und der SID wird ziemlich heiß, so dass man ihn fast nicht anfassen kann.
    Ich nehme den Rechner nochmal auseinander, vielleicht ist die eine von der Tastatur verloren gegangene Schraube unter's Mainboard gerutscht - das wäre echt saublöd.


    Wenigstens hat die Riemenbehandlung beim 1541 etwas gebracht. Habe mal Spacedoubt geladen, was mit seinen 200 Blocks dem 1541 ausreichend was zu tun gibt - hat alles geklappt und der vorher teils sichtbare Schlupf ist weg.
    Wenigstens etwas...

  • Ja, der ist gelötet und wird sehr warm. Die Tastatur hatte Waschwasser im Innern. Nach Trocknung ist das Problem beseitigt.
    Das Ton-Problem sollten wir vielleicht in einen neuen Thread verlegen.
    Ich habe heute vom Dachboden meiner Eltern noch vier C64 geborgen, drei Brotkästen und einen im flachen Gehäuse mit NTSC, made in USA und einen Stempel außen am Gehäuseboden eingeschmolzen "REFURBISHED BY COMMODORE".
    Einer der Brotkästen hat noch die gleichen Tastenfarben wie der VC20, von dem übrigens auch noch ein Exemplar dabei ist. Aber darüber mache ich einen anderen Thread auf...