Denise 1.0.x Emulator

  • Ja, CPU Bedarf scheint etwas hoch. Steht aber auch, das das Teil absolut akkurat arbeitet. Higan (SNES) braucht auch viel CPU Power. In der neuesten Version kannst du das Keyboard Layout wählen, danach dann auf "Assign" klicken. Unter Settings ->Configuration ->Input kannst du auch die Treiber wählen. Direct Input oder Raw Input.

  • Mein erster Eindruck ist bisher sehr gut. Wirkt nicht überladen und ist einfach zu konfigurieren. Schön wäre evtl. ein kleiner Wizard bzw. autoscan nach den ROMs.
    Klar könnten ein paar Menüs besser gestaltet sein. Vorallem das Keymapping ist ein ziemlicher krampf. Bis ich die '*' Taste auf die linke Umschalttaste gelegt hatte :(


    Werde mir Denise doch jetzt öfters reinziehn ;)

  • Mappen muß man aber mit der neuen Version nicht mehr selbst (aber schön, das es noch geht). Einfach das german (de) Layout (wie oben im Screenshot) auswählen und auf Assign klicken. Mir ist nur aufgefallen das die UK/US/FR Layouts nicht die korrekten Tasten, die sich vom DE Layout unterscheiden, belegen. Ist irgendwie alles das DE Layout.

  • Quote from angryking

    Nö, es ist so, dass ich im gesamten Emu gar nichts schreiben kann, auch in keinem Dialog Feld. Meine Tastatur ist nirgends verfügbar. Alles tot.

    seltsam. Unter dem Schnelltasten List Feld alle Eingabe Treiber probiert? Irgend ein besonderes Tastatur Modell ?



    Quote from angryking

    Weiter fällt mir auf, der Emu verbrennt fast meine CPU, selbst im Leerlauf.

    Wenn im System Menu das Feature "Sid Hazard" aktiviert ist, verbraucht er besonders viel power. Außerdem verbraucht er in diesem Modus Ressourcen selbst im Leerlauf, weil der thread dafür nicht gestoppt wird. Das muss ich noch ändern.
    Sid Hazard kostet unproportional viel Mehr Leistung in Bezug auf den praktischen Gewinn. Ist wirklich kaum zu empfehlen für die allgemeine Nutzung.


    Bei allen, die den emu das erste Mal benutzen, also noch keine settings Datei existiert, wird für das englische keyboard layout automatisch gemappt. Ich hab keine zuverlässige Plattform unabhängige Möglichkeit gefunden, das im OS eingestellte Tastatur layout auszulesen.


    Quote from Retro-Nerd

    Mir ist nur aufgefallen das die UK/US/FR Layouts nicht die korrekten Tasten, die sich vom DE Layout unterscheiden, belegen. Ist irgendwie alles das DE Layout.

    das funktioniert nur richtig, wenn du im OS das entsprechende keyboard layout nach installierst und aktivierst. Ich habe zum Test in Linux,Windows und OSX jeweils alle 4 layouts eingespeichert. Das zu Testen war ein Krampf.

  • Vorallem das Keymapping ist ein ziemlicher krampf. Bis ich die '*' Taste auf die linke Umschalttaste gelegt hatte

    Wenn man auf das bestehende mappt, wird es ergänzt. Nach maximal 4 mappings wird automatisch gelöscht.
    Wahrscheinlich erwarten hier die meisten, das es das Bestehende ersetzt.
    Um nicht 3 sinnlose mappings durchzuführen, kann die Löschen Funktion verwendet werden.

  • Quote

    das funktioniert nur richtig, wenn du im OS das entsprechende keyboard layout nach installierst und aktivierst. Ich habe zum Test in Linux,Windows und OSX jeweils alle 4 layouts eingespeichert. Das zu Testen war ein Krampf.

    Ah Ok, greift also auf die OS Layouts zu. Dachte, das wären interne Emulator Settings. :)

  • Quote

    Ah Ok, greift also auf die OS Layouts zu. Dachte, das wären interne Emulator Settings.

    beides. Buchstaben und Zahlen vom OS. Deswegen sind y und z nur vertauscht, wenn das layout im OS umgestellt wird. Alles andere wird im Emulator über scancodes geregelt. scancodes beschreiben die Position (layout unabhängig) der Taste, nicht die eigentliche Beschriftung. Das französische azerty layout ist ziemlich umständlich. Zahlen werden dort mit gedrückter shift Taste ausgelöst.

  • Good News, auf meinem Desktop Rechner geht die Tastatur. :)


    "Sid Hazard" ist ja standardmäßig deaktiviert, aber auch ohne und mit neuem Build läuft 1 Core hier einfach immer auf 100% (Gesamt 25%). Ohne Fokus 12.5%


    Aktiviere ich "Sid Hazard", geht die Gesamt CPU Nutzung hoch (auf 37.5%) , also auf einem weiteren Kern. Ohne Fokus 25%



    Die 37.5% sind dann ja genau 3 meiner 8 Threads