C128 (flach) - Probleme mit Expansionsport

  • C128 (flach) - Probleme mit Expansionsport

    Hallo, Leute!

    Erstmal muß ich entschuldigen, ich hab' Deutsch seit Grundschule nicht gesprochen... :|

    Mein C128-Flach hat ein ungewöhnliches Problem. Ich habe zwei Steckmodulen für den C64 - Epyx Fastload Reloaded und PNP M-13 (Visawrite, Turbolader usw.). Beide funktionieren in meinem C64 (Klassiker, Aldi, C...) und C128DCR (geht in C64 Modus, natürlich), aber wenn ich ihnen im C128F stecke, habe ich diese Symptome:

    PNP M-13
    • 50% - geht ins C64 Modus, aber kein Menü oder Text, nur normale Rahmenfarbe (14) und Hintergrunddarbe (6)
    • 50% - geht ins C64 Modus, aber es zeigt "30179 BASIC BYTES FREE" ohne den Cursor an
    Epyx Fastload reloaded
    • C128 Modus - ignoriert das Steckmodul vollständig, die Maschine "funktioniert"
    • C64 Modus (mit C= Taste) - ignoriert das Steckmodul vollständig, die Maschine "funktioniert" mit "38911 BASIC BYTES FREE"
    Ich habe den Port mit Kontaktspray gereignigt (und nach 30 Minuten aufgeräumt), aber keine Verbesserung. ;(

    Hat jemand eine Idee? Ich weiß nicht, welche Adressen die module verwenden.

    Vielen Dank!
  • Ob die Kontakte am Expansionsport alle schön gleichmäßig und unverformt aussehen, kann man ja erkennen, wenn man von hinten draufschaut.
    Hast Du das bereits geprüft? Vermutlich ja.
    Ob die korrodiert sind, kann man so allerdings nicht erkennen.

    Du könntest höchstens ein Modul reinstecken und wenn es nicht erkannt wird, die einzelnen Kontakte vom Modul bis zu einem Lötpunkt im C128 messen. Dann kennst Du die ohmschen Übergangswiderstände.
    Oder hast Du das bereits gemacht?