SID zu leise - C128DCR

  • SID zu leise - C128DCR

    Hallo Leute,

    Ich habe seit kurzem einen C128DCR bei dem der SID extrem leise ist. Wenn Ich zu dem Thema google, sehe Ich, dass am wahrscheinlichsten der SID-Chip einen Schaden haben muss, also habe Ich mir einen neuen geholt. Leider ist das Problem immer noch da und der Sound ist exakt so leise wie vorher - nicht leiser oder lauter. Laut dem Verkäufer soll der SID in Ordnung sein.

    Später fand Ich den Text "C128 CHIPS AND COMMON SYMPTOM" in dem steht dass auch ein Transistor (Q2) schuld daran sein könnte. Vorher war ein SID mit der Beschriftung MOS 8580R5 0989 25 drin. Jetzt ist es ein CSG 8580R5 4091 25.

    Ich habe es nur im 128'er Modus mit der 'Risen from Oblivion v2' Demo getestet.
    Mir ist auch aufgefallen dass der Mauszeiger in Geos128 2.0 herumgezuckt hat, wie es im Text beschrieben wurde. Ich habe es erst auf die USB-Maus und den Tom-Adapter geschoben.
    Ausserdem startet der C64-Modus nicht wenn Ich die RR-Net Mk3 eingesteckt habe. Kein Text und kein Cursor.

    Wie könnte Ich jetzt vorgehen? Vielen Dank im Vorraus :)
    :S
  • Der SID hat 8,88 Volt. Andere 5 Volt Chips haben 4,95 Volt. Mein Multimeter kann etwas ungenau sein, Ich habe das noch nicht geprüft.

    An den Transistor komme Ich gerade nicht ran, werde erstmal das Netzteil ausbauen.

    Ich hab ein Bild vom, Ich glaube, ASCII Character Rom gemacht. Kann das links daneben Korrosion sein?


    :S
  • @Aries: Da der SID zu leise ist und die Maus "herumzickt" ist mit großer Wahrscheinlichkeit der SID defekt, da über die POT X und POT Y Eingänge auch die 1351 Maus abgefragt wird. Ich hatte in der Vergangenheit schon mehrere "leise" SIDs, nach austausch gegen einen funktionierenden SID war die Lautstärke dann wieder normal. Der 8580 braucht zusätzlich zur normalen 5 Volt Versorgungsspannung (Pin 25) auch noch eine 9 Volt Versorgungsspannung (Pin28) für den Analogteil des Chips, die von dir gemessenen 8,88 Volt kommen also ungefähr hin. Wenn die 9 Volt nicht stimmen produziert der SID meist "schräge" Töne, das hatte ich mal in Verbindung mit nem Stereo SID Board. Mit nur einem SID lief alles normal, mit dem Zweiten SID waren gelegentlich immer wieder "schräge" Töne zu hören. Nach austausch der Elkos in der 9 Volt Erzeugung für den SID lief dann alles. War ein C64 mit nem ASSY 250469 Board drin, mit dem Transistor und ner Zenerdiode zur Regelung der 9 Volt.
  • ADAC schrieb:

    Das sieht mir nur nach Flussmittelresten aus. Kannst ja mal mit IsoProp wegputzen :syshack:
    Jo, das hat gewirkt. Sieht ganz normal aus unter der weiß-gelben Kruste :)


    So, habe den Transistor Q2 gemessen und er zeigt 3,33V E und 3,57V B. Neben dem rechten und linken Beinchen sind jeweils diese Buchstaben. In der Mitte scheint kein Strom zu fließen.

    Pin 25 am SID macht 4,93V. Das ist auch ok, denke Ich.

    Hmmm, ist wahrscheinlich schwer zu beweisen, dass der SID schon Kaputt war, bevor er bei mir ankam.
    :S

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Aries ()

  • "In der Mitte" ist der Collector, der muss an 9 V liegen (siehe Schaltplan oben). Wenn die fehlen, wird der Audio-Ausgang des SIDs nicht verstärkt, sondern durch R28 und die BE-Strecke des Tarnsistors sogar noch abgeschwächt. Bitte überprüfen, warum da keine 9 V anliegen.

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • kinzi schrieb:

    "In der Mitte" ist der Collector, der muss an 9 V liegen (siehe Schaltplan oben). Wenn die fehlen, wird der Audio-Ausgang des SIDs nicht verstärkt, sondern durch R28 und die BE-Strecke des Tarnsistors sogar noch abgeschwächt. Bitte überprüfen, warum da keine 9 V anliegen.


    Hab mich beim messen vertan, es liegen doch 8,85V an C an :(
    :S
  • So, hab' beim C64 auf einem 250469 nachgemessen, weil ich an den C128DCR grad nicht rankomme; die Schaltung ist aber ähnlich. Ich habe an AUDIO_OUT beim SID ca. 4,5 V; ebenso an der Basis des Transistors. Am Emitter des Transistors habe ich ca. 3,8 V.

    Deine beiden Messwerte (3,33 V an E und 3,57 V an B) sind dubios, da müsste wie bei mir 0,7 V Spannungsabfall zwischen B und E zu messen sein. Irgendwie ist der Transistor nicht im Arbeitspunkt. Schon möglich, dass das an einem kaputten SID liegt, aber gleich zwei kaputte? ?(

    Kannst du mal direkt an Pin 27 messen, was da rauskommt? VORSICHT - nicht abrutschen auf Pin 28, dort liegen die 9 V!
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Aries schrieb:

    Pin 27 sagt 6,33 Volt.
    Huiii ... das scheint mir falsch, auch laut Datenblatt:

    Der 8580 (identisch mit 6582) müsste im "Ruhezustand" ca. 4,5 V liefern (passt bei meiner Messung)

    Der 6581 müsste im "Ruhezustand" ca. 6 V an Pin 27 liefern.

    Das schaut mir aus, als ob der dauernd nach oben ausgesteuert wäre. Kannst du mal im C64-Mode "POKE 54296,0" eingeben und dann nochmals messen? (Nur zur Sicherheit.)

    An EXT_IN ist da wohl nichts angelötet oder extern am DIN-Stecker angesteckt?

    R11 (1 kOhm) darf für einen 8580 nicht bestückt sein - ist der evtl. drin?
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • kinzi schrieb:

    Aries schrieb:

    Pin 27 sagt 6,33 Volt.
    Das schaut mir aus, als ob der dauernd nach oben ausgesteuert wäre. Kannst du mal im C64-Mode "POKE 54296,0" eingeben und dann nochmals messen? (Nur zur Sicherheit.)

    An EXT_IN ist da wohl nichts angelötet oder extern am DIN-Stecker angesteckt?

    R11 (1 kOhm) darf für einen 8580 nicht bestückt sein - ist der evtl. drin?

    Wenn Ich den POKE 54296,0 Befehl gebe, hat Pin 27 4,5V (statt 6,33V) und der Transistor auf B 3,43V (statt 3,57).

    Es ist nur das Videokabel und Tastatur eingesteckt, sonst nichts. Es macht in den Voltzahlen keinen unterschied, wenn Ich das richtig gesehen habe. Habe mit und ohne Videokabel gemessen. Es ist dieses hier : ebay.de/itm/Commodore-C128-C12…aa593e:g:5mEAAOSwFNZWvI4k

    Dann habe Ich nur das 40-Zeichen Kabel abgezogen und ein Extrakabel (SCART) für den 40-Zeichenmodus eingesteckt und habe den Fernseher auf SCART umgestellt - aber es ist nichts zu hören.

    Auf R11 ist nichts verlötet.

    Das Mainboard ist ganz unverbastelt (soweit Ich das sehen kann) und das Siegel war (soweit Ich mich erinnern kann) noch unbeschädigt. Leider ist dieser C128DCR mein einziger Commodore Rechner, also kann Ich die SIDs nicht woanders testen :(
    :S
  • OK, die 4,5 V gefallen mir besser. :thumbup:

    An der Basis 3,57 V wär irgendwo auch noch OK, aber dann müssen am Emitter 0,7 V weniger zu messen sein. Kannst du das auch noch mal überprüfen? Wenn da nicht um die 2,9 V zu messen sind hat der Transistor evtl. doch was.

    Was theoretisch auch noch möglich wäre ist ein defekter Auskoppelkondensator C85 (10 µF). Viel bleibt dann nicht mehr, außer defekte SIDs.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Falls du die Möglichkeit bzw. ein RF-Kabel hast, würde ich den 128er mal über das (also über Modulator) in den Fernseher einspeisen.

    Vielleicht hast auch die Möglichkeit, den Audioausgang des C128er an einer HiFi-Anlage/Verstärker einzuspeisen um da mal zu sehen, ob der SID da lauter kommt.

    Letzte Möglichkeit was mir da noch einfällt (und die einfachere), ein Spiel oder Demo mit digitalen Samples wiederzugeben. Sind die Samples lauter als der Rest würde ich auf 2x def. SID tippen.
  • kinzi schrieb:

    OK, die 4,5 V gefallen mir besser. :thumbup:

    An der Basis 3,57 V wär irgendwo auch noch OK, aber dann müssen am Emitter 0,7 V weniger zu messen sein. Kannst du das auch noch mal überprüfen? Wenn da nicht um die 2,9 V zu messen sind hat der Transistor evtl. doch was.

    Was theoretisch auch noch möglich wäre ist ein defekter Auskoppelkondensator C85 (10 µF). Viel bleibt dann nicht mehr, außer defekte SIDs.

    Hab nochmal gemessen: 3,68V B und 3,44V E also heute mal ca. 0,08 Volt mehr. 8,97V auf C, auch etwas mehr.
    Pin 27 hat 6,40V und Pin 28 8,94V, also auch der SID hat um das Gleiche mehr Volt als Gestern. Irgendwie kommt mir der SID auch ein wenig lauter vor als Gestern, aber vielleicht ist das nur subjektiv.

    Capstan schrieb:

    Falls du die Möglichkeit bzw. ein RF-Kabel hast, würde ich den 128er mal über das (also über Modulator) in den Fernseher einspeisen.

    Vielleicht hast auch die Möglichkeit, den Audioausgang des C128er an einer HiFi-Anlage/Verstärker einzuspeisen um da mal zu sehen, ob der SID da lauter kommt.

    Letzte Möglichkeit was mir da noch einfällt (und die einfachere), ein Spiel oder Demo mit digitalen Samples wiederzugeben. Sind die Samples lauter als der Rest würde ich auf 2x def. SID tippen.

    Wenn Ich den 128'er mit meiner Audioanlage verbinde ist es das Selbe. Ein RF-Kabel habe Ich nicht. Später werde Ich mal Sample Demos testen.

    Das beste wäre natürlich, wenn es nur der Transistor wäre. Ich habe noch nie einen gekauft. Wo kriegt man sowas her? Löten kann Ich schon, aber von Schaltungen habe Ich keinen Plan :)
    :S
  • Aries schrieb:

    Wo kriegt man sowas her?
    Bei Reichelt:

    reichelt.de/2SC-Transistoren/S…nr=SC+1815&SEARCH=2sc1815

    Transistor 4 cent, Versand 5 Euro :( ... wo wohnst du? Evtl. gibt's bei dir im Umkreis ja noch 'nen Elektronikladen.
    Oder du brauchst zufällig noch was anderes von Reichelt.

    Oder du nimmst einen (fast) beliebigen BC-Typen, z. B. den BC547 oder BC337; die haben aber andere Anschlussbelegungen. Der Transistor in dieser Schaltung muss nichts können, jeder beliebige NPN sollte funktionieren.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)