DOS Spiele Sound-Problem unter Windows 3.1

  • DOS Spiele Sound-Problem unter Windows 3.1

    Ich habe folgendes Problem:

    Einige DOS-Spiele versagen trotz korrekter Soundkarten-Treiber (DOS- und Windows) unter Windows 3.1 bei der Soundwiedergabe den Dienst. Ram-Speicher steht dem Spielen unter Windows mehr als genügend zu verfügung. Das Spiel startet, aber kein Ton kommt raus. Auffallend ist dass es sich hierbei nur um Spiele handelt wo die IRQ beim Spielstartl automatisch ermittelt wird. Bei DOS-Spielen wo die IRQ über ein Setup-Programm eingestellt wird, funktioniert der Ton einwandfrei.

    Sowohl DOS-Treiber wie auch Windows sind auf die Werte: Adresse=220 IRQ=5 DMA=1 UDMA=5 eingestellt. "Set Blaster" Umgebungsvariable ist auch entsprechend gesetzt.

    Aufgefallen ist mir das bei folgenden Spielen:
    Bifi: Action in Hollywood, Victor Loomes, Abenteuer Europa (eigendlich sämmtliche Spiele mit PSMCFG (egal welche version) als Setup-Programm)
    Der Planer, Der Planer Extra, Der Planer Gold

    Mache ich irgendwas falsch? Oder mag Windows 3.1 keine automatische IRQ-Weitergabe? Unter DOS habe ich mit der automatischen IRQ Ermittlung keine Probleme.
  • Warum spielst du auch DOS-Spiele unter Windows 3.x? Sowas macht man doch nicht, denn es gibt dabei Probleme, wie du ja selber siehst. Also Windows verlassen und direkt unter DOS Spiel starten.
    Dieser Beitrag wurde bereits 64 mal editiert, zuletzt von »Bagitman« (Heute, 00:03)
  • Bagitman schrieb:

    Warum spielst du auch DOS-Spiele unter Windows 3.x? Sowas macht man doch nicht, denn es gibt dabei Probleme, wie du ja selber siehst. Also Windows verlassen und direkt unter DOS Spiel starten.
    Windows hat einfach das bessere Speichermanagment. Währen man unter DOS die Config.Sys und autoexec.bat teilweise erst auf das Spiel abstimmen muss (was teilweise doch sehr Mühsam ist und teilweise mehrere Reboots braucht bis die Konfigurationen stimmen), hat man unter Windows 3.1 eine virtuellen Speicher und mit PIF-Dateien kann man dem Spiel genau den Ram-Speicher auf dem Weg geben, den es braucht. (ohne den lästigen rumgefrimsel in der autoexec.bat und config.sys)
  • Ich würde zumindest mal als erstes prüfen, ob die Spiele mit Deinen Einstellungen unter DOS direkt funktionieren oder ob das Verhalten genauso wie unter Windows 3.1 ist.
    Wenn es abweicht, weiß Du zumindest, dass Windows etwas. Wenn es das gleiche Verhalten ist, liegt es nicht am Windows.
    Die Eingrenzung wäre erstmal wichtig, damit Du weißt, wo das Problem zu suchen ist.