Anleitung zum installieren des XUM1541 auf Ubuntu/Linux

  • Anleitung zum installieren des XUM1541 auf Ubuntu/Linux

    Anleitung um das XUM1541 von CBM Crew auf Ubuntu 12.04 und warscheinlich auch 14.x, 16.x zu installieren.
    Stand: 20.11.2017

    Alles was in "Quellcodeformatierung" ist muss auf der Shell eingegeben oder gecopypastet werden.

    Es müssen erstmal einige Voraussetzungen geschaffen werden:

    Quellcode

    1. sudo apt-get install libusb-dev build-essential linux-headers-generic git libncurses-dev
    2. cd ~
    3. git clone https://github.com/cc65/cc65.git
    4. cd cc65
    5. make
    6. sudo PREFIX=/usr make install
    Dann lade sourceforge.net/projects/openc….4.99.99.tar.bz2/download
    herunter und entpacke es in das Homeverzeichnis.


    Quellcode

    1. cd ~/opencbm-0.4.99.99
    2. make -f LINUX/Makefile opencbm plugin-xum1541
    3. sudo make -f LINUX/Makefile install install-plugin-xum1541
    4. sudo ln -s /usr/local/lib/libopencbm.so.0 /usr/lib/libopencbm.so.0
    Zur Zeit funktioniert der Zugriff auf CBM Laufwerke nur als Superuser (root).. es liegt wohl an Dateirechten in der USB-LIB
    Ich bin da aber selber noch am suchen.
    Also alle Befehle von OpenCbm mit sudo ausführen.

    Zum Test XUM 1541 anschliessen, Floppy anschliessen und einschalten. Dann:

    Quellcode

    1. sudo cbmctrl detect
    eingeben. Da sollte dann sowas wie

    8: 1541-II

    kommen. Dann ist alles Korrekt

    Wenn eine beschriebene Disk im Laufwerk liegt dann auch gerne mal


    Quellcode

    1. cbmctrl dir 8
    testen.
  • dann hat´s bei Dir also auch gefunzt :thumbsup:

    und danach ganz zum Schluß könnte man noch die nibtools installieren, so könnte man mit dem XUM1541 dann auch in Richtung G64 was machen ...:


    Quellcode

    1. sudo apt-get install subversion
    2. mkdir ~/nibtools
    3. cd ~/nibtools
    4. svn co https://c64preservation.com/svn/nibtools/trunk
    5. cd trunk
    6. cp include/WINDOWS/opencbm.h include/LINUX/
    7. make -f GNU/Makefile linux
    8. sudo cp nibconv nibread nibrepair nibscan nibsrqtest nibwrite /usr/local/bin/
    funzte alles so auf meinem Thinkpad T61 mit Ubuntu 14.04

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GI-Joe ()

  • JMP$FCE2 schrieb:

    Komisch... du hast 14.04 ich hab 12.04.. es Bestätigt das man einfach keine Lust hat daran rumzubasteln wenn die Karre gerade gut läuft.
    ja, das gleiche Problem hab ich auch immer. Wenn alles supi löppt und man ist zufrieden ist´s vorbei mit LTS-Support
    Darum habe ich auf vielen Geräten bereits arch-Linux wegen der rolling-release Sache.
    Always uptodate ohne neu zu installieren - so zumindest die Theorie ;)
    klappt aber bis jetzt problemlos.

    bekommst Du denn noch Updates ?
    imho läuft der LTS-Support von 12.04 in 2017 aus.
  • JMP$FCE2 schrieb:

    Zur Zeit funktioniert der Zugriff auf CBM Laufwerke nur als Superuser (root).. es liegt wohl an Dateirechten in der USB-LIB
    Ich bin da aber selber noch am suchen.
    Also alle Befehle von OpenCbm mit sudo ausführen.
    Mittlerweile hab ich rausgefunden was das Problem mit den Rechten ist:
    Ich bin nicht Mitglied der Gruppe 'users'... ist wohl nicht mehr üblich das jeder User automatisch in diese Gruppe kommt.

    Also:

    Quellcode

    1. sudo usermod -aG users EuerBenutzername
    machen, und komplett vom System abmelden (oder neustarten)

    Dann gehts auch ohne dieses sudo ^^
  • Mh, hat noch jemand das Problem das Zoomfloppy nur immer einen Befehl annimmt, diesen auch perfekt ausführt und dann hängt der Bus.
    Erst ein abtrennen des USB Kabels an der Zoomfloppy lässt die Floppy wieder reagieren, aber auch nur wieder für einen Befehl.

    Es gibt ein Tool, welches genau ein USB Gerät reseten kann.
    Dieses Programm verwende ich immer, dh ich muss nicht immer das USB Kabel trennen, aber halt nach jedem Befehl erst das USB Gerät per Befehl reseten.

    Das nervt :-/
    Hat da vielleicht jemand eine Idee?
    --------------------------------------------------------------------------------------------------------
    RapidFire BBS: rapidfire.hopto.org:64128
  • 7Saturn schrieb:

    Jupp, bei mir reicht es, einen echten USB 2.0 Port zu nehmen. Am 3.0er habe ich dasselbe Problem.
    Mh, bei mir leider nicht....
    Auch ein direktes anschliessen am PC USB Port bringt den selber Fehler :(
    --------------------------------------------------------------------------------------------------------
    RapidFire BBS: rapidfire.hopto.org:64128
  • Hab hier WIMRE aber vor einigen Wochen mal einen Faden zu der Frage. Wüsste aber blöderweise nicht, wonach man genau suchen muss...
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890