C64 Farbprobleme?

  • Ach so, das ist ein fertig konfektioniertes Kabel. Da ist es natürlich schwierig zu raten ... am besten eines kaufen, aufschneiden und wenn es passt noch eines kaufen. :D
    Belebt auch die Wirtschaft ... :whistling:
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • bastie1977 schrieb:

    kinzi schrieb:

    Fazit:
    Das Übersprechen auf dem Kabel zum Bildschirm passiert nachweislich, wenn das Kabel keine einzeln abgeschirmten Adern hat. Gegenteilige Behauptungen sind im Reich der Märchen anzusiedeln.
    Einwandfreie Darstellung, sauber. :)
    Damit hat er mit'm S/W bzw. Grünbild jetzt 'mal nur nachgewiesen, dass das Schachbrettmuster durch die Leitung ins Chroma eingespeist wird. Ich ich meinen Posts sprach aber immer von Farbe. Die hat nämlich eine etwas höhere Hürde.., aber auch nicht unmöglich (will ich auch gar nicht behaupten).

    Hier in Thread Post 172 hat jemand das Chroma immer bereits direkt im C64 (Modulatoreingang) vor dem Kabel an und abgestöpselt und hatte eben trotzdem das Schachbreztmuster. Ergo entsteht das Muster -dank dem Beweis- ebenfalls auch im (oder manchem älteren, diesem 469er hier im Thread nicht) C64 selbst, nicht nur durch zu wenig abgeschrimte Kabel.
    Das ist also kein Märchen.. . Beide Fälle sind kein Märchen. :)
    ' war Anfang 2000 schonmal unter dem Kennnamen 'c64fan' hier unterwegs.
  • Das lässt sich auch einfach zusätzlich provozieren: Wenn man den Chroma Stecker während der Bildanzeige wegnimmt, somit der Farbdecodierer im Monitor noch (durch sein zu sensibles Verhalten) auf Farbe initialisiert ist / stehen bleibt..,
    dann bleibt trotz dass nur noch Luma am Monitor hängt etwas Farbe bestehen.
    Wenn man aber den Monitor oder C64 ausschaltet und von vornherein nur den Luma Stecker am Monitor hat [also ohne den erwähnten Monitor-Farbdecodierer-Initialisierungstrick], hat man meistens 'n astreines Luma S/W Bild ohne Farbe und ohne Schachbrettmuster.
    Zumindest mit einem zweiadrigen bzw. dreiadrigen(+ Audio) Chinchkabel [C= Original, oder gleichweitige Nachbauten] mit Einzelleitungen, so wie es das btw. auch früher als Zubehör bzw. offiziellem Chroma/Luma Kabel fast nur genau so gab.
    ' war Anfang 2000 schonmal unter dem Kennnamen 'c64fan' hier unterwegs.
  • CommieSurfer schrieb:

    Damit hat er mit'm S/W bzw. Grünbild jetzt 'mal nur nachgewiesen, dass das Schachbrettmuster durch die Leitung ins Chroma eingespeist wird. Ich ich meinen Posts sprach aber immer von Farbe. Die hat nämlich eine etwas höhere Hürde.., aber auch nicht unmöglich (will ich auch gar nicht behaupten).
    Das Schachbrettmuster IST das Chroma-Signal. Es ist ein 4.43 MHz Takt bei dem sich die Farbinformation aus seiner Phasenlage ergibt.


    CommieSurfer schrieb:

    Das lässt sich auch einfach zusätzlich provozieren: Wenn man den Chroma Stecker während der Bildanzeige wegnimmt, somit der Farbdecodierer im Monitor noch (durch sein zu sensibles Verhalten) auf Farbe initialisiert ist / stehen bleibt..,
    dann bleibt trotz dass nur noch Luma am Monitor hängt etwas Farbe bestehen.
    Wenn das so passiert stimmt was nicht mit deinem Monitor. Wenn der auf S-Video steht und du Chroma abziehst musst das Bild s/w werden, auch wenn auf LUMA noch Chroma drauf ist wird daraus keine Farbe mehr abgeleitet weil der Farbdekoder das Signal nicht zu sehen bekommt. Was du dann noch sehen kannst ist das Chroma als eben dieses Schachbrettmuster.

    Wenn du sehen willst wieviel Chroma auf Luma zu finden ist, dann musst du den Monitor auf FBAS schalten und ihm nur das Luma-Signal geben. Bleibt das Bild jetzt s/w ist alles OK, wird es mehr oder weniger farbig hast du Chroma wo es nicht sein sollte.
  • Jetzt komm nicht mit Fakten, Gerrit, das verwirrt doch nur. :D

    Gerrit schrieb:

    Es ist ein 4.43 MHz Takt bei dem sich die Farbinformation aus seiner Phasenlage ergibt.
    Und ich würde mal meinen, es ist deshalb ein Schachbrett und kein Steifenmuster, weil sich bei PAL die Phasenlage pro Zeile um 180° ändert ("Phase Alternating Line").
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • kinzi schrieb:

    Und ich würde mal meinen, es ist deshalb ein Schachbrett und kein Steifenmuster, weil sich bei PAL die Phasenlage pro Zeile um 180° ändert ("Phase Alternating Line").
    Wobei es Farben gibt bei denen die Phasenumkehr wieder dasselbe ergibt... Die Rahmenfarbe, die ein C16 beim Einschalten produziert ist eine solche, da bekomme ich auf dem Display ein Streifenmuster. Schalte ich auf eine andere Farbe um bekomme ich ein Schachbrett.
  • Gerrit schrieb:

    CommieSurfer schrieb:

    Damit hat er mit'm S/W bzw. Grünbild jetzt 'mal nur nachgewiesen, dass das Schachbrettmuster durch die Leitung ins Chroma eingespeist wird. Ich ich meinen Posts sprach aber immer von Farbe. Die hat nämlich eine etwas höhere Hürde.., aber auch nicht unmöglich (will ich auch gar nicht behaupten).
    Das Schachbrettmuster IST das Chroma-Signal. Es ist ein 4.43 MHz Takt bei dem sich die Farbinformation aus seiner Phasenlage ergibt.

    CommieSurfer schrieb:

    Das lässt sich auch einfach zusätzlich provozieren: Wenn man den Chroma Stecker während der Bildanzeige wegnimmt, somit der Farbdecodierer im Monitor noch (durch sein zu sensibles Verhalten) auf Farbe initialisiert ist / stehen bleibt..,
    dann bleibt trotz dass nur noch Luma am Monitor hängt etwas Farbe bestehen.
    Wenn das so passiert stimmt was nicht mit deinem Monitor. Wenn der auf S-Video steht und du Chroma abziehst musst das Bild s/w werden, auch wenn auf LUMA noch Chroma drauf ist wird daraus keine Farbe mehr abgeleitet weil der Farbdekoder das Signal nicht zu sehen bekommt. Was du dann noch sehen kannst ist das Chroma als eben dieses Schachbrettmuster.
    Wenn du sehen willst wieviel Chroma auf Luma zu finden ist, dann musst du den Monitor auf FBAS schalten und ihm nur das Luma-Signal geben. Bleibt das Bild jetzt s/w ist alles OK, wird es mehr oder weniger farbig hast du Chroma wo es nicht sein sollte.
    Das war natürlich mit'm anderen Monitor*, keiner der den du dir da überexakt denkend extra u. absichtlich für mich zum letztendlich gerade dann/deswegen eben immernoch fälschlichem Widerlegen herauspickst.. . *Sondern CM 8833er Modelle, der auf Luma schliesslich gleichzeitig Farbe bzw. den Composite Eingang hat ! - ergo habe ich da eben trotz nur Luma dran die beschriebene Farbe gehabt, aber nur mit dem Trick da -wenn eben der Farbdecodierer vorher auf irgendeine Weise auf Umwege hinten 'rum an einem anderen Eingang der Scartbuchse, wo normalerweise Chroma ist, getriggert wurde. Genau wie bescherieben eben..-.
    --
    Btw.: Genau das was du im letzten Satz schreibst, habe ich damit also getestet (weil das Monitormodel bakanntlich nur Composite + RGB hat). Die Farbe im Luma konnte man aber eben nur dann sehen, wenn der o.g. Trick vorher angewandt wurde.
    Ansonsten war's nämlich blitzsauber s/w + natürlich die vertikalen Linien (die sind im Luma nunmal).
    ' war Anfang 2000 schonmal unter dem Kennnamen 'c64fan' hier unterwegs.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von CommieSurfer ()

  • Gerrit schrieb:

    CommieSurfer schrieb:

    Damit hat er mit'm S/W bzw. Grünbild jetzt 'mal nur nachgewiesen, dass das Schachbrettmuster durch die Leitung ins Chroma eingespeist wird. Ich ich meinen Posts sprach aber immer von Farbe. Die hat nämlich eine etwas höhere Hürde.., aber auch nicht unmöglich (will ich auch gar nicht behaupten).
    Das Schachbrettmuster IST das Chroma-Signal. Es ist ein 4.43 MHz Takt bei dem sich die Farbinformation aus seiner Phasenlage ergibt.
    Ich denke eher, dass da bei den C= Rechnern zusätzlich (oben drauf) zum Farbsignal oder Farbtakt noch irgendwas einstreut. U. das erst ergibt dann den Fliegengittereffekt, nicht die Farbe selbst. So genau muss man schon sein, wenn man es schon genau nimmt.. . ;)
    Ein NES über Composite, PSX / SNES über Composite oder S-Video ((mit unausreichend abgeschirmten Kabeln -Chromaleitung auf die Lumaleitung auch hier 'mal absichtilich übersprechen lassen-, spätestens dann !)) und alle die ich 'vergessen' habe.. bringen diesen Gittereffekt schliesslich nicht (Farbausfransungen ja, das ist überall so - technisch/Chroma Norm unabdingbar, aber nicht dieses C= Fliegengitter). Müsste da ja auch so sein, wenn es zu 100% nur an der 4,43 MHZ Technik von Chroma liegt u. liegen würde ! Denn die ist überall die gleiche.
    Desweiteren filtert der z.B. 425er Modulator diesen Effekt mit'm HF Teil im Modulator zufällig fast komplett heraus, OHNE die Farbwerte an sich auch nur irgendwie zu beeinträchtigen / zu kippen. Wie das im Link zu dem anderen Thread mitunter auch Thema ist. Daher liegt da vielmehr 'was harsches / übersteuerndes zum Farbsignal oben drauf zu Grunde, bei den C= Rechnern. Also etwas unnormales und separates, als welches es [Anm.: dieser Gittereffekt] zu betrachten und einzuordnen ist.
    Oder meint ihr, das ist allein aufgrund der höheren über der Norm liegenden Outputstärke des Chroma bei den C= Rechnern so gegeben (wobei ist das beim C16 überhaupt noch so ? Fliegengitter ja, aber das über der Norm der Chroma Signalstärke ?, wäre dann ja nämlich schon 'mal ein Bsp. um auch das zu widerlegen), dass das [Anm.: Fliegengitter] erst dann entsteht ? Aber auch das müsste dann eben erstmal bewiesen werden, dass es nur daher kommt u. nicht durch etwas 'oben drauf' / zusätzlich ins Chroma eingespeistes.
    ' war Anfang 2000 schonmal unter dem Kennnamen 'c64fan' hier unterwegs.
  • CommieSurfer schrieb:

    zum Farbsignal oder Farbtakt noch irgendwas einstreut. U. das erst ergibt dann den Fliegengittereffekt, nicht die Farbe selbst.
    Doch, doch... Miss es aus wenn dir danach ist (*), das was du da als Fliegengitter siehst ist der Farbträger von 4,43 MHz und bei PAL ergibt seine Phasenlage die Farbe.

    (*) Pixeltakt bei einem PAL C64 sind 7,88 MHz, eine volle Periode des Farbtaktes ist also knapp 3 Pixel breit.
  • Das es bei vielen Computern und Konsolen (nicht nur beim C64) diesen Fliegengittereffekt statt des typischen "Dot Crawl" gibt, liegt ganz einfach daran, daß man sich einen zweiten Quartz gespart hat und alle Frequenzen aus dem Farbquartz erzeugt, wobei alles außer dem Farbträger nur annäherungsweise den Normen entspricht.
    Eigentlich sind die Farbträgerfrequenzen bewußt so krumm gewählt worden, um genau solche Fliegengittereffekte zu vermeiden. Das funktioniert aber nur, wenn alle Frequenzen exakt eingehalten werden (15625 Hz Zeilenfrequenz und 50 Halbbilder pro Sekunde bei PAL), was beim C64 und vielen anderen Computern bekanntlich nicht der Fall ist.
  • LogicDeLuxe schrieb:

    Das es bei vielen Computern und Konsolen (nicht nur beim C64) diesen Fliegengittereffekt statt des typischen "Dot Crawl" gibt, liegt ganz einfach daran, daß man sich einen zweiten Quartz gespart hat und alle Frequenzen aus dem Farbquartz erzeugt, wobei alles außer dem Farbträger nur annäherungsweise den Normen entspricht.
    Das war durchaus Absicht, man wollte den dot crawl vermeiden. Bei einem bewegten Bild stört er nicht, aber bei einem Standbild wie einem Computer ist er sehr lästig.
  • Mit einem zweiten, unabhängigen Quarz bekommt man keinen Dot Crawl, sondern 'color flicker all over the place' an jeder (vertikalen) farbigen Kante. Siehe ZX Spectrum, besonders die frühen Issues.

    Gerrit schrieb:

    Wenn das so passiert stimmt was nicht mit deinem Monitor.
    Philips schaltet tatsächlich beim 1084 im Y/C-Modus die Farbträgerfalle ab und den Color-Eingang zum PAL-Decoder durch, läßt den Y/Comp.-EIngang aber weiterhin drauf. Immerhin mittels Transistorstufe getrennt, sodaß das Color-Signal nihct in den Luminanzkanal rübersuppt... aber ich habe keine vernünftige Erklärung, warum sie nicht stattdessen das Y/Comp.-Signal abbschalten und C ständig dran lassen. Oder einen 3p2t-Schalter nehmen.


    kinzi schrieb:


    Fazit:
    Das Übersprechen auf dem Kabel zum Bildschirm passiert nachweislich, wenn das Kabel keine einzeln abgeschirmten Adern hat. Gegenteilige Behauptungen sind im Reich der Märchen anzusiedeln.
    Nicht so voreilig, junger Freund. Erstens: Commodore hat die Erzeugung des Composite-Signals mehrdfach geändert, mit tendenziell besser werdender Trennung von Luma und Color. Meine Erfahtrungen stammen beispielsweise von einem 128er, der theoretisch sogar noch besser sein sollte als der C64 E. Zweitens hatte ich durchaus getrennt geschirmte Kabel verwendet (wie effektiv die Schirmung in dem Frequenzbereich auch immer gewesen sein mag). Und drittenms war die Behauptung meinerseits nicht 'ich habe Muster gesehen', sondern 'der PAL-Decoder hat Signalreste gesehen, die er zu decodieren versucht hat'. Und _da_ hast Du gerade überhaupt nicht bewiesen- im Gegenteil, ich meine in Deinen Bildern noch leichte Helligkeitsschwankungen zu entdecken, die genau das sein könnten. Oder aber Reste vom Pixel-Takt, der dann aber völlig wilde Farben oder -mangels Burst- keine Farbinfo abgeben würde.

    Blöderweise ist mindestens der fragliche Monitzor inzwischen defekt und ich momentan nicht in der Lage, ihn zu flicken...

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mc71 () aus folgendem Grund: Verzweifelter Versuch Zitate zweier Seiten in ein gemeinsames Posting zu ziehen, weil diese mistige Forensoftware es nicht schafft Folgepostings ihrer Quelle zuzuordnen- vulgo: Baunstruktur.