Commodore 1551: U8 blockiert U9

  • Commodore 1551: U8 blockiert U9

    Habe hier einen interessanten Fehler vorliegen. vielleicht weiß ja jemand was dazu ...

    An meinen Plus/4 sind ständig 2 1551 angeschlossen, mit Geräteadresse 8 und 9. Schalte ich nur die 9 an, aber die 8 bleibt aus, aber eingesteckt, bekomme ich kein Zugriff auf die 9. Als wenn der Bus hängt, es wird keine Fehlermeldung oder so ausgegeben. Ziehe ich dagegen die 8 vom Rechner ab, und es ist nur die 9 am Expansionsport angeschlossen, funktioniert der Zugriff auf die 9 ohne Probleme. Ein angeschlossenes und eingeschaltetes serielles Laufwerk auf Adresse 8 blockiert nichts.

    Sind beide 1551 eingeschaltet, funktionieren beide problemlos.
  • Wundert mich jetzt nicht. Denn die Umschaltung zwischen den Adressen passiert über einen Eingang der PLA im Paddle. Wenn die daran hängende 1551 abgeschaltet ist wird dieser Eingang als 'LOW' gelesen und die PLA mappt den 6523T in den entsprechenden Speicherbereich. Das scheint der für ID9 zu sein.
  • Muss auch nicht. Ob die Floppy auf ID8 oder ID9 reagiert wird über die Adresse an der der 6523T im Speicher des C16/+4 zu finden ist entschieden. Damit du das von der Floppy aus steuern kannst muss es dazu eine Leitung geben. Im Schaltplan zum Paddle ist die deutlich zu sehen. Wird als 'DEY' gekennzeichnet, in der 1551 heisst sie 'DEV'. Sie hängt an PC2 des 6525 in der 1551. Ist die 1551 ausgeschaltet hat diese Leitung 0V, wird also von der PLA als 'LOW' interpretiert.

    Daraus ergibt sich, daß der 6523T bei ausgeschalteter 1551 eben immer noch sichtbar ist, aber nicht notwendigerweise auf der Adresse auf die die 1551 per Jumper eingestellt ist oder vor dem Abschalten per Software eingestellt wurde.
  • So, das ganze mal mit einen anderen Rechner und 2 anderen 1551 ausprobiert. Es bleibt der gleiche Fehler, wobei nun die Frage ist, ob es ein Fehler ist oder gezielt so gewollt. Denn ...

    Gerrit schrieb:

    Wenn die daran hängende 1551 abgeschaltet ist wird dieser Eingang als 'LOW' gelesen und die PLA mappt den 6523T in den entsprechenden Speicherbereich.
    Du meinst also, wenn der Eingang LOW gelesen wird, blendet er den 6523T dort ein, wo eigentlich der für U9 erscheinen sollte? Der 6523T wird ab $FEE0 bis $FEEF für U8 oder $FEC0 bis $FEDF eingeblendet.

    Ausprobiert habe ich übrigens auch, die Paddles in unterschiedlicher Reihenfolge am Plus/4 zu hängen, also erst U8, dahinter U9 (also die logische Reihenfolge der Geräteadressen) oder auch andersherum.
  • cbm-warrior schrieb:

    Du meinst also, wenn der Eingang LOW gelesen wird, blendet er den 6523T dort ein, wo eigentlich der für U9 erscheinen sollte?
    Ja, damit hast du zwei Stück 6523T die an derselben Adresse lauschen und da nur eine dahinterhängende Floppy eingeschaltet ist gibt das zwangsläufig Ärger.


    cbm-warrior schrieb:

    Ausprobiert habe ich übrigens auch, die Paddles in unterschiedlicher Reihenfolge am Plus/4 zu hängen, also erst U8, dahinter U9 (also die logische Reihenfolge der Geräteadressen) oder auch andersherum.
    Das Paddle reicht den Expansionport unverändert duch, es kann also keinen Unterschied machen.


    cbm-warrior schrieb:

    Es bleibt der gleiche Fehler, wobei nun die Frage ist, ob es ein Fehler ist oder gezielt so gewollt
    Eher ein Fehler der keinen interessiert hat, die 1551 wurde etwas mit der heissen Nadel gestrickt wie man am Rest des Systems sehen kann.

    Das komplett zu korrigieren ist gar nicht so einfach. Du bräuchtest eine weitere Leitung im Kabel die die +5V von der 1551 ins Paddle bringt und dort die Freigabeleitung eines Gatters eines 74LS126 steuert welches zwischen PLA und 6523T sitzt. Dazu noch ein Pullup am /CS des 6523T und schon ist der garantiert inaktiv wenn die 1551 abgeschaltet ist.
  • cbm-warrior schrieb:

    Es bleibt der gleiche Fehler
    s/Fehler/Verhalten

    cbm-warrior schrieb:

    gezielt so gewollt.
    +1

    Man arbeitet für normal mit Floppy 8; eine ausgeschaltete Floppy wird also auf #9 am wenigsten stören. Und ganz abklemmen kann man sie auch nicht, das würde eine zusätzkliche Leitung von der Floppy zum Paddle benötigen und man hätte das Problem, daß der TriPort im Paddle nicht initialisiert wird, wenn man die Flioppy nach dem Rechner einschaltet.
  • Benutzer online 1

    1 Besucher