VC 20 keine Schrift und keine Zeichen

  • VC 20 keine Schrift und keine Zeichen

    Hallo,
    habe mal eine Frage an Euch. Habe mir einen VC 20 ersteigert. Beim ersten Einschalten war alles problemlos.
    Heute hab ich ihn nochmal ausprobiert. Auf einmal zückte der Cursor wie verrückt, dann war die ganze Schrift weg. Auch bei nochmaligen an und ausschalten bleibt nun die Schrift weg.
    Was kann kaputt sein? Habe leider gar keine Ahnung...
    Danke für Eure Antworten!
    lg Peter
  • Hast du ne Floppy oder Datasette? Dann probier mal "blind" nen Befehl einzugeben. Spielmodul ginge vermutlich auch.
    Alternativ müsste auch ein BASIC Kommando um die Hintergrundfarbe zu ändern reichen. Wenn sich da was tut isses das sehr wahrscheinlich das Char-ROM (mit etwas Pech das Farb-RAM, aber eher unwahrscheinlich).
    Wenn sich nichts tut evtl. das BASIC-ROM (oder der evtl. vorhandene Chip-Select Schaltkreis)
  • Erste Frage: was für einen VC hast Du? Ist die Power-Buchse rechts 2-polig oder DIN? Das geschilderte Symptom tritt auch bei defektem RAM auf. Um hier weiterzukommen, muß erst bekannt sein, was für eine Hauptplatine in deinem VC-20 steckt.

    Nächste Frage: hast Du ein Multimeter und weißt Du, wie man damit umgeht? Als nächstes sollte nämlich auch noch das Netzteil gecheckt werden, damit es dir im Zweifelsfall nicht noch mehr Bauteile im Rechner brät.
  • Hallo,
    Habe heute mal Eure Ratschläge durchprobiert, also der VC regiert auch nicht mehr auf die Datasette und auch keine Rahmen-bzw. Hintergrundfarbenänderung mittels Poke-Befehl ist mehr möglich...
    Habe alle Chips mit IR-Thermometer gemessen, alle werden warm ausser der Reihe UC2 bis UC 6. Ist das dass Basic?
    lg Peter
  • Das "Netzteil" ist dann nur ein einfacher abgesicherter Trafo und sollte im Leerlauf (also VC-20 ausgeschaltet bzw. direkt an den Pins - beim Messen nicht kurzschließen!) etwa 10-11 V~ liefern. Die 5 Volt werden daraus im VC mit einem Gleichrichter und Spannungsregler erzeugt, die mißt Du am besten am großen Glättungskondensator (Edit: C44).

    Da der VC den weißen Hintergrund mit türkisem Rahmen liefert, sind zumindest der Videochip und die CPU soweit in Ordnung, sonst käme dein VC noch nicht mal soweit.

    Das interne RAM steckt in den Chips UD2..UD6 und UE2..UE6. Check erstmal die Rückseite auf eine kalte oder lose Lötstelle, bei Verdacht nachlöten. Dann solltest Du dir ein oder zwei 2114 zum Testen besorgen: setz' einen 2114 von oben huckepack nacheinander auf die 10 Chips (richtig rum und nur im ausgeschalteten Zustand stecken und wieder wegnehmen!!!). Falls der Chip darunter eine taube Nuß ist, wird er vom aufgesetzten Chip "überstimmt", dann tut's der Rechner wieder und Du weißt, welchen Chip Du auslöten und ersetzen darfst.

    Kurzer Zwischenbericht nach diesen Tests wäre prima.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Mike ()

  • 2114 sind SRAM-Chips, welche 1024 4-Bit Werte speichern. 10 von denen ergeben so die 5 KB RAM, die im VC-20 eingebaut sind. Ein weiterer 2114 hält die Farbinformation für jedes Zeichen.

    Ich kann dir an der Stelle (also, mangelnde Löterfahrung...) aber nur raten, hier mal im Forum zu schauen wo ein Treffen in nächster Zeit in deiner Nähe stattfindet, und schreibst mal kurz in so einen Thread mit Verweis hierhin rein, ob Du deinen defekten VC mal dahin mitbringen kannst. Wenn Du, ohne dich wirklich gut auszukennen, mit dem Lötkolben loslegst, ist einfach die Gefahr zu groß, daß noch mehr kaputtgeht.

    Also, bis auf den Videochip sind alle ICs im VC-20 (halbwegs) Standard-Komponenten und immer noch gut erhältlich - die ROMs kann man auch recht problemlos ersetzen.