CBM3022 mit defektem Bildschirm

  • CBM3022 mit defektem Bildschirm

    Ich hatte hier noch einen CBM3032 rumstehen, der schon seit einigen Monaten vor sich hin staubt.
    Heute Vormittag habe ich das Board repariert. Die dyn. RAMs sind vermutlich alle gestorben, weil mal wieder die Diode in der -5V Spannungsmimik defekt war und die RAMs -10V bekommen haben. Ich hatte
    noch keine Lust die alle auszulöten.
    Dann noch ein defekter 74191 in der Takterzeugung und ein defektes C000-ROM. Und das Video-RAM war auch hinüber. Bis auf das RAM scheint das Board wieder ok zu sein (getestet in einem anderen CBM)

    Aber der Monitor ist tot. Die Bildröhre glimmt nicht. Der Trafo liefert 17,8 Volt nach oben. Das scheint ok zu sein.

    Als erstes wollte ich mal die Monitorplatine entstauben, aber ich scheitere schon beim Ausbau. Ich müsste in den Monitor hineingreifen, um die hinteren Rastbolzen zu lösten, aber das traue ich mich nicht.
    Ich haben noch nie einen Monitor repariert und habe einigen Respekt vor den Spannungen.

    Was muss ich machen, damit im Monitor garantiert alles spannungs- und ladungsfrei ist und ich bedenkenlos die Platine ausbauen kann?
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / C64+1541 / VC20

  • Problem ist, ohne Spannung kann man schlecht messen... Im Monitor dürftest du irgendwo einen Regler finden, meiner Erinnerung nach ein 7812 der aus den erwähnten 17V die vom Monitor benutzten 12V macht. Der wäre mein erster Verdächtiger falls sich davor nicht noch irgendwo eine Sicherung rumtreibt.
  • Gerrit schrieb:

    Problem ist, ohne Spannung kann man schlecht messen
    Ja, ok - das geht dann schon irgendwie. Ich wüsste nur gerne vorher, was man anfassen darf und was nicht.
    Und vorher muss - wie gesagt - erstmal die ganze Platine raus. Ich denke, dann kann man auch besser messen.

    EDIT: ich habe die Platine jetzt losbekommen - aber Mist! Die ist ja an der Ablenkeinheit fest angelötet. Das wird ja spassig. :S
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / C64+1541 / VC20

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von detlef ()

  • Warum kann ich jetzt nicht mehr Editieren bzw. bekomme beim Speichern eine Fehlermeldung?

    Also was ich noch ergänzen wollte:

    Weil ich die Verbindung vom Zeilentrafo zur Bildröhre nicht abbekomme (ja, ich habe die Bildröhre vorher nach Anleitung aus dem Netz entladen), habe ich erst mal davon Abstand genommen, die Platine ganz auszubauen. Ich kann sie jetzt aber soweit aus dem Gehäuse ziehen, dass ich messen kann.
    Am Ausgang des 12V-Spannungsreglers messe ich keine Spannung. Der ist dann wohl hinüber. Zum Glück ist er angeschraubt und nicht genietet.

    Aber zum Wechseln muss jetzt trotzdem die Platine raus und ich kriege diese doofen Federhaken an der Anodenkappe nicht heraus. Und ich möchte auch nicht die Bildröhre beschädigen.
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / C64+1541 / VC20

  • Den Anodenstecker muss Du nicht unbedingt herausfummeln. Wenn Du die Röhre schon entladen hast, kannst Du den Anodenstecker mit einer gebogenen Spitzzange zuerst nach "oben" drücken und versuchen, ob Du den unteren Haken heraus bekommst und dann nach unten drücken etc.

    Die hinteren Befestigungsbolzen der Platine habe ich mit einer gebogenen Spitzzange zusammengedrückt und gleichzeitig die Platine dort etwas angehoben. So bekommt man die ganz gut heraus.

    Vor dem 7812 sind 4 Dioden als Gleichrichter - messe die auch.
    <--- Das da ist eine Hälfte meines Ichs
  • Eloy_Dorian schrieb:

    Den Anodenstecker muss Du nicht unbedingt herausfummeln. Wenn Du die Röhre schon entladen hast, kannst Du den Anodenstecker mit einer gebogenen Spitzzange zuerst nach "oben" drücken und versuchen, ob Du den unteren Haken heraus bekommst und dann nach unten drücken etc.

    Die hinteren Befestigungsbolzen der Platine habe ich mit einer gebogenen Spitzzange zusammengedrückt und gleichzeitig die Platine dort etwas angehoben. So bekommt man die ganz gut heraus.

    Vor dem 7812 sind 4 Dioden als Gleichrichter - messe die auch.
    Am Eingang des 7812 habe ich ca. 22 Volt gemessen. Deswegen bin ich davon ausgegangen, dass es der Regler ist.
    Das mit dem Anodenstecker werde ich gleich noch mal probieren.

    Wieviel Ampere muss des 7812 können? Reicht 1A aus?
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / C64+1541 / VC20

  • Eloy_Dorian schrieb:

    Ich glaube, ich habe bei meinem 3032 einen mit 1,5A eingebaut.
    Ok.

    Der Tipp mit dem Hochschieben des Anodensteckers war super - ging ganz leicht raus.

    Ich habe jetzt den ganzen Bildschirm abgeschraubt. So kann ich an meinem Lötplatz arbeiten, ohne die Kabel zu Ablenkeinheit ablöten zu müssen. Die Platine lässt sich ja weit genug herausziehen. Ich muss das ganze Teil sowie so noch mal komplett zerlegen und den Flugrost beseitigen. Im Moment soll er erst mal nur funktionieren.

    Hah! Ich habe sogar 7812 mit 1,5A da. :thumbsup:
    Dann werde ich den morgen gleich einbauen. Für heute reicht's erst mal.

    EDIT: Ich konnte es dann doch nicht abwarten und habe den 7812 gleich eingebaut - und es funktioniert! :tanz:
    Morgen kann ich mich dann um die Tastatur kümmern. Ich habe gerade festgestellt, das da höchstens 10 Tasten funktionieren. :cry:

    Vielen Dank für die Hilfe !!!
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / C64+1541 / VC20

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von detlef ()