Mal wieder... 1541 von jetzt auf gleich plötzlich Dauerläufer

  • OK, sorry, dann sind wir da teilweise einem Irrtum aufgesessen. Macht aber nichts. Wenn wir schon dabei sind, Durchgänge zu prüfen:

    Prüfe Durchgang von Pin 40 der CPU auf Pin 6 (bzw. dessen Lötstelle auf der Platine) des 7486.
    Prüfe Durchgang von Pin 40 der CPU auf CIA 1 Pin 34.
    Prüfe Durchgang von Pin 40 der CPU auf CIA 2 Pin 34.
    Diese vier Bauteile hängen an /RESET und müssen untereinander verbunden sein.

    Wenn das passt, bau alles wieder ein und miss bitte an Pin 5 des 7486 beim Einschalten. Dort muss zuerst 0 V anliegen und die Spannung dann in kurzer Zeit auf 5 V ansteigen.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • OK, und ist der Dauerläufer weg?
    Ist Pin 6 bzw. Pin 40 für kurze Zeit nach dem Einschalten auf 0 V und steigt dann an?

    Die Zeitkonstante von R25/C46 ist ca. 100 ms, d. h. nach 0,1 bis 0,2 s müsste die /RESET-Leitung an Pin 40 der CPU von 0 auf ca. 5 V ansteigen. (4,5 V sind OK.)
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Tausch mal den C46. Schaden kann's nicht
    Wenn der durch Alterung viel zu wenig Kapazität hat, kann es sein, dass der Reset zu kurz ist.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Laut Schaltplan 100 µF / 16 V.
    Du kannst auch einen mit mehr Kapazität und/oder größerer Spannung nehmen; 220 µF / 25 V z. B. gingen auch. Dann wird halt der Reset etwas länger.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Grade die Messfunktion für Kondensatoren an meinem MM entdeckt > zeigt 100 an.
    Reset per Brücke von den freiliegenden Kontaktpunkten des C46 auf der Platine gemacht > Spannung an Pin 40 fällt sofort auf 0,1V ab. Brücke weg, Spannung steigt auf 4,4~4,5V
    Läuft nach wie vor pausenlos.

    PS: Das 7486 Beinchen habe ich wieder mit der Platine in Kontakt gebracht.
  • axorp schrieb:

    Tatsuo schrieb:

    Läuft nach wie vor pausenlos.
    dann ist reset in ordnung.
    Ja, dann ist er jetzt in Ordnung, war evtl. eine kalte Lötstelle. Dann kannst du jetzt weitersuchen. Miss mal die Spannung an Pin 4 der CPU (/IRQ).
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Tatsuo schrieb:

    Meine Frage: Bevor ich 74LS14 (gelötet) und 7406 (gesockelt) tausche, wollte ich erfragen, ob ich ohne Oszilloskop (nur mit Multimeter) die Fehlerquelle eindeutig lokalisieren und was es noch außer den beiden Bausteinen sein kann. Ich hab mal was von einem Kondi gelesen...

    Vielen Dank :)
    Diese Tabelle hatte ich mal erstellt.
    Fehlersuchhilfe mit Multimeter.
    Gruß GT76
  • Das passt. Nur mit dem Multimeter, ohne Oszilloskop ist es schwierig. Hat dein Multimeter einen Frequenz-Messbereich? Wenn ja, was für eine max. Frequenz?
    Ansonsten kannst du nur versuchen, GT76s Messpunkteliste durchzugehen.

    Als nächstes zu überprüfen wäre die Takterzeugung (PHI0, Pin 37, müsste 1 MHz sein) und die Chip-Select-Erzeugung der ROMs; dort sind UC6 (74LS00) und UC5 (74LS04) beteiligt.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Wie geschrieben: Takterzeugung an der CPU, "PHI0", Pin 37, müsste 1 MHz sein.

    Außerdem an den ROMs an Pin 20 (/CS); allerdings weiß ich jetzt grad nicht, was da rauskommen muss, irgendwas (Schwankendes) zwischen 10 und 100 kHz vermutlich. Wenn am /CS der ROMs nicht zu messen ist (0 Hz) ist schlecht.

    Was hast du für ein Multimeter? Eventuell findet sich da ein Handbuch im Inetrnet, wo der max. Messbereich drinen steht.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)