CBM 4016-N reparieren

  • Ich habe jetzt nachgemessen und eine Kaltergätebuchse mit Filter passt mir da längenmäßig nicht rein und ich möchte nicht zu viel vom Original verändern.
    Außerdem müsste ich eine neue Platte machen um Sicherung, Schalter und Kaltgerätebuchse nebeneinander hinzubekommen.
    Da wäre mir dann doch lieber nur den Primärfilter zu tauschen. Geht einfach schneller.

    Ich hätte auf eBay einen gefunden. Könnte ich diesen dafür verwenden?
    Falls nein welchen günstigen könnte ich dafür verwenden?

    Oder kann ich einen solchen Primärfilter auch einem alten PC Netzteil oder ähnlichem ausbauen? Es liegt ja oft mal viel Elektroschrott rum.

    ebay.at/itm/Netz-Entstorfilter…13cd07:g:guwAAOSw0hlZsXJE
  • lnino schrieb:

    Wenn nach der Überbrückung immer noch die Sicherung fliegt dann kann es nur mehr der "Waschmaschinen Glätter" sein.
    der elko kann es ja nicht sein, du hast doch den stecker abgezogen?
    dann ist der elko ohne funktion.

    nur wenn der stecker, an der platine, eingesteckt ist,
    geht die wechselspannung vom trafo zu dem gleichrichter auf der platine und
    über den stecker zum elko.

    gruß
    helmut
  • Eloy_Dorian schrieb:

    Folge dem Rat von axorp und lass den Netzfilter weg.
    Okay, dann werde ich das machen. Ist sicher der schnellste und einfachste Weg.
    Wie gehe ich hier am Besten vor?

    Einfach die Kabel des Netzfilter abzwicken und dann die beiden blauen und beiden schwarzen Drähte jeweils mit einer Lüsterklemme verbinden?

    axorp schrieb:

    der elko kann es ja nicht sein, du hast doch den stecker abgezogen?dann ist der elko ohne funktion.

    nur wenn der stecker, an der platine, eingesteckt ist,
    geht die wechselspannung vom trafo zu dem gleichrichter auf der platine und
    über den stecker zum elko.
    Achso, das wusste ich nicht. Ich hatte angenommen, dass der rot markierte Elko auch in Funktion ist, wenn der Stecker vom Mainboard abgesteckt ist.

  • Da sieht man auch schön die Trafo Anschlüsse 220 und 240 Volt. Die Umstellung auf 240 Volt lässt den Trafo deutlich weniger warm werden und brummen. Ein erster Schritt für einen kühlen CBM 4000 :)

    Einiges zum Thema CBM Ice Age findet man auch hier:
    ICE AGE für CBM Netzteile

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Asklia ()

  • Asklia schrieb:

    Bei der Gelegenheit vielleicht auch von 220 Volt auf 240 Volt umstellen.
    Heisst roten/schwarzen Draht vom Trafo an Netzfilter bzw. Buchse umlöte

    Kannst du das noch mal erklären? Welchen Draht muss man wohin umlöten?
    Geht das auch bei anderen CBMs? (3000er/2000er?)
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / diverses C64-/VC20-Zeugs

  • lnino schrieb:

    Einfach die Kabel des Netzfilter abzwicken und dann die beiden blauen und beiden schwarzen Drähte jeweils mit einer Lüsterklemme verbinden?
    achtung, die blauen sind normal die eingänge und die schwarzen kabel die ausgänge.

    falls du die blauen miteinander verbindest, machst du einen kurzschluss.

    bitte nachsehen am netzkabel. ein kabel vom netztkabel muss direkt zum trafo
    und das andere kabel, vom netzkabel, geht über sicherung, an den anderen anschluss am trafo.

    gruß
    helmut
  • Ja, die Umstellung geht im Prinzip bei allen "europäischen" CBM Geräten der 4000er und 8000er sowie 1541/1571 Reihe mit Transformator. Dies gilt NICHT für Geräte mit Schaltnetzteil.
    Allerdings gibt es verschiedene Bauformen; die Hinweise sind nicht allgemeingültig.

    4000/8000 Computer und Floppies: Der meist dicke Trafo hat auf der Primärseite 3 anstelle von 2 Anschlüssen. Zwei davon werden für 220 Volt benutzt. Der dritte Anschluss ist dann für 240 Volt. Man lötet den Draht vom mittleren Anschluss ab auf den dritten äusseren. Eine 1541, 1571 und 8250 hat bereits einen dritten und isolierten Draht am Trafo.

    Ein wenig dazu habe ich hier mal geschrieben:
    8032 Spannungsumstellung 220 - 240 Volt

    Mit deinem Multimeter einfach den Widerstand zwischen den Wicklungen bzw. Leitungen messen. Der grössere Widerstand ist für 240 Volt. Habe so meinen 8032, 3040, 4040, 8250, 1541 und 1571 umgestellt. Die brummen nun weniger und werden dadurch auch etwas weniger warm. Wesentlich mehr Wärme spart man durch den ersatz der Längsregler gegen Schaltregler; siehe "Ice Age".
  • detlef schrieb:

    Kannst du das noch mal erklären? Welchen Draht muss man wohin umlöten?
    Geht das auch bei anderen CBMs? (3000er/2000er?)
    achtung, es gab auch trafos mit 2x 110V. :(

    bitte vor dem umlöten überprüfen ob es eine 240V wicklung gibt.


    1. nachsehen ob am trafo eingang drei anschlüsse vorhanden sind.

    1a. falls nur zwei anschlüsse vorhanden, dann kann man nicht umbauen.

    1b. falls drei anschlüsse vorhanden, prüfen ob es eine 110V oder 240V wicklung ist.
    es könnte ja auch ein gerät für 240V (england) sein und man würde es von 240V auf 220V umbauen :(


    2. gerät einschalten und am spannungslosen netzstecker, die ohmzahl, der wicklung, messen.

    2a. falls am freien anschluss nur ca. 2x die hälfte an ohm vorhanden, gegenüber den belegten,
    dann ist es ein 2x 110V trafo und ein umbau auf 240V ist nicht möglich!

    2b. falls zwischen dem freien anschluss und einem der belegten, die ohmzahl, höher zu messen ist,
    als an den beiden original belegten (das sind die am netzstecker) dann muss man das netzkabel
    umlöten, an den etwas höher ohmigen anschluss.
    nach dem umlöten muss die ohmzahl, am netzstecker, ca. 10% höher sein als vorher!

    2c. falls die ohmzahl, zwischen dem freien anschluss und den belegten, etwas kleiner ist (nur ca. 90%),
    als an dem netzkabel vorhanden. dann nicht umbauen, dann ist es schon ein 240V gerät!
    man würde es von 240V auf 220V umbauen!

    gruß
    helmut
  • axorp schrieb:

    achtung, die blauen sind normal die eingänge und die schwarzen kabel die ausgänge.
    falls du die blauen miteinander verbindest, machst du einen kurzschluss.
    Danke für den Hinweis. Ich habe nun die richtige Zusammensetzung gefunden.
    Vorerst mit Lüsterklemmen um mal zu schauen ob es den gewünschten Effekt bringt.
    Und siehe da, die Sicherung bleibt intakt. Erst mal noch nichts wegen 240V umgestellt.
    Danke für den Tipp mit dem Netzfilter. Komisch, dass dieser scheinbar durch den Paketversand defekt wurde. :(



    Wenn ich nun den CBM einschalte, dann macht er "diedeliep" und für den Bruchteil einer Sekunde erscheint dieser Bildschirm.
    Danach ist der Bildschirm schwarz.
    Habe so was schon mal im Internet gesehen und es war als "Garbage Screen" betitelt.
    Wie gehe ich hier vor um den Fehler zu finden und zu beseitigen?

  • lnino schrieb:

    Wenn ich nun den CBM einschalte, dann macht er "diedeliep" und für den Bruchteil einer Sekunde erscheint dieser Bildschirm.
    Danach ist der Bildschirm schwarz.

    er macht ja einen reset und inizialiert den monitor und die i/os usw.
    und er piepst ja. den bildschirm löscht er ja auch.

    dann ist ja der cpu bus wohl ok.
    ich vermute zeropage-ram oder ein rom defekt.
    er kommt nicht dazu anzuzeigen wieviel ram frei ist.

    das $Fxxx und das $Exxx rom scheint ok zu sein. nun kann ich mich, nach jahrzehnten,
    nicht mehr erinnern, in welchem rom die ram free-routine ist. spontan würde ich sagen im $Dxxx.

    ich hoffe das sich @Toast_r hier meldet, er hatt inzwischen sehr viel erfahrung, mit den cbm rechnern.

    oder einer, hatt die möglichkeit, an einem cbm 3xxx, 4xxx oder 8xxx,
    nur mal das $Dxxx ( $Cxxx, $Bxxx) rom zu entfernen und nachsehen ob dann auch nur der bildschirm gelöscht wird
    ohne der commodore start free meldung.

    gruß
    helmut
  • axorp schrieb:

    christian @Toast_r, nils @for(;;), @Jogi und ich,

    sind auf der cc2017, anfang oktober, in berlin. classic-computing.de/veranstaltungen/cc2017/
    dann würden wir deinen rechner reparieren.
    Wow, vielen lieben Dank für das Angebot. Das ist total nett.

    Leider ist das soooooo weit weg von meinem zu Hause Österreich (Tirol).
    Und genau an diesem Wochenende bin ich leider schon woanders unterwegs.

    Kannst du mir sagen was ich selbst machen kann?
    Mit dem Lötkolben kann ich gut umgehen. Also ICs mit der Lötlitze entfernen sockeln usw ist kein Problem.

    Wenn du mich etwas leitest dann bekomme ich das sicher hin.
  • ich hoffe es meldet sich hier einer, bei dem, die roms gesockelt sind.

    die können einfach, durch entfernen, von einem rom, testen ob ihr rechner
    sich dann auch so meldet wie deiner zur zeit.

    du könntest uns nur deine platine zusenden und wir würden die dann auf der cc2017 reparieren.
    falls wir es hier, in den kommenden zwei wochen, nicht hinbekommen.

    gruß
    helmut
  • Wenn die Roms kaputt sind wie würdet ihr die reparieren? Die alten ICs bekommt man doch nicht mehr zu kaufen, oder?

    Mit dem Versenden der Platine habe ich etwas Bauchweh. Viele meiner letzten Pakete kamen beschädigt bei mir an. Behutsames Umgehen ist da leider fehl am Platz.

    Was würdet ihr denn für eine Reparatur verlangen? Ohne zu wissen was kaputt ist wird man das schwer sagen können.

    Eigentlich war der CBM als Bastelprojekt gedacht in dem ich so viel Hand wie möglich anlegen kann. Es ist sehr verlockend das Mainboard repariert zu bekommen, aber irgendwie möchte ich selber auch was machen. :)
  • lnino schrieb:

    Was würdet ihr denn für eine Reparatur verlangen? Ohne zu wissen was kaputt ist wird man das schwer sagen können.
    unser stundenlohn ist null komma nix :) und die ersatzeile, geben die vereinsmitglieder, meistens auch kostenlos ab :)
    unser "Verein zum Erhalt klassischer Computer e.V." ist zum erhalt der rechner ja da.
    deswegen habe ich mich da auch angemeldet und bin da auch eingetreten.
    weil mir der erhalt der geräte und die weitergabe der reparaturtips sehr wichtig ist.

    lnino schrieb:

    Eigentlich war der CBM als Bastelprojekt gedacht in dem ich so viel Hand wie möglich anlegen kann. Es ist sehr verlockend das Mainboard repariert zu bekommen, aber irgendwie möchte ich selber auch was machen.
    so sehe ich das auch.
    jeder, der interesse hatt, sollte unterstützt werden, seine erfahrung selbst zu sammeln
    und nichts ist schöner, als wenn man es selbst schaft, fehler logisch zu finden und zu reparieren.

    ich mag es eigentlich nicht, wenn man anfängt, etwas, auf gut glück, auszulöten oder zu tauschen.
    dann kann es vorkommen, das man noch mehr kaputt macht und noch mehr fehler sich selbst einbaut.

    wenn man den fehler gefunden hatt oder ihn einkreisst und dann erst lötet
    und es immer noch nicht geht, kann man sehr schnell selbst feststellen ob noch etwas defekt ist oder
    man den neuen fehler selbst verursacht hatt. (z.b. beinchen umgeknickt, lötkleks, durchkontaktierung zerstört und und und)

    ich selbst möchte viel lieber, wenn du ihn mit unserer hilfe, selbst reparierst.

    leider habe ich keinen platz, mein hobbyraum ist immer noch nicht fertig
    und viele sachen habe ich mir noch nicht neu angeschafft.

    ich hoffe das sich hier noch welche melden, die dir auch helfen können.
    sonnst melde dich bitte, in unserem vereinsforum, mit an.
    da ist toast_r und jogi und die sind hier selten. da werden sie geholfen.

    die roms kann man durch eproms ersätzen und die können sie dir programmieren.

    gruß
    helmut
  • lnino schrieb:

    Danke für den Tipp mit dem Netzfilter. Komisch, dass dieser scheinbar durch den Paketversand defekt wurde.
    Die Dinger sterben ganz spontan. Das muss nicht unbedingt mit dem Transport zu tun haben. Das würde ich auch nicht dem Verkäufer anlasten.
    PET 2001 / CBM 3032 / CBM 3040+4040 / CBM 8250 (Dauerleihgabe) / diverses C64-/VC20-Zeugs