1571 macht immer "File not found error"

  • Laut der Symptom-Ursache-Liste von Ray Carlsen kommt als nächstes IC der 251829-01 in Betracht. Was dieser Chip genau macht, konnte ich bisher nicht herausfinden, außer dass es ein "gate array" ist, welcher auch in der 1541, 1551 verwendet wird. Habe jetzt erst mal einen Sockel eingelötet und einen NOS 251829-01 aus einer Lagerauflösung bestellt, ich hoffe mal, dass ich dann die Ursache gefunden habe und die Floppy wieder funktioniert.

    Grüße,
    Ralf
  • Der 251829-01 sitzt auch in meiner 1570 und 1551 Floppy. Er hat drei Funktionen, davon ist eine bus-seitige, Select-Signale für RAM, ROM, VIAs und CIA zu erzeugen - wenn das kaputt wäre, könnte man die Floppy kaum ansprechen. Diese Funktion ist wohl intakt.

    Die einzige mir wesentlich erscheinende Funktion dieses Bausteins im Bereich der Schreib-Lese-Hardware (also der Datenpfad zum Kopf hin) ist die sogenannte Sattelkorrektur, die meines Wissens aber nur auf den inneren Spuren 31-35 aktiv wird und dort vorsorglich bestimmte Fehlerbedingungen abfängt. Wäre die Sattelkorrektur kaputt, müsste man aber zumindest die äußeren Spuren klaglos lesen können.
    Gesendet über das Bimetall Thermorelais meines Rowenta DW 4015 Dampfbügeleisens
  • Einfach mal gefragt ;)

    Bist Du sicher das es an der Platine liegt?

    Hab auch eine 1571 hier, aus einem C128D, welche nicht richtig will.

    Durch Austauschen, mit einem zweiten C128D, hab ich festgestellt das es am Laufwerk selber liegt.
    Anderes LW mit der Gleichen Platine = funktioniert, LW mit anderer Platine = funktioniert nicht.

    Köpfe sind gereinigt und Messwerte OK, mehr hab ich noch nicht gemacht.

    Nur damit Du nicht alle IC ersetzt und es nix bringt :rolleyes:

    Gruss C=Mac.
  • Mal grundsätzlich, hast du an dem c64 mit dem du deine 1571 testest, auch mal ein anderes laufwerk angeschlossen ob das läuft? Wenn nicht kann auch der 7406 im c64 diesen defekt aufrufen...hatte ich schon mal!

    Ansonsten würde ich mit U15 74ls14 erstmal tauschen.

    Hier gibts auch 1571 troubleshooting guide, allgemein hilfreich.

    Welchen 7406 hast du getauscht? U16 oder U8 ? ...evtl. sollte man hier beide ersetzen ?(
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Hallo,

    ja an dem C64 hatte ich auch eine 1541 und eine OC118 zwischenzeitlich laufen lassen, die funktionieren, der C64 ist okay.

    U15/74LS14 muss ich mal austauschen, habe ich glaube ich sogar da.

    Den Troubleshooting-Guide bei Retro Isle kannte ich noch nicht, werde ich mal durchschauen.

    Ich hatte den U8 - 7406 getauscht, weil der laut der Troubleshooting-Liste von Ray Carlsen für einen "Drive not ready Error" verantwortlich sein kann.

    Grüße,
    Ralf
  • Bei der 1541 ist es oft der 7406 welcher neben dem 7414 sitzt...deswegen habe ich gefragt. Aufgrund des anderen layouts der 1571 würde ich hier vorsorglich erstmal beide 4706 und danach den 7414 tauschen, die kosten ja nicht die welt...wenns dann immer noch nicht läuft weiß ich auch nicht :huh:
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Versuche mal einen Track direkt anzusteuern.


    120 input "track to read";t
    130 input "sector to read";s
    140 open 15,8,15
    150 open 5,8,5,"#"
    160 print#15,"u1";5;0;t;s
    170 for i=1 to 20
    180 get#5,a$:if a$="" then a$=chr$(0)
    190 print a$
    200 next
    210 close 5:close 15



    Gruß: Stephan
  • So mal ein update: Diese Woche ist der 251829-01 gekommen, brauchte ich ja nur noch in den schon eingelöteten Sockel einsetzen und ...................................................................................................................................................................................................
    LÄUFT!
    ES lag also genau an diesem IC.
    Danke nochmals allen für die Hilfe.

    Grüße,
    Ralf