Reparaturversuch Schneider CPC 464

  • Könntest Du mir bitte ein Foto der ausgebauten Platine in hochauflösend senden oder hier einstellen. Die Revisionsnummer steht auf der Platine. Waren die Kabel da schon angelötet? Das ist schon mindestens die vierte Revision mit flacher Tastatur und Folienschuhen. Die ersten hatten noch echte Kabel und Stecker.

    Gruß
    Tom
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • Auf der Platine steht:

    PT NO.Z70200
    MC0008C

    Die Kabel waren so. Da bin ich unschuldig :)
    Das einzige was ich da mal gemacht hatte, war nen MP3 Port
    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von pachen ()

  • Hallo,

    die Aufnahme ist angekommen. Du tauscht bitte 74HC04 gegen baugleiches TTL aus. Alle ausgetauschten IC gleich Sockeln.
    Die RAM Bausteine bekommst du bei Bobbel im Shop KLICK MICH AN die sind dort auf Lager und der Preis ist gut.
    Alternativ bei EBay schauen.

    40010, Z80A und AY habe ich hier als Ersatzteil liegen. Die anderen Bausteine habe ich nicht da. Wenn Du ein Oszi hast, erstmal messen wo und ob überhaupt noch Signale vorhanden sind.

    Bei Überspannung gehen in der Regel die TTL und die RAMs sofort kaputt. Ebenso die Z80A CPU. Ich würden den jetzt komplett durchsockeln und einmal alles neu machen. Das ist in ca. sechs Stunden erledigt.

    Gruß
    Tom
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • sooo ^^ sockel und ttl´s sind bestellt :)
    werde alle ic´s dann mal sockeln.

    ram muss ich noch schauen.

    @Pentagon werden uns bestimmt einigen ^^ aber erstmal sockeln usw :) ^^ aber ich schaff das nicht in 6h ^^ ich brauch da meine zeit :P

    bilder usw. wenns dann soweit ist.

    gruss
    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65
  • soooo :)

    die rams sind raus - die sockel drin :)
    74hc04 raus und gesockelt :)

    Frage:

    kann ich die rams und den 74hc04 einsetzten und das system testen ?
    oder muss ich damit rechnen das die gegrillt werden?

    Gruss


    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65
  • Du kannst das testen, das ist kein Problem. Kann nur sein das die CPU und 40010 durch sind, dann bleibt es halt "dunkel"
    Bitte nicht verpolen, Plus ist innen. Und bitte nur 5 Volt stabilisiert, 2000mA besser 2500 mA.

    Gruß und viel Erfolg
    Tom / Pentagon
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • Juhhhuuuuuuu :)


    Bild :)
    Tape :)

    aaaaaaaaaaber ^^
    einschalten am rechner will nicht.
    wenn der schalter am rechner auf on ist kann ich den rechner am monitor anschalten
    schalte ich den rechner am rechner aus (doofer satz) kann ich nicht am rechner wieder anschalten.

    jemand dazu ne idee ?
    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65
  • wenn ich den cpc an mein netzteil hänge verbraucht es beim einschalten ca. 500 mA
    wenn ich den das netzteil bei eingeschaltetem cpc anschalte auch ca. 500 mA

    in beiden fällen kommt kein signal raus

    schalte ich das netzteil ein wenn der cpc eingeschaltet ist liegt der verbrauch bei 610-620 mA
    und ich hab ein bild

    komische sache ^^

    unter basic ein ?free(0) bringt 43533
    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65
  • Für eine Ferndiagnose, war ich ja gar nicht schlecht :D (/Me klopft sich auf die Schulter)

    Hast Du mal den Powerschalter selbst überprüft? Schaltet der wirklich einwandfrei? Bei gefühlt 70% aller meiner CPC war der irgendwann mal hin oder verklebt. Man muss die vier Blechfähnchen am Schalter aufbiegen und den vorsichtig zerlegen. Vorsicht das Innenleben fliegt durch die Feder schnell weg. Dann den Schalter ordentlich spülen und reinigen. Danach wieder zusammenbauen.

    Ansonsten könnten die Elkos noch platt sein. Das hatte ich auch schonmal, da schaltete er sich (CPC6128) nur noch verzögert oder gar nicht mehr ein.

    Die Funktion ist ja sonst wieder hergestellt und von daher kann der jetzige Fehler nichts arges mehr sein.

    Glückwunsch zur Rettung, hast Du gut gemacht :thumbsup:
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • Das hat nichts mit 8-Bit oder 16-Bit zu tun, sondern mit der Alterung der Elkos. Beim CPC 6128 waren alle platt und durch. Ich tausche die mittlerweile obligatorisch. Danach sind die Rechner wieder laststabil an den Ports, das Bild ist deutlich kräftiger und hat keine Streifen. Es kann nicht schaden die 30 Jahre alten Dinger rauszuwerfen. Am meisten bemerkt man den Unterschied in den alten Monitoren. Der Austausch ist fast Pflicht.
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • Nach dem Grillversuch sind die RAM´s sehr warm geworden und wurden alle 8 ersetzt
    der 74LS04 ist auf Tip von Pentagon mit gewechselt worden.
    ob der hin war ?? ka ^^ und überprüfen nachträglich geht nicht :) da ich die IC´s abgeknipst habe.

    vor dem 12V Test ging der Schalter.
    das merkwüdige ist ja, das das per Schalter oder anstecken des Netzteils sich der Rechner nicht rührt ( Stromverbrauch ca. 500 mA ).
    NUR wenn ich bei eingeschaltetem Rechner & verbundenem Netzteil das Netzteil anschalte kommt der Rechner (Stromverbrauch ca. 620 mA). Sowas wie ein kleiner Stromstoß ?

    Gruss
    pachen
    Amiga 2000 - 68020 , C128 D , C64, 1541, DTV
    Turbo Chameleon 64
    Zx81, Spectrum 16K , Robotron KC 87, Robotron KC 85/3, Philips MSX VG 8010
    Schneider CPC 464 + Monitor GT65
  • Hi @pachen,

    genau so ein Verhalten hatte ich die Tage an meinem C64, siehe hier: Commodore C64 startet nicht per Schalter nur per Einstecken des Netzteils

    Ich dache zuerst auch an einen Defekt vom C64 aber nach dem Wechsel auf ein anderes Netzteil ließ er sich wieder wie gewohnt am Gerät selber einschalten.

    Weiß jetzt nicht ob dir das für den Schneider hilft aber schaden kann die Info wohl auch nicht ^^

    Gruß Thomas
    Experto credite - 3d-druck-community.de