Schlechte Farben mit SVIDEO Mod beim VC-20

  • Schlechte Farben mit SVIDEO Mod beim VC-20

    Ich versuche gerade die Svideo Mod von Mrr19121970 auf meinem VC-20 zum laufen zu bringen, dabei gibt es aber Probleme.
    Die Farben stimmen alle nicht und sind blass, obendrein gibt es seltsame blaue und gelbe Schatten bei den Zeichen (siehe Bild). Das komische ist, dass wenn ich den VC-20 unverändert laufenlasse, dass dann das die Farben ganz normal sind, aber eben auch schlecht lesbar und unschärfer.
    Im Moment habe ich den VIC Chip mit dem Pin 2 über dem Sockel hängen, von dort geht dann das Kabel für ins SVIDEO Kabel (mit Svideo zu SCART Adapter in meinen LCD Fernseher). Wie gesagt, nicht gemoddet und mit einem SCART Kabel sehen die Farben normal aus.

    Hat jemand eine Idee, woran das liegen könnte?20170703_170629.jpg
  • paranoid64 schrieb:

    S-Video zu SCART Adapter machen kein S-Video, sondern schalten Luma/Chroma zusammen und geben das im Scart über Composite aus.
    Doch, gibt es auch, Chroma geht dabei an den Pin für 'rot'. Muss der Fernseher aber können.

    Ansonsten... Hast du Chroma direkt verbunden oder den üblichen Kondensator (siehe Schaltplan VC20) dazwischengeschaltet?
  • Nein, es ist kein Kondensator verbaut. Diese Mod ist eigentlich "Plug and Play", der VIC kommt in einen Sockel, der Pin zwei hat ein Kabel, welches nicht mehr in die Platine leitet, sondern direkt mit dem SVIDEO Stecker verbunden wird. Diese Sockelversion funktionierte aber noch schlechter bei mir. Die Farben verschwanden nach kurzer Zeit komplett, und das Bild wurde eigentlich schwarz weiß. Jetzt, da ich den VIC direkt im eigentlichen Sockel habe, aber mit Pin 2 draußen vor, ist as Bild stabil, aber eben wie zu sehen.
  • Nach dem Einbau des S-Video-Mod muss man meistens noch den Poti neben dem VIC etwas drehen, dann sind die Farben wieder kräfitger, siehe auch:

    sleepingelephant.com/denial/wi….php?title=S-Video_output

    Bitte achte aber darauf, dass dein Wiedergabegerät wirklich S-Video verarbeitet und darstellt und auch im Kabel nichts neu vermischt wird. Sonst kann es nicht klappen.
  • naujoks schrieb:

    Ich versuche gerade die Svideo Mod von Mrr19121970 auf meinem VC-20 zum laufen zu bringen,..][/attach]
    interessant,... ich habe derzeit auch zuviel "grün",... (bei mir aber,.. ohne jeden MOD!!)

    was ist das denn für ein MOD ?? wurde hier irgendwo etwas darüber berichtet ??
    ist mir leider nicht vorher aufgefallen....

    danke, mfG.
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • Mein TV hat keinen Svideo Eingang, sondern nur Scart. Dafür habe ich den SVIDEO auf Scart Adapter. Ich hatte gehofft, dass das kein Problem ist.
    Das können schon zwei verschiedene Fehlerquellen sein! Was genau ist das für ein TV? Gib mal Marke und Typ durch, in der Bedienungsanleitung sollte stehen ob der überhaupt einen S-Video-Eingang hat und wenn ja wie der aktiviert wird.

    Und dann der "S-Video auf Scart"-Adapter: Was ist das für einer? Einer, der nur die richtigen S-Video-Pins verbindet oder einer, der aus S-Video wieder Composite zusammenmischt? Bitte ebenfalls Marke/Typ/Fotos, am besten auch von der Innenverkabelung.
  • Noch hinzuzufügen wäre, dass wenn ich den VC-20 im normalen Zustand ohne Mod an das Svideo Kabel mit Scart Adapter an den TV anschließe, das Bild ganz normal angezeigt wird. Normal, also mit schlecht lesbarem farbigen Zeichen.
  • Gerrit schrieb:

    Ansonsten... Hast du Chroma direkt verbunden oder den üblichen Kondensator (siehe Schaltplan VC20) dazwischengeschaltet?
    Von 6561 PIN2 (Chroma out) ist ein 0.1uF KerKo und 360ohm wiederstand eingebaut und direct nach S-VIDEO chroma Anschluss. Hier das problem muss entweder S-Video/SCART umwander oder fernseher selbst. Diese mischt CHROMA/LUMA als composite und andert die farben.
  • naujoks schrieb:

    Leider kann mein TV das nicht. Ich wusste überhaupt nicht, dass man das bei einigen TVs einstellen kann!
    Das kann sogar mein alter Röhren-TV von Philips schon... 2 SCART, einer kann RGB, der andere FBAS oder S-Video (umschaltbar). Dort ist es echtes S-Video, das Bild ist deutlich besser als bei FBAS. Ist einer der Gründe warum ich das Teil noch habe und nicht bei der Umstellung auf LCD entsorgt habe.
  • Wikipedia SCART-Artikel schrieb:

    Es ist nicht möglich, RGB und S-Video simultan zur Verfügung zu stellen, da bei letzterem der Pin 15 für die Übertragung des separaten Farbsignals (Chrominanz) „missbraucht“ wird. Einige Geräte übertragen das Chroma-Signal auch über Pin 11. S-Video war in der ursprünglichen SCART-Norm (noch) nicht vorgesehen, deshalb hat der Stecker zu wenig Pole, um dafür eine eigene Leitung anzubieten.
    Pin 11 wäre RGB-Grün, das würde die falsche Farbe (grün) erklären. Nur mal so als Schuss ins Blaue. Evtl. ist das S-Video-zu-SCART-Kabel nach diesem Standard beschaltet und liefert daher ein grünes Bild.
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)
  • kinzi schrieb:

    Pin 11 wäre RGB-Grün, das würde die falsche Farbe (grün) erklären. Nur mal so als Schuss ins Blaue. Evtl. ist das S-Video-zu-SCART-Kabel nach diesem Standard beschaltet und liefert daher ein grünes Bild.
    Nicht wirklich... Chroma ist ein Signal bei den die Farbinformation in der Phasenlage des 4.43MHz-Trägers zu finden ist. Wenn du das auf einen RGB-Input legst und den als RGB benutzt wirst du senkrechte Striche auf dem Monitor zu sehen bekommen, aber keinesfalls eine uniforme Farbe.
  • Hast du das mal ausprobiert? Muss ich glaube ich mal machen, würde mich interessieren, wie das aussieht. :)

    Ich kenne die o. a. Schaltung nicht, aber was ist, wenn auf Pin 2 z. B. irgendein Gleichanteil mitkommt, der nicht sauber genug ausgefiltert wird? Ein falsches Signal - was auch immer, evtl. auch Luma oder irgendein Übersprechen - auf RGB-G (Pin 11) würde jedenfalls den Grünstich erklären. Ich würde das erstmal ausschließen wollen, wenn ich den Fehler suchen würde.

    Überhaupt würde ich mal den ganzen Signalweg vom VIC über sämtliche Adapter und Kabel zum SCART-Stecker durchklingeln. Wer weiß, was da kreuz und quer verbunden ist. Aber das ist nur mein Ansatz als Praktiker ...
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)
  • kinzi schrieb:

    Hast du das mal ausprobiert? Muss ich glaube ich mal machen, würde mich interessieren, wie das aussieht.
    Hab ich anders ausprobiert... Man nehme einen C16 und schliesse den per passendem Kabel an einen Monitor an der S-Video kann. Auf der Platine des C16 streut das Chroma-Signal dermassen in Luma ein, daß du dann diese vertikalen Striche hast.


    kinzi schrieb:

    Ich kenne die o. a. Schaltung nicht, aber was ist, wenn auf Pin 2 z. B. irgendein Gleichanteil mitkommt, der nicht sauber genug ausgefiltert wird?
    Deshalb ist bei solchen Schaltungen auch immer ein Kondensator im Spiel, der sorgt dafür, daß nur der Wechselspannungsanteil durchkommt.