Hello, Guest the thread was called3.3k times and contains 36 replays

last post from Kratznagel at the

Version 1.0 erhältlich

  • Quote

    Original von tecM0
    tools wie D64Writer, SIDplayer, fileBrowser usw. würde ich eh auf die SD auslagern


    ...

    Quote

    Original von tecM0


    DAGEGEN! das ist verschwendeter speicherplatz. wenn schon ein pluginSystem dann
    richtig! systemStuff=ROM tools=plugin .... alles andere ist gemurkse.


    T.


    Ja, was denn nun? ;)


    P.S.: Ein D64-Writer ist aus meiner Sicht als Plugin auf der SD-Karte besser untergebracht. Dann wäre im ROM auch mehr Platz, z.B. für ein paar komfortabel ansprechbare FAT-Routinen usw...


    CU
    Kratznagel

  • Es hieß doch, dass im ROM des MMC eh zu wenig Platz wäre, um eine vernünftige Transferroutine mit eingebautem Fastloader/-saver unterzubringen.
    Und das Transferprog auf der SD-Karte unterzubringen hat daher den Vorteil, dass die Coder sich nicht auf den (ja wohl eh nicht ausreichenden) geringen Platz im ROM zu beschränken brauchen.

  • Der d64 writer ist immer noch buggy!
    Hat sich wenig verbessert an der Situation des buggy .d64 writers zur 0.99!
    Kann man mal austesten mit dem Demo "sphaeristerium" von Horizon, Plush usw, #1 auf der LCP'05.
    Wenn man das mit dem MMC transferiert lädt das Startfile nicht! Und das ist beileibe nicht das einzige, was nicht geht...
    Beim Update auf 1.0 gab's Probleme, das MMC wollte partout nicht über die reguläre Update-Funktion (F5?) updaten, nur mit der Recovery-Disk konnte ich es letztendlich doch überreden!
    Vielleicht lag's ja daran, dass ich von Oliver auf der RCC ne verbesserte 0.99 Version aufgespielt bekommen habe und das MMC dachte, dass es schon auf dem neuesten Stand ist...

  • Meins kam mit 0.98, 0.99 hab ich gar nicht erst draufgemacht. Das Update auf 1.00 war völlig problemlos. Und dass die Transferfunktion im Moment noch nicht wirklich nutzbar ist, ich denke, da brauchen wir uns doch nun echt nichts vorzumachen. Deshalb doch auch die Überlegungen eine "vernünftige" Routine über die SD-Karte als Plugin zu realisieren.
    Nach dem Update habe ich testeshalber mal einen Transfer versucht. Da aber die Geschwindigkeit noch immer dieselbe (langsame) ist, gabs gleich einen Reset... :)

  • Seit die langen Dateinamen unterstützt werden, muss man bei den Ordnern und Dateinamen arg aufpassen, dass sie richtig geschrieben sind (gross/klein). Hatte ich in der Vergangenheit auch schon arge Probleme damit.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Quote

    Original von x1541
    Seit die langen Dateinamen unterstützt werden, muss man bei den Ordnern und Dateinamen arg aufpassen, dass sie richtig geschrieben sind (gross/klein). Hatte ich in der Vergangenheit auch schon arge Probleme damit.


    wie...richtig!? gross..klein...? ist das nicht egal?
    erklär' das mal bitte!



    T.

  • Quote

    Original von erik1967
    Hallo, "normales " Update über F5 funktioniert bei mir auch nicht. Hat jemand Probleme mit PlugIns? Lassen sich seid 1.0 bei mir nicht mehr ansprechen.
    Das Bild flackert kurz, und das war es dann auch.


    Mit dem Update auf 1.0 hatte ich keine Probleme.
    Die Picture Plugins funtkionieren bei mir auch nicht. Ich verwende jetzt immer xray64 um pics als .prgs rauszuschreiben/zu konvertieren. FLI interlaced wird ja auch unterstützt. Das Dateibrowser .prg von TNT zeigt bei mir nur einen grünen Rand an und bleibt stehen. Auf dem lemon-Forum hatten auch andere dieses Problem.

  • Ob das in der 1.0 immer noch so ist weiss ich nicht, noch keine Zeit gehabt ...


    Aber generell ist es so, dass Windows ja meistens zwei Einträge pro Datei bzw. Verzeichnis anlegt. Einen Eintrag gibt es nur wenn weniger als 8.3 Zeichen und keine gemischte Gross/Kleinschreibung verwendet werden. Aber so ganz reproduziertbar war das bei mir leider nie :( Im Readme des mmc64 update steht auch irgendwo dass man da aufpassen muss ...

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Quote

    Originally posted by erik1967
    Hallo, "normales " Update über F5 funktioniert bei mir auch nicht. Hat jemand Probleme mit PlugIns? Lassen sich seid 1.0 bei mir nicht mehr ansprechen.
    Das Bild flackert kurz, und das war es dann auch.


    Hatte auch Probleme mit dem Update. Ich habe das Updatefile mit Linux auf die Karte geschrieben - funktionierte nicht. Dann Windoof gebootet und mit Windoof draufgeschrieben -> funktioniert. Hat wohl wirklich was mit Groß-/Kleinschreibung bzw. mit dem Fat16 zu tun.

  • Es könnte theoretisch sein, daß Linux beim kopieren keinen 8.3 Dateinamen erstellt hat. Windows macht dies jedoch standardmäßig (läßt sich auch abschalten, z.B. mit TweakXP).
    Alles nur Vermutungen... Linux ist prinzipiell ok zum lesen von FAT/NTFS Partitionen, beim schreiben würde ich jedoch eher XP nehmen.
    Was anderes: Funktioniert bei Euch der Filebrowser von TNT (mmc.prg)? Egal was ich versuche, ich bekomme nur eine Textzeile mit grünem Rand.
    Kennt jemand Euch eine Liste/Zusammenstellung von Ein-Dateien-Spielen (als prgs)? Das ständige entzippen und extrahieren aus D64 Images bin ich leid...

  • Hmm, hab schon eine andere Karte probiert (vorher Siemens 32MB MMC, jetzt Agfa 512MB SD), hat aber nichts geholfen.


    Da TNT den Filebrowser öfters upgedatet hat (siehe lemon64-Thread) läuft bei Dir eventuell eine andere Version!?
    Meine Datei ist vom 26.5., 12:59; 5745 bytes groß. Kannst Du bitte mal nachschauen ob Du dieselbe Version hast?

  • Scheint die gleiche Version zu sein: http://www.sci.fi/~tenu/c64/mmc.zip
    Merkwürdig. Das einzige, was mir aufgefallen ist, ist dass nach der Nutzung des Filebrowsers beim Reset der Bildschirm kurz rot wird, bevor das MMC64-Menü erscheint, was darauf hindeutet, dass die Karte wohl irgendwie falsch angesprochen wurde. Aber das Laden von Programmen klappt wie gesagt problemlos.
    Ich habe übrigens eine 512er CnMemory SD-Karte.


    CU
    Kratznagel