Victor Vicky Portable - Floppy Problem

  • Victor Vicky Portable - Floppy Problem

    Ich habe in meiner Sammlung auch zwei Victor Vicky Portable. Ausgesprochen seltene Modelle. Die tragbare Variante des Victor 9000 / Sirius I. Der eine läuft anstandslos, der zweite bootet nicht von Diskette. Bei meinen Recherchen habe ich festgestellt, das im Netz nicht viel über diese spezielle Variante der Victor/Sirius - Computer zu finden ist.



    mit CPU Board



    Ohne CPU-Board



    Zum Problem: die Floppy werden beim Einschalten initialisiert, aber eindeutig langsamer als im funktionierenden Rechner. Nach dem Einlegen einer Bootdiskette erfolgt auch ein Zugriff auf das Laufwerk mit der Diskette, danach versucht er auf das andere Laufwerk zuzugreifen. Das war's dann.
    ich habe das Floppy-Controller-Board aus dem funktionierenden Victor Vicky Portable in den nicht funktionierenden eingebaut. Der Victor bootet damit. Der Fehler lässt sich damit auf das Floppy-Controller-Board eingrenzen.



    Der Controller ist ähnlich aufgebaut wie das Board einer 8250, zumindest hat das 'X1541" in einem Post in einem anderen Forum festgestellt. Allerdings ging's da um das Desktop-Modell. Überraschend ist das nicht, der Konstrukteur ist in beiden Fällen Chuck Peddle. Auf dem Board befinden sich vier R6522P, die hätte ich unter Verdacht. Gezielt auf einen bestimmten zu tippen ist wahrscheinlich auch für die Profis hier schwierig, ohne Schaltplan. Wenn ich die vier nacheinander auslöte, kann ich die R6522P in einem C64 testen ?

    Edit1: bei Bedarf kann ich detaillierte Fotos des Boards nachliefern.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • ADAC schrieb:

    Das gesockelte IC schon mal getauscht (bevor du anfängst rumzulöten) ?

    Gruß, Gerd
    Hast ja recht, gegentauschen, einen Versuch war's wert. Das IC aus dem defekten Rechner funktioniert im intakten Rechner, ist also OK.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Multisync ()

  • Nochmal die Frage, nur zur Sicherheit: die Pinouts von Rockwell 6522P und MOS 6522 sehen identisch aus. Hat die schon mal jemand im C64 1451 o.ä. verwendet ? Ich würde die IC's aus der Vicky gerne in der 1541 testen.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Multisync ()

  • Schmitti schrieb:

    Commodore selbst hat die Rockwell Variante teilweise in der VC1571 verwendet. Allerdings kannst Du die Rockwell 6522 nicht im C64 testen. Der verwendet die nicht. Wenn Du eine VC1541 hast, könntest Du sie darin ausprobieren oder einen VC20 nehmen.

    Die vier Diskettenlaufwerke sind alle in Ordnung? Nicht dass es nur am Floppy-Laufwerk liegt.
    Irrtum meinerseits, im C64 6526, in der 1541 6522. Die Laufwerke sollten OK sein. Ich hab ja die Platine aus dem funktionierenden Rechner in den defekten eingebaut, siehe ersten Post. Der geht damit einwandfrei.

    Ich habe jetzt alle 4 6522 gesockelt und die IC's in einer 1541 getestet. Einer ging nicht, könnte aber auch beim Auslöten zu heiss geworden sein. Jedenfalls, auch ein Ersatz in Form eines MOS 6522 brachte keine Änderung des Zustands. Vielleicht ist ja auch einer der 74LS - IC's defekt, kommt ja bei der 1541 auch vor. Nicht das ich im Schaltplan lesen ein Spezialist wäre, aber schon blöd, Fehlersuche so ganz ohne.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • hier sind wenigstens Schaltpläne von dem normalen Sirius. Die Floppy scheint ohne eigene CPU auszukommen, hat aber eine MCU zur Steuerung der Motoren. Das GCR ROM habe ich auch gefunden, dass ist der Teil, der Ähnlichkeit zur 8250 hat. Auch der Inhalt.

    actsirius1.co.uk/
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • x1541 schrieb:

    hier sind wenigstens Schaltpläne von dem normalen Sirius. Die Floppy scheint ohne eigene CPU auszukommen, hat aber eine MCU zur Steuerung der Motoren. Das GCR ROM habe ich auch gefunden, dass ist der Teil, der Ähnlichkeit zur 8250 hat. Auch der Inhalt.

    actsirius1.co.uk/
    Danke Nicolas, die habe ich auch schon gefunden. Die Platine des Portables unterscheidet sich optisch schon sehr von der des Victor/Sirius Desktops. Das Portable ist auch ein paar Jahre später auf dem Markt gekommen. Allerdings: das Portable ist 100% kompatibel, die Logik muss also die gleiche sein. Die Kiste kriege ich wieder hin, und wenn ich das ganze Board sockeln muss.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Stimmt, das mit den Floppy-Laufwerken geht auf meine Kappe. Das hätte ich rauslesen können.

    Beim Test mit dem MOS6522 ist der IC auch heile geblieben? Falls nein, ist etwas in der Schaltung, dass die 6522 an der Position kaputt macht.
    Die Rockwell 6522 sind ja auch nur die 1 MHz Version wie der MOS6522. Die Geschwindigkeit sollte daher auch passen.

    Ja, dann vielleicht mal die Umgebung des defekten Rockwell 6522 prüfen, ob es dort (warum auch immer) vielleicht noch ein IC erwischt hat. Wäre zumindest ein Ansatz.
    Welcher IC war den Defekt und was ist dort in der Nähe?
  • Schmitti schrieb:

    Stimmt, das mit den Floppy-Laufwerken geht auf meine Kappe. Das hätte ich rauslesen können.

    Beim Test mit dem MOS6522 ist der IC auch heile geblieben? Falls nein, ist etwas in der Schaltung, dass die 6522 an der Position kaputt macht.
    Die Rockwell 6522 sind ja auch nur die 1 MHz Version wie der MOS6522. Die Geschwindigkeit sollte daher auch passen.

    Ja, dann vielleicht mal die Umgebung des defekten Rockwell 6522 prüfen, ob es dort (warum auch immer) vielleicht noch ein IC erwischt hat. Wäre zumindest ein Ansatz.
    Welcher IC war den Defekt und was ist dort in der Nähe?
    Direkt in der Nähe sind zwei DS75160AN, wohl für die IEEE-488 Schnittstelle zuständig. Die habe ich natürlich nicht da.

    Ich habe mal die Elkos ein bisschen durchgeckeckt, allerdings ohne einen auszulöten. Die, die sich messen lassen, haben teilweise hohe Kapazitäten, weit über dem Nennwert. Ein 100uF hat z.B. 170uf. Die könnte man auch alle wechseln. Gehen aber nur axiale rein, da die Platinen recht eng übereinander sitzen. Muss ich auch erst besorgen.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Multisync ()

  • Ich habe jetzt die Floppy-Controller-Platine aus dem funktionierenden Portable nochmal in den Defekten eingebaut. Tatsache, mit der geht er. Liegt wirklich irgendwo an der Platine, Floppy-Laufwerke und Kabel sind OK.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Ja, das ist zumindest schon mal auf die Leiterplatte eingegrenzt.
    Die Kondensatoren klingen jetzt nicht defekt. Von daher würde ich die pauschal mit den Messdaten nicht tauschen. Wenn, würde ich sie erstmal auf einer Seite auslöten und dann nochmal messen. Deine gemessenen Werte klingen an sich nämlich gut.
    Den IC 75160 bietet übrigens bei Ebay jemand für 1,99 EUR unter Artikelnummer 360684048193 an, falls Du Beschaffungsprobleme hättest.
    Sind sonst noch andere IC mit dem defekten 6522 in Verbindung?
  • Schmitti schrieb:


    ... Sind sonst noch andere IC mit dem defekten 6522 in Verbindung?
    Ehrlich gesagt weiss ich's nicht mehr genau, aber einer der beiden links.



    Die 75160 habe ich bereits bestellt, wird aber wohl dauern, bis die aus Israel da sind. Sockeln kann ich sie ja mal.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Schmitti schrieb:

    Ein kleiner DIL-IC ist ja auch bereits gesockelt. Den könnte man vielleicht auch relativ leicht testweise mal tauschen. Insgesamt müsste man aber die Leitungen auf der Platine jetzt verfolgen. Auf dem Foto alleine kann ich das so nicht erkennen, ob nd was noch an den 6522 dran hängt.
    Den habe ich gesockelt, ein 74LS74, der war an den Pins braun verfärbt. Habe ich gegen einen neuen getauscht. Oberhalb der beiden 6522 hängen auf jeden Fall noch zwei LS04 und ein LS14 dran.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Neu

    Multisync schrieb:

    Schmitti schrieb:

    Ein kleiner DIL-IC ist ja auch bereits gesockelt. Den könnte man vielleicht auch relativ leicht testweise mal tauschen. Insgesamt müsste man aber die Leitungen auf der Platine jetzt verfolgen. Auf dem Foto alleine kann ich das so nicht erkennen, ob nd was noch an den 6522 dran hängt.
    Den habe ich gesockelt, ein 74LS74, der war an den Pins braun verfärbt. Habe ich gegen einen neuen getauscht. Oberhalb der beiden 6522 hängen auf jeden Fall noch zwei LS04 und ein LS14 dran.

    Ich bin komplett auf dem Holzweg, schmitti. Der Bereich für die Floppy-Laufwerke ist hier. Unten sieht man die beiden Anschlüsse. Die beiden 6522 links davon sind für IEEE-488- sowie für die serielle Schnittstelle.

    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Neu

    Ok, kann passieren. Welches war jetzt der defekte 6522? Der auf Position U4C oder U4F?

    Was mir als erstes auf dem letzten Bild auffällt, sind die Handverdrahteten Leitungen. Hast Du die verlegt oder waren die ab Werk so?
    Sind die per Hand verdrahteten Leitungen auf Deiner zweiten funktionierenden Platine genauso vorhanden?
    Falls es da eine Differenz gibt, prüf die auf jeden Fall mal nach.
    Ansonsten, wenn die auf der funktionierenden Platine auch so vorhanden sind, kontrollier vielleicht trotzdem mal, ob die Verbindungen noch alle in Ordnung sind oder eventuell sogar eine Leitung fehlt. Solche Sonderleitungen sind oft Quelle für Fehler, da sich da mal etwas lösen kann.

    Vielleicht kommen wir darüber ja weiter.
  • Neu

    Schmitti schrieb:

    Ok, kann passieren. Welches war jetzt der defekte 6522? Der auf Position U4C oder U4F?

    Was mir als erstes auf dem letzten Bild auffällt, sind die Handverdrahteten Leitungen. Hast Du die verlegt oder waren die ab Werk so?
    Sind die per Hand verdrahteten Leitungen auf Deiner zweiten funktionierenden Platine genauso vorhanden?
    Falls es da eine Differenz gibt, prüf die auf jeden Fall mal nach.
    Ansonsten, wenn die auf der funktionierenden Platine auch so vorhanden sind, kontrollier vielleicht trotzdem mal, ob die Verbindungen noch alle in Ordnung sind oder eventuell sogar eine Leitung fehlt. Solche Sonderleitungen sind oft Quelle für Fehler, da sich da mal etwas lösen kann.

    Vielleicht kommen wir darüber ja weiter.
    Dioe handverdrahteten Leitungen sind auf dem funktionierenden Board identisch vorhanden. Ich habe sie durchgemessen, sind alle funktionsfähig. Auf den Unterseite ist nichts mehr. Der defekte 6522 liegt/lag auf der Schiene IEEE-488/Serielle. Die habe ich mittlerweile alle gegengetauscht und auch in der 1541 getestet.

    Den 3090F habe ich auch gegengetauscht, der ist es auch nicht. Die Leiterbahnen schauen unter dem Mikroskop oben wie unten alle sehr gut aus, keine Kratzer, gar nichts. Bleiben nur noch die ca. 10 Ligik-IC's sowie ein Haufen Widerstände und Dioden. Nur unter die Abdeckung habe ich noch nicht geschaut, vielleicht sitzen da noch Spannungswandler o.ä.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Neu

    Ich muss mich wohl um die Spannungen kümmern. In dem Bereich unter der Abdeckung (auf dem Bild der Bereich links oben) befinden sich Kondensatoren mit 400V bzw. 500V. Die haben die doch nicht zum Spass eingebaut.

    Edit1: Doch, haben sie, es kommen definitiv nur 5V auf das Board.
    Edit2: alle vier 6522 kriegen ihre 5V.

    Den Elko unten links habe ich getauscht, der hatte einen feinen Riss, war vom Messen her aber OK.

    .....................................................................
    I love the smell of burnt aluminum oxide in the morning

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Multisync ()