Hello, Guest the thread was called1.2k times and contains 7 replays

last post from BseCat at the

Fehlermeldung

  • moin moin,


    ich möchte gern wissen, was heißt diese Fehlermeldung ganz genau:


    21,READ ERROR,00,00
    SYNC-Markierung eines Datenblockes wurde nicht gefunden


    denn das zeigt mein C=64 an, wenn ich Disketten formatiere.


    also,
    1. Diskette rein
    2. N-Befehl über programme (N:leer,85) meine formatierung
    3. 21,READ ERROR,00,00


    4. N-Befehl über Basic (open1,8,15,"n:leer,85":close1)
    5. Ready. und Floppy blinkt
    6. OPEN1,8,15 RETURN
    FORI=1TO40:pOKE781,1:SYS65478:SYS65487:SYS65490:SYS65484:IFST=0THENNEXT RETURN
    7. 21,READ ERROR,00,00


    das blinken is klar, weil das Prog gleich die Fehlermeldung zeigt, blinkt sie auch nicht.


    kann mir das jemand erklären.

  • dTen werden kodiert auf die Diskette geschrieben, nach der Kodierung folgen in den DAten nie mehr als 2 Nullbits oder 8 1Bits aufeinander. Vor dem Datenblock gibt es noch einen Headerblock, der Track, Sektor, und Nochirgendwas enthält, vor beiden ist jeweils eine Sync-Markierung. Eine Sync-Markierung besteht aus einer ganzen Reihe von 1en und wird schon von der Hardware erkannt.
    Ich weiß nicht mehr genau, was die Original-Formatierroutine so alles treibt. Ich glaube, sie leert erstmal eine Spur, schreibt nur eine Sync und misst dann anschliessend, wieviel Platz sie gleichmäßig auf Lücken verteilen kann. Jedenfalls liest sie bei der Formatierung auch mal, und bei diesem Lesen wurde keinerlei Sync auf der Spur gefunden.
    Wen Du formatierte Disketten normal benutzen kannst würde ich sagen, daß die Diskette kaputt ist.

  • Quote

    Original von BseCat
    moin moin,


    ich möchte gern wissen, was heißt diese Fehlermeldung ganz genau:


    21,READ ERROR,00,00
    SYNC-Markierung eines Datenblockes wurde nicht gefunden


    Moin,


    das heisst genau, was Du geschrieben hast:"SYNC-Markierung wird nicht gefunden" :P
    Meistens deutet das auf einen dejustierten Schreib/Lesekopf hin.

  • Quote

    Original von silbertroll


    Moin,


    das heisst genau, was Du geschrieben hast:"SYNC-Markierung wird nicht gefunden" :P
    Meistens deutet das auf einen dejustierten Schreib/Lesekopf hin.


    Nein, meistens nicht. Da kommen dann eher "weiche" Lesefehler wie 23 oder auch mal 20 oder 22. Beim Formatieren kann das aber schonmal gar nicht sein, weil ja die Diskette auch mit der falschen Justierung geschrieben wird, danach ist sie also immer einwandfrei lesbar.


    Den Fehler bekommt man z.B. wenn an der Schreib/Leseelektronik oder am Kopf etwas kaputt ist. Er kann auch mal vorkommen, wenn man statt der vorgeschriebenen SD oder DD Disketten fälschlicherweise HD verwendet. Dafür ist die 1541 nämlich nicht geeignet.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • mahlzeit,


    ich vergaß, ich habe 4 x 1541 II bei dreien macht er diese zicken, die 4. hab ich noch nicht probiert und noch ne alte 1541, an der hab ich auch noch nicht probiert.
    die disketten laufen soweit alle, die progs und spiele funktionieren.
    die diskette wird formatiert : N:leer <---- so ist das io, dann kann ich die diskette weiterbenutzen nur wenn ich ,00 dransetze dann zickt er.
    genauso kurios ist, ich habe eine diskette da sind anwenderprogs drauf, ein paar progs will ich auf eine andere diskette kopieren. ich benutze ein filecopyprog. kopiere die dateien rüber, dann kommen fehlermeldungen wie:
    prog a ok.
    prog b ok.
    prog c write error
    prog d read error
    prog e ok
    prog f disk id mismatch
    prog g ok
    prog h illegal track error
    prog i ok
    so sieht das ungefähr aus und das alles auf einer leeren formatierten diskette. das 2. kuriose ist, wenn ich dann den kopiervorgang nochmal wiederhole, dann sind von den 9 progs plötzlich 7 ok und 2 haben fehler, mach ich das ganze nochmal sind wiederum nur 6 ok und 3 nicht. dazu muß ich noch sagen das die fehlermeldungen nicht immer bei den gleichen progs sind, das wechselt sich. echt kurios oder steckt da system hinter, oder was? hat jemand ne ahnung, was das sein könnte oder woran das liegt?
    gruß