Meine Reparatur eines defekten 20 Euro plus/4 aus der Bucht

  • Meine Reparatur eines defekten 20 Euro plus/4 aus der Bucht

    Hallo,
    ich wollte einmal von meiner Reparatur eines "defekten" plus/4 berichten, den ich bei ebay für 20 Euro inklusive Netzteil geschossen habe. Da die Tastatur noch wie neu aussah, also strahlend weiss, habe ich da einfach mal zugeschlagen.

    Als das Paket dann ankam, erstmal Inspektion ... :search:
    Etwas staubig, aber das Gehäuse ist komplett in Ordnung. Nur das Commodore Label - gebrochen : 1.jpg
    Dann aufschrauben und Inspektion im inneren ...
    An den RAMs wurde herumgelötet und eines wurde auch irgenwann mal getauscht : 2.jpg

    Unter den Rams ein Brücke - wohl beim auslöten des Vorbesitzers eine Bahn gerissen : 3.jpg

    Das olle Tastaturkabel (natürlich) unten sowie sogar oben kaputt : 4.jpg

    An den beiden 6529 wurden jeweils ein Pin durch geknipst :huh: und weitere Defekte konnte ich erstmal nicht feststellen. Also endlich mal einschalten und ..... Taadaa : 5.jpg

    Immerhin, TED geht - aber RAM defekt. Tastatur konnte ich zu dem Zeitpunkt noch nicht testen, also abwarten.
    Als allererstes die kompletten RAMs mit meiner Entlötstation ausgelötet (Die Micron RAMs sind wirklich nicht besonders gut ...) und mal schauen wie es unter den ICs aussieht.
    Natürlich wie erwartet, eine Leiterbahn inklusive Durchkontaktierung war raus aber der Rest war in Ordnung. Das geht ja noch :6.jpg

    Als nächstes Sockel einlöten, die Pins an den 6529 (Wieso knipst man die durch ?? ?( ) wieder zusammenlöten
    und das Board mit neuen RAM bestücken, sowie die untere Lötbrücke wieder erneuern : 7.jpg8.jpg

    Nun kam die Tastatur dran. Was mache ich damit ? Ein anderes Flachbandkabel besorgen das irgendwann auch wieder kaputt ist ? Nee.. meine Entscheidung fiel auf ein erneuern mit einem Kabelstrang und Stecker, so wie beim C64. Da aber unten im Gehäuse des plus/4 sehr, sehr wenig Platz ist, habe ich eine Winkelleiste genommen und diese auf ca. 45° gebogen. So kann ich den Stecker noch aufstecken und es passt so wirklich gerade eben da unten rein ...
    9.jpg
    Nachdem jetzt alles zu meiner Zufriedenheit wieder hergestellt war, kam der anschließende Funktionstest und ***Trommelwirbel*** ...
    Alles läuft, sogar die Tastatur mit dem 6529 Chip war komplett in Ordnung !!! : 10.jpg

    So habe ich nun einen tadellos funktionierenden plus/4 für 20 Euro ( zzgl. ca 10 Euro Ersatzteile ) in meiner Sammlung :thumbsup:

    Was ich jetzt nur noch suche ist eine Gehäuse Oberschale, damit ich das gebrochene plus/4 Label ersetzen kann. Vielleicht hat von euch jemand was über ... :saint:


    Ich hoffe diese kleine Reparaturzusammenfassung ist eine kleine Anregung für alle Commodore Bastler unter uns :thumbup:


    Gruß snickers (Michael)
  • snickers schrieb:

    Immerhin, TED geht - aber RAM defekt. Tastatur konnte ich zu dem Zeitpunkt noch nicht testen, also abwarten.
    Erst mal prüfen, ob die Joysticks richtig funktionieren, die werden hierüber auch abgefragt.

    snickers schrieb:

    Nun kam die Tastatur dran. Was mache ich damit ? Ein anderes Flachbandkabel besorgen das irgendwann auch wieder kaputt ist ? Nee.. meine Entscheidung fiel auf ein erneuern mit einem Kabelstrang und Stecker, so wie beim C64. Da aber unten im Gehäuse des plus/4 sehr, sehr wenig Platz ist, habe ich eine Winkelleiste genommen und diese auf ca. 45° gebogen. So kann ich den Stecker noch aufstecken und es passt so wirklich gerade eben da unten rein ...
    Wenn man das Kabel immer gerade rauszieht und wieder aufsteckt, hält es eigentlich sehr lange. Leider sind mir schon sehr viele so ausgefranste Kabel begegnet. Gilt übrigens auch für die C-116 Tastatur.

    Und man sollte natürlich das Oberteil nur nach links wegklappen.

    snickers schrieb:

    Etwas staubig, aber das Gehäuse ist komplett in Ordnung. Nur das Commodore Label - gebrochen : 1.jpg

    Was ich jetzt nur noch suche ist eine Gehäuse Oberschale, damit ich das gebrochene plus/4 Label ersetzen kann. Vielleicht hat von euch jemand was über ... :saint:
    Einige Gehäusereste lagern noch in meiner Bastelkiste. Werde da mal einen Blick reinwerfen und gucken, ob ich dir helfen kann. ;)
  • cbm-warrior schrieb:

    snickers schrieb:

    Immerhin, TED geht - aber RAM defekt. Tastatur konnte ich zu dem Zeitpunkt noch nicht testen, also abwarten.
    Erst mal prüfen, ob die Joysticks richtig funktionieren, die werden hierüber auch abgefragt.

    snickers schrieb:

    Nun kam die Tastatur dran. Was mache ich damit ? Ein anderes Flachbandkabel besorgen das irgendwann auch wieder kaputt ist ? Nee.. meine Entscheidung fiel auf ein erneuern mit einem Kabelstrang und Stecker, so wie beim C64. Da aber unten im Gehäuse des plus/4 sehr, sehr wenig Platz ist, habe ich eine Winkelleiste genommen und diese auf ca. 45° gebogen. So kann ich den Stecker noch aufstecken und es passt so wirklich gerade eben da unten rein ...
    Wenn man das Kabel immer gerade rauszieht und wieder aufsteckt, hält es eigentlich sehr lange. Leider sind mir schon sehr viele so ausgefranste Kabel begegnet. Gilt übrigens auch für die C-116 Tastatur.
    Und man sollte natürlich das Oberteil nur nach links wegklappen.

    snickers schrieb:

    Etwas staubig, aber das Gehäuse ist komplett in Ordnung. Nur das Commodore Label - gebrochen : 1.jpg

    Was ich jetzt nur noch suche ist eine Gehäuse Oberschale, damit ich das gebrochene plus/4 Label ersetzen kann. Vielleicht hat von euch jemand was über ... :saint:
    Einige Gehäusereste lagern noch in meiner Bastelkiste. Werde da mal einen Blick reinwerfen und gucken, ob ich dir helfen kann. ;)
    Das hört sich doch gut an :)
  • Sehr schöne und saubere Arbeit, herzlichen Glückwunsch zu dem schönen Teil und Danke für die Fotostory. Die Lösung mit dem Kabelstrang gefällt mir besonders gut.

    Gruß
    Tom / Pentagon
    "Um den Krieg zu überleben, muss man selbst zum Krieg werden." - John Rambo / Rambo II - "Der Auftrag"
  • oasenkind3 schrieb:

    Sehr genial,
    die Idee mit dem erneuerten Kabel ist genial.
    Das ist genau die Richtige Idee für meinen Plus 4.
    Der braucht auch nen neues Kabel.
    Das Kabel ist von Conrad Bestell-Nr.: 1244007 , habe es dann einfach auf 18 gekürzt.
    Als kleiner Hinweis, die Stiftleiste vor dem Einlöten richtig biegen, nicht danach.
    Da muss etwas ausprobiert werden, dass alles über die Ferrit-Perlen kommt, aber auch noch unter den Deckel passt. Immer ein Stückchen nachbiegen. Zum Schluß dann Einlöten.

    Gruß snickers (Michael)
  • Hi....ich wollte meinen plus 4 auch nach über 25 Jahren wieder in Betrieb nehmen um meiner Tochter mal vorzuführen, wie es früher war Doch leider tut sich nichts...die rote LED leuchtet nicht...das Netztteil liefert Strom, soviel habe ich nachgemessen....für den Rest fehlt mir die Ahnung...kannst du mir mal kurz beschreiben, wie ich weiter vorgehen sollte ?
    Bzw. Kann man dir das Geräte zur Reparatur übersenden ??
    Danke schon mal im Voraus....
  • Das gleiche Phänomen hatte ich neulich auch an einem plus/4 vom Flohmarkt.
    Es kam keine Spannung an den Chips an.
    Ich habe den Powerschalter großzügig mit Ballistol eingesprüht.
    Nach ca.20 Minuten hatte es gewirkt und einigem mal betätigen des Schalters läuft er wieder.

    Erstmal Netzteil messen ob 5V Gleichspannung und 9V Wechselspannung kommen.

    Die beiden oberen Pins sind 9V Wechsel und die unteren 5V Gleichspannung.

    Als nächstes auf dem Board messen. 5V liegen zum Beispiel an den orangenen Scheibenkondensatoren an den RAMs an.
    "We don't stop playing because we grow old; we grow old because we stop playing."

    George Bernard Shaw