FPGASID Firmware Flashen

  • So, es gibt wieder was zu tun!

    ich habe nun das erste Bugfix Release für die FPGASID Firmware veröffentlicht. Hierzu habe ich ein neues Thema aufgemacht. Diskussion dazu bitte dann erst mal hier. Ich werde ggf dann ein neues Thema "Flashen" aufmachen, falls Bedarf gesteht.
    Beim Download des Flashtools findet sich auch eine Detailierte Anleitung, wie das tool zu installieren und zu benutzen ist. Ich hoffe ihr kommt damit klar.
  • FPGASID Firmware Flashen

    Bei mir findet der China Blaster keinen Treiber obwohl ich den gerade installiert habe. Ich probiere weiter :)
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Manuell ging es nun, aber Programmierung bleibt bei 98% stehen. Ich probiere weiter :)
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Ich habe alles nochmal auf einem Intel basierten Lenovo T400 installiert, auch mit Win7-32. Beim Treiber installieren hatte ich die gleiche Hürde. Programmieren ist bei 98% kurz gehangen, ging dann aber weiter und programmierte auch den zweiten Chip. Jetzt steht da 100% (Successful).

    Merke: Intel Software auf AMD CPU lieber nicht ...
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Ich melde auch mal Erfolg hier, mein FPGASID ist erfolgreich geflashed.
    Mein System ist ein Windows 2012 R2 (weil er halt neben dem C64 steht) auch da musste ich fuer den USB-Blaster die Treiber manuell installieren.
    Programmieren hat einfach nach der Anleitung funktioniert, Danke Andi!
    Erste Hoerprobe war positiv, ich meine die 8580er Stuecke hoeren sich einiges besser an, ich muss da aber noch mit dem Digi Wert spielen.
    LMans - Rastaline Dub finde ich noch etwas komisch, aber es geht in die richtige Richtung. :)
    Vielen Dank Andi!
  • Werde das später auch noch testen, hoffe es klappt mit Win10.
    Wie im Showroom schon geschrieben habe ich den FPGASID im SX64 getestet,
    läuft einwandfrei und ohne Probleme. Bin gespannt wie das ganze nach dem Update ist :)
  • Seit Ihr eigentlich alle mit der Programmierhardware versorgt?

    Ich hätte noch einen China-USB-Blaster, den ich unkompliziert an einen Alphatester abgeben könnte. Der ist zwar originalverpackt (eingeschweißt), dennoch gebe ich keine Funktionsgarantie. Will dafür aber auch nichts haben...

    Kurze PN an mich reicht...

    Gruß,
    Thomas
  • Für die leute mit windows 10:

    Erst nach anleitung vorgehen. Anschließend im gerätemanager auf das usb-gerät gehen und treiber aktualisieren wählen. Dann auf computer suchen im verzeichnis "C:\intelFPGA\16.1\qprogrammer\drivers" (unterordner einbeziehen) ...schwupps wird der treiber installiert.
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • bei mir bleibt das "Auto Detect" bereits nach dem Fund von Device2 hängen...
    den USB Treiber musste ich auch manuell anstossen und im richtigem Verzeichnis noch einmal suchen lassen...

    hiernach bleibt er hängen: (ein Windows 7 , 32bit Rechner mit AMD Prozessor ohne Internet Verbindung)
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • Das normale Verhalten nach Druecken auf OK waere eine kurze Sanduhrpause von ca 1 Sekunde, dann kommt das Hauptbild mit den erkannten Chips.
    Offensichtlich funktioniert bei Dir aber der Kontakt zum FPGASID, denn das FPGA und das CPLD werden korrekt erkannt.
    Du kannst jetzt mal (wie in der Anleitung beschrieben) diesen Schritt einfach ueberspringen und gleich die Files ins Programm laden. Interessant waere zu sehen, ob er da wieder haengen bleibt oder was sonst so passiert.
    Wenn Das klappt wuerde ich ganz mutig mal das Flashen starten und das Ergebnis abwarten.

    Natuerlich kannst Du auch die Flash Software nochmal deinstallieren und frisch installieren. Eventuell sind auch andere inkompatible Treiber installiert. Ich denke da vor allem an Treiber von "USB nach seriell"-Adaptern. Die sind haeufig Quelle von solchem Ungemach.
  • So,.... "Update" hat geklappt...

    aber zuerst Software und Treiber mehrfach installiert / deinstalliert und andere Treiber versucht "abzuschalten"...
    der PC hat in der Vergangenheit aber schon diverse USB auf RS232, und USB OBD Adapter gesehen...
    und blieb weiter immer wieder hängen...

    => also kurzerhand noch einen ca. 8 Jahre altes ASUS EeePC mit Win7 aus dem Schrank gekramt.

    Installiert, USB Treiber von Hand installiert... und tatattaa... es läuft alles wie beschrieben.
    Wenn man die beiden Datein in der richtigen Reihenfolge einläd, muss man auch nichts mehr drehen...

    SO!! Version Rev 03 ist drauf...

    Mein ersten Demos, (die mit der Urversion "brummten".. klingen jetzt ohne Probleme,
    muss aber einen zweiten "echten" C64 parallel als Referenz abspielen...)

    Vielen Dank soweit Andi, ich werde dann weiter berichten..

    Micha
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • Super, dass Du es hinbekommen hast! Leider basieren fast alle dieser Flash Adapter auf irgend welchen FTDI Chips mit jeweils angepassten Treibern. Wenn man dann so was schon mal installiert hatte, gibt es schnell mal eine Inkompatibilität mit weiterer Hardware. Da hilft dann nur radikales Aufräumen aller Treiber und manchmal noch durchforsten der Registry um verbliebene Treiberleichen los zu werden.
  • Neu

    Hallo!

    Mein Usb-Blaster ist nun auch aus China eingetroffen. Weiß jemand, ob das mit Win XP nicht funktioniert? Ich hab leider nur WinXP und Win 3.1.

    Das Ding braucht erst mal eine halbe Stunde um das Archiv zu entpacken und dann kommt eine Fehlermeldung. Im Gerätemanager wird der USB Blaster aber richtig erkannt und die rote LED leuchtet auch.

    Hat jemand das auf XP erfolgreich installiert?
    Bilder
    • usbk2.jpg

      48,03 kB, 586×518, 3 mal angesehen
    • usbk3.jpg

      19,47 kB, 425×239, 0 mal angesehen
  • Neu

    Elko's trocknen mit der Zeit aus und werden taub. Leider ist dies nach 20 Jahren und mehr ehr die Regel als eine Ausnahme. Halbleiter sterben eigentlich nur wenn die Bedingungen um sie herum aus dem Ruder laufen und die Betriebsparameter weit aus den Spezifikationen gedriftet sind. Überhitzung wie es beim VIC gerne mal der Fall ist, können auf Dauer auch zu Schäden führen. Ich hab keine Ahnung was man sich damals bei Commodore dabei dachte, diese Dinger derart heiß werden zu lassen. Von Linearreglern bin ich es gewohnt dass sie durch die hohe Verlustleitung teuflisch warm werden können - VC20 Besitzer und die Besitzer der ersten 1540/1541 wissen auch um dieses Thema bescheid. Bemerkenswert ist allerdings der Erfolg der C64 Serie.
    Der Byteblaster funktioniert sogar mit Windows-10 x64 - es muss nur die richtige Software eingesetzt werden. Altera nennt das Ding USB-Blaster und GNU nutzt dafür auch ein Tool dass eigentlich JTAG-Debugger und Programmer untertützt. openjtag.org/index.php?option=com_content&view=article&id=3 . Die sprechen auch mit dem Bytebluster und können auch mit einem FTDI Chip basiertem Adapter so ziemlich alles programmieren, was sich so nach In-System anhört.
  • Neu

    Hallo Andi,
    es scheint am WinXP zu liegen. Die Installation ist durchgelaufen. Nur eben mit der Fehlermeldung wie oben gezeigt. Am Windows-7-Laptop meiner Frau hat die Installation geklappt, wie in Deiner PDF beschrieben. Morgen werd ich mal probieren ob programmieren auch geht.
    Gruß
    Stephan
  • Benutzer online 1

    1 Besucher