PC 10-III Laugenschaden-Restauration. Nur noch bisschen RAM :)

  • Tolle Arbeit! Mir sind folgende Punkte aufgefallen:

    1. Kondensator getauscht: 220 <-> 470; Ich würde den originalen Wert wieder nehmen, wenn nicht klar ist, ob der Wert irrelevant ist. Wenn er nur eine Spannung blocken soll, wäre es egal, wenn ein analoger Pfad daran beteiligt ist, funktioniert es mit dem falschen wert nicht zuverlässig.

    2. Ersatz 74S-Typen: Teilweise sind die 74S-Typen deutlich schneller als die 74F-Typen. 20 % können durchaus dabei sein und wenn genau das Timing auf Kante gestrickt ist, funktioniert es mit den 74F-Typen nicht. Meine Empfehlung: 74S-Typen nehmen. Da die ICs in der Produktion mehr kosten als langsamere, nimmt der Hersteller die normalerweise nicht umsonst, wenn er Geld sparen kann.

    3. Beim DRAM müsste der PC 10-III auch noch welche vom Typ 41464 haben, nicht nur Typen 41256. Die von Dir genannten Ersatztypen müssten gehen. Allerdings gab es auch früher schon Spezialmodi, bei DRAMs. Ich glaube im Amiga 1060 wurden die verwendet. Wenn das im PC 10-III auch der Fall ist, wäre natürlich der gleiche Sharp-Typ empfehlenswert. Idealerweise hat eine Bank gleiche Typen.

    4. Ja, die LLeitung solltest Du repariert bekommen. Viel Erfolg.
  • Hi @Schmitti,

    vielen Dank für dein Statement:

    Zu 1:
    Ja, die Frage ist, ob das auch wirklich ein 220 nf ist, den ich mit nem 470er getauscht habe. Da ich sowieso noch paar Durchkontaktierungen bei den RAM Bänken neu von unten verzinnen muss kann ich mal schauen ob ich nicht irgendwo einen 220 nf finde, vorausgesetzt, das ist wirklich ein 220 nf. Das Original-Teil ist leider zu einem hohen Widerstand geworden, zeigt sogar MOhm an, also sicherlich defekt und das dürfte ein Kondensator sein.

    Zu 2:
    Ja klingt echt plausibel aber weist was das "Lustige" an der Sache ist? Selbst mit den LS Bausteinen bekomme ich den RAM Bank Error, sprich Bank 1 OK, Bank 2 + 3 gibt es nicht. Die S-Typen sind wirklich schwer zu finden, was mir aufgefallen sind.

    Zu 3:
    Jeah :)

    Zu 4:
    Denke ich auch ;)

    Gerrit schrieb:

    Ja, das sind normale 41256, also 256Kx1 DRAMs. Die Teile, die Pollin für 40 cent / Stück verkauft gehen als Ersatz. Sie dürfen nur nicht langsamer sein als das, was verbaut ist.
    Jo Pefekt. Hab soeben Sockeln + ICs geordert und sind NOS. Hab schon mal dieselben RAMs für was anderes gekauft, sind wirklich top.
    Mich würde noch interessieren, ob Bank 1 die unterste Reihe ist oder die mittlere Reihe. Denn da bei der mittleren Reihe, wo das weiße IC sprich das Widerstandsnetzwerk ist
    ist gleich daneben ein RAM IC.

    Ich trau mich wetten dass der sich evtl. auch mit vollgesaugt hat und wenn das Bank 2 ist z.B. und der IC halb tot ist...

    Einfach Blöd wenn man keinen kompatiblen Test-RAM hat... Aber hab mir jetzt 16x rausgelassen :)

    @All:

    Wird ein lustiges Projekt hier :D
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Nicht vergessen, das Zeug ist NOS, das heisst, ein paar davon können alleine durch die Lagerung schon defekt sein. Ich kauf deshalb immer ein paar mehr wenn sich der Preis in Grenzen hält.

    Miss mal die weissen Netzwerke durch, vielleicht hat davon einer aufgegeben.
  • Gerrit schrieb:

    Nicht vergessen, das Zeug ist NOS, das heisst, ein paar davon können alleine durch die Lagerung schon defekt sein. Ich kauf deshalb immer ein paar mehr wenn sich der Preis in Grenzen hält.
    Hoppala. Da war Maus Schneller als Hirn. Naja schauen wir mal... Als ich meine XT Bridgekarte mit neuem RAM versorgt hab, waren die ICs fehlerfrei. Doch diese ist momentan zum Testen verliehen, sonst hätte ich ja quasi Test-RAM gehabt dann.

    Gerrit schrieb:

    Miss mal die weissen Netzwerke durch, vielleicht hat davon einer aufgegeben.
    Ein guter Plan.

    Und es gibt dazu sogar ein PDF :thumbsup: Hat sogar Military Standard: tt electronics_890-334416.pdf
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Darius ()

  • So,

    RP301, hier haben alle 7 Widerstände 33 Ohm = Läuft
    RP302, hier haben alle 7 Widerstände 33 Ohm = Läuft
    RP303, hier haben alle 7 Widerstände 33 Ohm = Läuft

    So, es wird Zeit zum Messen der Durchkontaktierungen des RAM (512k) Bereiches.
    Die Lötseite wurde ja neu verzinnt, nun messe ich die Oberseite auf Durchgang, nicht dass die Lauge evtl da eine Leiterbahn unterm Chip gegessen hat...

    Gruß
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • So,

    die Leiterbahnen der Oberseite sehen auch gut aus. Ich kann jede Durchkontaktierung von Anfang bis Ende einer Bank fehlerfrei messen.
    Somit sollten die RAM Verbindungen soweit gut aussehen.

    Aber wer viel Misst Misst Mist und deshalb messe ich nochmal paar Verbindungen...
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • MGR3SA schrieb:

    Die 74S00 gibts bei EBay.
    Jo, aber die Preise sind da auch nicht ohne. Also da die F-Serie nun sehr nah dran an der S Serie ist und der RAM Error auch mit meinen LS-Bausteinen aufgetreten ist
    bleibt mir wohl nichts anderes übrig als den ganzen RAM zu sockeln und mir da nochmal nach Freilegung nochmals die Leiterbahnen dort anzuschauen, wobei das eigentlich
    echt gut aussieht, aber evtl ist ja eine Durchkontaktierung unter einem RAM IC.

    Und mit neuerem RAM weiß ich mehr.

    Aber heute nicht mehr, kein Bock :drunk:
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Grüß euch,

    jo, aber sollte es wirklich nur wegen der exzipliten ich will nur S-Version haben, bräuchte ich halt den kompletten Vierer-Satz,
    also S00, S04, S08, S10, aber ich denke eher das ich einen zusätzlichen RAM Defekt habe. Bei einem Bekannten mit identischen SANYO RAM
    starben diese auch öfters. Das kenne ich eigentlich nur bei MT RAMs.

    @MGR3SA
    SIcherlich ist jetzt 1 Euro nicht so schlimm, aber dann bräuchte ich dann einen S04, und dann den nächsten usw und als ich dann für einen IC 8 Euro sah, nee...

    Bevor ich ja die Sockeln eingebaut habe, habe ich nochmals die blanken Kupferkontakte durchgeklingelt, also da dürfte eigentlich kein Fehler sein.

    Aber den RAM Sockeln, das wird ein paar Tage dauern :D

    Gruß
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Gerrit schrieb:

    Kann man nicht mit dem bei DOS beiliegenden Programm 'debug' sich den Speicher ansehen? Vielleicht findet man so schneller das defekte RAM und muss nicht alle auslöten...
    Gibt es da nicht ein kleines Speichertest-Programm, dass sich selber in den Video RAM kopiert, hier in den Hercules RAM oder CGA und direkt vom Video RAM aus ausführt und den Speicher von Zelle 0 aus bis Ende durchtestet?
    Da gab es doch irgendwas, oder bin ich auf dem Holzweg ?
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Neu

    Hey @Salator,

    schön wieder was von dir zu lesen (hören).
    JA Genau, CTRAM Test. Das war's ! Vielen Dank für die Gedankenstütze.

    Es muss nur noch geprüft werden, ob dies auch auf der Hercules läuft.

    Gruß
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Neu

    So,

    da ich heute sowas von die Schnauze V*ll (TM) hab, ein Abschlussbild:


    Sämtliche RAM ICs wurden entfernt, und bis auf eine (!) halb ausgerissene VIa, die sich einfach per Jumperdraht wieder verbinden lässt, sind die Lötaugen
    heile geblieben!

    Wie ich mir schon gedacht habe, waren der untere rechte RAM und der obere rechte RAM mit Grünspan bedeckt und die Kontakte waren dunkelgrau/Schwarz.
    Hier ist die Lauge wohl auch mit reingelaufen und ich denke, dass ein IC sich vollgesaugt hatte und das andere evtl. gerade noch so lebt.

    Auf alle Fälle habe ich die Nase gestrichen Voll für heute und freue mich, wenn ich morgen die Sockeln und den Austausch RAM bekomme. Dann werden wir sehen, ...

    Übrigens sehen die Durchkontaktierungen Oberseite vom Durchgang her Super aus!

    Und wehe ich hab wieder 256k RAM, dann raste ich aus :rolleyes:

    Aber einen Vorteil hat es: Ein gesockelter RAM ist viel besser als ein fest verbautes :thumbsup:

    Gruß
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Neu

    daybyter schrieb:

    Mach aber vor dem Sockel einlöten gut sauber!

    Ein Sockel ohne Kontakt ist ja auch nicht viel besser...
    Das habe ich erledigt :thumbsup: Mehrfach sogar. Einige IC Plätze war ja noch Grünspan vom NiCD drauf...
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Neu

    Grüß euch,

    nun erfolgt ein größeres Status-Update.

    Es handelt sich hier um dieses tolle Gerät:


    Hier sieht man schön, wie die Lauge das erste rechte RAM IC der oberen Bank angegriffen hatte:

    (Die untere Bank war auch nicht besser)

    So sollte es nach dem Reinigen aussehen:

    (Glänzig!)

    Wir setzen die neuen Sockel ein:

    (Natürlich alles mehrfach gereinigt)

    Ein Hotfix, dass nicht ab Werk ist muss auch noch getätigt werden:

    Das ist mein Hotfix :D Eine Via hat es nur zur Hälfte überlebt, doch kein Problem...

    Wir setzen den neuen NOS RAM ein:

    (Das sieht zu professionell aus :thumbsup: )

    Und hier der Smoke-Test (TM):


    640 kByte RAM! 640 kByte RAM!

    Der Rechner scheint zu laufen !!! :thumbup: :thumbup: :thumbup: (Und das auch nach 5x Aus und wieder Einschalten - Hier hat der RAM dann versagt)

    Wir führen eine Diagnose durch:


    Wir beginnen den Speichertest:



    Und hier der RAM Fehlerfrei:


    So wie es aussieht, läuft der C= PC 10 III wohl stabil. Doch ob es auch weiterhin Stabil läuft wird sich zeigen. Bin aber guter Dinge!
    Und es läuft wohl mit den F-LS ICs einwandfrei, doch hierzu muss das System mehr belastet werden.

    Danke hier an @Toast_r für die genauen Aufschlüsselungen und natürlich an all die anderen. Übrigens ist der gesuchte Kondensator tatsächlich ein 220 nF! Den 470 nF habe ich entfernt und gegen einen 220 nF getauscht.
    Ob der Rechner auch weiterhin stabil läuft (Netzteil 5V Schiene -> 5.02 V) wird sich zeigen aber auch hier bin ich guter Dinge. Somit kann man sagen dass meine Überprüfungen auf Leitungsschäden etc. hier doch keinen
    Fehler gebracht hatte. Hier war auch noch zusätzlich der RAM defekt, entweder durch den Schluck Lauge und Kapillarwirkung in das RAM oder einfach so gestorben.

    Fakt ist GoldStar (LG) war die Lösung :thumbsup:

    Gruß
    1x C64C / 1x C64G / 1x C128 /1x 1541-II / 1x 1541-I / 1x 1571-II /1x Amiga 500 / 1x Philips CM8833-II (Amiga) + CM8802 (C64) / CPC464+GT65 - CPC6128+CTM644
  • Benutzer online 1

    1 Besucher