Hello, Guest the thread was called1.2k times and contains 10 replays

last post from Rotzwald at the

Umlaute im Contiki Webbrowser

  • Ich benutze Contiki-Webbrowser mit RR-Net regelmäßig. Einziges Manko: Umlaute und Sonderzeichen wie das "ß" werden nicht dargestellt. Da ich programmiertechnisch ein Nackedei bin, eine Frage an die Community: Kann das ein großes Problem sein, die Umlaute zu impementieren?

  • Wie ich im 8-Bit-Browser-Thread schon schrieb, müssten sinnvollerweise 2 Fähigkeiten gegeben sein: Zum Einen müsste Kontiki mit UTF-8 (zumindest den ersten 256 Zeichen davon) umgehen können – sonst kommen die Umlaute erst gar nicht verwertbar an. Ich nehme an, dass sich die bisherige Fähigkeit auf die 128 Zeichen des ASCII-Zeichensatzes beschränkt.


    Zum Anderen müssen natürlich die betreffenden Zeichen im Charset enthalten sein. Da Kontiki, wie auch der C64 grundsätzlich, die Hälfte seines Charsets mit invertierten Zeichen "verschwendet", hat er allerdings auch nur 128 Chars zu Verfügung. Also entweder muss man andere darstellbare Zeichen opfern oder aber auch den Zeichensatz auf UTF-8-Niveau (zumindest die ersten 256 Chars) bringen. Allerdings muss man dann auch gleich gucken, wie man Links anzeigt (denn da verwendet Kontiki die invertierten Zeichen). Wenn man Links über Farben kennzeichnen würde, wäre das aber möglich. Nur wäre das wahrscheinlich alles ein etwas größerer Umbau, den man nicht mal eben macht.


    Vielleicht mal bei den Kontiki-Entwicklern nachfragen? (oder auf Realisierung des Retro-Proxy-Konzeps hoffen)

  • Ein halber Schritt in die richtige Richtung könnte auch das Ersetzen von ä durch ae, ß durch ss etc. sein.

    ────────────────────────────────────────────────────────────
    Time of Silence - Time of Silence 2 Development Blog
    ────────────────────────────────────────────────────────────

  • Ein halber Schritt in die richtige Richtung könnte auch das Ersetzen von ä durch ae, ß durch ss etc. sein.

    Richtig. Aber dafür müsste natürlich erstmal ein "ä" beim Parser ankommen. Heutzutage wird ein ä ja nicht mehr in HTML-ASCII-Code umschrieben, sondern kommt als UTF-8 Code 00E4 (Position 228) herein. Ich nehme an, dass Kontiki (zumindest auf dem C64) alles über Position 127 einfach schon beim Reinkommen ignoriert, da es das ohnehin nicht auswerten kann. Und wenn kein "ä" eingelesen wurde, kann man auch kein "ae" davon machen. Aber vielleicht liege ich da ja auch falsch.