Hello, Guest the thread was called24k times and contains 160 replays

last post from CapFuture1975 at the

Fragen zum Gotek im Amiga 500

  • Das Update kommt auf dem Usb-Stick ins Root-Verzeichnis. Beim Einschalten des Rechners muss man dann beide Knöpfe am Gotek drücken, dann müsste das Update starten. Ist schon lange her, wo ich das mal gemacht habe.


    Ah, besten Dank. Und noch eine Frage ist mir gerade eingefallen: Bei einem normalen Amiga mit Floppy Laufwerk mach ich zum Ausschalten des Rechners immer den "Affengriff", um die laufende Software zu beenden, entferne die Diskette und wenn dann wieder das Kickstart Bild erscheint betätige ich den Schalter am Netzteil. Wie mach ich das jetzt bei nem Rechner mit Gotek? Nach dem "Affengriff" bootet das Gotek ja sofort wieder das Spiel im Slot. Kann ich dann trotzdem am Netzteil einfach ausstellen? Oder wie stelle ich das System am besten aus ohne Gefahr zu laufen mir was zu zerschießen.

  • waren das nicht 999 ? :D

    Nein. Es sind 1.000 (000-999). Wobei das ziemlich Wumpe ist.



    EDIT:
    @Hofmarc71


    Ich habe im Slot 000 Ein ADF mit einem Bootblock, der auf einen Mausklick wartet. Der zeigt auch an, ob irgendwelche Vektoren manipuliert sind (Viren). Damit bin ich bisher gut gefahren.

  • Wenn ich mich recht errinere:


    1) Man download ein spezielles programm der ein bootloader auf dem gotek programmiert. Hierzu brauchst du (USB) programmier hardware, (wie dieses). Jeder bootloader wird vom software programmiert, und kann nur 1x benutzt werden da der bootloader nicht afgespeichert wird, und kostet.... 10 euro?.
    2) Wenn der bootloader programmiert ist, dann gibt es noch die firmware/software die auf dem USB stick benotigd ist. Diese software kan mann (kostenlos) downloaden.


    Es ist eine weile her, aber das tool/programm zum programmieren ist teil der bestellungs procedur.

  • Besten Dank für die Bauanleitung. Leider bin ich was das Basteln angeht relativ beschränkt. Im Internet gibt es ja tolle Beispiee dazu, mit Display und den Schaltern und so. Ich hab jetzt beim Disketten Einschub die kleine Brücke schon entfernt und wenn ich das Gotek da ansetze, kommt man ja auch gut an die Knöpfe und den Stick und man kann es zumindest mit einer Schraube festmachen. Werd mir aber trotzdem noch einen Fuß bauen, der das alles in Form hält. Woraus baut man sich da am besten son Fuss? Etwas aus Plastik und dann festkleben mit Plastikkleber? Wie gesagt, es ist mein zweiter Bastel-Amgia. Mein richtiger Floppy Amiga wird nicht mit Kleber und Säge bearbeitet.



    Ich messe bei nächster Gelegenheit mal nach und geb dir dann Bescheid. Ich würde erst mal schauen, dass das Gotek jetzt richtig sitzt im Gehäuse und dann messen, wieviel Kabel mir fehlt. Kannst du echt solche Kabel selber anfertigen, mit Stecker? 8o Wenn das Kabel dann etwas zu lang ist, macht das ja nix, oder? Weil es dann ja wahrscheinlich auf dem Motherboard liegt. Solang alles gut isoliert ist?

    Das ist im übrigen wie / als ob man das Gotek mit seinem Gehäuse vorne an die obere A.-Gehäuseschale kleben würde.* Die Position u. Höhe die das dann mit einem solchen Fuß hätte bzw. hat. (*Wäre aber total unpraktikabel, da das Kabel dann ja sehr sehr lang sein müsste, um den A. damit dann noch öffnen u. schliessen zu können.)
    Daher ist es auch nicht soo wichtig ob der Fuß dann großflächig genug, 100% im Gleichgewicht (gerade oder nicht ganz gerade) etc. ist, da das Gotek ((ausserdem)) von der oberen Gehäuseschale des Amiga -von oben 'drückend'- gehalten u. auch gerade gehalten wird.
    Das Gotek Kann also nicht großartig nach oben und unten wackeln. Und nach vorne u. hinten auch nicht, wegen zuvor im 1. Posting beschriebenen.


    Ich hatte da zwei übereinandergeklebte Deckel von den teureren 2,50 € frisch gepresssten Saftflaschen aus dem Kühlregal genommen, ergab die korrekte Höhe. Diese genauen Deckel gibt's aber inzw. nicht mehr.
    Es geht aber auch ein Deckel einer (z.B. Dentagard, Signal Zahnpastatube), der dann innen in einen gängigen / normalen (z.B. Granini) Saftdeckel -gibt nur noch diese eine Sorte von Saftfl.-Deckeln, sind alle indentisch- hineingeklebt wird. Ergibt auch die ca. 2,3 cm Höhe. ;)


    Oder man sägt sich 'was aus Holz auf diese Länge (Höhe), .. .



    ---


    Die beiden Gotek Buttons habe ich in den Disk-Auswurfschlitz des A.-Gehäuses gelegt. Stinknormale Conrad Druckknöpfe (gibt's standardmäßig in rot oder grün) in Schaltergröße, die passen da samt ihren Muttern zum etwas festziehen passgenau nebeneinander hinein. Dann die obere A.-Gehäuseschale drauf - hält. Das macht ja quasi Sinn auch (an genau dieser Stelle ;)).
    Dazu musste ich nur die rechte vordere Ecke des Gotek Gehäuses um ein paar cm wegsägen, weil die Druckköpfe sonst nach hinten hin nicht genug Platz gehabt hätten.. .
    -
    Genug Platz wäre aber auch hinten rechts an der unteren A.-Gehäuseschale. Dort ein paar Löcher für Schalter / bzw. diese Druckknöpfe zu bohren. An dieser unsichtbaren Stelle würde ich es ausnahmsweise auch noch nicht als Verschandeln eines Amiga500 Gehäuses bezeichnen. Da hat jeder Schalter und Knopf genug Platz nach hinten hin, die Floppy kommt erst ein paar cm weiter innen, etwas entfernt davon. Da ist also guter Freiraum für sowas.

  • Vielen Dank für eure zahlreichen, informativen Antworten. Ich werd am Wochenende mal sehen, was ich davon umsetzen kann.


    Auf der hier schon verlinkten Seite Mingos Commodorpage hab ich im Bezug auf das Update beim Gotek noch eine nützliche Anleitung gefunden. Wie das immer so ist, mit dem Fragen stellen und dann die Infos selber finden :rolleyes:


    Für zukünftige Fragensteller im Bezug auf Updates beim Gotek stell ich ihn hier mal rein...


    http://mingos-commodorepage.co…20A%20bis%20Z%20(Teil%204)


    Schönes Wochenende :winke:

  • Hallo zusammen,


    ich habe jetzt mal bei meinem Gotek ein Update der Firmware durchgeführt, auf Version 3.0.8.2a. Das Update hab ich durchgeführt wie in in dem Link in meinem Post davor beschrieben. Hat auch alles funktioniert, allerdings habe ich nach wie vor nur 15 Slots zum Bestücken von Games bzw. Software. Also doch noch was falsch gemacht, vergessen? :/

  • Sofern die neue Versionsnummer auf dem Bildschirm angezeigt wird, hat das Update aber wohl schon soweit komplett hingehauen.


    Gibt's dagegen evtl. eine andere/neue Bootdatei, die das erst (mehr Slots) ermöglicht ?


    Ich bin noch immer auf einer älteren FW, kann also nichts weiteres -ausser diese Vermutungen- dazu sagen.

  • Wenn man es im "Autoboot"-Modus laufen lässt dann hat man nur die 15 Slots, das macht aber nichts, man muss halt jedes mal wenn man Mehrere-Disketten-Spiele spielen will, diese neu vergeben, ist aber schnell gemacht.


    Die anderen Modus sind hier gut erklärt, braucht man aber ein LCD und zusätzlichen Taster für: http://mingos-commodorepage.co…20A%20bis%20Z%20(Teil%204)


    Übrigens, beim Gotek-Hxc hat man nur Drive A!

    Sofern die neue Versionsnummer auf dem Bildschirm angezeigt wird, hat das Update aber wohl schon soweit komplett hingehauen.


    Gibt's dagegen evtl. eine andere/neue Bootdatei, die das erst (mehr Slots) ermöglicht ?


    Ich bin noch immer auf einer älteren FW, kann also nichts weiteres -ausser diese Vermutungen- dazu sagen.

    Ja, die Versionsnummer stimmt überein. Also hat das Update funktioniert. Ich hab eben noch mal in diesem Thread gelesen und bin dabei auf einem Text von CapFuture gestoßen. Siehe Zitat dazu. Ich lasse im Moment natürlich den Autoboot Modus laufen. Dann liegt es daran, oder? Wenn ich das im Text richtig verstehe, dann gibt es ja noch den Indexed Mode und den Normal Mode, der aber für mich nicht in Frage kommt, weil ich ja kein zusätzliches Display verwende. Man muss beim Update halt noch die Autoboot Modus Datei erneuern. Aber auch danach sind es immer nur 15 Slots. Scheinbar geht es in diesem Modus nicht mehr?

  • Vlt. war's auch einfach eine von jmd. in die Welt gesetzte Unwahrheit, u. die "nur" 15 Slots bestanden und bestehen bis heute ;).
    (Bei der anderen/alten/kostenfreien non HxC FW war das so: Erst nur 30 Slots, dann später 99 oder 999. Verwechslung mit dieser vlt. .)

    Ich komm ja mit den 15 Slots auch ganz gut klaro. Dachte nur, es wäre noch eine gute Ergänzung. Aber es scheint wirklich so zu sein, dass es im Autoboot Modus nur 15 Slots gibt.


    Noch was anderes: Irgendwie sind immer wieder ADFs dabei in meiner Sammlung, die im WinUAE prima laufen, aber auf dem Gotek im Amiga 500 dann nicht mehr. Meist ist nach dem Trainer Menü oder dem Titelbild Schluss und das Spiel wird dann nicht mehr weiter geladen. Woran könnte das liegen?

  • Noch was anderes: Irgendwie sind immer wieder ADFs dabei in meiner Sammlung, die im WinUAE prima laufen, aber auf dem Gotek im Amiga 500 dann nicht mehr. Meist ist nach dem Trainer Menü oder dem Titelbild Schluss und das Spiel wird dann nicht mehr weiter geladen. Woran könnte das liegen?

    Hast Du eine Speichererweiterung in deinem Amiga, wenn nicht, dann könnte das der Grund sein. Oder, wenn es anders herum ist, die Speichererweiterung mal abschalten.

  • Speichererweiterung -wenn eine dran is' (s.o.)- leicht defekt wäre auch noch möglich. Hatte ich 'mal mit meiner A501: Alles an 1MB Spielen u. solche die es gewinnbringend verwenden ausser Pinball Fantasies (u. Jaguar XJ220) lief ohne sichtbare Fehler, Pinball F. lief nur bis zum Titelbild u. manchmal auch bis zum Menü (mit Fehlern) oder auch ab und zu nur bis kurz vor dem Titelbild (Titelmusik schon geladen u. da, sonst nichts).
    Dann habe ich die meisten Lötstellen der Speicherkarte 'mal nachgelötet u. fortnan geht's auch mit dieser Speichererweiterung nun ohne Fehler (sie hatte 'n leichten Angriff durch Säure vom Akku).


    Oder natürlich mit einer zweiten Speichererweiterung 'mal probieren, falls vorhanden.

  • Speichererweiterung -wenn eine dran is' (s.o.)- leicht defekt wäre auch noch möglich. Hatte ich 'mal mit meiner A501: Alles an 1MB Spielen u. solche die es gewinnbringend verwenden ausser Pinball Fantasies (u. Jaguar XJ220) lief ohne sichtbare Fehler, Pinball F. lief nur bis zum Titelbild u. manchmal auch bis zum Menü (mit Fehlern) oder auch ab und zu nur bis kurz vor dem Titelbild (Titelmusik schon geladen u. da, sonst nichts).
    Dann habe ich die meisten Lötstellen der Speicherkarte 'mal nachgelötet u. fortnan geht's auch mit dieser Speichererweiterung nun ohne Fehler (sie hatte 'n leichten Angriff durch Säure vom Akku).


    Oder natürlich mit einer zweiten Speichererweiterung 'mal probieren, falls vorhanden.

    Speicherweiterung auf 1 MB ist drin und die arbeitet auch fehlerfrei. Daran hatte ich auch erst gedacht.



    Natürlich hast du 999 slots, wenn du die aktuelle Software auf deinen USB Stick kopierst. Firmware alleine reicht nicht.

    Also ich hab laut Anleitung das Update durchgeführt und dann aus dem Update Download Zip File auch die Autoboot Modus Datei ersetzt. Was genau fehlt da jetzt noch, was ich updaten muss auf meinem USB Stick? :/

  • Wegen den Ladeproblemen nochmal: Hat dein Gotek einen Soundmod ? Ich hatte nur Probleme damit, da es das abgegriffene Signal (rückkoppelnd-)störte u. so Lesefehler entstanden. Daher kommt der Mod bei mir vorerst nicht mehr dran, ohne das läuft alles.

    Ich glaube nicht. Das man künstliche Disketten-Geräusche und sowas hört? Nein, hab ich nicht.
    Es ist auch echt merkwürdig, was geladen wird, und was nicht. Lotus 1, Batman Returns, Spy who loved me gehen ohne Probleme. Aber Licence to kill, Cliffhanger, Batman The Movie, Giana Sisters gehen nicht. Und das sind doch alles Spiele die nicht wirklich 1MB Arbeitsspeicher brauchen. Hatte mal mit den ADFs von dem Game Dracula getestet. Das Spiel braucht laut Hülle 1 MB Arbeitsspeicher und ich hatte mir die ADFs selber erstellt von meinen eigenen Disketten. Das Spiel läuft ohne Probleme. An der Speichererweiterung liegt es also wirklich nicht. Generell gehen aber mehr ADFs nicht, als das sie laufen. Also von 20 ADFs gehen bestimmt 15 nicht. Könnte es vielleicht am Update liegen? :/




    Aus dem Archiv HxC_Floppy_Emulator_Manager muss die autoboot.hfe und die hxcsdfe.cfg auf den USB Stick, dann sollte es passen.


    Ah, die hxcsdfe.cfg Datei hab ich beim Update nicht ersetzt. Daran wird es wohl liegen. Teste ich mal durch. Vielleicht aufen dann ja auch die ADFs ohne Fehler.