Hello, Guest the thread was viewed85k times and contains 581 replies

last post from Fepo at the

Wir bauen uns für 1,74€ ein WLAN Modem

  • Mit Verspätung habe ich jetzt auch ein WLAN-Modem aufgebaut (mit Level Shifter und Display), und es dürfte korrekt funktionieren, allerdings habe ich noch Probleme mit der Bedienung, mit einem BBS habe ich mich leider noch nicht verbinden können.


    Beim allerersten Versuch habe ich in CCGMS den Modem-Typ auf "User Port 300-2400" und die Baud-Rate auf 300 gestellt.


    Dann im ASCII-Modus


    at$ssid=MeinTollesHeimWlan

    at$passs=MeinTollesWlanPasswort


    eingegeben, und mit


    atc1


    die WLAN-Verbindung gestartet, und das hat auf Anhieb wunderbar geklappt!


    Dann wie in der Beschreibung beschrieben...


    at&p0

    at&k1

    at$sb=9600


    und dann noch mit


    at&w die Einstellungen im Modem gespeichert (stehen die Einstellungen beim nächsten Start eigentlich automatisch zur Verfügung, oder muss man die jedes Mal mit atz laden?).


    Seither klappt die Verbindung zum WLAN leider nicht mehr, nach "Connecting to..." kommt nach ein paar Sekunden immer die Meldung "Could not connect to...".


    Was läuft da falsch?

    Kann/soll ich at&p0 und at&k1 wieder rückgängig machen? Was waren eigentlich die Default-Werte?

  • Ich vermute mal, man muss dem Programm auch mitteilen, dass es jetzt ein 9600-taugliches Modem bedienen soll.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • also... die richtige Schnittstelle ist UP9600.

    Immer.

    Mit 300 bd anzufangen ist korrekt.


    Da Dein Modem jetzt schon auf 9600 eingestellt ist, musst Du jetzt in der Einstellungsseite CCGMS auch auf 9600 stellen.


    Stefan

  • Da Dein Modem jetzt schon auf 9600 eingestellt ist, musst Du jetzt in der Einstellungsseite CCGMS auch auf 9600 stellen.

    Ja, das hatte ich schon gemacht, aber es klappt dennoch nicht. Hier ein paar Fotos.


    Mit den Standardeinstellungen zu Beginn (300 Baud und "User Port 300-2400") drücke ich Enter, und es kommt die Begrüßungsmeldung des Modems, das schaut mal gut aus:



    Im Display steht "OFFLINE", ist das eh normal? Ist damit die Verbindung des Terminal-Programms zum Modem gemeint, oder jene zum WiFi?



    Dann...

    at&p0

    at&k1

    at$sb=9600

    ...und in den Einstellungen die Baud-Rate und den Modem-Typ so eingestellt:



    Im Display werden nun 9600 Baud angezeigt:



    Aber das Verbinden zum WiFi klappt nicht.



    Genauso verhält es sich auch zu Beginn mit 300 Baud, wobei das Verbinden wie gesagt beim allerersten Versuch geklappt hat.

  • RobertK


    Faszinierend, ich hab mir letztens die Version ohne Display zusammengebrutzelt und habe dort das exakt gleiche Phänomen ;(


    Beim ersten mal hat die Verbindung zum WLan ohne Probleme funktioniert, auch eine Mailbox konnte ich anwählen, danach nie wieder ...


    Ich hatte das dann aus Zeitmangel erstmal beiseite gelegt :/

  • Im Display steht "OFFLINE", ist das eh normal? Ist damit die Verbindung des Terminal-Programms zum Modem gemeint, oder jene zum WiFi?

    nö.

    Du hast keine Verbindung zu deinem WLAN.

    Laut der Meldung in einem der unteren Bildern konnte sich das Modul nicht verbinden.

    Vorschlag:

    Kannst Du zu Testzwecken mit deinem Handy einen "MobilHotspot" einrichten?

    Der Einfachheit wegen SSID 1234 und Passwort 12345678 ?

    Es geht um das überprüfen, ob es überhaupt funktioniert. Möglicherweise hast du ein Problem mit der groß und der Kleinschreibung, die ja beim C64 umgekehrt ist.


    Stefan

  • Also, bei RobertK kommt keine Verbindung zum Router zustande. Das sieht man an der Displaymeldung. Frage zur Sicherheit: wenn das mit dem Hotspot klappt... hast Du dann evtl. in der Fritzbox "nur bekannte WLAN Geräte" aktiviert?


    zweitens... saublöde Frage...

    Bei euch beiden scheint ja die Modifikation up 9600 nicht zu funktionieren. Die "Brücken" am Userport Stecker habt ihr eingelötet? Das Bauteil im C64 (komme gerade nicht drauf) was beim 128er für den Burstmodus benutzt wurde, das ist noch in Ordnung?


    Stefan

  • Stefan Both


    Hab drei C64 getestet, daran liegts eher nicht, ist halt auch komisch dass beim allerersten Mal die Verbindung zum WLAN hergestellt werden könnte, danach nie wieder.


    Der ESP hat eine IP bekommen, konnte ich auch In der Fritz Box nachvollziehen. Auch ein mobiler Hotspot, WiFi Tethering und ein Gast Zugang ändern nichts an der Situation ... Auch kein neu flashen des ESP ...

  • Kannst Du zu Testzwecken mit deinem Handy einen "MobilHotspot" einrichten?

    Der Einfachheit wegen SSID 1234 und Passwort 12345678 ?

    Es geht um das überprüfen, ob es überhaupt funktioniert. Möglicherweise hast du ein Problem mit der groß und der Kleinschreibung, die ja beim C64 umgekehrt ist.

    Jetzt wollte ich schon schreiben: ja, mit dem Mobil-Hotspot habe ich das schon probiert, dasselbe in Grün. Andererseits kann man da schnell mal das Kennwort probeweise ändern, und so habe ich eines mit nur ein paar Ziffern eingestellt.


    Und siehe da: das wars!!! Vielen Dank für den Tipp!





    Jetzt muss ich mich erst mal in die Bedienung von solchen BBS einarbeiten, das ist für mich komplettes Neuland.

  • Ich darf euch nun meine Modem-Konstruktion präsentieren:



    Bei einem Aufbau auf einer Lochrasterplatine hatte ich die Befürchtung, irgendwas falsch zu verbinden und am Ende meinen C64 zu schrotten, daher habe ich eine kleine Platine entworfen, zumal mir das mit Sprint Layout großen Spaß macht, und außerdem kann man da vorher alle Verbindungen gründlich prüfen.


    Mein Ziel war es, eine möglichst kleine Platine zu entwerfen, und ich glaube, das ist mir ganz gut gelungen, viel kleiner geht es kaum - die Mindestgröße wird ja durch NodeMCU, OLED-Display und den Levelshifter vorgegeben.


    Ich habe mich beim Entwerfen der Platine von jemandem (nicht hier aus dem Forum) beraten lassen, von dem ich viel gelernt habe und der sich wirklich gut auskennt - vielleicht zu gut. :-) Denn derjenige hat mir die Schutz-Schaltung für den Reset-Button entworfen, die verhindern soll, dass jemand durch dauerhaftes Drücken des Reset-Buttons Schaden am C64 anrichtet. Die beiden Kondensatoren und der Widerstand sorgen dafür, dass immer nur ein kurzer Reset-Impuls gesendet wird. ADAC hat meine Vermutung schon bestätigt, dass das eine Fleißaufgabe war. :-)


    Mit dem Jumper J1 kann man die Stromversorgung vom C64 unterbrechen (wenn der Strom via NodeMCU-USB kommen soll) oder schließen - alternativ dazu gibt es an der Unterseite eine Kabelbrücke, die ich geschlossen habe.


    Ich habe noch drei Platinen übrig, die ich in den Marktplatz gestellt habe.

  • Ich habe mir mal von mingos Commodore Page dieses unten abgbildete
    Modem mit Wifi gebaut.
    Ist ein ESP 12-E drauf.

    Es fiel mir heute in die Hände :)
    Wollte es ausprobieren und habe es angeschlossen.
    Habe die Terminalsoftware gestartet. Eigentlich müsste es ja ,da es schon funktioniert hat
    laufen.
    Habe 300 Baud erst probiert und dann auf 9600 Baud.
    Laut I-Net ( Mingois Seite ist to :( ) habe ich alles richtig eingestellt.
    Ist die CSMG Software.

    Mein Problem ist, dass ich keine Eingaben machen kann ( AT Befehle )
    Habe auch dafür den ASCII Modus mit SHIFT+F7 eingestellt.

    Hat jemand eine Anleitung und weiß, was ich verkehrt mache ?

  • Das Prototype-Board ist cool. Wo gibts die denn?

    OliverW. hat mal solche gemacht, könnte eines von ihm sein.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.