Schwarzer Bildschirm ASSY 250407 Rev B

  • Schwarzer Bildschirm ASSY 250407 Rev B

    Hi!

    Ich habe hier ein 250407 Rev B Board mit schwarzem Bildschirm. Folgendes wurde gemacht, bzw. analysiert:

    - Originalnetzteil 9V und 5V stabil und i.O.
    - Spannungswandler 78xx liefern je 12V und 5V stabil
    - SID entfernt
    - PLA gesockelt und gegen UltimatePLA getauscht (als häufigste Fehlerquelle erschien mir das sinnvoll)
    - CIA 1 und 2 entfernt

    Leider weiter schwarzer Bildschirm.

    - Rechner reagiert auf Reset, Floppy läuft ebenfalls an (keine Blindkommandos werden ausgeführt).
    - DeadTest aus Diagnostic Cartridge (vintage-computers.it/diagnostic-cartridge) liefert interessanterweise nach ca 10 Sekunden einen vollständig grauen Bildschirm
    - Kein RAM-Chip wird heiß
    - Kein weiterer Chip wird anormal heiß

    Ich kann löten und mit einem Multimeter umgehen...

    Nächste Idee ist, das ich mir die TTL Chips vornehme die laut personalpages.tds.net/~rcarlsen/cbm/c64/c64-ic.txt mit einem Blank Screen zu tun haben können.

    Weitere Ideen oder Hinweise würden mich sehr feuen!
  • Danke für die Hints! Ein Foto stelle ich noch bereit und freue mich das ich vielleicht mit den TTL Glück haben könnte.

    Die MOS 7708 (zwei sind da auf dem Board) nehme ich mir heute mal vor und berichte.

    Daumen drücken wäre hilfreich ;)
  • Schwarzer Bildschirm ASSY 250407 Rev B

    So MOS 7708 auf U13 durch 74LS257 ersetzt. Keine Veränderung.

    Als nächstes MOS7708 auf U25 durch den zuvor ausgebauten ersetzt (habe gerade keinen zweiten 257).

    Rechner startet, allerdings friert er gleich ein und es erscheinen merkwürdige Zeichen. Manchmal nur ein Ready oben links.

    Dead Test läuft, gegen Ende des Tests löst sich der Bildschirminhalt sozusagen auf.

    Lade gerade ein YouTube Video hoch:

    So sieht der Bildschirm aus ohne Modul:



    Außerdem ist alles über TV-out in Schwarz-Weiß. Regler am VIC schon probiert ohne Änderung.

    Immerhin einen Schritt weiter. :)



    Sent from my iPhone using Tapatalk
  • Beide 7708 haben denselben Datecode, da ist es recht wahrscheinlich, daß beide einen Schuss haben, besorg dir also einen weiteren 74LS257 und teste noch mal.

    Bitte mal nicht nur über Modulator sondern auch über Video-Out probieren. Idealerweise an mehr als einem Fernseher/Monitor.
  • Gerrit schrieb:

    Auf der anderen Seite der Platine ist noch ein MOS-TTL, der 7707. Dafür gehört ein 7406 oder 74LS06 rein.

    Ziemlich oft reicht es aber die beiden 7708 zu tauschen.
    hallo @Gerrit, danke,

    nun ist mir, nach 25 jahren, dank dir, eingefallen was der 6. punkt war,
    bei einer reparatur eines c64 und eines sx64 mit zu überprüfen.

    es ist der 7406. ein treiber steuert die /aec und geht zu den 74ls257 und der pla.
    da ist ein sehr niederohmige widerstand, 180 ohm, dadurch wird der 7406 sehr sehr belastet.

    da gibt es boards die haben einen ganz anderen widerstand eingelötet.
    dieser widerstand beeinflusst sehr das timing. soweit ich mich erinnern kann ist beim sx64
    ein ganz anderer eingebaut, den ich manchmal auch geändert habe.

    habe jetzt keine lust, in den verschiedenen schaltplänen, nachzusehen, versuche endlich zu schalfen.
    heute ist retro-treffen in köln :) und ich wollte nicht erst zum schluss hinkommen.

    diese 6 punkte sind sehr wichtig, damit keine unnötigen timingproblemen entstehen können.
    besonders später, z.b. durch altern der bauteile, dann laufen die rechner auch nicht stabil über längere zeit.
    und es gibt probleme mit den verschiedenen plas und vics.

    rams, selbst langsamme typen, musste ich damals nie gegen schnellere tauschen,
    da gab es keine probleme, nur die defekten wurden erneuert.

    gruß
    helmut

    edit:

    progrulez schrieb:

    Ok, besorge einen weiteren 257 und melde mich dann nochmal.
    falls du den 7406 schon hast versuche es mal mit ihm.
    aber wie gerrit schon schrieb, mos-ttl macht probleme.

    gruß
    helmut

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von axorp ()

  • axorp schrieb:

    es ist der 7406. ein treiber steuert die /aec und geht zu den 74ls257 und der pla.
    da ist ein sehr niederohmige widerstand, 180 ohm, dadurch wird der 7406 sehr sehr belastet.

    da gibt es boards die haben einen ganz anderen widerstand eingelötet.
    Ja, das waren die älteren Boards, da war dieser Widerstand 1kOhm. Funktionierte auch.

    Irgendwann wurde auf 180 Ohm umgestellt und ab da war das so.
  • Schwarzer Bildschirm ASSY 250407 Rev B

    Den 7707 habe ich durch einen 7406 den ich da hatte ersetzt. Jetzt wieder zurück zum schwarzen Bildschirm - auf die 257 Lieferung warte ich noch... Vielleicht ist der alte MOS nun völlig hinüber.


    Sent from my iPhone using Tapatalk
  • Schwarzer Bildschirm ASSY 250407 Rev B

    Ein weiterer Zwischenstand: 257 ist nun da, das heißt beide MOS 7708 und der 7707 sind aktuell getauscht.

    Der U27 ist noch drin, tausche ich morgen.

    Außerdem noch alle Kondensatoren.

    Hier die Bilder von Deadtest und C64 Diag die immer noch Fehlfarben und entsprechenden Müll ausgeben.

    Getestet nun über Composite statt TV out.




    Sent from my iPhone using Tapatalk