MP3 Patch und Laufwerksverwaltung

  • Hallo C=Mac,

    C=Mac schrieb:

    Boote ich von der Diskette/Partition wird bis zum MP3-Hintergrundbild (keine Menüzeile, keine Laufwerke) gebootet und fertig.
    Ich muss auf der Diskette/Partition zuerst GeosEditor Manuel starten und ein LW an-/abwählen, erst dann funktioniert die Diskette/Partition.
    Kann es irgendwie sein, dass da in der Reihenfolge der Laufwerke von A bis D beim ersten Start nach der Installation ein Laufwerk fehlt?
    Aber normalerweise kommt dann eine Meldung, dass die Konfiguration nicht stimmt und der GeosEditor wird automatisch gestartet ...
    Seltsam, seltsam ....

    C=Mac schrieb:

    Auf der MP3 128 Startdiskette war er vorhanden, hab hin vor der Installation gelöscht.
    Wie?
    Wenn Du ihn einfach über TopDesk löscht, bleibt die Speicherbank, die er belegt hat weiterhin vom Druckertreiber benutzt. Gibt es da sowas wie "Deinstallieren", damit die Speicherbank auch wieder frei wird?

    Boote mal nochmal von dieser Startdiskette und klicke wenn das Fenster dieser Diskette geöffnet ist, auf den Papierkorb. Taucht dann die gelöschte Datei in der Liste auf?

    Ich mache sowas in Geos/MP3 mit einem Disk-Monitor, lösche den gelöschten Eintrag direkt im Directory und räume die Disk auf. Dann ist es definitiv weg.
    (Aber Vorsicht, man muss wissen, was man da macht, sonst kann die Diskette zerschossen werden...)

    C=Mac schrieb:

    Mit GeoB..... (weiss den Namen grade nicht ) kann D64 erzeugen.
    Danach direkt oder in eine ZIP-Datei?
    Und hier im Thread?
    Mit GeoBeap geht das, ja.
    Dann beide D64 in ein Archiv (ZIP, GeoZIP, oder am PC: 7z) und als Anhang hier im Thread.


    C=Mac schrieb:

    Rein vom Aussehen sehen die Dateien nicht anders aus, als bei der 1581-Version.
    Wie es natürlich im Programm ist keine Ahnung.
    Ja,

    Aber die Disk 2 könnte mit einen speziellen Disknamen oder mit einer speziellen ID (Topdesk nimmt da normal immer TD) formatiert sein. Oder es wurde ein Byte im Directory, das normal nicht benutzt wird, geändert. Das kann ich sagen, wenn ich mir die 2 D64s mal genauer angeschaut habe....


    C=Mac schrieb:

    Ich hab eh das Gefühl das sich MP3 64 und MP3 128 nicht immer gleich verhalten.
    Am meisten fällt mir das bei der Verwendung von Native-Verzeichnisse auf.
    Ob der fehlende Parallelanschluss oder die fehlende SCPU (beim C128) einen Einfluss haben,

    Auf jeden Fall gibt es da je 2 Treiber für die HD-Formate in der Disk-Datei. Einer für seriellen Anschluss und einen für parallelen Anschnluss der CMD-HD. Möglicherweise daher ein paar Unterschiede. Das müssen aber HD-Besitzer sagen...

    Gruß
    Werner
  • wweicht schrieb:

    Kannst Du Deine Kauf-Version mal mit der hier ( originale GEOS-Applikationen jungfräulich ) vorhandenen vergleichen (esc_p2.zip)?
    Hab ich endlich verglichen, sind die Selben.

    Pusti64 schrieb:

    Ist das wirklich eine original Diskette von W. Grimm?
    Vom Aufkleber her würd ich sagen, ja.


    wweicht schrieb:

    Kann es irgendwie sein, dass da in der Reihenfolge der Laufwerke von A bis D beim ersten Start nach der Installation ein Laufwerk fehlt?
    Aber normalerweise kommt dann eine Meldung, dass die Konfiguration nicht stimmt und der GeosEditor wird automatisch gestartet ...
    Seltsam, seltsam ....
    Ist genau gleich wie bei der Installation auch.
    Wie gesagt, keine Ahnung warum.
    Aber ich weiss ja, wie ich das Problem "umgehen" kann.


    wweicht schrieb:

    Auf jeden Fall gibt es da je 2 Treiber für die HD-Formate in der Disk-Datei. Einer für seriellen Anschluss und einen für parallelen Anschnluss der CMD-HD. Möglicherweise daher ein paar Unterschiede. Das müssen aber HD-Besitzer sagen...
    Von daher wäre es sicherlich möglich, HD parallel am C64 und nur seriell am C128D.
    Muss ich mal am C64 testen, indem ich das Parallelkabel entferne.


    wweicht schrieb:

    Mit GeoBeap geht das, ja.
    Dann beide D64 in ein Archiv (ZIP, GeoZIP, oder am PC: 7z) und als Anhang hier im Thread.
    Hab die Datei mal angehängt, hoffe es funktioniert.

    - D64 mit GeoBeap 2.0a unter MP3 64 erstellt
    - Mit GeoZip für MP3 gezipt
    - Mit GeoDos auf 3.5" Disk kopiert
    - Mit Mac hier hoch geladen.

    MP36441.ZIP

    Gruss C=Mac.
  • C=Mac schrieb:

    Hab ich endlich verglichen, sind die Selben.
    Danke.

    Gut, somit kann man davon ausgehen, dass auf der F64-Wolke die neuesten bekannten Versionen der Programme liegen.

    Ich werde mir diesen ESC-P2-Treiber irgendwann mal näher anschauen. Vielleicht kann man da was ändern, so dass er auch unter MP3 richtig in der RAM arbeitet. Das wird aber definitiv dieses Jahr nichts mehr und nächstes Jahr nicht gleich. Also Geduld ;) ...


    C=Mac schrieb:

    Wobei gelöscht ist ja anscheinend nicht gelöscht

    Wie kann ich rausfinden ob da noch eine Daten-Zombie rumwandert?
    Nun, ich kenne das Problem nur unter Geos 128 und nur bei selbststartenden Programmen (Auto_Exec). Die Routine, die diese Dateien beim Booten startet scheint sich um das eine Byte im Directory-Eintrag nicht zu kümmern und startet sie trotzdem ...
    Wenn auf C64/C128 auf Disk eine Datei gelöscht wird, wird immer nur das eine Byte (CBM-Filetyp) gelöscht und die von der Datei belegten Blöcke werden freigegeben. Irgendwann, wenn andere Dateien auf diese Disk kopiert werden, wird der Directory-Eintrag komplett überschrieben.

    Eine "einfache Methode" sowas endgültig los zu werden:
    - Starte MP3 komplett neu von der betroffenen Disk
    - Wenn die Datei gelöscht wurde, führe im TopDesk folgendes aus:
    1. Tasten-Kombination C= w (alle Dateien anwählen)
    2. Tasten-Kombination C= t (Dateien sortieren)
    3. Kopiere jetzt 8 Dateien (egal welche und wie groß die sind, es dürfen nur keine selbststartenden (Auto_Exec) sein
    4. Lösche die 8 Dateien wieder
    5. 1. und 2. nochmal ausführen
    6. Tastenkombination C= v (Aufräumen (Validate))

    Damit ist das Ding definitiv weg.

    Jetzt Rechner aus und komplett neu von der Disk starten.


    Das Problem ist: Wenn der Druckertreiber "heimlich" in die RAM kopiert wird, überschreibt er irgendetwas, was unter MP3 von anderen Sachen benutzt wird. Will sagen: Es könnte "unerklärliche" Probleme geben.


    C=Mac schrieb:

    Von daher wäre es sicherlich möglich, HD parallel am C64 und nur seriell am C128D.
    Muss ich mal am C64 testen, indem ich das Parallelkabel entferne.
    Das wird unter Umständen nicht reichen. Es gibt da im GEOS.EDITOR (im Reiter "Laufwerke" unten rechts) einen Schalter "HD-Kabel". Also zusätzlich mal schauen, wie der jeweils eingestellt ist.


    C=Mac schrieb:

    Hab die Datei mal angehängt, hoffe es funktioniert.
    Danke. Hat funktioniert.

    Ich habe noch nicht probiert, ob die Installation mit diesen 2 D64 funktioniert und ob es da irgendwelche Besondeheiten auf Disk gibt, aber es handelt sich dabei laut Info-Block der 6 Dateien um die letzte bekannte MP3 C64 Version vom 09.01.2000.

    Gruß
    Werner
  • kurzer Zwischenbericht:

    Test die Installation von MP3-64 von 1541 gerade in WinVice. Ist zwar schnarch langsam (muss auf dem Rechner (älteres Nootbook mit WinXP) wohl wieder auf eine ältere Version zurück, nach WinVICE-2.4.29-x86-r31469 ist der Rechner wohl zu alt. Habe momentan WinVICE-2.4.32-x86-r32195 zumTesten drauf, da erreicht x64sc nur so um 65-70% Geschwindigkeit).

    Aber der Diskwechsel mit den D64s von C=Mac hat schon 3x problemlos funktioniert. Komplett-Installation von 1541 (A:) auf 1581 (C:) läuft noch ...

    Sieht also schonmal gut aus... :D

    Gruß
    Werner
  • So, Installation von MP3-64 von 1541 auf 1581 unter WinVice ist durch. Hat problemlos geklappt (Diskwechsel auf 1541 (insgesamt 3x) werden angefordert und funktionieren). MP3-64 von 1541 auf 1581 (Komplett-Installation) läuft. Anschließendes Neu-Laden von MP3 (WinVice beendet und neu gestartet) funktioniert ebenfalls.

    Ich werde das Ganze auch nochmal an meinem C128DB testen. Weiß noch nicht, wann ich dazu komme. Bin aber zuversichtlich, dass auch das funktioniert.

    Dann werde ich mir auch die 2 Disketten (D64) näher ansehen. Das sollte doch auch für MP3-128 hin zu bekommen sein .... ;)

    Gruß
    Werner
  • wweicht schrieb:

    Ich werde mir diesen ESC-P2-Treiber irgendwann mal näher anschauen. Vielleicht kann man da was ändern, so dass er auch unter MP3 richtig in der RAM arbeitet. Das wird aber definitiv dieses Jahr nichts mehr und nächstes Jahr nicht gleich. Also Geduld ...
    Der Treiber-Teil welcher den Treiber ins RAM kopiert, wird unter MP3 und Wheels nicht benötigt (steht jedenfalls im Infoblock).

    Ob der Druckertreiber selber unter MP3 funktioniert, kann ich nicht mehr testen.
    Der neue Drucker hat keinen Centronics-Anschluss mehr, somit brauch ich die Druckertreiber im Commodore-Lager nicht mehr.


    wweicht schrieb:

    Eine "einfache Methode" sowas endgültig los zu werden:
    - Starte MP3 komplett neu von der betroffenen Disk
    - Wenn die Datei gelöscht wurde, führe im TopDesk folgendes aus:
    1. Tasten-Kombination C= w (alle Dateien anwählen)
    2. Tasten-Kombination C= t (Dateien sortieren)
    3. Kopiere jetzt 8 Dateien (egal welche und wie groß die sind, es dürfen nur keine selbststartenden (Auto_Exec) sein
    4. Lösche die 8 Dateien wieder
    5. 1. und 2. nochmal ausführen
    6. Tastenkombination C= v (Aufräumen (Validate))

    Damit ist das Ding definitiv weg.

    Jetzt Rechner aus und komplett neu von der Disk starten.


    Das Problem ist: Wenn der Druckertreiber "heimlich" in die RAM kopiert wird, überschreibt er irgendetwas, was unter MP3 von anderen Sachen benutzt wird. Will sagen: Es könnte "unerklärliche" Probleme geben.
    Hab's jetzt mal so unter MP3 128 und 64 gemacht.
    Gleichzeitig hab ich MP3 128 neu installiert, aus GEOS 128.

    Dabei hab ich festgestellt das die Installationsdateien beschädigt waren.
    Installation brach immer beim Kopieren von GeosDisk (94%) ab, mit der Fehlermeldung: Die Datei konnte nicht entpackt werden! Fehler Code: 2

    Hab das ganze Archiv neu runtergeladen und auf dem Mac einen anderen Entpacker verwendet.
    Ebenfalls hab ich das D81-File mit dem DOS-Treiber auf den C64/128 übertragen und nicht mit GeoDOS.

    Jetzt gab es keine Probleme mehr.
    Boot-Disketten booten ohne Probleme.


    wweicht schrieb:

    Das wird unter Umständen nicht reichen. Es gibt da im GEOS.EDITOR (im Reiter "Laufwerke" unten rechts) einen Schalter "HD-Kabel". Also zusätzlich mal schauen, wie der jeweils eingestellt ist.
    Auf dem C64 aktiviert, beim C128 deaktiviert.


    wweicht schrieb:

    Aber der Diskwechsel mit den D64s von C=Mac hat schon 3x problemlos funktioniert. Komplett-Installation von 1541 (A:) auf 1581 (C:) läuft noch ...
    :D Freut mich, dass es funktioniert.


    Noch ein paar Fragen zu MP3:

    - Kann ich auf den Boot-Disketten einen Boot-Sektor installieren (128'er Version)?
    Wenn ja womit?

    - Ist es möglich Ordner/Unterverzeichnisse in einem separaten Fenster zu öffnen?

    - Welchen Vorteil hat es die Laufwerkstreiber ins RAM zu kopieren?

    Besten Dank und schönes Wochenende

    Gruss C=Mac.
  • wweicht schrieb:

    So, Installation von MP3-64 von 1541 auf 1581 unter WinVice ist durch. Hat problemlos geklappt (Diskwechsel auf 1541 (insgesamt 3x) werden angefordert und funktionieren). MP3-64 von 1541 auf 1581 (Komplett-Installation) läuft. Anschließendes Neu-Laden von MP3 (WinVice beendet und neu gestartet) funktioniert ebenfalls.

    Ich werde das Ganze auch nochmal an meinem C128DB testen. Weiß noch nicht, wann ich dazu komme. Bin aber zuversichtlich, dass auch das funktioniert.

    Dann werde ich mir auch die 2 Disketten (D64) näher ansehen. Das sollte doch auch für MP3-128 hin zu bekommen sein .... ;)

    Gruß
    Werner

    wweicht schrieb:

    Dann werde ich mir auch die 2 Disketten (D64) näher ansehen. Das sollte doch auch für MP3-128 hin zu bekommen sein ....
    Hallo Werner,
    was genau hast Du vor?
  • C=Mac schrieb:

    Hab's jetzt mal so unter MP3 128 und 64 gemacht.
    Nun, meiner Erfahrung nach trat das Problem mit den gelöschten selbststartenden Programmen nur bei der C128 Version auf.


    C=Mac schrieb:

    Der neue Drucker hat keinen Centronics-Anschluss mehr, somit brauch ich die Druckertreiber im Commodore-Lager nicht mehr.
    Nicht ganz ;) .
    Beim Start von Geowrite wird die Länge einer Seite aus dem aktiven Druckertreiber ausgelesen. Wenn keiner da ist werden irgendwelche Standard-Werte benutzt.


    C=Mac schrieb:

    Dabei hab ich festgestellt das die Installationsdateien beschädigt waren.
    Installation brach immer beim Kopieren von GeosDisk (94%) ab, mit der Fehlermeldung: Die Datei konnte nicht entpackt werden! Fehler Code: 2

    Hab das ganze Archiv neu runtergeladen und auf dem Mac einen anderen Entpacker verwendet.
    Ebenfalls hab ich das D81-File mit dem DOS-Treiber auf den C64/128 übertragen und nicht mit GeoDOS.
    Nun, beim Transport von Dateien über Disketten (DOS-Treiber von MP3 oder GeoDOS) kann immer mal was schief gehen. Meiner Erfahrung nach arbeiten beide aber zuverlässig.


    C=Mac schrieb:

    Jetzt gab es keine Probleme mehr.
    Gut zu hören :)


    C=Mac schrieb:

    - Welchen Vorteil hat es die Laufwerkstreiber ins RAM zu kopieren?
    Wenn der Geos.Editor gestartet wird, wird immer auch die Disk-Datei geladen. Wenn Du z.B. bei laufenden MP3 mal irgendwas in den Einstellungen ändern willst, muss immer auch die Disk-Datei auf dem aktuellen Laufwerk verfügbar sein.
    Das Einschalten dieser Option bewirkt, das die Disk-Datei beim Booten direkt in die RAM kopiert wird und dann immer aus dem RAM geladen wird. So brauchst Du die Disk-Datei nur auf der Boot-Disk/Partition zu haben. Du sparst ca. 85 kB auf jeder anderen Disk und das Laden ist schneller.

    Den Rest beantworte ich in den nächsten Tagen, sobald ich die Zeit finde. Muss morgen wieder früh raus. Vielleicht kann ja mal ein andere hier den Rest beantworten .... ;)

    Gruß
    Werner
  • Pusti64 schrieb:

    wweicht schrieb:

    Dann werde ich mir auch die 2 Disketten (D64) näher ansehen. Das sollte doch auch für MP3-128 hin zu bekommen sein ....
    was genau hast Du vor?
    Ganz einfach ;)

    Vor einiger Zeit gab es hier mal das Thema: MP3 von 1541 installieren. Bei den neueren Versionen (6 Installations-Dateien) ging das bisher nicht. Simples Kopieren der je 3 Dateien auf irgendwelche 1541-Disks funktioniert nicht. Da muss also während der Installation irgendetwas abgefragt werden. Das kann simpel der Diskname oder die Disk-ID (siehe Format-Befehl) oder eben ein spezielles Byte irgendwo auf Disk (Directory oder was weiß ich) sein.

    Jetzt haben wir für MP3-64 originale 1541-Disketten von C=Mac, die zumindest unter WinVice funktionieren. Der Test an "originaler" Hardware steht noch aus. Ich will das nur mal genauer rausbekommen und dann hoffentlich diese Variante auch für das neue MP3-128 einrichten. Normalerweise müsste die Methode von MP3-64 auf MP3-128 anwendbar sein...

    Gruß
    Werner

    Nachtrag: siehe hier:

    GEOS MegaPatch V3 von 1541 installieren (auf eine Native Partition)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von wweicht ()

  • Hallo C=Mac,
    ich verstehe deine Frage nicht ganz. Du hast Dir doch dann bereits MP3 auf ein Disk installiert. Warum möchtest Du dann noch einen Bootsektor erzeugen ?

    Wenn Du das betreffende Lfw. nochmal anklickst, dann wird es in einem anderen Fenster angezeigt. Wo du den gewünschten Ordner dann halt öffnest .
  • C=Mac schrieb:

    - Kann ich auf den Boot-Disketten einen Boot-Sektor installieren (128'er Version)?
    Wenn ja womit?
    Schau mal auf die Diskette zur HD oder RL. Da gibt es ein Programm "AUTO-BOOT 128" (normales C128 Basic-Programm). Das sollte das erledigen.

    Achtung:
    Bei NativeMode-Partitionen kann das Programm problemlos benutzt werden, auch wenn MP3-128 schon installiert ist. Hier ist der Track 1 Sektor 0 immer geschützt.
    Bei "normalen" Partitionen (1541, 1571, 1581) ist Vorsicht angebracht. Wenn MP3 schon installiert ist, kann es sein, dass der Boot-Sektor schon benutzt wird. Hier empfiehlt es sich, zunächst auf einer frisch formatierten Partition den Boot-Sektor aufzutragen und dann erst die Diskette zu beschreiben. Und: Die Partitionen dürfen erst unter MP3 validiert (Aufräumen) werden, wenn der Topdesk mit meinem Patch gepatcht ist. Ansonsten wird der Boot-Sektor nicht mehr als belegt gekennzeichnet und könnte überschrieben werden.

    Ansonsten mal ins HD/RL-Handbuch schauen, da ist das Programm kurz beschrieben.

    Gruß
    Werner
  • wweicht schrieb:

    Nun, meiner Erfahrung nach trat das Problem mit den gelöschten selbststartenden Programmen nur bei der C128 Version auf.
    Sicher ist sicher :D


    wweicht schrieb:

    Nicht ganz .
    Beim Start von Geowrite wird die Länge einer Seite aus dem aktiven Druckertreiber ausgelesen. Wenn keiner da ist werden irgendwelche Standard-Werte benutzt.
    Stimmt an das habe ich nicht mehr gedacht, werd bei Gelegenheit wieder einen Druckertreiber hinzufügen.


    Pusti64 schrieb:

    Hallo C=Mac,
    ich verstehe deine Frage nicht ganz. Du hast Dir doch dann bereits MP3 auf ein Disk installiert. Warum möchtest Du dann noch einen Bootsektor erzeugen ?
    Der C128 (im 128'er-Modus) fragt beim Einschalten auf dem Laufwerk 8 immer den Bootsektor ab.
    Ist keiner vorhanden oder keine Diskette eingelegt passiert nix, es erscheint die normale Raedy-Meldung.
    Ist einer vorhanden wird das entsprechende Programm automatisch geladen.

    Im Alter wird man halt faul ^^


    wweicht schrieb:

    Schau mal auf die Diskette zur HD oder RL. Da gibt es ein Programm "AUTO-BOOT 128" (normales C128 Basic-Programm). Das sollte das erledigen.
    Werd ich mir mal ansehen ob es auch auf normalen 1571 Disketten funktioniert.


    Mac Bacon schrieb:

    Als Bootmaker für den 128er pflege ich dies zu empfehlen...
    Besten Dank, werd es mir mal ansehen.
    Zwar ist mir nicht klar, warum Du grade diese Programm empfiehlst :whistling: ^^

    Gruss C=Mac.
  • Hallo,

    wweicht schrieb:

    Ich werde das Ganze auch nochmal an meinem C128DB testen.
    Ich habe heute die Installation von MP3-64 von 1541-Diskette ( MP3 Patch und Laufwerksverwaltung ) an meinem C128DB probiert. Habe von Geos 64 aus einmal auf die RAM (Lfw. B) und einmal in ein D81 auf meinem uIEC (Lfw. C) . Dabei traten keinerlei Probleme auf. Die Installation lief mit Disketten-Wechsel durch und ich konnte das System anschließend auch problemlos vom uIEC starten.

    Damit steht fest, dass die 2 D64s von C=Mac in Ordnung sind. ;)

    Gruß
    Werner

    PS: nun muss ich nur noch MP3 128 von 1541 als Quelle zum Laufen bekommen ........
  • :thumbsup: :thumbsup:





    Eine weitere Frage hätte ich noch :whistling:

    Um die Farben der Datei-Icons zu ändern braucht es laut Anleitung den "Pad color mgr".
    Handelt es sich dabei um das Programm auf der originalen GEOS-Disk, oder ist das ein anderes Programm?

    Gruss C=Mac.
  • Hallo,

    Pusti64 schrieb:

    Funktioniert MP3 128 auch mit 40 statt 80 Zeichen
    also: Für MegaPatch 128 ist ein 80-Zeichen-Monitor zwingend. Man kann zwar vom 40-Zeichenmodus aus booten, aber Topdesk 128 für MP3 ist 80-Zeichen only. Spätestens wenn Topdesk 128 geladen wird, wird automatisch auf 80-Zeichen umgeschaltet.
    Aber normale 40-Zeichen-Programme (z.B. geoDOS) laufen auch in MP3-128. Es kommt dann eine Meldung, dass der Bildschirm umgeschaltet werden muss. Für den Start von Hilfs-Programmen (Desk Accessories) gibt es im Topdesk 128 unter "geos" - "Hilfsprogramme" extra ein Icon ("40 / 80"). Damit können auch 40-Zeichen Hilfsmittel gestartet werden...

    Gruß
    Werner